Insert a rewriteable or blank disc when trying to use CD/DVD Creator, with blank disc in CDR drive

Bug #109763 reported by UbuntuKevin on 2007-04-24
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Unknown
hal (Ubuntu)
Medium
Unassigned
Declined for Feisty by Sebastien Bacher

Bug Description

Hopefully someone has an answer for this one.

I get the previously stated message "Insert a rewritable or blank disc" when I attempt to use CD/DVD Creator to burn files, although any and all CDR's I've put into the drive have all been new and blank.

Thanks,

Kevin

Massimo Forti (slackwarelife) wrote :

I have the same problems

Changed in nautilus:
status: Unconfirmed → Needs Info
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you run lshal and /usr/lib/nautilus-cd-burner/list_cddrives with a CD to the drive and copy that to a comment?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
Massimo Forti (slackwarelife) wrote :

The same problem when I insert cd audio. Sound Juicer does not start.
All options are enabled in Ubuntu 7.04
This problem start after uodate from 6.10

Changed in nautilus:
status: Needs Info → Confirmed
Changed in nautilus:
status: Confirmed → Needs Info
Massimo Forti (slackwarelife) wrote :

:~$ /usr/lib/nautilus-cd-burner/list_cddrives

Drive:
  name: DVD-RW DVR-K14
  device: /dev/scd0
  door: closed
  type: CD-R, CD-RW, DVD-R, DVD-RW, DVD+R, DVD+R DL, DVD+RW, CD, DVD
  is mounted: FALSE
  max read speed: 4233 KiB/s (CD 28.2x, DVD 3.1x)
  max write speed: 4233 KiB/s (CD 28.2x, DVD 3.1x)
  write speeds: 4233 KiB/s (CD 28.2x, DVD 3.1x)
                        3528 KiB/s (CD 23.5x, DVD 2.6x)
                        2822 KiB/s (CD 18.8x, DVD 2.0x)
                        1764 KiB/s (CD 11.7x, DVD 1.3x)
                        705 KiB/s (CD 4.6x, DVD 0.5x)

Media:
  label: ''
  type: CD-R (blank)
  is writable: TRUE
  is appendable: FALSE
  capacity: 701.00 MiB approx. or 80 mins 0 secs
  size: 0.00 MiB approx. or 0 mins 0 secs
---

Although I dabbled in Redhat and a couple of other Linux distributions in
the past, I'm not so sure what you mean or how to do what you just
suggested. I would appreciate it if you could explain a little more.

Thanks,
Kevin

On 4/25/07, Sebastien Bacher <email address hidden> wrote:
>
> Thank you for your bug. Could you run lshal and /usr/lib/nautilus-cd-
> burner/list_cddrives with a CD to the drive and copy that to a comment?
>
> ** Changed in: nautilus (Ubuntu)
> Importance: Undecided => Medium
> Assignee: (unassigned) => Ubuntu Desktop Bugs
>
> --
> Insert a rewriteable or blank disc when trying to use CD/DVD Creator, with
> blank disc in CDR drive
> https://bugs.launchpad.net/bugs/109763
> You received this bug notification because you are a direct subscriber
> of the bug.
>

UbuntuKevin (kevin-w) wrote :

Oops, I spoke before I thought about your email there. Here's some more info. I ran it as you see, with a blank CDR in my Plextor CDR drive.

kevin@discustank:~$ /usr/lib/nautilus-cd-burner/list_cddrives

** (process:6955): WARNING **: No property volume.disc.capacity on device with id /org/freedesktop/Hal/devices/volume_empty_unknown

Drive:
  name: CD-S500/A
  device: /dev/scd1
  door: open
  type: CD
  is mounted: FALSE
  max read speed: 8800 KiB/s (CD 58.6x, DVD 6.5x)
  max write speed: 0 KiB/s (CD 0.0x, DVD 0.0x)
  write speeds:
Media:
  label: ''
  type: Couldn't open media
  is writable: FALSE
  is appendable: FALSE
  capacity: Could not be determined
  size: Could not be determined
---
Drive:
  name: CD-R PX-W8432T
  device: /dev/scd0
  door: closed
  type: CD-R, CD-RW, CD
  is mounted: FALSE
  max read speed: 5645 KiB/s (CD 37.6x, DVD 4.1x)
  max write speed: 1411 KiB/s (CD 9.4x, DVD 1.0x)
  write speeds: 1350 KiB/s (CD 9.0x, DVD 0.9x)
                        1200 KiB/s (CD 8.0x, DVD 0.8x)
                        1050 KiB/s (CD 7.0x, DVD 0.7x)
                        900 KiB/s (CD 6.0x, DVD 0.6x)
                        750 KiB/s (CD 5.0x, DVD 0.5x)
                        600 KiB/s (CD 4.0x, DVD 0.4x)
                        450 KiB/s (CD 3.0x, DVD 0.3x)
                        300 KiB/s (CD 2.0x, DVD 0.2x)
                        150 KiB/s (CD 1.0x, DVD 0.1x)

Media:
  label: ''
  type: Unknown Media (blank)
  is writable: FALSE
  is appendable: FALSE
  capacity: Could not be determined
  size: 0.00 MiB

I attached the contents of information from running lshal.

Massimo Forti (slackwarelife) wrote :

UbuntuKevin, sebastian is trying to understand because when we insert the cdr blank the bruning program does not start. To do this he need to know the hardwer behaviors.
Your O.S. works differently to mine, when I insert cdr black Ubuntu recognizes the type of cd, but don't start the programm, in your the type of support was not found.
Why this ??? Interesting !

Massimo Forti (slackwarelife) wrote :

My lshal.

Sorry I forget to arrach this before.

Thanks

Sebastien Bacher (seb128) wrote :

There is no volume.disc.capacity, looks like an hal bug

Changed in nautilus:
assignee: desktop-bugs → nobody
status: Needs Info → Unconfirmed
UbuntuKevin (kevin-w) wrote :

so any ideas on how I could fix it?

On 4/30/07, Sebastien Bacher <email address hidden> wrote:
>
> There is no volume.disc.capacity, looks like an hal bug
>
> ** Changed in: hal (Ubuntu)
> Sourcepackagename: nautilus => hal
> Assignee: Ubuntu Desktop Bugs => (unassigned)
> Status: Needs Info => Unconfirmed
>
> --
> Insert a rewriteable or blank disc when trying to use CD/DVD Creator, with
> blank disc in CDR drive
> https://bugs.launchpad.net/bugs/109763
> You received this bug notification because you are a direct subscriber
> of the bug.
>

MPH (mphonke) wrote :

I have the same problem with CD/DVD Creator not recognizing a blank CD-R in the burner.

FWIW, My configuration has two similarities to UbuntuKevin's...

1) My CD burner is also a PLEXTOR PX-W8432T

2) I also have a second device that can read CDs... a TOSHIBA DVD-ROM SD-M1502. In my case, the TOSHIBA drive is scd0, and the PLEXTOR burner is scd1.

UbuntuKevin (kevin-w) wrote :

Hey MPH,

That's good to know that it could be a plextor driver problem. I hope
someone finds a fix for it. I keep getting updates showing available to fix
programming/developing bugs like in Python, but I don't do anything in that.

Still not going back to Windows....

On 5/6/07, MPH <email address hidden> wrote:
>
> I have the same problem with CD/DVD Creator not recognizing a blank CD-R
> in the burner.
>
> FWIW, My configuration has two similarities to UbuntuKevin's...
>
> 1) My CD burner is also a PLEXTOR PX-W8432T
>
> 2) I also have a second device that can read CDs... a TOSHIBA DVD-ROM
> SD-M1502. In my case, the TOSHIBA drive is scd0, and the PLEXTOR burner
> is scd1.
>
>
> ** Attachment added: "\MPHSERVE\NETSHARE\Mike\lshal.txt"
>
> http://librarian.launchpad.net/7573149/%5CMPHSERVE%5CNETSHARE%5CMike%5Clshal.txt
>
> --
> Insert a rewriteable or blank disc when trying to use CD/DVD Creator, with
> blank disc in CDR drive
> https://bugs.launchpad.net/bugs/109763
> You received this bug notification because you are a direct subscriber
> of the bug.
>

doug (doughahn56) wrote :

its not plextor problem
I get the same thing on my samsung rewriter

doug@buntu1:~$ /usr/lib/nautilus-cd-burner/list_cddrives

** (process:5409): WARNING **: No property volume.disc.capacity on device with id /org/freedesktop/Hal/devices/volume_empty_cd_r

Drive:
  name: SAMSUNG CD-R/RW SW-248F
  device: /dev/hdc
  door: closed
  type: CD-R, CD-RW, CD
  is mounted: FALSE
  max read speed: 8467 KiB/s (CD 56.4x, DVD 6.2x)
  max write speed: 0 KiB/s (CD 0.0x, DVD 0.0x)
  write speeds:
Media:
  label: ''
  type: CD-R (blank)
  is writable: TRUE
  is appendable: FALSE
  capacity: Could not be determined
  size: 0.00 MiB approx. or 0 mins 0 secs

MPH (mphonke) wrote :

Per Doug's link just above, I tried using the Configuration editor on nautilus-cd-burner but it didn't work for me. I tried all combinations of settings for burnproof, debug and overburn but no combination worked. I even rebooted the PC but nothing changed.

smk (pobox95) wrote :

I have the same problem with LG CD-RW CED-8120B. None of the solutions suggested here work.

smk (pobox95) wrote :

I might add that until this problem is solved, programs such as the Serpentine and the gThump, which depend on the CD/DVD creator, are also crippled.

Nelson Benitez (gnel) wrote :

For those who the published workarounds didn't work maybe can test if the problem is in the permissions of the device file because that was my problem on a similar bug[1] I had.

[1] http://bugs.gentoo.org/show_bug.cgi?id=100460#c7

MPH (mphonke) wrote :

Per the Gentoo link, I right-clicked on the blank CD icon... but no "Unmount" option is available. If I right click -> Properties on the blank CD icon and click on the volume tab, the Mount Point, File System and Mount Options each report "Not Mounted". Furthermore, while the media is listed above as "CD-ROM Disc", the size was "2048.0 GB"... as in 2048 Gigabytes.

BTW... when right-clicking on the blank CD icon, the only options NOT grayed-out are Open, Browse Folder, Stretch Icon, Eject and Properties.

trtl (pdersjant) wrote :

Same problem with a NEC DVD_RW ND-1300A. Changing the permissions as per Nelsons suggestion did fix the problem.

I might add that as a workaround I burned from the commandline using sudo without problems. So it does seem to be a permission problem. This happens on a fully up-to-date Feisty 32bit, with both nautilus-burner and gnomebaker here.

David C (da-cas) wrote :

I have same problem and can add another CD-RW to the list.
I'm sure it was ok under edgy (as I made feisty cds) but now under Feisty my LG CD-RW CED-8080B reports similar problem:
Same message also if logged in as root:
I checked and changed the permissions on /dev/hdb with no effect (as per Nelson Benitez 's suggestion) (and in any case I am a member of the cdrom group).
I have also tried altering the gconf nautilus-cd-burner options as per doug's suggestion.
And using the commandline option (I ran "nautilus-cd-burner --source-iso=file.iso") didn't change anything.
So it seems to be a generic problem (HAL?)

Further info, My feisty is fully up-to-date and running kernel (as shown in motd):
Linux ubuntu 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686

root@ubuntu:~# /usr/lib/nautilus-cd-burner/list_cddrives
** (process:6192): WARNING **: No property volume.disc.capacity on device with id /org/freedesktop/Hal/devices/volume_empty_unknown

Drive:
  name: LG CD-RW CED-8080B
  device: /dev/hdb
  door: closed
  type: CD-R, CD-RW, CD
  is mounted: FALSE
  max read speed: 5645 KiB/s (CD 37.6x, DVD 4.1x)
  max write speed: 1411 KiB/s (CD 9.4x, DVD 1.0x)
  write speeds: 1350 KiB/s (CD 9.0x, DVD 0.9x)
                        1200 KiB/s (CD 8.0x, DVD 0.8x)
                        1050 KiB/s (CD 7.0x, DVD 0.7x)
                        900 KiB/s (CD 6.0x, DVD 0.6x)
                        750 KiB/s (CD 5.0x, DVD 0.5x)
                        600 KiB/s (CD 4.0x, DVD 0.4x)
                        450 KiB/s (CD 3.0x, DVD 0.3x)
                        300 KiB/s (CD 2.0x, DVD 0.2x)
                        150 KiB/s (CD 1.0x, DVD 0.1x)

Media:
  label: ''
  type: Unknown Media (blank)
  is writable: FALSE
  is appendable: FALSE
  capacity: Could not be determined
  size: 0.00 MiB

Barry DeZonia (bdezonia) wrote :

I too am having this problem on 7.04 with all updates applied. I'm running two installations (one on a 350 mhz g3 powerpc box with 1024 mb ram and one on a 1.8 ghz dell dimension 4500 with 1024 mb ram) and it happens on both of them. I cannot get to the ppc to see its device model but on the dell its using an older (pulled from a dell) LG CED-8080B with the latest cdrom firmware you can get from Dell. The ppc system is also using an older CDRW pulled from a Dell (and its cdrom firmware has not been updated).

David C (da-cas) wrote :

I have some additional comments: Problem is still there when using HAL 0.5.9 (backport to feisty).
Also I attach HAL debug output.

David C (da-cas) wrote :

And some lshal output.

Barry DeZonia (bdezonia) wrote :

I've checked my ppc machine and coincidentally it also has a LG CED-8080B. The only difference between the two CDRWs is one has firmware 1.04 and one has firmware 1.07. And of course there is the hardware platform difference (PPC vs i386). If there is any info needed please let me know and I'll gather it.

David C (da-cas) wrote :

IMHO, this is may not be a bug in HAL, but a bug in nautilus-cd-burner, probably introduced at version 2.15.
I have successfully written CD using nautilus-cd-burner 2.14.3 on my Feisty system.
The problem appears to be that alternative strategies used to be adopted if volume.disc.capacity was not present, and this is no longer the case (see the function nautilus_burn_drive_get_media_size in nautilus-burn-drive.c (2.14.3), and compare with monitor_set_drive_media in nautilus-burn-drive-monitor.c (2.18.2))
I think it is a nautilus problem because the volume.disc.capacity property is optional in HAL, as can be seen from the spec http://webcvs.freedesktop.org/hal/hal/doc/spec/hal-spec.html?view=co#device-properties-volume-disc

An alternative approach may be to add some config to HAL for the missing drives, but this is going to be very piece-meal.

David

I'm wondering what the prognosis is of this. I have the same problem on my ma's computer. She'd really like to be able to burn CDs again.

David C (da-cas) wrote :

Despite my earlier comment, I have now got a patch for HAL that appears to work for me, based on code that was in Nautilus a while back. I have contacted the HAL developers so hopefully it will appear there sometime soon. In the mean time, I'll submit a patch here once I have it in appropriate format.

David C (da-cas) wrote :

Folks might like to try the attached patch (I generated it as patch to 0.5.9, but it might work with earlier versions) to see if it resolves the problem.
It worked for me, and I was able to install the resulting package onto my machine.

Tony Sweeney (macsuibhne) wrote :
Download full text (4.3 KiB)

Hi,

I'm coming in to this discussion a little late, but have the same issue. My goal in adding to this discussion is to add some additional searchable information to the bug report. Some details:

sweeney@ubuntu:~$ uname -a
Linux ubuntu 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
sweeney@ubuntu:~$

i.e. brand new Feisty 7.04 install. My CD drive is a TEAC W512 EB:

sweeney@ubuntu:~$ lshal -u storage_model_CD_W512EB -l
udi = '/org/freedesktop/Hal/devices/storage_model_CD_W512EB'
  storage.partitioning_scheme = '' (string)
  storage.removable.media_size = 2048 (0x800) (uint64)
  org.freedesktop.Hal.Device.Storage.method_execpaths = {'hal-storage-eject', 'hal-storage-closetray'} (string list)
  org.freedesktop.Hal.Device.Storage.method_argnames = {'extra_options', 'extra_options'} (string list)
  org.freedesktop.Hal.Device.Storage.method_signatures = {'as', 'as'} (string list)
  org.freedesktop.Hal.Device.Storage.method_names = {'Eject', 'CloseTray'} (string list)
  info.interfaces = {'org.freedesktop.Hal.Device.Storage', 'org.freedesktop.Hal.Device.Storage'} (string list)
  info.addons = {'hald-addon-storage'} (string list)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_model_CD_W512EB' (string)
  info.udi = '/org/freedesktop/Hal/devices/storage_model_CD_W512EB' (string)
  linux.fstab.options = 'user,noauto' (string)
  linux.fstab.mountpoint = '/media/cdrom0' (string)
  storage.cdrom.write_speed = 2117 (0x845) (int)
  storage.cdrom.read_speed = 5645 (0x160d) (int)
  storage.cdrom.support_media_changed = true (bool)
  storage.cdrom.hddvdrw = false (bool)
  storage.cdrom.hddvdr = false (bool)
  storage.cdrom.hddvd = false (bool)
  storage.cdrom.bdre = false (bool)
  storage.cdrom.bdr = false (bool)
  storage.cdrom.bd = false (bool)
  storage.cdrom.dvdplusrdl = false (bool)
  storage.cdrom.dvdplusrwdl = false (bool)
  storage.cdrom.dvdplusrw = false (bool)
  storage.cdrom.dvdplusr = false (bool)
  storage.cdrom.dvdram = false (bool)
  storage.cdrom.dvdrw = false (bool)
  storage.cdrom.dvdr = false (bool)
  storage.cdrom.dvd = false (bool)
  storage.cdrom.cdrw = true (bool)
  storage.cdrom.cdr = true (bool)
  storage.requires_eject = true (bool)
  storage.hotpluggable = false (bool)
  info.capabilities = {'storage', 'block', 'storage.cdrom'} (string list)
  info.category = 'storage' (string)
  info.product = 'CD-W512EB' (string)
  storage.size = 0 (0x0) (uint64)
  storage.removable = true (bool)
  storage.removable.media_available = true (bool)
  storage.physical_device = '/org/freedesktop/Hal/devices/pci_1106_571_ide_1_1' (string)
  storage.firmware_version = '2.0B' (string)
  storage.vendor = '' (string)
  storage.model = 'CD-W512EB' (string)
  storage.drive_type = 'cdrom' (string)
  storage.automount_enabled_hint = true (bool)
  storage.media_check_enabled = true (bool)
  storage.no_partitions_hint = true (bool)
  storage.bus = 'ide' (string)
  block.is_volume = false (bool)
  block.minor = 64 (0x40) (int)
  block.major = 22 (0x16) (int)
  block.device = '/dev/hdd' (string)
  linux.hotplug_type = 3 (0x3) (int)
  info.parent = '/org/freedesktop/Hal/de...

Read more...

David C (da-cas) wrote :

Tom,
I think it likely that the patch I had attached to my previous message (entitled Additional disc identification) provides a fix for problem with old drives.
The issue is that newer drives have a command that returns the size of the disc, for older drives this command is missing, but you can probe the disc itself to get the information.
This is what my patch to hal does.
It is in a format that you can just drop it into the debian/patches directory of HAL and then rebuild and re-install it.
I have sent it to the HAL developers but so far there have been no comments from them.

I tested it on my LG drive using HAL 0.5.9, but I expect the patch would work with 0.5.8 - the only reason I upgraded was in the hope that this problem would have been resolved, and I don't think the affected file has been touched for a couple of years.

It would be good to get your feedback on the patch as this would double the number of devices on which it has been tested!

David

David C wrote:
> Tom,
> I think it likely that the patch I had attached to my previous message (entitled Additional disc identification) provides a fix for problem with old drives.
> The issue is that newer drives have a command that returns the size of the disc, for older drives this command is missing, but you can probe the disc itself to get the information.
> This is what my patch to hal does.
> It is in a format that you can just drop it into the debian/patches directory of HAL and then rebuild and re-install it.
> I have sent it to the HAL developers but so far there have been no comments from them.
>
> I tested it on my LG drive using HAL 0.5.9, but I expect the patch would
> work with 0.5.8 - the only reason I upgraded was in the hope that this
> problem would have been resolved, and I don't think the affected file
> has been touched for a couple of years.
>
> It would be good to get your feedback on the patch as this would double
> the number of devices on which it has been tested!
>
> David
>
>
David,

I'd gladly give this a try, but I don't know the first thing about
building Linux from source. I've been building FreeBSD and XFree86 from
source for years, and have build the GNU toolchain more times than I
care to think about. But I don''t know where to start with Linux. The
documentation doesn't seem geared to someone who just wants to get the
source and build it (or I'm looking in all the wrong places). If you
could give me a pointer, or better yet a definitive recipe for building
HAL, I'd love to give this a go. The Sony drive I was going to swap in
turned out to be dying, so I have a day or so to kill waiting for a
replacement drive which is ultimately destined for the donor machine
anyway, so I have a real incentive to get this working.

Tony.

Download full text (3.4 KiB)

Tony,

You have to get the source package for HAL.
Do something like:
$ mkdir ~/hal; cd ~/hal; apt-get source hal
This will download a few files and a directory (in my case hal-0.5.9).
Then add my patch: (assuming you download my patch to the Desktop):
$ cp ~/Desktop/68-disc_identification.patch hal-0.5.9/debian/patches
Then from within tha hal-0.5.9 directory you run:
$ cd hal-0.5.9; debuild -i -us -uc -b
to build a binary package: the package will be called something like
hal_0.5.9-1ubuntu2~feisty1ubuntu1_i386.deb in the directory above the
hal-0.5.9 one.
I found
and then you install it using dpkg:
$ cd ~/hal/
$ dpkg -i hal_0.5.9-1ubuntu2~feisty1ubuntu1_i386.deb

I think that is sufficient, but at the build stage you may well find you are
missing a whole load of tools that you will need to add using either apt-get
or Synaptic, things like the debian support tools package, like debuild for
example, that I think is in package debian-builder.

David

>From: Tony Sweeney <email address hidden>
>Reply-To: Bug 109763 <email address hidden>
>To: <email address hidden>
>Subject: Re: [Bug 109763] Re: Insert a rewriteable or blank disc when
>tryingto use CD/DVD Creator, with blank disc in CDR drive
>Date: Mon, 20 Aug 2007 19:44:56 -0000
>
>David C wrote:
> > Tom,
> > I think it likely that the patch I had attached to my previous message
>(entitled Additional disc identification) provides a fix for problem with
>old drives.
> > The issue is that newer drives have a command that returns the size of
>the disc, for older drives this command is missing, but you can probe the
>disc itself to get the information.
> > This is what my patch to hal does.
> > It is in a format that you can just drop it into the debian/patches
>directory of HAL and then rebuild and re-install it.
> > I have sent it to the HAL developers but so far there have been no
>comments from them.
> >
> > I tested it on my LG drive using HAL 0.5.9, but I expect the patch would
> > work with 0.5.8 - the only reason I upgraded was in the hope that this
> > problem would have been resolved, and I don't think the affected file
> > has been touched for a couple of years.
> >
> > It would be good to get your feedback on the patch as this would double
> > the number of devices on which it has been tested!
> >
> > David
> >
> >
>David,
>
>I'd gladly give this a try, but I don't know the first thing about
>building Linux from source. I've been building FreeBSD and XFree86 from
>source for years, and have build the GNU toolchain more times than I
>care to think about. But I don''t know where to start with Linux. The
>documentation doesn't seem geared to someone who just wants to get the
>source and build it (or I'm looking in all the wrong places). If you
>could give me a pointer, or better yet a definitive recipe for building
>HAL, I'd love to give this a go. The Sony drive I was going to swap in
>turned out to be dying, so I have a day or so to kill waiting for a
>replacement drive which is ultimately destined for the donor machine
>anyway, so I have a real incentive to get this working.
>
>Tony.
>
>--
>Insert a rewriteable or blank disc when trying to use CD/DVD Creator, ...

Read more...

It seems that nobody from Ubuntu has commented on this issue in almost 4 months! Does a "medium" bug really get zero attention in 4 months? A patch has even been published here by David C. Could somebody at Ubuntu at least review that and publish an update?

David C (da-cas) wrote :

It doesn't help that Sebastien Bacher, who declined this for Feisty, is not on the distribution list for this bug.

Can I repeat Brian's call for someone to consider my patch and (hopefully) put an end to this bug.

Also while reviewing this, note that the fix will also clear bug #66254
as it is the same issue.

So if Sebastien (was he the only Ubuntu person subscribed?) has declined the fix and then unsubscribed himself is this bug now orphaned without _any_ Ubuntu visibility? How does that work? Surely every open bug in Ubuntu has to be owned by somebody in Ubuntu, no? That's sure how it works in the software company I work for.

Do we have to open up a new, duplicate bug in order to get some Ubuntu visibility again?

Maybe I will wait a day or two for some comment from Ubuntu on this bug (not sure how that will happen though if nobody from Ubuntu is watching) before saying or doing anything more.

Tony Sweeney (macsuibhne) wrote :

I have built David's patch with hal-0.5.8.1 as shipped with Feisty 7.04 and can verify it fixes my problem (I can now burn discs on this Frankenputer). This is a near virgin install, and the only system component I have built is HAL, approximately as described above. If I get time tomorrow, I'll log the bug and a pointer to the fix with FreeDesktop.org, as that seems to be the official upstream escalation path (there's no separate HAL point of contact, and there's a bunch of similar bug reports (and fixes) already on FD.O:

https://bugs.freedesktop.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__all__&product=hal&content=CDROM+blank+burn+volume.disc.capacity

). Hopefully that will flush this bug once and for all.

Tony.

trtl (pdersjant) wrote :

Just to confirm: on a (reasonably fresh) 7.04 AMD system, the patch works and fixes the bug here. As Tony did, I only built hal and nothing else.

David C (da-cas) wrote :

Great News: Can trtl and Tony state the kind of CD drive you are using, so we can list those for which it is known to work.

My drive, as reported in the info.product field in HAL is
LG CD-RW CED-8080B

I think Canonical folks do get this thread: e.g. Ubuntu Bugs, so there is some visability, just that I didn't see S.B. on that list.

I have sent this patch to the distribution list for HAL:
<email address hidden>
(which you need to subscribe to first, see
http://lists.freedesktop.org/mailman/listinfo/hal
)
but it has elicited NO response whatsoever.

Perhaps a few more voices would help.

Regards

David

David C wrote:
> Great News: Can trtl and Tony state the kind of CD drive you are using,
> so we can list those for which it is known to work.
>
Mine is listed in my followup to the bug report, but it's lost in the
detail. Here is again:

    TEAC CD-W512EB

Tony.
> My drive, as reported in the info.product field in HAL is
> LG CD-RW CED-8080B
>
> I think Canonical folks do get this thread: e.g. Ubuntu Bugs, so there
> is some visability, just that I didn't see S.B. on that list.
>
> I have sent this patch to the distribution list for HAL:
> <email address hidden>
> (which you need to subscribe to first, see
> http://lists.freedesktop.org/mailman/listinfo/hal
> )
> but it has elicited NO response whatsoever.
>
> Perhaps a few more voices would help.
>
> Regards
>
> David
>
>

--
quis custodiet ipsos custodes? -- Juvenal VI, 347-8

trtl (pdersjant) wrote :

Mine is a N.E.C. ND1300A..

James Daily (jamesdaily) wrote :

I have the same symptoms on my CD drive, an old TEAC CD-W516EB. I have a fresh install of Ubuntu Feisty Fawn 7.04.

I have not tested the HAL thing you guys are talking about - I don't know much about compiling my own packages from source.

Glad to hear it works. Can you let us know what your CD drive is. There is a list of CDs for which the fix is reported good in the last 4 messages on https://bugs.launchpad.net/ubuntu/+source/hal/+bug/109763.

I patched 0.5.9 because, before working on the patch, I got the most recent HAL in case others had fixed the problem. The patch works just fine for both cases, so you might just have to use the latest sources and re-apply to avoid the irritating update messages until a patch is adopted by Canonical.

Perhaps you (and others subscribing to either 66254 or 109763 (the same problem, just expressed slightly differently)) contact the HAL developers directly with your observations (and I'm CC'ing the Debian maintainer on this).

The problem has only recently started to appear because until around a year ago (specifically N-C-B 2.14.3, last
date in the sources of which is 31/07/06) contained code that probed the disc directly when HAL failed to return the MMC value.

Debian Testing uses
2.18.2, from 29/05/07, so developers/distributors have not actually had very long to
discover that there are quite a number of folk out there with old CD
drives that used to work and that will no longer do so.

My patch to HAL was just a slight re-coding of the code from N-C-B 2.14.3, and I did that rather than simply patching N-C-B because it seemed a cleaner place to make the mod: e.g. the 'Hardware Information' Browser now reports the empty CD size, and that would not have worked unless the change were made in HAL.

Regards

David

> From: <email address hidden>
> To: <email address hidden>
> Date: Sat, 1 Sep 2007 14:06:54 +0000
> Subject: [Bug 66254] Re: empty CD not correctly recognized by hal
>
> Thank you David. Your patch worked for me too. My own patches posted on
> 2007-07-07 and 2007-07-08 don't work. I'm still trying to make them
> work.
>
> Unfortunately ubuntu update notifier constantly suggests to replace the
> patched version with a more recent version because I applied the patch
> to version 0.5.8.1 of hal.
>
> I saw that you tried to draw the hal developers' attention to the bug
> and your patch on the hal mailing list and I am astonished that neither
> the hal nor the ubuntu developers seem to take notice of it.
>
> --
> empty CD not correctly recognized by hal
> https://bugs.launchpad.net/bugs/66254
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
Celeb spotting – Play CelebMashup and win cool prizes
https://www.celebmashup.com

Ulrich Büchsel (buechsel) wrote :

David's patch applied to hal 0.5.8.1 worked for me too. My drive is a

Lite-on LTR12101B

Greetings

Ulrich

cha0s (ruben-coder) wrote :

Thank you David, it worked like a charm here. Worth mentioning that I had to use "cp ~/Desktop/68-disc_identification.patch hal-0.5.8.1/debian/patches", since I guess I got an earlier version. It applied fine and executed perfectly. Cheers!

ThomasLee82 (kamiyasha) wrote :
Download full text (4.1 KiB)

Just wishing to say that the problem seems to exist on Gutsy as well, even after applying David's patch.

Attached is a copy of the lshal output (no clue what I was looking for in there), and here is a copy of the CD Drives List for my CD-R/RW drive.

thomas@thomas-desktop:~/hal$ /usr/lib/nautilus-cd-burner/list_cddrives
gnome-mount 0.6
Device /dev/hdd is in /etc/fstab with mount point "/media/cdrom0"

** (gnome-mount:31112): WARNING **: /bin/umount said error 512, stdout='', stderr='umount: /media/cdrom0 is not mounted (according to mtab)
'

Drive:
  name: SAMSUNG CD-R/RW SW-252S
  device: /dev/hdd
  door: closed
  type: CD-R, CD-RW, CD
  is mounted: FALSE
  max read speed: 8468 KiB/s (CD 56.4x, DVD 6.2x)
  max write speed: 8468 KiB/s (CD 56.4x, DVD 6.2x)
  write speeds: 8400 KiB/s (CD 56.0x, DVD 6.2x)
                        8250 KiB/s (CD 55.0x, DVD 6.0x)
                        8100 KiB/s (CD 54.0x, DVD 5.9x)
                        7950 KiB/s (CD 53.0x, DVD 5.8x)
                        7800 KiB/s (CD 52.0x, DVD 5.7x)
                        7650 KiB/s (CD 51.0x, DVD 5.6x)
                        7500 KiB/s (CD 50.0x, DVD 5.5x)
                        7350 KiB/s (CD 49.0x, DVD 5.4x)
                        7200 KiB/s (CD 48.0x, DVD 5.3x)
                        7050 KiB/s (CD 47.0x, DVD 5.2x)
                        6900 KiB/s (CD 46.0x, DVD 5.1x)
                        6750 KiB/s (CD 45.0x, DVD 4.9x)
                        6600 KiB/s (CD 44.0x, DVD 4.8x)
                        6450 KiB/s (CD 43.0x, DVD 4.7x)
                        6300 KiB/s (CD 42.0x, DVD 4.6x)
                        6150 KiB/s (CD 41.0x, DVD 4.5x)
                        6000 KiB/s (CD 40.0x, DVD 4.4x)
                        5850 KiB/s (CD 39.0x, DVD 4.3x)
                        5700 KiB/s (CD 38.0x, DVD 4.2x)
                        5550 KiB/s (CD 37.0x, DVD 4.1x)
                        5400 KiB/s (CD 36.0x, DVD 3.9x)
                        5250 KiB/s (CD 35.0x, DVD 3.8x)
                        5100 KiB/s (CD 34.0x, DVD 3.7x)
                        4950 KiB/s (CD 33.0x, DVD 3.6x)
                        4800 KiB/s (CD 32.0x, DVD 3.5x)
                        4650 KiB/s (CD 31.0x, DVD 3.4x)
                        4500 KiB/s (CD 30.0x, DVD 3.3x)
                        4350 KiB/s (CD 29.0x, DVD 3.2x)
                        4200 KiB/s (CD 28.0x, DVD 3.1x)
                        4050 KiB/s (CD 27.0x, DVD 2.9x)
                        3900 KiB/s (CD 26.0x, DVD 2.8x)
                        3750 KiB/s (CD 25.0x, DVD 2.7x)
                        3600 KiB/s (CD 24.0x, DVD 2.6x)
                        3450 KiB/s (CD 23.0x, DVD 2.5x)
                        3300 KiB/s (CD 22.0x, DVD 2.4x)
                        3150 KiB/s (CD 21.0x, DVD 2.3x)
                        3000 KiB/s (CD 20.0x, DVD 2.2x)
                        2850 KiB/s (CD 19.0x, DVD 2.1x)
                        2700 KiB/s (CD 18.0x, DVD 1.9x)
                        2550 KiB/s (CD 17.0x, DVD 1.8x)
                        2400 KiB/s (CD 16.0x, DVD 1.7x)
                        2250 KiB/s (CD 15.0x, DVD 1.6x...

Read more...

Cha0s: can you let us know what device you had success with?

ThomasLee82:
The problem will persist in all future versions until the HAL team decide to support old (non-MMC2) CD-RW drives.
They did not appear interested in my patch, presumably because they do not believe that there are (significant numbers of) users with old drives.

However, the fact that your device doesn't work is interesting, as the patch was to allow reporting of the media size using the HAL property "volume.disc.capacity". I think that is the only effect of the change I made. From the lshal output, I see that your device appears to be doing this, so I must assume that either the device is MMC-2 or my patch is installed.

Therefore I have to ask what the error is that you are observing?

I have identical entries in my lshal output for all the volume.* entries.
The following is cut from YOUR lshal output:
udi = '/org/freedesktop/Hal/devices/volume_empty_cd_r'
  block.device = '/dev/hdd' (string)
  block.is_volume = true (bool)
  block.major = 22 (0x16) (int)
  block.minor = 64 (0x40) (int)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_model_SAMSUNG_CD_R/RW_SW_252S' (string)
  info.capabilities = {'volume.disc', 'volume', 'block'} (string list)
  info.category = 'volume' (string)
  info.interfaces = {'org.freedesktop.Hal.Device.Volume', 'org.freedesktop.Hal.Device.Volume'} (string list)
  info.parent = '/org/freedesktop/Hal/devices/storage_model_SAMSUNG_CD_R/RW_SW_252S' (string)
  info.udi = '/org/freedesktop/Hal/devices/volume_empty_cd_r' (string)
  linux.fstab.mountpoint = '/media/cdrom0' (string)
  linux.fstab.options = 'user,noauto' (string)
  linux.hotplug_type = 3 (0x3) (int)
  linux.sysfs_path = '/sys/block/hdd/fakevolume' (string)
  org.freedesktop.Hal.Device.Volume.method_argnames = {'extra_options', 'extra_options'} (string list)
  org.freedesktop.Hal.Device.Volume.method_execpaths = {'hal-storage-eject', 'hal-storage-eject'} (string list)
  org.freedesktop.Hal.Device.Volume.method_names = {'Eject', 'Eject'} (string list)
  org.freedesktop.Hal.Device.Volume.method_signatures = {'as', 'as'} (string list)
  storage.model = '' (string)
  volume.block_size = 0 (0x0) (int)
  volume.disc.capacity = 735051776 (0x2bd00000) (uint64)
  volume.disc.has_audio = false (bool)
  volume.disc.has_data = false (bool)
  volume.disc.is_appendable = false (bool)
  volume.disc.is_blank = true (bool)
  volume.disc.is_rewritable = false (bool)
  volume.disc.type = 'cd_r' (string)
  volume.fstype = '' (string)
  volume.fsusage = '' (string)
  volume.fsversion = '' (string)
  volume.is_disc = true (bool)
  volume.is_mounted = false (bool)
  volume.is_mounted_read_only = false (bool)
  volume.is_partition = false (bool)
  volume.label = '' (string)
  volume.linux.is_device_mapper = false (bool)
  volume.mount_point = '' (string)
  volume.num_blocks = 4 (0x4) (int)
  volume.size = 2048 (0x800) (uint64)
  volume.uuid = '' (string)

_________________________________________________________________
Get free emoticon packs and customisation from Windows Live.
http://www.pimpmylive.co.uk

Changed in hal:
status: Unknown → Confirmed
Changed in hal:
status: Confirmed → Fix Released

Hi All,

There hasn't been any recent activity in this bug report. Just curious if this is still and issue in the latest Hardy Alpha, hal version 0.5.10-5ubuntu8. Thanks.

Changed in hal:
status: New → Incomplete

The changes I provided in the patch included here were commited into the HAL project on 2007-12-07,
and form part of the debian package for HAL 0.5.10-5:

HAL 0.5.10-5 is part of HARDY, but the patch has NOT been backported to Feisty or Gutsy.

The change above can be applied to any of these: there should not be any problem with compatibility as this area of code is very stable.

David

_________________________________________________________________
Get Hotmail on your mobile, text MSN to 63463!
http://mobile.uk.msn.com/pc/mail.aspx

David C (da-cas) on 2008-03-04
Changed in hal:
status: Incomplete → Fix Committed
status: Fix Committed → Confirmed
rtimai (rtimai) wrote :

Many, many, many thanks to David C:

68-disc_identification.patch FIXED the unrecognized blank disc issue with

    HP CD-Writer+ 8200 series
    Ubuntu 7.1 (gutsy)

Linux newbie <1yr, followed David's preliminary instructions, followed suggestions in the error message, installed pbuilder, updated all dependencies, compiled the patch, and installed the resulting hal_0.5.9.1-6ubuntu5_i386.deb file from Root Termnal. In this case pbuilder removed 26 packages and replaced them with 33 packages. Although the installation ended with "starting hal..." nautilus-cd-burner recognized a blank CD only after rebooting.But I can now burn CDs in the native application after 8 months of frustration!

Roger

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.