Dell Latitude C600 backlight remains on in S3 suspend

Bug #370617 reported by Rob Foehl on 2009-05-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Medium
hal-info (Ubuntu)
Undecided
Unassigned

Bug Description

Older Dell Latitude C600 upgraded from 8.10 to 9.04, LCD backlight now remains on in S3 suspend. Specifically, suspend/resume overall works as expected, the panel is shut off, but the backlight remains lit (even with the lid closed). Reproducible every time, and a clear regression from 8.10 and earlier. Normal DPMS functionality and 'xset dpms force off' work as expected, though in either case, the backlight and panel will be powered back on during the suspend process, thus the only available workaround for this is to avoid suspend and power the machine off.

The device identifies itself as 'ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)', Xorg uses the R128 driver for this chip. There are no unusual messages in dmesg or the Xorg log and no other functionality seems to be affected. Oddly enough, the backlight will actually shut off momentarily on a resume, and is then powered back on just prior to the mode switch back to X.

Rob Foehl (rwf) wrote :

Discovered that correct behavior occurs when using 'pm-suspend --quirk-dpms-suspend', and also that 'radeontool light off' has no effect. Not sure whether that did under 8.10 or earlier, but the only listed quirk in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi for the C600 is 'radeon_off' (which has not changed since prior releases). Adding 'dpms_suspend' restores correct backlight behavior, patch attached. Also verified that removing the 'radeon_off' quirk has no noticable effect.

Still unsure what caused the regression, although my current suspicion is that something (kernel?) broke whatever magic is behind the 'radeon_off' quirk. Will post findings to upstream mailing list and see what happens.

affects: ubuntu → hal-info (Ubuntu)

From https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/370617

"""
Older Dell Latitude C600 upgraded from 8.10 to 9.04, LCD backlight now remains on in S3 suspend. Specifically, suspend/resume overall works as expected, the panel is shut off, but the backlight remains lit (even with the lid closed). Reproducible every time, and a clear regression from 8.10 and earlier. Normal DPMS functionality and 'xset dpms force off' work as expected, though in either case, the backlight and panel will be powered back on during the suspend process, thus the only available workaround for this is to avoid suspend and power the machine off.

The device identifies itself as 'ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)', Xorg uses the R128 driver for this chip. There are no unusual messages in dmesg or the Xorg log and no other functionality seems to be affected. Oddly enough, the backlight will actually shut off momentarily on a resume, and is then powered back on just prior to the mode switch back to X.

---

Discovered that correct behavior occurs when using 'pm-suspend --quirk-dpms-suspend', and also that 'radeontool light off' has no effect. Not sure whether that did under 8.10 or earlier, but the only listed quirk in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi for the C600 is 'radeon_off' (which has not changed since prior releases). Adding 'dpms_suspend' restores correct backlight behavior, patch attached. Also verified that removing the 'radeon_off' quirk has no noticable effect.

Still unsure what caused the regression, although my current suspicion is that something (kernel?) broke whatever magic is behind the 'radeon_off' quirk. Will post findings to upstream mailing list and see what happens.

"""

tags: added: patch-forwarded-upstream

http://cgit.freedesktop.org/~dkukawka/hal-info/commit/?id=704b6e796a4ada939a949b055d2cca704d1941bf , get merged later.

commit 704b6e796a4ada939a949b055d2cca704d1941bf
Author: Rob Foehl <email address hidden>
Date: Thu Sep 9 13:46:05 2010 +0200

    fix suspend quirk for Dell Latitude C600

    Fixed suspend quirk for Dell Latitude C600. Use dpms_suspend.
    lp#370617

Changed in hal:
importance: Unknown → Medium
status: Unknown → Fix Released
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Changed in hal:
importance: Medium → Unknown
Changed in hal:
importance: Unknown → Medium
Vibhav Pant (vibhavp) wrote :

Attached debdiff

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.