Ubuntu

Samsung NC10 brightness keys block keyboard and produce all-or-nothing effect

Reported by anwe0212 on 2008-11-07
110
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
hal-info (Ubuntu)
Medium
Chris Coulson
Hardy
Undecided
Unassigned
Intrepid
Undecided
Martin Pitt
linux (Ubuntu)
Medium
Andy Whitcroft
Hardy
Medium
Unassigned
Intrepid
Medium
Stefan Bader

Bug Description

On my Samsung NC10 Netbook some FN keys do not work.

Working:
Speaker Off. Volume Control, Sleep Buttom, Mousepad off

Not working:
WLAN off, brightness up/down, LCD off, Battery

Brightness down gives an e009
Brightness up gives ab e008

setkeycodes e009 $KEY_BRIGHTNESSDOWN # Fn+Down
setkeycodes e008 $KEY_BRIGHTNESSUP # Fn+Up

This is working, but gives no button release event, so brightness goes up 100% or down 0%. And it also blocks the keyboard.

Any ideas on this?

TIA

Andreas

Using intreped X86

Anthony Noto (angusthefuzz) wrote :

Thank your for your bug report and helping to make Ubuntu better. Please see the following guide and post the requested information as separate attachments: https://wiki.ubuntu.com/Hotkeys/Troubleshooting

This link may also be of some help: https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

If you have any questions, don't hesitate to post another comment.

Berno Loewer (bernoloewer) wrote :

Same here.

I didn't try the setkeycodes part, but i used xev to find out what happens when i press one of the keys.

But - maybe because i didn't use setkeycodes - the keyboard is not blocked. The messages i see in xev after brightness-up stop when i press volume-up/-down.

Anthony Noto (angusthefuzz) wrote :

Please post the following files as separate attachments:

lshal -m > lshal.log
dmesg > dmesg.log
lsinput > lsinput.log
xkbcomp -xkb :0 - > xkbcomp.txt
setxkbmap -print > xkbmap.txt

Thanks in advance.

Sorry for the incomplete report ...

Here are the requested logs

dmesg

dmesg when pressed not working FN keys

lshal is empty, no entries when pressing not working FN keys.

lsinput

xkbcomp gives me an error

 xkbcomp :0
Warning: Could not load keyboard geometry for :0
                  BadAlloc (insufficient resources for operation)
                  Resulting keymap file will not describe geometry

Anthony Noto (angusthefuzz) wrote :

This sounds like multiple problems are occurring at once. I am confirming this report based on containing the required debugging information for the problem concerning the brightness keys blocking the keyboard and jumping from 0-100%. Please file a separate bug report about the other non-working hotkeys. Thank you.

edufl13 (andy-diginights) wrote :

I have the same problem.

But maybe this helps:
I also set the keymaps Andreas already described. After an X restart i´m able to use the brightness keys and the keyboard gets stuck.
But i can still switch to a console with the ALT+CTRL+F1-F6 keys. After switching back to X with CTRL+ALT+F7 i am able to use the keyboard again. If i use the brightness keys once more the brightness goes down to 0% or up to 100% without an release event.

Hi edufl13

as a workaround you can use:

sudo apt-get install gconf-editor xbacklight

gconf-editor

apps -> metacity global_keybindings

assign
run_command1 <Alt>F11
run_command2 <Alt>F12

or any keys you want.

apps->metacity->keybinding_commands unter

assign
command_1 xbacklight -dec 10
command_2 xbacklight -inc 10

restart xserver ... alt f11 and f12 will set the brightness.

more important for me is the WIFI off problem ....
more info at
https://bugs.launchpad.net/bugs/296489

dimasta (korbmacher) wrote :

I have the same problems with the fn-keys, which were written above... I hope that these problems will be solved.. thx

alain57 (alain57) wrote :

same problem here.
i first through it may be an acpi problem, because when i add "acpi=off" in grub, the brightness worked

after some search i found out that the keys were not mapped, so i did a
setkeycodes e008 225
setkeycodes e009 224

in console (CTRL+ F1-F6) it work normaly
but in graphical mode it bugs with two problems

first : brightness go to 0% or 100% even if i release the key
second : the keyboard won't react any more... i needed to switch back in console mode (CTRL ALT F1) and to come back in X (ALT F7) to have a working keyboard again

funnyly when i press the up key just after setting the brightness, well it stop increasing or decreasing brightness, like the release code is given...

alain57 (alain57) wrote :

maybe this can help you guys, at least i hope so :

i killed gnome-power-manager and run it this way
gnome-power-manager --no-daemon --verbose
i pressed the decrease button ONCE and then the increase button ONCE (because
the brightness was at 0%)
then i switch to console and back in graphic mode (because i loose the
keyboard) and killed gnome-power-manager

Doesnt look like somebody is interested in solving this ...

Thanks for nothing, other distris are much quicker than you.
I found a solution, so no need for you to look at this ... the few 100000 owners will be happy with Win XP.
Good work.

I wish you good luck, you will need it.

alain57 (alain57) wrote :

can you share your solution please ?

BjornW (bjornw) wrote :

I installed Hardy (8.04.1) using the Alternate installer and I had to use acpci=off as a boot option to install Ubuntu. I noticed that when I used this boot option the brightness keys such as the up and down arrow, but also the FN+F5 key worked as expected. Perhaps this info can help us further determine the issue and solve it? Feel free to contact me for more info if this is needed. I'm willing to test and check things.

BjornW (bjornw) wrote :

I made a typo in the description before.
Its not:

acpci=off

but

acpi=off

Sorry.

alain57 (alain57) wrote :

just to inform that i opened 2 bug report

one on kernel.org
and an other on Xorg

here is the link of the last one

http://bugs.freedesktop.org/show_bug.cgi?id=18590

because with acpi=off it worked, i opened first an acpi bug, but in console mode (CTRL ALT F1 for example) the brightness work well, i was told it is no acpi bug and i needed to open an Xorg bug.

ls (schildm) wrote :

On my NC10 the Brightness Keys are working, however, if i used them once, the keyboard is completely dead and XFCE hangs (Menus are not opening any more).

Davide P. (scaltro) wrote :

I've tried to boot with acpi=off option on my intrepid kernel and I encountered these problems on boot:

Frequency CPU scaling doesn't work anymore.
Wifi can't be powered-off yet.

Instead they're perfectly working:
Screen off key
Brightness UP/DOWN

It's a fault in how some of the Fn keys don't send the key release code, making the OS think that the key is being held down. I have submitted a patch to the kernel which fixes this issue, allowing the Fn keys (including brightness) to be used properly.

For those who want to see the patch:
http://bugzilla.kernel.org/show_bug.cgi?id=12021

To get the brightness to work, you also need to add the following scancode lines to /usr/share/hotkey-setup/samsung.hk
  scancodes e008 225
  scancodes e009 224

You should then find that the brightness works correctly. There is a scancode for the battery to make it work (but I don't have it to hand)

The wireless and other buttons are still a work-in-progress

Chris Coulson (chrisccoulson) wrote :

As it seems that at least part of the problem is due to the keys not producing keycodes, I'm assigning a hal-info task, where a quirk can be added to provide the correct scancode -> keycode mapping.

Changed in gnome-power-manager:
importance: Undecided → Medium
Chris Coulson (chrisccoulson) wrote :

Until recently, the battery and WLAN keys weren't mapped to any xkeysym's, and the battery key was also disabled in gnome-power-manager. A recent update to xkeyboard-config and gnome-power-manager has rectified this, and these keys should work as long as there are no other issues with them

I think I saw a post on one of the HAL mailing lists showing that some keycodes had been added. I can't seem to find it in google now (will continue to have a look for it).

The battery key works on mine with gnome-power-manager, providing i setup the scancode (which HAL should take care of). My wireless doesn't seem to disable, though that's an issue I will look at later tonight.

Andrew Ross (rockclimb) wrote :

There is an additional problem, that the keys don't produce release events. This is fixed by a kernel patch - see http://bugzilla.kernel.org/show_bug.cgi?id=12021

The kernel team should probably take a look at this - once the release event is in place then there are a number of easy ways to assign the hotkeys. The hotkey-setup package is one option, but the HAL option is probably better.

Andy

Chris Coulson (chrisccoulson) wrote :

I've added a kernel task and linked to the upstream bug report for the missing key-release problem

Changed in linux:
importance: Undecided → Medium
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

I've got the scancodes for the brightness keys. For the other non-working keys (battery / LCD / WLAN), could you please run:

"tail -f /var/log/kern.log"

...then press these non-functioning keys and post any output. If they aren't being mapped to any keycodes, it would be good to know before I send the hal-info part of this report upstream. If they are mapped, then there is a problem elsewhere and you should open a separate bug report for those keys.

Thanks

Changed in hal-info:
status: Confirmed → Incomplete
Changed in linux:
status: Unknown → Confirmed

The patch on the kernel bugzilla fixes the key release problem, I know this as I wrote it. It fixes all of the key releases, allowing them to be mapped by HAL correctly. There was mention of it being included in a hotkey file (still can't find the page link)

As for the scancodes, there is an attachment on the kernel bugzilla that lists all of the codes that the Fn keys produce. This will be what the hal team are after for the mappings. The list can be found at http://bugzilla.kernel.org/attachment.cgi?id=19300

If I get a chance I will look into the HAL config to see if I can create a quick patch to fix it. It still remains an issue though about unpatched kernels having the correct scancodes, as the keys would repeat to infinity (not a good idea when turning wireless on/off etc)

Stuart

Chris Coulson (chrisccoulson) wrote :

Thanks for the info Stuart. All of those key mappings are already present in hal-info for other Samsung models. All that is needed is just another match rule added to 30-keymap-misc.fdi. Could someone with this laptop please run "lshal > lshal.log" and attach the log file.

Thanks

fpe (f-esser) wrote :

Here it is.

Chris Coulson (chrisccoulson) wrote :

Thanks, that should do it.

Changed in hal-info:
status: Incomplete → Triaged
Andrew Ross (rockclimb) wrote :

Any chance someone in the Ubuntu Kernel team could apply the patch to the next Intrepid kernel, or do we need to wait for it to filter down from upstream?

Cyril Buquet (cyril11) wrote :

Hi

I have the same problem with my Samsung R60+
I have updated my HAL file 30-keymap-misc.fdi according to this :
+ http://bugzilla.kernel.org/show_bug.cgi?id=11102
+ http://cgit.freedesktop.org/hal-info/diff/?id=f03aa98039195e5e2b6f0c70068af43fd9b5479d

This action have solved some hidden key press problem, but the latest HAL release (http://cgit.freedesktop.org/hal-info/commit/?id=fa25c3520610d2b096b3d7e95edd45acf37c3561) can't be good for my R60+

My principal problem is the no-keyrelease problem. Under evtest, some key don't produce a keyrelease event.

Fn+UP / Fn+DOWN
Event: time 1230883744.271072, -------------- Report Sync ------------
Event: time 1230883746.692780, type 4 (Misc), code 4 (ScanCode), value 88
Event: time 1230883746.692799, type 1 (Key), code 225 (Brightness up), value 2
Event: time 1230883746.692802, -------------- Report Sync ------------
Event: time 1230883747.450533, type 4 (Misc), code 4 (ScanCode), value 89
Event: time 1230883747.450550, type 1 (Key), code 224 (Brightness down), value 2

Fn+F5 (under windows, LCD backlight off)
Event: time 1230883747.450554, -------------- Report Sync ------------
Event: time 1230883751.961216, type 4 (Misc), code 4 (ScanCode), value 84
Event: time 1230883751.961229, type 1 (Key), code 148 (Prog1), value 2

Fn+F8 (under windows, power policy)
Event: time 1230883752.908417, -------------- Report Sync ------------
Event: time 1230883753.328253, type 4 (Misc), code 4 (ScanCode), value b3
Event: time 1230883753.328270, type 1 (Key), code 202 (Prog3), value 2

Fn+F9 (under windows, Wifi switch)
Event: time 1230883753.328274, -------------- Report Sync ------------
Event: time 1230883754.833517, type 4 (Misc), code 4 (ScanCode), value 86
Event: time 1230883754.833533, type 1 (Key), code 238 (?), value 2

This keys can't be used.

Sorry for my poor english

Cyril Buquet (cyril11) wrote :

I have proposed a quirk for HAL for R60P keyboard. I'm waiting from approval, but i attach the proposition if this can help.

I have the key release problem, but, the patch submited to the kernel mailing list can't work for R60P
> DMI_MATCH(DMI_PRODUCT_NAME, "NC10")

For R60P : system.hardware.product = 'R59P/R60P/R61P'

Is it possible to modify this patch for R60P ?

Changed in linux:
status: Confirmed → In Progress
Changed in linux:
status: In Progress → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Andy Whitcroft (apw) on 2009-01-29
Changed in linux:
assignee: nobody → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

@Cyril -- could you attach your dmidecode output please.

@All I have build some test kernels with the suggested patch applied. Could those of you with NC10s test them and report back here. The kernels can be found at the URL below:

    http://people.ubuntu.com/~apw/lp295251-intrepid/

Changed in linux:
status: In Progress → Incomplete
alain57 (alain57) wrote :

i´m on jaunty with 2.6.29 git kernel
if you apply hopkins given patch, then it will correct the problem, but NOT entirelly
to have the brightness work without a problem on ubuntu :

1 : the hal fdi need to be modified so the brightness key are known
2: gnome-power-manager need to be patched too, there is a patch here :
http://bugzilla.gnome.org/show_bug.cgi?id=569100

i will check tonight if the gpm patch work, but the code seems ok to me

i would test the kernel, but i can't, because i use ext4 as filesystem, and it is only in 2.6.28

zinaf (zinaf) wrote :

I would love to test the kernels but I am not experienced in this and not at all confident about how to do it. If there were instructions on what to do then I would gladly volunteers since I am very much interested in this problem to be resolved.
thank you all for the hard work you are doing.

mlmss (mlmss) wrote :

@Andy I just installed your kernel on my NC10 with EasyPeasy 1.0 (orig. kernel 2.6.27-8). At the first glance everything works fine except of one big problem: I don't have WLAN anymore (the atheros card is not found). Regarding the FN keys, Brightness up/down are working as expected but Wireless on/off and brightness on/off don't work (should they?).
I hope this helps. Thanks for your work.

Chris Coulson (chrisccoulson) wrote :

Your non-functioning keys is probably related to the hal-info fix that hasn't been done yet, unless they worked before the kernel update.

Sorry, I had the intention of working on that bit but just haven't got round to it yet.

Changed in hal-info:
assignee: nobody → chrisccoulson
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

The R60P quirk is already in the latest version of hal-info in jaunty and intrepid-proposed. The only missing quirk appears to be for the R70, from a duplicate of this one.

mlmss - forget my last message, your NC10 already has the necessary quirks. Could you switch to a console (CTRL+ALT+F1) and run "sudo showkey -k", press the keys that aren't working and tell me if you see a keycode for any of them (and what the code is).

Chris Coulson (chrisccoulson) wrote :

For anyone running the R70S, I have a version of hal-info in my PPA to test, alongside Andy's test kernel

Cyril Buquet (cyril11) wrote :

@Andy: I have attached the dmidecode as asked.
I hope this helps. Thanks for your work.

Next, i will test your kernel.

Cyril Buquet (cyril11) wrote :

@Andy: I have tested your kernel (linux-image-2.6.27-12-generic_2.6.27-12.28~lp295251apw1_i386.deb),
but this not solve the key release on R60P.

May be it's normal, because your waiting for dmidecode output.

Cyril Buquet (cyril11) wrote :

I found some other bugs that related to Samsung laptop keyboard :

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/212800 Samsung Q45
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/146710 Samsung Q45, RV700, Q210, R70, R60, R700
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/296489 Samsung NC10

May be this can help.

mlmss (mlmss) wrote :

@Chris unfortunately there are no keycodes for wireless on/off, LCD on/off and Monitor switch, however for brighness up/down there are also no keycodes although they are working now. For speaker on/off and Volume up/down there are keycodes so in general showkey -k was working.

@All has somebody a hint what I could do that the wireless card is working again? I've compared the modules and it seems that there is no ath5k module with this kernel.

Cyril Buquet (cyril11) wrote :

@mlmss: Can you check this file :
/usr/share/hal/fdi/information/10freedesktop/30-keymap-misc.fdi

 Search for NC10: You should found this line :
<match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" contains_outof="NC10;SP55S;SQ45S70S;SX60P...

If not, search SP55S, and add NC10 like sample, save and reboot for test keycode.

mlmss (mlmss) wrote :

@Cyril I followed your advice and added NC10 to the line you mentioned (it was not there before) but nothing changed. Still now working wireless on/off, LCD on/off and Monitor switch and still no keycodes with showkey -k.

Chris Coulson (chrisccoulson) wrote :

Do you see any scancodes? Try running "sudo showkey -s" from a terminal instead. If you see scancodes for those keys, what are they?

Cyril Buquet (cyril11) wrote :

@mlmss: You should use showkey from console, not under X11 (KDE / GNOME /... )
Hit CTRL+ALT+F1
Next, log into system with you habitual login.

Now, you can use "sudo showkey -s"

At end, type exit, to logout, and ALT+F7 to go back on GNOME / KDE.

On my R60+, showkey work only on console.

mlmss (mlmss) wrote :

@Chris and Cyril: I'm a bit confused, I'm not a linux expert and I thought I did it right but obviously not. Now I tried again showkey -k and showkey -s and in both cases I see keycodes, however in completely different styles. Here my results:
1. showkey -k
Brightness on/off keycode 148
Wireless on/off keycode 238
Monitor Switch keycode 431
Mail? (Fn+F7) keycode 149
Internet? (Fn+F8) keycode 202
Each time it shows one for press and one for release

2. showkey -s
Brightness on/off 0xe0 0x1f 0xe0 0x9f
Wireless on/off 0xe0 0x73 0xe0 0xf3
Monitor Switch nothing shown
Mail 0xe0 0x17
       0xe0 0x97 (here it shows 2 lines)
Internet 0xe0 0x2b 0xe0 0xab

I hope this helps and sorry that I did not make it right the first time.

Martin Pitt (pitti) wrote :

Current hal-info in Jaunty sets the keymap for the NC10. The current {hardy,intrepid}-proposed packages do that as well, but I'll pull them (also) because of this kernel bug, which renders the hotkeys unusable.

Changed in hal-info:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

linux 2.6.28-7.20 (just uploaded to Jaunty) should fix this:

linux (2.6.28-7.20) jaunty; urgency=low

  [ Tim Gardner ]

  * SAUCE: Input: atkbd - Samsung NC10 key repeat fix
[...]

Could people please try this once it is built and hits the archive?

Zygmunt Krynicki (zkrynicki) wrote :

I'll test that as soon as 2.6.28-7.20 hits the archive.
It's still broken on .19 BTW (backlight control keys just hang the keyboard in X)

Zygmunt Krynicki [2009-02-09 19:08 -0000]:
> It's still broken on .19 BTW (backlight control keys just hang the keyboard in X)

That's an effect of a keypress acting as a series of indefinite
keypresses. Try switching to Ctrl+Alt+F1 and back, that helped on my
friend's NC10.

Martin Pitt (pitti) wrote :

The current hardy/intrepid-proposed hal-info enable keymaps on the NC10. I'm going to disable that again in a followup upload, so that people don't get bitten by that bug.

Changed in hal-info:
assignee: nobody → pitti
status: New → Triaged
Martin Pitt (pitti) wrote :

New hal-info uploaded to hardy/intrepid-proposed uploaded which fixes this; waiting for Steve to process.

Changed in hal-info:
status: Triaged → In Progress
status: New → In Progress
Colin Watson (cjwatson) on 2009-02-10
Changed in hal-info:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted hal-info into hardy-proposed and intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Zygmunt Krynicki (zkrynicki) wrote :

I have just tested this on NC10 (with 2.6.28.7-20) and it seems to work.
I have just one comment: compared to the speed of adjusting sound (FN+left,right arrows) adjusting brightness (FN+up,down arrows) is about x2-x3 times slower.

Martin Pitt (pitti) wrote :

Closing linux/jaunty task then, thanks for testing!

Could anyone also please test the current hal-info in intrepid/hardy-proposed and confirm that it does *not* enable hotkeys on the NC10 any more?

Changed in linux:
status: Incomplete → Fix Released
Muharem Hrnjadovic (al-maisan) wrote :

I have a Samsung Q45 laptop running Jaunty and exhibiting very much the same problems when using the brightness control keys.

Muharem Hrnjadovic (al-maisan) wrote :

More info re. the Samsung Q45: the keys for brightness control are recognised but there is no release:

This is the output from "xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'" :

keycode 233 = (keysym 0x1008ff02, XF86MonBrightnessUp), state = 0x0
keycode 232 = (keysym 0x1008ff03, XF86MonBrightnessDown), state = 0x0

Muharem Hrnjadovic (al-maisan) wrote :

I am running the following kernel BTW:

Linux fn80 2.6.28-7-generic #20-Ubuntu SMP Mon Feb 9 15:42:34 UTC 2009 x86_64 GNU/Linux

zinaf (zinaf) wrote :

Hello everyone,
would it be possible for someone to post a write-up of the fix (step-by-step instruction) for those like me who are not so experienced with linux.
What should be the steps fix the fn keys problem on NC10. Is it just upgrading to the '-proposed' or is there a need to modify the key map as it was written many posts ago.
I have honestly now lost track of what has to be done.
Your help for silly folks like me would be much appreciated.
Cheers

Muharem Hrnjadovic (al-maisan) wrote :

I was poking around with the Samsung Q45 and discovered a work-around by chance:

  * press (amd release) the blue 'Fn' key *alone*
  * depending on the focus that will open a menu somewhere on the desktop but do not worry and just ignore that for a moment
  * now use the Fn-Up/Down key combinations to adjust the screen brightness as desired
  * finally press the 'Esc' key twice

Outcome: screen brightness adjusted without a messed up keyboard :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~intrepid2

---------------
hal-info (20090128-0ubuntu1~intrepid2) intrepid-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

hal-info (20090128-0ubuntu1~intrepid1) intrepid-proposed; urgency=low

  * New upstream git snapshot:
    - Add Nokia E51 mobile modem (LP: #261416)
    - Add Nokia N and E series modems (LP: #303748)
    - Add ATT USBConnect Mercury modem (LP: #306604)
    - Add Sony Ericsson W890i music player (LP: #314618)
    - Fix detection of AT&T Option 3G modems again (LP: #316120)
    - Add ZTE AC8700 (EV-DO) modem (LP: #321213)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~hardy2

---------------
hal-info (20090128-0ubuntu1~hardy2) hardy-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Thomas (teoverton) wrote :

I am very much confused here. How is this fixed with the hal-info update. I have that package installed, and my function keys still will not release... Am I missing something here?

pittipatti (pittipatti) wrote :

As Cyril stated in comment 45 and Muharem in comment 62
this bug also affects the Samsung Q45 notebook. (Bug #212800)

The status for the q45 is that the needed infos are already in hal-info
but the keyboard still does not send key-release events like the NC10 does.

So could you please update the proposed kernel patch to also include the
Q45.
I attached the needed dmi infos.

Stephen Brandwood (sbrandwoo) wrote :

I have a Samsung Q210 laptop running Intrepid.

The volume keys work perfectly (including on-screen graphic), but the brightness keys have no effect at all. xev shows no events when these keys are pressed. I have updated hal-info but there has been no effect.

Anything else I should try? Thanks.

Martin Pitt (pitti) wrote :

SteveB, you have a different model. Please open a new bug report against hal-info and submit output of lshal.

Stefan Bader (smb) wrote :

To sync status. The fix "Input: atkbd - Samsung NC10 key repeat fix" has been integrated with stable update 2.6.27.15 and is included in the 2.6.27-13.29 kernel (currently in -proposed)

Changed in linux:
importance: Undecided → Medium
status: New → Fix Released
Andy Whitcroft (apw) on 2009-03-09
Changed in linux:
status: Fix Released → Fix Committed
Andy Whitcroft (apw) on 2009-03-10
Changed in linux:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → In Progress
Andy Whitcroft (apw) on 2009-03-10
Changed in linux:
assignee: nobody → apw
Andy Whitcroft (apw) wrote :

I have had a look at the possibility of a Hardy backport for this. It is not as simple a patch and therefore far from guarenteed to be accepted as an SRU. But if there is anyone still on Hardy affected by this and they could test this combination, then please could you test the kernels at the URL below and report back here. These kernels are available at the URL below:

    http://people.ubuntu.com/~apw/lp295251-hardy/

Changed in linux:
status: In Progress → Incomplete
pierre82 (mail-pierrehoening) wrote :

I come from 'Bug 219116 Multiple hotkeys don't work with Samsung R70 T7300 Despina' because it has the status of being duplicate of this one. And I'm using Ubuntu 9.04 where some fn-keys are not working. And when I compare 9.04 to 8.10 I lost the fn+f9 (wlan on/off) what was in 8.10.

Now working: fn+volume up/down, fn+f10 (touchpad), fn+www, fn+esc (standby), fn+f6 (sound), fn+f11, fn+-, fn+*, fn++, fn+enter

The rest: no function.

Please fix this and thx in advance.

pierre82 (mail-pierrehoening) wrote :

Sorry I mean that i come from Bug 295251.

pierre82 (mail-pierrehoening) wrote :

Nonsense i was confused in my last post - lol.

Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Changed in linux:
status: Confirmed → Fix Released
frizzle21 (frederik-nnaji) wrote :

i'm using lucid on an NC10 and brightness still doesn't work.
how's that?

Wysłane z iPhone'a

Dnia 2010-04-02 o godz. 04:37 "frederik.nnaji"
<email address hidden> napisał(a):

> i'm using lucid on an NC10 and brightness still doesn't work.
> how's that?
>

Which bios version fo you have?

Regards
Zygmunt

I'm using a new Samsung NB30 with Lucid and for me the Brightness Up/Down buttons (FN up/down) neither work, nor does the toggle Backlight button (Fn F5). The patch must have left the new kernel. I tried Fedora 13 Live CD and it has the same problem.

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu Hardy):
assignee: Andy Whitcroft (apw) → nobody

This also affects the N145 on out-of-the-box Ubuntu 10.10.
I had to use the following steps to get Ubuntu working well on my N145:
http://twistedpairdevelopment.wordpress.com/2010/11/16/installing-ubuntu-on-a-samsung-n145-and-possibly-others/

The keyboard locking can simply be solved by adding "*N145*" to the "/lib/udev/rules.d/95-keyboard-force-release.rules" file.
Getting the brightness to actually function required Voria's PPA.

Surely there is a better method than adding every single Samsung laptop model ever released to the udev file?!

Martin Pitt (pitti) wrote :

Adam, this was fixed for good in latest udev by applying the rule to all Samsung computers.

Changed in linux:
importance: Unknown → Medium
calinb (cbrabandt) wrote :

Martin, I just installed 10.10 Netbook Edition on my N145 and there still appear to be problems here. I had to put "*N*" in the "/lib/udev/rules.d/95-keyboard-force-release.rules" list to get the keyboard to release but the brightness function keys have no effect other than to temporarily.display the slider overlay on the desktop. Adam's grub file suggestions made no difference and I've installed the packages he cites in his guide. I'm running 2.6.35-25-generic and the Lucid kernel does not appear to be necessary (suspend and hibernate work with wifi).

Reuben Thomas (rrt) wrote :

This worked fine for me for a long time, but seems to have stopped working in oneiric: the brightness control works OK, but it goes all the way up or down for each press of Fn+Up or Fn+Down (actually, it's a little odder than that: Fn+Down always makes it go to minimum, then Fn+Up once makes it go up one step, then Fn+Up again makes it go to maximum).

Reuben Thomas (rrt) wrote :

I'm using an NC-10, BTW. All the quirks & fixes mentioned above seem still to be in place.

Reuben Thomas (rrt) wrote :

If I use the current natty 2.6.38-11 kernel, the brightness control works fine again, so it seems to be a kernel problem.

Stefan Bader (smb) wrote :

@Reuben, could you please open a new bug for this? You can reference this one in the description but it helps to have a seperate instance to track any steps on this re-occuring problem. Thanks.

riban (brian-riban) wrote :

I have reported recurrence of brightness control failure on nc10 running Ubuntu 11.10 (kernel 3.0) as issue #883431.

Julian Wiedmann (jwiedmann) wrote :

This release has reached end-of-life [0].

[0] https://wiki.ubuntu.com/Releases

Changed in linux (Ubuntu Hardy):
status: Incomplete → Invalid
Jannes (iwashere) wrote :

Nice to see you still care about this issue after all these years. I am
actually still using a device.
Am 18.08.2013 19:46 schrieb "Julian Wiedmann" <email address hidden>:

> This release has reached end-of-life [0].
>
> [0] https://wiki.ubuntu.com/Releases
>
> ** Changed in: linux (Ubuntu Hardy)
> Status: Incomplete => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/295251
>
> Title:
> Samsung NC10 brightness keys block keyboard and produce all-or-nothing
> effect
>
> Status in The Linux Kernel:
> Fix Released
> Status in “hal-info” package in Ubuntu:
> Fix Released
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “hal-info” source package in Hardy:
> Fix Released
> Status in “linux” source package in Hardy:
> Invalid
> Status in “hal-info” source package in Intrepid:
> Fix Released
> Status in “linux” source package in Intrepid:
> Fix Released
>
> Bug description:
> On my Samsung NC10 Netbook some FN keys do not work.
>
> Working:
> Speaker Off. Volume Control, Sleep Buttom, Mousepad off
>
> Not working:
> WLAN off, brightness up/down, LCD off, Battery
>
> Brightness down gives an e009
> Brightness up gives ab e008
>
> setkeycodes e009 $KEY_BRIGHTNESSDOWN # Fn+Down
> setkeycodes e008 $KEY_BRIGHTNESSUP # Fn+Up
>
> This is working, but gives no button release event, so brightness
> goes up 100% or down 0%. And it also blocks the keyboard.
>
> Any ideas on this?
>
> TIA
>
> Andreas
>
> Using intreped X86
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/295251/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.