Ubuntu

no brightness-control on samsung laptop

Reported by pittipatti on 2008-04-06
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Declined for Hardy by Steve Langasek

Bug Description

Hardware:
  - Samsung Notebook Q45-Aura T7100 Duke (the one with intel graphics GM965)

Ubuntu Hardy-i386
Kernel: 2.6.24-15

brightness-control is not working on this laptop.

1. the the Fn-keys don't get mapped (see bug #212790)
2. there are no sysfs-files for controlling the display-brightness

pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) wrote :
pittipatti (pittipatti) on 2008-04-06
description: updated
Steve Langasek (vorlon) on 2008-04-16
Changed in linux:
importance: Undecided → Low

Hi pittipatti,

It unfortunately looks like this did not get resolved for the Hardy release. Care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10 ? You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Tobias Pflug (tobias-pflug) wrote :

I am running 8.10 on a Samsung Q45. The brightness control now works somewhat but is still
bugy. At first attempt I could change brightness just fine, but then the keyboard seemed to
be dead. X did however receive ctrl-alt-1 and after switching to a tty and back the keyboard
input is working fully again. Now however when I try changing the contrast hitting FN-[brightness-up]
or FN-[brightness-down] it seems to receive multiple invocations and hence turns the
brightness all the way up or all the way down.

please let me know what additional information I can provide which might of of use.

@ Tobias: can you please tell which graphics hardware your q45 has
(intel/nvidia)?

The bugreport was for the intel-version and I can't confirm that it is
working with latest Intrepid 2.6.27-2.3 on a q45 with intel graphics..

The problem is, that the needed module video.ko can't be loaded, because
it freezes the laptop immediately.
This bug is handled in bug #146692 and a fix is available.

But still with this fix brightness-control isn't available on the intel q45.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Triaged
Nermal (pjprior) wrote :

Hi,

I've just got an samsung Q45 UK model (NP-Q45A00A/SUK ) with the intel graphics. Under ubuntu 8.10RC I see the same thing Tobias sees if I blacklist the video module. If I leave it unblacklisted, the system freezes on boot.

 Also on boot I get told my pnp bios caused a fatal error - it recovers and continues but recommends booting with pnpbios=off.

Mathieu Fluhr (mathieu-fluhr) wrote :

Hi all,

I just experienced the same situation as Tobias Plug described. Bascially with 8.04, the brightness control was marked "not avialable" under Gnome... now it is somehow available, but locking some part of the keyboard and the menu display. So I decided to investigate a little bit more:

First of all this does not come from 'hotkey-setup'. I simply uninstall it, rebooted and guess what, same issue.
I then took a look to all the running processes, killing all the suspicious ones. Then I came to the 'gnome-power-manager'. As the process is automatically re-launching itself, I also de-install it.... and then, no problems at all:
 - brightness hotkey are not working anymore (same behaviour as 8.04)
 - sound hotkeys are still working perfectly.

So I guess that there is a slight bug in 'gnome-power-manager' package.

Mathieu Fluhr (mathieu-fluhr) wrote :

And btw, I am running a Q45 with nVidia graphics, using the 177 driver.

Nermal (pjprior) wrote :

From what I've read it seems the Samsung bios ( > 09ST) is buggy and doesn't allow acpi to take over all the hotkeys correctly so the brightness keys still generate keycodes (repeatedly) and this seems to make X go weird (keyboard unresponsive, display sluggish).

Downgrading the bios to 08ST (using the information at https://wiki.ubuntu.com/LaptopTestingTeam/SamsungQ45) fixes the problem for me.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Antony Neu (antony-neu) wrote :

I'm using a Q45 aura Tyreen with Intel Graphics.
Brightness Control used to work with 9.04 and 8.10 but with 9.10 it doesn't work anymore.

Rene Lindsay (rjklindsay) wrote :

The Samsung R560 has the same problem, but I have a partial work-around.
If you press Fn+Up/Down, the brightness bar appears and starts flickering, but the brightness does not change. Instead the keyboard seems to lock up.
You can return the keyboard to normal by pressing Ctrl-Alt-F3, then Ctrl-Alt-F7
The Gnome brightness control applet also does not work.
However, you CAN adjust the brightness from the terminal, with the following commands:
For full brightness, type: smartdimmer -s 100
for low brightness, type: smartdimmer -s 30

I placed a set of script files with these commands on the desktop.
Now if only I could get the Fn+Up/Down keys to execute these commands...

postadelmaga (postadelmaga) wrote :

I have a "Samsung n150" and running Lucid and the problem is the same : no brightness control.

smartdimmer command doen't work here ...
output:
init_nvclock() failed!

instead that works good:

setpci -s $DEVICE F4.B=$var2

with:
- DEVICE=00:02.0
and
- var2=`echo "ibase=10; obase=16; a=($var1d+$AMOUNT);if (a<255) print a else print 255" | bc`
               echo "$0: increasing brightness from 0x$var1 to 0x$var2"

It has been years. When can we have this problem solved, or we shall
abandon using the notebooks from Samsung?

2010/3/28 postadelmaga <email address hidden>:
> I have a "Samsung n150" and running Lucid and  the problem is the same :
> no brightness control.
>
> smartdimmer command doen't  work here ...
> output:
> init_nvclock() failed!
>
> instead that works good:
>
> setpci -s $DEVICE F4.B=$var2
>
> with:
> - DEVICE=00:02.0
> and
> - var2=`echo "ibase=10; obase=16; a=($var1d+$AMOUNT);if (a<255) print a else print 255" | bc`
>               echo "$0: increasing brightness from 0x$var1 to 0x$var2"
>
> --
> no brightness-control on samsung laptop
> https://bugs.launchpad.net/bugs/212800
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Łukasz Lew (lukasz-lew) wrote :

Yes, please let's fix it ...

madbiologist (me-again) wrote :

@Rene Lindsay - What version of Ubuntu are you using?

Pietro Battiston (toobaz) wrote :

In case it turns useful to someone (else)...

http://www.pietrobattiston.it/brightung

ldm (lucky-dm-77) wrote :

from https://bugzilla.kernel.org/show_bug.cgi?id=14052

I have a Samsung Q45 and I'm an Ubuntu user since Feisty Fawn.
I have read a lot about 'Fn keys' on Samsung laptops in bugzilla and also in
bugs.launchpad.net.
This bug has been marked as fixed, but it is still present! (also in Lucid Lynx
with kernel 2.6.32-22)

Anyway yesterday I have tried this solution
http://www.voria.org/forum/viewtopic.php?f=3&t=296 and it works fine:
package 'samsung-backlight' enables brightness up/down
package 'samsung-tools' enables wireless on/off

It seems to be a DKMS (Dynamic Kernel Module Support),
it is possible to include this code directly in linux kernel source tree?

ldm (lucky-dm-77) wrote :

from https://bugzilla.kernel.org/show_bug.cgi?id=14052

the answer of the developer for this bug:

'You need to talk to your distribution to make sure that they apply
force_release workaround upon booting the box.'

so can you please include this patch in ubuntu kernel?

Something similar is also needed for the Samsung NB30 as neither the brightness nor the touchscreen work on this with the 10.40 LTS.

ldm (lucky-dm-77) wrote :

bug still present in Ubuntu 10.10 :(

Tom K. C. Chiu (tomchiukc) wrote :

That is far too bad. :-(

2010/10/26 ldm <email address hidden>:
> bug still present in Ubuntu 10.10  :(
>
> --
> no brightness-control on samsung laptop
> https://bugs.launchpad.net/bugs/212800
> You received this bug notification because you are a direct subscriber
> of the bug.
>

WebNuLL (babciastefa) wrote :

It affects me too on Samsung Q1 Tablet PC.

Daniil Bondarev (xonatius) wrote :

I've added backlight brightness support to samsung-backlight kernel module. Currently for N120, N130, NC10, NP-Q45, X320/X420/X520, X360, R518 and R510/P510. You can get it from https://github.com/xonatius/samsung-backlight .
It would be awesome, if somebody test it. (=

WebNuLL, could you send lspci and lspci -n please?

Erni35 (dczekay) wrote :

After reading about kernel support for samsung laptops I switched to 11.04. But inserting with "modprobe samsung-laptop" ended up with fatal error -> no such device. The kernel was called with acpi_backlight=vendor

Erni35

madbiologist (me-again) on 2011-04-21
tags: added: hardy lucid
papukaija (papukaija) wrote :

The brightness control works in any Samsung laptop starting with Oneiric (it introduced the new samsung_laptop kernel driver). Therefore I'm marking this bug as fixed. However, please note that the backlight flickers in Oneiric until bug 810093 is fixed. The flickering can be stopped by changing the baclight brigtness. Further workarounds and more details cas be found from that bug. Feel free to continue to report any other bugs you may find.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
tags: removed: q45
Haze aulaian (haze-psut) wrote :

so finaly i was able to fix somthing in backtrack 5 r3 on Samsung N150 netbook , actually its a fix for all ubuntu users , its the backlight issue which is really irritating kept searching it for 2 months with no hope until 30 minutes ago , it took 4 hours of searching and reading , linux has issues with Samsung ACPI , my netbook has intel 3150 GPU it installs the driver perfectly but you will not be able to control the brightness , there was a fix provided by "voRia" called "samsung-backlight" , claiming to fix the problem on ubuntu 9.04 and 10.04(which back track is based on) , still didnt fix it , so my fix is going to the terminal and writing the following command:
echo 4 > /sys/class/backlight/samsung/brightness ..... as the number determines the level of brightness and it was from 0 to 8 levels , i tried to put it in the panel as launcher but it only works in terminal , i wish if someone could tell me how to assign a command to a keyboard , like if i can assign it to the brightness shortcut key on my netbook that originally was made for windows acpi brighntess control , also i noticed if i removed the intel driver and rebooted the brightness control works natively with FN keys but when i bring back the driver it doesnt , so im guessing its a problem in the driver it self ,finally i want to say im not an expert in linux and i thought this might be a contribution

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.