Comment 36 for bug 595265

I thought I would post what finally worked for me albeit it is annoying it still worked.
I tried all the different suggestions here and nothing worked.
Then I started to wonder if it was a conflict with another account that was doing this.
I removed all my other accounts and without closing the "add account" window added my Fb account using my branded name (not email) as was suggested in #19 and the add button appeared.

Please note 2 things.
#1 I had already authorized my facebook account before this attempt so I did not get the over sized window this time as it detected I had already authorized it.

#2 For those of you that have the full window here is a solution I figured out by fluke.
Maximize the window then click the bottom of the visible part of the window and it will shift to the bottom half of the window and you can see all your buttons. Click the top half to go back up, my only note to this is by doing this it slightly offsets the place you have to click on buttons. For me it was the bottom 1/3 of the button that now worked and would high light when I hovered over it.

Hope this helps.
Selleena