Indicator applet shows 'setup broadcast accounts', even when accounts are setup and running

Bug #548814 reported by Ed Hewitt on 2010-03-26
250
This bug affects 47 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Installed the Lucid beta2 and when I set new accounts in gwibber they are setp fine but indicator messages still shows 'setup broadcast accounts' this happens unless we install python-indicate

chewit for large icons, its a known bug of the icon theme so converted this into one bug report

summary: - Large icons and Gwibber broken in Me Menu
+ Shows 'setup broadcast accounts' even accounts set and running
description: updated
affects: indicator-applet (Ubuntu) → indicator-messages (Ubuntu)
Changed in indicator-messages (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
importance: Medium → Low

Did this continue after a reboot? It seems like the messaging menu
isn't noticing Gwibber running at all. There is no running application
indicator either.

  status incomplete

Ted Gould (ted) on 2010-03-27
Changed in indicator-messages (Ubuntu):
status: Confirmed → Incomplete

I have rebooted, but no change.

If wont fix it, could you tell me a way to solve this problem.

James Gregory-Monk (jamgregory) wrote :

I installed Lucid on Thursday and successfully set up Gwibber with my Twitter and Facebook accounts. At this point, it said I had broadcast accounts set up. However, at some point between Thursday and Saturday, an update appears to have broken this. Even if I reboot and ensure Gwibber is running, the Messaging menu still shows 'Set up broadcast account'.

Omer Akram (om26er) wrote :

@Ted, at the moment I am running the Live session of 20100327 daily build I created gwibber account but still its showing 'setup broadcast accounts' chat and mail work fine after setting the accounts.

Omer Akram (om26er) on 2010-03-27
Changed in indicator-messages (Ubuntu):
status: Incomplete → New
Changed in indicator-messages (Ubuntu):
assignee: nobody → Indicator Applet Developers (indicator-applet-developers)
Josh Holland (jshholland) wrote :

I just saw this problem on my Lucid install. Clicking on the "Set up X" button gave the behaviour as expected if it were set up, and subsequently the icons were right.

Josh Holland (jshholland) wrote :

Actually, that's not true for the "Broadcast" one. I have Gwibber set up and running, but it still shows "Set up broadcast account". To clarify, clicking on the entry for the chat and mail opened the respective applications and changed the entries to just "Chat" and "Mail", clicking on "Set up broadcast accounts" opened up Gwibber but left "Set up broadcast accounts" in the applet.

Hey guys,

Could you please attach ~/.cache/indicators/messages/seen-db.keyfile
That file tracks all applications that the messaging menu has seen and
when entries get added there is when it changes the text on the menu
item.

 Thanks,
  Ted

A couple of hours ago i was going to report this bug (didn't know this was here).
When i logged into gnome it showed as "Set up broadcast account" without doing an updates I click on "set up...." and it opened the gwibber menu with my 3 accounts on it. Since than it has either shown a "> Broadcast" or just "Broadcast". I'm not real sure why it changed from "set" to broadcast"

Josh Holland (jshholland) wrote :

~/.cache/indicators/messages/seen-db.keyfile

Vitaly (vbabiy86) wrote :

Here is mine

David Barth (dbarth) on 2010-03-29
Changed in indicator-messages:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Medium
milestone: none → ubuntu-10.04-beta-2
status: New → Triaged
Omer Akram (om26er) on 2010-03-29
Changed in indicator-messages (Ubuntu):
status: New → Triaged
Ken VanDine (ken-vandine) wrote :

Can anyone still experiencing this check to see if python-indicate is installed? and make sure gwibber-service is running?

Steve Trout (steve-trout) wrote :

gwibber-service is running, but python-indicate is not installed.

Josh Holland (jshholland) wrote :

Same for me: gwibber-service is running, but no python-indicate

Ted Gould (ted) wrote :

Okay, I'm going to pass this over to Gwibber. It really needs to have a requires in the packaging for python-indicate.

affects: indicator-messages (Ubuntu) → gwibber (Ubuntu)
Changed in gwibber (Ubuntu):
assignee: Indicator Applet Developers (indicator-applet-developers) → nobody
affects: indicator-messages → null
Changed in null:
assignee: Ted Gould (ted) → nobody
milestone: ubuntu-10.04-beta-2 → none

same for me, gwibber-service is running, python-indicate not installed.

On Mon, Mar 29, 2010 at 11:15 AM, Josh Holland <email address hidden> wrote:

> Same for me: gwibber-service is running, but no python-indicate
>
> --
> Shows 'setup broadcast accounts' even accounts set and running
> https://bugs.launchpad.net/bugs/548814
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in NULL Project: Triaged
> Status in “gwibber” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: indicator-applet
>
> Even if gwibber has all accounts set it shows 'setup broadcast accounts' in
> the messaging menu this happened with the latest messaging menu updates.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Mar 26 13:52:34 2010
> DistroRelease: Ubuntu 10.04
> ExecutablePath: /usr/lib/indicator-applet/indicator-applet
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> NonfreeKernelModules: nvidia
> Package: indicator-applet 0.3.4-0ubuntu1
> ProcEnviron:
> LANG=en_GB.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
> SourcePackage: indicator-applet
> Uname: Linux 2.6.32-17-generic i686
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/null/+bug/548814/+subscribe
>

Installing python-indicate solved the problem here.

Omer Akram (om26er) wrote :

installed python-indicate then rebooted and it was still showing 'setup broadcast accounts' then clicked on it and as gwibber started messaging menu showed two entries of gwibber but 'setup broadcast accounts' was not there

Ken VanDine (ken-vandine) wrote :

python-indicate is a recommends for gwibber, not a dependency which is correct. The default install includes python-indicate, so it should use the messaging menu out of the box.

The dupe entries would be a different bug. I have only seen that when running gwibber from a source checkout.

Changed in gwibber (Ubuntu):
status: Triaged → Invalid
Omer Akram (om26er) wrote :

python-indicate is not installed by default. I checked in the manifest of todays' daily build and its not there either

I agree - I installed from beta1 fresh and it wasn't installed. I've just installed it now and that has fixed it.

In which case, why did this previously work (pre-27/03) and now doesn't?

Hugh Saunders (hughsaunders) wrote :

 Added branch of gwibber packaging with python-indicate dependency.

Hugh Saunders (hughsaunders) wrote :

Ahh, ignore me, I just read Ken's comment in #21, Gwibber doesn't _need_ to use the indicator menu to function, so python-indicate is not a dependency. So the problem is why isn't python-indicate being installed by default.

Maybe python-indicate should be a dependency of ubuntu-desktop or some other meta package?

Hugh Saunders (hughsaunders) wrote :

hugh@hugh-desktop:~/Projects/packaging$ apt-cache rdepends python-indicate
python-indicate
Reverse Depends:
  gajim
  gwibber-service

Now that is strange, as I had gwibber-service installed, but had to install python-indicate manually.

Conscious User (conscioususer) wrote :

Hugh, isn't your apt configured to treat recommendations as dependencies? I don't know if this affects discoverage of reverse-depends, but it might be the cause.

Conscious User (conscioususer) wrote :

As a side note, I thought recommended packages *were* installed in a default Ubuntu install. Isn't the whole indicator stack only recommended?

mikbini (mikbini) wrote :

Could this be related to bug #548540? In my case gwibber-service is running but non-functional (stuck somewhere eating up cpu until I kill it) and I never managed to see anything anything but "Set Up Broadcast Account...", even after setting up it.

Conscious User (conscioususer) wrote :

@mikbini: I think it's an unrelated issue, probably involving the keyring.

With respect to this report, dId you try installing python-indicate?

mikbini (mikbini) wrote :

@Conscious User: I just did that and it worked with a glitch: immediately after I log in the menu entry still reads "Set Up Broadcast Account...". After ~10 seconds it turns to "Broadcast"; I just suppose that gwibber-service needs some time to start up.

While this works and is quite acceptable, it's also quite different from the way the entries for mail and chat behave.

Matthew Ames (supermatt) wrote :

It has worked for me too, but the question is: why isn't this a gwibber dependency? How did this even get uninstalled?

Conscious User (conscioususer) wrote :

If I remember correctly, the long startup time (for both the service and the gui) is a bug being worked on. Once this is fixed, there will probably be no noticeable difference between Gwibber and the other two with respect to behavior.

Conscious User (conscioususer) wrote :

SuperMatt, read the comments above. It is not a Gwibber dependency because Gwibber does not need it to work. What is broken is proper integration with the desktop, so it should be a dependency of ubuntu-desktop or another meta package.

Tarek Loubani (tareko) on 2010-04-10
summary: - Shows 'setup broadcast accounts' even accounts set and running
+ Indicator applet shows 'setup broadcast accounts', even when accounts
+ are setup and running
Omer Akram (om26er) wrote :

python-indicate is certainly not in the default install.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Low → Medium
status: Invalid → Confirmed
Omer Akram (om26er) on 2010-04-11
description: updated
Morgan Collett (morgan) wrote :

I upgraded from karmic and I don't have python-indicate installed - so same problem as others have reported here.

Just installed a fresh copy of Intrepid Beta 2, updated and then tried to setup accounts. python-indicate not installed by default - I'm getting the same problem as reported in this thread.

*Sorry - I meant Lucid, not Intrepid!!!!

Ken VanDine (ken-vandine) wrote :

We need the indicate-python MIR approved, it is at bug 561508

Martin Pitt (pitti) wrote :

indicate-python is in main now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.95-0ubuntu3

---------------
gwibber (2.29.95-0ubuntu3) lucid; urgency=low

  * debian/control
    - Depend on python-indicate instead of recommend (LP: #548814)
 -- Ken VanDine <email address hidden> Tue, 13 Apr 2010 09:10:29 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Jamie Jones (jbjonesjr) wrote :

Has this been regressed back in? Current version of Gwibber (2.30.0.1-0ubuntu1 : http://packages.ubuntu.com/lucid/gwibber) no longer has a dependency on python-indicate? Gwibber-service does ( 2.30.0.1-0ubuntu1 : http://packages.ubuntu.com/lucid/gwibber-service), but didn't seem to install on my lucid upgrade.

I noticed this as I'm trying to debug this issue my Indicator/Me Menu not recognizing that Gwibber is set up correctly. This is with a Lucid upgrade that was installed with the release candidate, so pretty recently. While following this thread, I realized that I did not have python-indicate installed, even though gwibber and gwibber-service were installed (so where's the gwibber-service depends?). Also including my ~/.cache/indicators/messages/seen-db.keyfile.

crjackson (crjackson) wrote :

I have the same problem except that it's empathy rather than Gwibber. I went to add myself to the bug report for empathy but it directed me to this as a duplicate bug.

Should I report this somewhere else? It sure is annoying, I have three machines telling me to setup the accounts and they are already setup. What gives?

Peter Bomars (pbomars) on 2010-09-19
Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
Tudor Holton (tudor) wrote :

This bug appears to have resurfaced. Although I've manually installed python-indicate but I'm still getting the Gwibber "Broadcast Accounts" dialog pop up every 10-15 mins. It's getting pretty annoying. Since python-indicate is installed, does that make it a separate bug?

Ken VanDine (ken-vandine) wrote :

That would be a separate bug. It probably means you have an account failing to authenticate. One of the accounts should be highlighted in that UI.

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released

I still have this problem. I've manually installed python-indicate, but "Set Up Broadcast Accounts" /still/ appears in the indicator applet. I have three broadcast accounts configured (twitter, facebook, buzz), all have authenticated and are working fine. No accounts are highlighted in the "Broadcast Accounts" UI.

Running Maverick, gwibber/gwibber-service 2.33.0~bzr894-0ubuntu1~daily1

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers