gwibber or desktopcouch-service crashed with CancelledError in __init__()

Bug #542761 reported by Kernel-1 on 2010-03-20
494
This bug affects 141 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Սահակ

Bug Description

Binary package hint: gwibber

gwibber or desktopcouch-service crashed with CancelledError in __init__()

On liveCD of 10.04

bring up gwibber or desktopcouch-service either by memenu->Broadcast Accounts or Applications->Internet->Gwibber

Get New Keyring Password dialog. click 'cancel' -> crash

ProblemType: Crash
Architecture: amd64 (looks like present in both 32 and 64bit architecture according to duplicate bugs)
Date: Sat Mar 20 16:33:35 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gwibber
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: gwibber 2.29.92.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/bin/gwibber']
SourcePackage: gwibber
Title: gwibber crashed with CancelledError in __init__()
Uname: Linux 2.6.32-16-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Kernel-1 (oligofrenolog) wrote :
tags: removed: need-duplicate-check
Kamus (kamus) wrote :

Please could you upgrade to latest version of gwibber (2.29.94) and check if this problem is still affecting you? Thanks in advance!

visibility: private → public
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Սահակ (petrosyan) on 2010-04-07
Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
Kamus (kamus) wrote :

@Սահակ, please don't change status if you don't know what are you doing. @Kernel-1, any news about this issue? Thanks!

Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete
sebastian-s (sebastian-s) wrote :

I had another go at this bug with Gwibber 2.29.94-0ubuntu1 from the Beta2 ISO in Testdrive.
As I did not know how to add the apport report to this but I opened a new one, #559517

Kamus (kamus) wrote :

@Kernel-1, Please could you run under latest version of gwibber: gwibber --debug > gwibber-debug.log and attach output to your report (following those steps to reproduce this issue), Thanks!

Uncle Spellbinder (spellbinder) wrote :

 Just happened to me with fresh, fully updated install of Beta 2.

Morris Cavestro (fly82) wrote :

When I close gwibber I have this bug in livecd with pendrive

Սահակ (petrosyan) wrote :

this bug is still present in Ubuntu 10.04 Release Candidate.

gwibber crashes with 100% reproducibility when pressing the "Cancel" button.

tags: added: bugpattern-needed
tags: added: bugpattern-written
removed: bugpattern-needed
nUboon2Age (nuboon2age) on 2010-06-14
Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
nUboon2Age (nuboon2age) wrote :

Still present in released 10.04 liveCD (64 bit). Started Gwibber from the Applications->Internet menu, and canceled at the first New Keyring Password dialog box. Reproducible seemingly at will.

tags: added: iso-testing
nUboon2Age (nuboon2age) on 2010-06-14
summary: - gwibber crashed with CancelledError in __init__()
+ gwibber or desktopcouch-service crashed with CancelledError in
+ __init__()
nUboon2Age (nuboon2age) wrote :

Please see also Bug #527036 (now marked as duplicate of this one) in which Chad Miller, Frans and others had released a bug fix (apparently ineffective).

nUboon2Age (nuboon2age) on 2010-06-14
description: updated
description: updated
Omer Akram (om26er) wrote :

Most of gwibber crashes were caused by desktopcouch in Lucid. but in Maverick gwibber thankfully does not use desktopcouch. so this bug does not exist in Maverick

Kamus (kamus) wrote :

Since gwibber is not using desktopcouch as backend, I will mark this bug as fixed. Please fill any other problems that you can encounter. Thanks in advance

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Bilal Shahid (s9iper1) on 2012-02-22
Changed in gwibber:
status: New → Fix Released
To post a comment you must log in.