gwibber-service crashed with AttributeError in exclude_databases()

Bug #539583 reported by Greg Grossmeier on 2010-03-16
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Ken VanDine
gwibber (Ubuntu)
Medium
Ken VanDine
Lucid
Medium
Ken VanDine

Bug Description

Binary package hint: gwibber

Trying to start gwibber from the indicator applet. Nothing shows up except this crash report and one for the gwibber process, bug 539586, "gwibber crashed with DBusException in call_blocking()".

ProblemType: Crash
Architecture: amd64
CheckboxSubmission: b503beacb1fcaa6399875cf210a9514e
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Tue Mar 16 09:48:02 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
InterpreterPath: /usr/bin/python2.6
Package: gwibber-service 2.29.92.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with AttributeError in exclude_databases()
Uname: Linux 2.6.32-16-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public
description: updated
tags: removed: need-duplicate-check

Confirming because both I and Shane Fagan are experiencing this issue in Lucid.

Changed in gwibber (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in gwibber:
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Ryan Paul (segphault)
milestone: none → 2.30.0
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: High → Medium
milestone: none → ubuntu-10.04-beta-2
Shane Fagan (shanepatrickfagan) wrote :

Its fixed now :)
Its actually a problem with ubuntu one. If you
1. Log out of Ubuntu one
2. delete the .config/ubuntuone and .config/desktop-couch and .cache/ubuntuone and .cache/desktop-couch
3. Go to gnome-keyring (applications>passwords and encryption keys) and delete all the ubuntuone keys in there (it should be fairly obvious which ones they are)
4. Restart ubuntuone

From there you login to your account and gwibber should start working again.

Shane, that process isn't working for me, unless I didn't do something correctly.

1. I killed ubuntuone-syncdaemon and -login (and wasn't logged into the web interface)
2. yep
3. just had one OAuth key
4. started U1 via System-> Prefs -> U1
5. restarted and connected
6. launched gwibber from indicator-applet, same crash.

Shane Fagan (shanepatrickfagan) wrote :

Oh I forgot .local/desktop-couch
So do everything above and also delete .local/desktop-couch too

That worked, Shane.

If this works for everyone to resolve this issue, is there something else that should be done? Any new users experiencing this?

Jorge Castro (jorge) wrote :

I had this problem too, thanks for the fix Shane.

Shane Fagan (shanepatrickfagan) wrote :

No bother :)

Changed in gwibber:
assignee: Ryan Paul (segphault) → Ken VanDine (ken-vandine)
status: Triaged → Fix Committed
Changed in gwibber (Ubuntu Lucid):
status: Confirmed → Fix Committed

didn't work for me!!

Ken VanDine (ken-vandine) wrote :

The fix hasn't been released yet, it will be in the next Gwibber release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.93-0ubuntu1

---------------
gwibber (2.29.93-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Use MAX_MESSAGE_LENGTH for max length instead of hard coding 140
    - Changed the views to not emit the entire doc as a value
    - Set default focus to the text input widget (LP: #528302)
    - Made a string translatable, requested by the translations
      team (LP: #534667)
    - Patch from Gabor Kelemen setting translation domain for .ui
      files (LP: #538846)
    - Mark strings translatable, thanks Kelemen Gábor (LP: #520462)
    - Added X-GNOME-Gettext-Domain to allow translations of the desktop
      files to be loaded at runtime (LP: #538851
    - Use the desktopcouch API for excluding the DB and handle
      errors (LP: #539583)
    - Set window icons properly so they scale nicely
    - Set account IDs in desktopcouch to force merging on sync instead of
      creating dupes (LP: #535263)
  * debian/patches/lp_report_to_ubuntu.patch
    - File bugs against the package (LP: #551132)
 -- Ken VanDine <email address hidden> Wed, 17 Mar 2010 13:20:24 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-03-30
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers