Gwibber can show duplicate accounts

Bug #535263 reported by Jono Bacon on 2010-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
High
Ryan Paul
gwibber (Ubuntu)
High
Ken VanDine
Lucid
High
Ken VanDine

Bug Description

Binary package hint: gwibber

On a recent upgrade my Gwibber started showing duplicate icons underneath the text entry and each icon representated an existing account. As such I had two Twitter icons for the same account and two ideni.ca icons. Interestingly, only one Facebook icon. Unfortunately, it looked like this cause Gwibber to check each account twice, quickly meeting my Twitter rate limit and causing a delay in getting tweets.

I am not sure what caused this, but I think it may have been Ubuntu One. I installed a new system, expected to see my Gwibber accounts there and didn't, so I added them manually, and then I suspect Ubuntu One synced and we have multiple duplicate accounts.

My recommendation is that a check is made for duplicate accounts details (namely, the same username/password).

ProblemType: Bug
Architecture: i386
Date: Tue Mar 9 10:53:01 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100304)
Package: gwibber 2.29.91-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.24-generic
SourcePackage: gwibber
Uname: Linux 2.6.32-16-generic i686

Jono Bacon (jonobacon) wrote :
Jono Bacon (jonobacon) wrote :

I forgot to mention, to resolve this I went into gwibber-accounts and deleted the duplicate accounts - this seems to have resolved the refreshing issues.

Victor Vargas (kamus) on 2010-03-10
Changed in gwibber (Ubuntu):
importance: Undecided → Low
Ken VanDine (ken-vandine) wrote :

I think this is something we really need to resolve ASAP. A huge benefit of using desktopcouch for storage is the ability to sync (there are others), we should do our best to ensure that scenario works well.

Changed in gwibber (Ubuntu):
importance: Low → High
milestone: none → ubuntu-10.04-beta-2
status: New → Confirmed
Changed in gwibber:
assignee: nobody → Ryan Paul (segphault)
importance: Undecided → High
milestone: none → 2.30.0
status: New → Confirmed
Jamu Kakar (jkakar) wrote :

This same bug happened to me. I installed lucid/alpha3 (fresh
install) and added my accounts. For whatever reason, they got
"lost" after I restarted Gwibber. So I added them again. Then, a
few days ago I noticed that I had duplicates. I did the same as
Jono, removed the duplicates, and now things are working fine.

Omer Akram (om26er) on 2010-03-17
Changed in gwibber (Ubuntu Lucid):
status: Confirmed → Triaged
Changed in gwibber (Ubuntu Lucid):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber:
status: Confirmed → Fix Committed
Changed in gwibber (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.93-0ubuntu1

---------------
gwibber (2.29.93-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Use MAX_MESSAGE_LENGTH for max length instead of hard coding 140
    - Changed the views to not emit the entire doc as a value
    - Set default focus to the text input widget (LP: #528302)
    - Made a string translatable, requested by the translations
      team (LP: #534667)
    - Patch from Gabor Kelemen setting translation domain for .ui
      files (LP: #538846)
    - Mark strings translatable, thanks Kelemen Gábor (LP: #520462)
    - Added X-GNOME-Gettext-Domain to allow translations of the desktop
      files to be loaded at runtime (LP: #538851
    - Use the desktopcouch API for excluding the DB and handle
      errors (LP: #539583)
    - Set window icons properly so they scale nicely
    - Set account IDs in desktopcouch to force merging on sync instead of
      creating dupes (LP: #535263)
  * debian/patches/lp_report_to_ubuntu.patch
    - File bugs against the package (LP: #551132)
 -- Ken VanDine <email address hidden> Wed, 17 Mar 2010 13:20:24 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-03-30
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers