[FFe][jaunty] Please update gwget to 1.0.1 version

Bug #334164 reported by Artur Rona on 2009-02-25
14
Affects Status Importance Assigned to Milestone
gwget(2)
Invalid
Undecided
Unassigned
gwget2 (Ubuntu)
Wishlist
Scott Kitterman

Bug Description

2009-02-17 David Sedeño <email address hidden>

 * configure.ac: Version 1.0.1
 * NEWS: news for 1.0.1

2009-02-15 David Sedeño <email address hidden>

 * src/gwget_data.h: don't make gwget_pref be extern (fix the epiphany
 extension)
 * epiphany-extension/ephy-gwget-extension.c: Send the destination dir
 var in the call to gwget.
 * epiphany-extension/gwget.xml.in.in: Set author and url.
 * epiphany-extension/Makefile.am: Include @GNOME_CFLAGS@
 to INCLUDE_CFLAGS so it can find libgnomeui.h.
 * configure.ac: Detects Epiphany > 2.18. Patch from
 Christoph Wickert.
 * Changelog: Convert to UTF-8

Update fixing bugs:
https://bugs.launchpad.net/ubuntu/+source/gwget2/+bug/349952
https://bugs.launchpad.net/ubuntu/+source/gwget2/+bug/243921

Related branches

Artur Rona (ari-tczew) on 2009-02-25
Changed in gwget2:
assignee: nobody → ubuntu-universe-sponsors
Artur Rona (ari-tczew) on 2009-03-01
Changed in gwget2:
assignee: ubuntu-universe-sponsors → albrt
Changed in gwget:
assignee: nobody → motu
Colin Watson (cjwatson) on 2009-03-01
Changed in gwget:
assignee: motu → nobody
Albert Damen (albrt) on 2009-03-03
Changed in gwget2:
assignee: albrt → nobody
Artur Rona (ari-tczew) on 2009-03-03
description: updated
Changed in gwget2 (Ubuntu):
importance: Undecided → Wishlist
Alessio Treglia (quadrispro) wrote :
Download full text (4.9 KiB)

ChangeLog since 0.99 release:

2009-02-17 David Sedeño <email address hidden>

 * configure.ac: Version 1.0.1
 * NEWS: news for 1.0.1

2009-02-15 David Sedeño <email address hidden>

 * src/gwget_data.h: don't make gwget_pref be extern (fix the epiphany
 extension)
 * epiphany-extension/ephy-gwget-extension.c: Send the destination dir
 var in the call to gwget.
 * epiphany-extension/gwget.xml.in.in: Set author and url.
 * epiphany-extension/Makefile.am: Include @GNOME_CFLAGS@
 to INCLUDE_CFLAGS so it can find libgnomeui.h. Fix bug #571790.
 * configure.ac: Detects Epiphany > 2.18. Patch from
 Christoph Wickert. Fix bug #571789.
 * Changelog: Convert to UTF-8

2009-02-12 David Sedeño <email address hidden>

 * NEWS: news for 1.00
 * configure.ac: Bump version to 1.00
 * configure.ac: Require gio and not gnome-vfs.
 * src/gwget_data.c, src/main_window.c, src/main_window_cb.c,
 src/main.c: Port to gio for local operations.

2009-02-08 David Sedeño <email address hidden>

 * data/gwget.glade: Set url label ellipsize to FINAL.

2009-02-07 David Sedeño <email address hidden>

 * src/gwget-application{.c, .h}, src/gwget-application-service.xml,
   main.c: Add destination directory parameter to OpenURI method.
   Fixes: #562993

2009-02-06 David Sedeño <email address hidden>

 * data/gwget.glade: Set Radiobuttons in recursive window in a group.
 Fix bug #533152.
 * data/preferences.glade: Fix GtkSpinButton Adjustment.

2009-02-06 David Sedeño <email address hidden>

 Patch from Michael Fotsch <email address hidden> with:
 * src/gwget_data.c: Support of mp3 playlist: When gwget finishes
 downloading an .m3u file, it asks the user whether it should download
 the files that it contains. If yes, the files will be added as
 additional downloads.
 * src/wget_data.c: Parser for wget version 1.11.4
 * Moved check_url function to utils.{.c.h}
 * In several places, leading and trailing whitespace is stripped from
 the user-specified URL. (This is a common pitfall when inadvertently
 copying leading spaces or trailing newlines into the clipboard.)

2008-09-09 David Sedeño <email address hidden>

 * src/gwget_data.h: Ooops, forget to commit that.

2008-08-28 David Sedeño <email address hidden>

 * src/wget-log.c: More error reporting checking and better general log parsing and
 reporting. Thanks to Rick Benson for the patch. Fix #388990 and #332434.

2008-08-18 David Sedeño <email address hidden>

 * src/wget-log.c: Fix "resolving" parsing in log line. Thanks to Rich Benson for the
 patch. Fix #432981.

2008-05-22 David Sedeño <email address hidden>

 * configure.ac: Remove gwget.desktop (is in data/ now).
 * src/main.c: translate program description in --help output. Thanks to Gabor Kelemen
 for the patch. Fix #534108.

2008-05-20 David Sedeño <email address hidden>

 * Make desktop file translatable and moved to data/. Fix bug #530310.
 * data/gwget.glade: Fix translatable attributes. Fix bug #529953. Thanks to
 Gabor Kelemen for the patchs.

2008-01-08 David Sedeño <email address hidden>

 * Rename configure.in to configure.ac
 * Use po/LINGUAS
 * autogen.sh: Update
 * data/gwget.glade: fix icon size in menus. Fix bug #504764. Thanks to
 Colomban Wendling.
    Set vi...

Read more...

Artur Rona (ari-tczew) wrote :

@Alessio Treglia,
Can you make the .deb package for gwget 1.0.1?

Artur Rona (ari-tczew) wrote :

I've created patch which fixes bug with depends. Bug with debian/epiphany-extension-gwget.install is alive.

Artur Rona (ari-tczew) wrote :

I'm learning about creating .deb packages, so this is not-professionally patch.

Artur Rona (ari-tczew) wrote :

I've created packages for gwget 1.0.1.

Artur Rona (ari-tczew) on 2009-03-29
description: updated
Artur Rona (ari-tczew) on 2009-03-29
description: updated
Artur Rona (ari-tczew) wrote :

I've got gwget 1.0.1 on my ppa.
https://launchpad.net/~ari-tczew/+archive/ppa

Alessio Treglia (quadrispro) wrote :

Thanks for your work!

Your patch needs some love, I'm on it.

Changed in gwget2 (Ubuntu):
assignee: nobody → quadrispro
status: New → In Progress
Changed in gwget:
status: New → Invalid
Alessio Treglia (quadrispro) wrote :

Well, the package has been built fine and now is available in my PPA.

Please test it and give some feedback (taking a screenshot could be a good idea).

Changed in gwget2 (Ubuntu):
assignee: quadrispro → nobody
status: In Progress → Confirmed
Artur Rona (ari-tczew) wrote :

What is the different since your my-ppa -> your ppa? I guess gwget from my ppa is working good...

I just did a clean to the diff and also added a patch to fix the
.desktop files, but all other changes are the same (in fact the
package in my ppa is signed with your name)

If you tested it, could you attach a screenshot of the application?

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Artur Rona (ari-tczew) wrote :

Wait... I'm looking into changelog for your work:

  * debian/rules:
    - Add --with-epiphany-version=2.26 to configure options to build with
      epiphany 2.26.

What? debian/rules is the same like file from my patch. Why are you signing that you modified debian/rules, if you didn't this? I don't understand.

Alessio Treglia (quadrispro) wrote :

+gwget2 (1.0.1-0ubuntu1) jaunty; urgency=low
+
+ * New upstream release (LP: #334164)
+ - Update depends to depend on epiphany-gecko 2.26 (LP: #349952)
+ - Remove other patches, code provided by upstream
+ - New patch 62_epi-226, allows epiphany 2.26
+ - Closing (LP: #243921)

I didn't see that change in your changelog, I thought you didn't it.

However, I apologize for that, that's new changelog:

gwget2 (1.0.1-0ubuntu1) jaunty; urgency=low

  [ Artur Rona ]
  * New upstream release (LP: #334164, also fixes LP: #243921).
  * Bump-up Build-Depends on epiphany-browser-dev to >= 2.26.
  * Depends on newer epiphany-gecko (LP: #349952).
  * Drop old patches, applied by upstream.
  * Add 62-epi_226.patch to allow building with epiphany 2.26.
  * debian/rules:
    - Add --with-epiphany-version=2.26 to configure options to build with
      epiphany 2.26.

  [ Alessio Treglia ]
  * debian/patches/01-fix_desktop_menu.patch:
    - Fix the desktop file according with Freedesktop.org spec.

 -- Artur Rona <email address hidden> Tue, 31 Mar 2009 23:18:45 +0200

There isn't anything new in that, you could report here the result of your tests, after ACK'ing by motu-sru I will upload this last review.

Artur Rona (ari-tczew) wrote :

Gwget is working good, but I've problem with shortcut in menu. No changes with 01-fix_desktop_menu.patch or no patch. May be this is problem only on my desktop.

Alessio Treglia (quadrispro) wrote :

As you can see, that patch fixes some little issues within .desktop file, which doesn't follow all Freedesktop.org specifications.

Which test did you do? Can you attach a screenshot please? I've installed the package on jaunty UNR beta, I couldn't have the necessary time for testing it but I can remember well that launcher has been installed fine.

Artur Rona (ari-tczew) wrote :

I remember that last version (0.99*) installed icon in menu. If your patch doing same things, I don't care about it. You can continue uploading packages.

Alessio Treglia (quadrispro) wrote :

http://www.uploadgeek.com/share-1F2D_49D3BC59.html

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Artur Rona (ari-tczew) wrote :

OK, so package is working good. I'm waiting for upload to jaunty repos.

Benjamin Drung (bdrung) wrote :

I have made some changes (drop --with-epiphany-version; epi-226.patch patches configure.ac instead of configure; autoreconf patch for generating the configure script). Here is the new changelog:

gwget2 (1.0.1-0ubuntu1) jaunty; urgency=low

  [ Artur Rona ]
  * New upstream release (LP: #334164, #243921).
  * Bump-up Build-Depends on epiphany-browser-dev to >= 2.26.
  * Depends on newer epiphany-gecko (LP: #349952).
  * Drop all old patches, applied by upstream.
  * Add 02-epi_226.patch and 03-autoreconf.patch to allow building with
    epiphany 2.26.
  * debian/rules: Drop --with-epiphany-version from configure options; the
    version is detected automatically.
  * Bump Standards-Version to 3.8.0.

  [ Alessio Treglia ]
  * debian/patches/01-fix_desktop_menu.patch:
    - Fix the desktop file according with Freedesktop.org spec.

 -- Artur Rona <email address hidden> Tue, 31 Mar 2009 23:18:45 +0200

Benjamin Drung (bdrung) wrote :

Here is the diff file for the debian directory and without the 03-autoreconf.patch. In this diff file you can see the changes better.

Artur Rona (ari-tczew) wrote :

@Benjamin Drung
Gwget 1.0.1 needs to 03-autoreconf.patch? You first made debdiff with 03-autoreconf.patch, later made without it... I'm so confused. The version 1.0.1 must get into jaunty repos and please tell me, what is the finally decision?

Artur Rona (ari-tczew) wrote :

Ok, I understand your post Benjamin.

@Alessio Treglia
I've made test for 01-fix_desktop_menu.patch and with or without patch, icon in menu is display@guest session :)

The new packages will be available soon on my ppa.

Benjamin Drung (bdrung) wrote :

Yes, it needs 03-autoreconf.patch. The first file is the real debdiff file. The second file is for having a quick look at the changes made to the debian directory.

Please have a look at "FeatureFreeze for new upstream versions" at [1]. When you have added all files listed on the wiki, we have to wait, till two people from the MOTU Release Team acknowledge the feature freeze exception.

[1] https://wiki.ubuntu.com/FreezeExceptionProcess

Artur Rona (ari-tczew) wrote :

Packages are available on my PPA. Please test it.

Artur Rona (ari-tczew) wrote :

From me, packages works good.

Artur Rona (ari-tczew) wrote :

gwget2 (1.0.1-0ubuntu2~ppa) jaunty; urgency=low

  [ Artur Rona ]
  * New svn update (LP: #334164, #243921).
  * Bump-up Build-Depends on epiphany-browser-dev to >= 2.26.
  * Depends on newer epiphany-gecko (LP: #349952).
  * Drop all old patches, applied by upstream.
  * debian/rules: Drop --with-epiphany-version from configure options; the
    version is detected automatically.
  * Bump Standards-Version to 3.8.0.

 -- Artur Rona <email address hidden> Sun, 12 Apr 2009 01:51:58 +0200

I've created new packages. Source is sync with svn rev. 639, because it has got applied 01-fix_desktop_menu.patch & 02-epi_226.patch and now translations are refreshed. Svn's small changes, so this is still stable package. Package has been built fine and now is available in my PPA.

@Benjamin
Could you review this, please?

Alessio Treglia (quadrispro) wrote :

Marking as "New" because we're waiting for an ACK by a MOTU release manager

Changed in gwget2 (Ubuntu):
status: Confirmed → New
Nathan Handler (nhandler) wrote :

ACK #1 from me. However, the patch itself needs a little work before it can be uploaded. For instance, the version in debian/changelog is wrong. Also, you should attach a .diff.gz instead of a debdiff for upgrades like this.

Artur Rona (ari-tczew) wrote :

Gwget is available on my-ppa, so you can get source from my-ppa's repository and change what you need.
https://launchpad.net/%7Eari-tczew/+archive/ppa/+files/gwget2_1.0.1-0ubuntu2~ari.diff.gz

Artur Rona (ari-tczew) wrote :

There is rebuilded version 1.0.1-0ubuntu3. I can't upload version *ubuntu1 or 2, because:
Rejected:
The source gwget2 - 1.0.1-0ubuntu1 is already accepted in ubuntu/jaunty and you cannot upload the same version within the same distribution. You have to modify the source version and re-upload.
https://launchpad.net/~ari-tczew/+archive/ppa/+files/gwget2_1.0.1-0ubuntu2_1.0.1-0ubuntu3.diff.gz

Benjamin Drung (bdrung) wrote :

I have fixed debian/watch, now you can grab the source package with uscan. Now it is also possible to run debuild twice.

gwget2 (1.0.1-0ubuntu1) jaunty; urgency=low

  [ Artur Rona ]
  * New upstream release (LP: #334164, #243921).
  * Bump-up Build-Depends on epiphany-browser-dev to >= 2.26.
  * Depends on newer epiphany-gecko (LP: #349952).
  * Drop all old patches, applied by upstream.
  * Add 02-epi_226.patch and 03-autoreconf.patch to allow building with
    epiphany 2.26.
  * debian/rules: Drop --with-epiphany-version from configure options; the
    version is detected automatically.
  * Bump Standards-Version to 3.8.0.

  [ Alessio Treglia ]
  * debian/patches/01-fix_desktop_menu.patch:
    - Fix the desktop file according with Freedesktop.org spec.

  [ Benjamin Drung ]
  * Fix debian/watch.
  * debian/rules: Remove data/org.gnome.gwget.service on clean target.

 -- Benjamin Drung <email address hidden> Sun, 19 Apr 2009 14:14:25 +0200

Benjamin Drung (bdrung) wrote :
Iulian Udrea (iulian) wrote :

Ack #2

Exception granted.

Is there any reason why you bumped the standards version to 3.8.0? If not, please don't change it.

Changed in gwget2 (Ubuntu):
status: New → Confirmed
Artur Rona (ari-tczew) wrote :

This is my first work on debian packages. While build package, I saw message, that standards version are out-of-date, so I change this to 3.8.0. Sorry for confuse.

Benjamin Drung (bdrung) wrote :

According to upgrading-checklist.txt (in the debian-policy package) the Homepage field was introduced with standards version 3.8.0.

Ubuntu has a policy of not changing the standards version in packages we
get from Debian. If the package isn't in Debian at all, then the standards
version change is appropriate if the package meets all the 3.8.0
requirements (don't make additional changes to achiev this right now).

Changed in gwget2 (Ubuntu):
assignee: nobody → kitterman
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwget2 - 1.0.1-0ubuntu1

---------------
gwget2 (1.0.1-0ubuntu1) jaunty; urgency=low

  [ Artur Rona ]
  * New upstream release (LP: #334164, #243921).
  * Bump-up Build-Depends on epiphany-browser-dev to >= 2.26.
  * Depends on newer epiphany-gecko (LP: #349952).
  * Drop all old patches, applied by upstream.
  * Add 02-epi_226.patch and 03-autoreconf.patch to allow building with
    epiphany 2.26.
  * debian/rules: Drop --with-epiphany-version from configure options; the
    version is detected automatically.

  [ Alessio Treglia ]
  * debian/patches/01-fix_desktop_menu.patch:
    - Fix the desktop file according with Freedesktop.org spec.

  [ Benjamin Drung ]
  * Fix debian/watch.
  * debian/rules: Remove data/org.gnome.gwget.service on clean target.

 -- Benjamin Drung <email address hidden> Sun, 19 Apr 2009 14:14:25 +0200

Changed in gwget2 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers