all disks and partitions are automounted in the live session

Bug #451613 reported by Tormod Volden on 2009-10-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt

Bug Description

Binary package hint: gvfs

On the 20091014.1 Desktop CD, all partitions are automounted.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 14 20:32:38 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091014.1)
Package: gvfs 1.4.0-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: gvfs
Uname: Linux 2.6.31-14-generic i686

Tormod Volden (tormodvolden) wrote :
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Hm, I cannot reproduce this on the current live CD. I have two HD partitions there, and neither is mounted automatically. Just when I browse them in nautilus and click on them they get mounted (without an authorization dialog, since the ubuntu user is an admin and has no password).

Can you please submit the output of "mount" and "gvfs-mount -li" right after booting the live system? I get

    can_mount=1
    should_automount=0

for the internal hd partitions.

Changed in gvfs (Ubuntu):
status: New → Incomplete
Tormod Volden (tormodvolden) wrote :

Too late, I have rebooted :) I will check tomorrow.

Tormod Volden (tormodvolden) wrote :

Ah with the freeze tomorrow, one last effort :)

Tormod Volden (tormodvolden) wrote :
Martin Pitt (pitti) wrote :

So, let's first confirm that it is nautilus, and not something else. Please boot the live CD, unmount all the partitions, then log out and back in in gdm with the "xterm" session. Run "metacity &" to get a WM, and perhaps "gnome-terminal" to get a multi-tab terminal.

Run "gnome-mount -oi" in one terminal, and then first check in another if you get any automounts (then it'd be gvfs, but I don't quite believe that). Then start nautilus, and check again if that mounted your drives. After that, please copy&paste the "gnome-mount -oi" output (just in case; I figure it will just show that the partitions where mounted, but let's see).

Thanks!

Martin Pitt (pitti) wrote :

Ah, I can reproduce this on my wife's computer, but not in kvm. How odd.

Changed in gvfs (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

So it seems to happen if gvfs-gdu-volume-monitor starts up and triggers dk-disks to start.

Martin Pitt (pitti) on 2009-10-15
Changed in gvfs (Ubuntu Karmic):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

I'm going to mark this RC, since this has the potential of damaging file systems (hibernated ones, changing fsck timestamps, etc.), and the live system isn't supposed to touch your existing system.

Changed in gvfs (Ubuntu Karmic):
milestone: none → ubuntu-9.10
Martin Pitt (pitti) wrote :

Ah, I figured out why it only happens sometimes. gdu monitor's update_volume() sets automount flag to TRUE in general. However, it is set to FALSE if the media detection time is older than the "new volume" detection by 5 seconds or more. Thus if dk-disks was already running, starting gvfs will usually set automount to FALSE since the difference will be more than 5 seconds. The rationale is:

      /* If a volume (partition) appear _much later_ than when media was insertion it
       * can only be because the media was repartitioned. We don't want to automount
       * such volumes.
       */

But if gvfs-gdu-volume-monitor triggers dk-disks startup, the "last media detection" time will be almost equal to "new volume", and automount will be TRUE.

I think we should generally disable automounting for system internal drives.

Martin Pitt (pitti) on 2009-10-19
Changed in gvfs (Ubuntu Karmic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.4.0-0ubuntu6

---------------
gvfs (1.4.0-0ubuntu6) karmic; urgency=low

  * Add 04_dont_automount_internal_partitions.patch: Disable automounting for
    internal partitions. This avoids automounting them on the live system.
    This does not change behaviour in installed system, since internal
    partitions require polkit authorization, and those do not get automounted.
    (LP: #451613)

 -- Martin Pitt <email address hidden> Mon, 19 Oct 2009 13:54:30 +0200

Changed in gvfs (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → Fix Released
Yuan Chao (yuanchao) wrote :

On 12.10, the live session also mounts all my harddisk partitions. (disk icons show up on the unity left panel) As the ext4 partitions are still mounted in a hibernated session, the mounting caused file system error after resuming and failed to boot. (recover mode fails too) I would suggest that this kind of behavior in live session should be done in read only mode if it's really needed. Same for hibernated windows partitions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.