nautilus does not recognize music cd

Bug #395470 reported by rashman00 on 2009-07-04
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Brasero
New
Medium
gvfs
Expired
High
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

i inserted a music cd to be played by rhythmbox, but it was not seen. After opening nautilus, i noticed it did not mount it automatically.

rashman00 (ryan-raasch) wrote :

forgot to say.

mplayer could play with cdda://

AND
sound-juicer could rip it.

BUT

rhythmbox could not see music disk.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, audio cds are not mounted that's expected, could you run "gvfs-mount -li" with the cd in the drive and "devkit --show-info <device>" where device is your cdrom device and copy the logs there?

summary: - [karmic] nautilus does not recognize music cd
+ nautilus does not recognize music cd
Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

Sebastien Bacher wrote:
> Thank you for your bug report, audio cds are not mounted that's
> expected,

Oh. Thanks. That makes sense. But how then can one play a music cd from
nautilus?

could you run "gvfs-mount -li" with the cd in the drive and
> "devkit --show-info <device>" where device is your cdrom device and copy
> the logs there?

$gvfs-mount -li

Volume(0): cdrom0
   Type: GUnixVolume
   ids:
    unix-device: '/dev/scd0'
   themed icons: [drive-optical] [drive]
   can_mount=1
   can_eject=1
   should_automount=1
Mount(0): Movies-2 -> file:///home/ryan/Movies-2
   Type: GUnixMount
   themed icons: [drive-harddisk] [drive]
   can_unmount=1
   can_eject=0
   is_shadowed=0

$devkit --show-info (Wrong syntax).

SO. I tried.

$ devkit --native-path /cdrom
$ devkit --native-path /dev/sr0

But no output.

BTW. I tried nautilus again, and the cdrom shows up, but can't mount or
play it. I also tried ryhthmbox again, but no dice.

Ryan

>
> ** Summary changed:
>
> - [karmic] nautilus does not recognize music cd
> + nautilus does not recognize music cd
>
> ** Changed in: nautilus (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: nautilus (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: nautilus (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>

Sebastien Bacher (seb128) wrote :

the issue seems a devicekit-disks one

affects: nautilus (Ubuntu) → devicekit-disks (Ubuntu)
Changed in devicekit-disks (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → New
Martin Pitt (pitti) wrote :

I can reproduce this. dk-disks is fine, it recognizes the medium. gvfs also sees it:

$ gvfs-mount -o
Monitoring events. Press Ctrl+C to quit.
Drive changed: 'Optiarc DVD+-RW AD-5560A'
Drive disconnected: 'Optiarc DVD+-RW AD-5560A'

However, there is no actual gvfs cdda:// volume for the audio CD. Banshee sees it just fine, but Rhythmbox and nautilus don't. So I suspect this is a problem in gvfs' cdda backend.

affects: devicekit-disks (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Low → Medium
status: New → Triaged
Jud Craft (craftjml+ubuntulp) wrote :

Upstream bugs.

GVFS
http://bugzilla.gnome.org/show_bug.cgi?id=594398

Brasero
http://bugzilla.gnome.org/show_bug.cgi?id=591640

This is a problem on Fedora as well. Since Banshee can still read and detect burned audio CDs just fine, maybe that means it has something to do with the recent HAL->Udev migration in GVFS, which is detailed at https://wiki.ubuntu.com/Halsectomy.

Check that page. What programs use GVFS? Nautilus, Rhythmbox, Brasero, Sound Juicer. Banshee still uses HAL (in the older 1.4.x series).

Which one still detects CDs? Banshee.

So until this gets fixed, this is a big problem. I can't read or rip any CDs that my iTunes-using friends make for me, for example.

In addition, since Nautilus can't detect the drive, GNOME programs cannot eject the disc when an audio CD is inside. (You can't call the "eject" operation on a drive that disappears in GVFS).

My guess is, this is a regression in the GVFS refactoring that didn't get caught.

Martin Pitt (pitti) on 2009-09-09
tags: added: regression-potential
tags: added: regression-release
removed: regression-potential
Martin Pitt (pitti) wrote :

I tested this on current lucid, and it works fine. Please yell if you still have problems.

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Florent Mertens (givre) wrote :

I just got this problem with an audio CD.
Exact same beahviour :

[Before inserting the dic]
flo@flo-laptop:~$ gvfs-mount -li
Drive(0): 60 GB Hard Disk
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sda'
  themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
  is_media_removable=0
  has_media=1
  is_media_check_automatic=0
  can_poll_for_media=0
  can_eject=0
  can_start=0
  can_stop=0
  start_stop_type=unknown
  Volume(0): 66 MB Filesystem
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     uuid: '6ee62768-822d-43d7-8525-737950a49256'
     unix-device: '/dev/sda1'
    themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
    can_mount=1
    can_eject=0
    should_automount=0
  Volume(1): 15 GB Filesystem
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     uuid: 'ead9c39f-c83f-4f93-a740-da192c932853'
     unix-device: '/dev/sda2'
    themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
    can_mount=1
    can_eject=0
    should_automount=0
    Mount(0): 15 GB Filesystem -> file:///media/disk-2
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      default_location=file:///media/disk-2
      themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
      can_unmount=1
      can_eject=0
      is_shadowed=0
  Volume(2): MUSIQUE
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     uuid: '43C0-343B'
     unix-device: '/dev/sda4'
     label: 'MUSIQUE'
    themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
    can_mount=1
    can_eject=0
    should_automount=0
    Mount(0): MUSIQUE -> file:///media/documents
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      default_location=file:///media/documents
      themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
      can_unmount=1
      can_eject=0
      is_shadowed=0
Drive(1): CD/DVD Drive
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sr0'
  themed icons: [drive-optical] [drive]
  is_media_removable=1
  has_media=0
  is_media_check_automatic=1
  can_poll_for_media=1
  can_eject=0
  can_start=0
  can_stop=0
  start_stop_type=unknown
flo@flo-laptop:~$ gvfs-mount -o
Monitoring events. Press Ctrl+C to quit.
[I insert the disc]
Drive changed: '_NEC DVD+-RW ND-6500A'
Drive disconnected: '_NEC DVD+-RW ND-6500A'
Drive connected: 'CD/DVD Drive'

Changed in gvfs (Ubuntu):
status: Fix Released → Confirmed
Florent Mertens (givre) wrote :

I forgot to say that :

Drive connected: 'CD/DVD Drive'

appear after i ejected the disc.

Martin Pitt (pitti) on 2010-04-01
Changed in gvfs (Ubuntu):
assignee: Martin Pitt (pitti) → Ubuntu Desktop Bugs (desktop-bugs)
kmb42vt (tbeposts) wrote :

I'm currently testing 10.04 beta 1 and have encountered something of the same problems not only with an audio CD but any CD/DVD (movie, audio or data). Insert a CD/DVD of any type into either of my optical drives (one burner and one player) and the respective drive disappears completely from Nautilus. Eject the disc and the drive reappears in Nautilus.

This did not occur in 9.10 and doesn't occur in Linux Mint 8.

Out of curiosity I booted the same machine using the Ubuntu 10.04 beta 1 Live CD (that I burned on this same machine using Brasero in Linux Mint 8) and the same problem occurs.

jacrider (andrew-thecallums) wrote :

I just upgraded to 10.04 LTS both with an upgrade from 9.10 and subsequently through a clean install of 10.04 LTS x64 from the install CD.

I am having difficulty mounting optical media. Sometimes it will mount a disk, but often it will "unmount" on its own without any input either from the user or any application. Often this happens while the drive is in use - my experience has been with Sound Juicer.

My only recourse is to reboot the machine.

I was not experiencing these problems in 9.10 to my knowledge.

Changed in gvfs (Ubuntu):
status: Confirmed → Triaged
Changed in gvfs:
importance: Unknown → High
status: Unknown → New
Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.