DBus error org.gtk.Private.RemoteVolumeMonitor.Failed

Bug #355522 reported by sloper on 2009-04-05
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Unassigned

Bug Description

DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

Fout org.freedesktop.DBus.Error.NoReply. can,t mount a external HD

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

hazylazysusan (hazylazysusan) wrote :

Yes, this happens when I try to mount an external drive, by clicking the drive in "Computer" in Nautilus.

And I found this https://bugzilla.redhat.com/show_bug.cgi?id=492242 Bug 492242 - Mounting NTFS or HFS drives displays seemingly pointless message "An operation is already pending"

"Description of problem:
As I was testing the nouveau driver using the Test Day 2009-03-25 Live CD, I
found that attempting to mount my HFS+ or NTFS internal partitions displayed
this error message:

Unable to mount location
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already
pending

However, after a second or two the partitions mounted as usual.

Version-Release number of selected component (if applicable):
Test Day 2009-03-25 Live CD

How reproducible:
Always

Steps to Reproduce:
1. Select Places > Computer from the menu
2. Attempt to mount HFS+ or NTFS volumes

Actual results:
Error message: "DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An
operation is already pending" as the volume is being mounted

Expected results:
Volumes mount without the error message being displayed

Additional info:
I was running off of a CD, not USB media- maybe the operation was just taking
longer than expected because of the slow read speeds?
"

travellinggreg (geliovson) wrote :

This happens for me too but with a dvdin my dvd drive.

I only get this message:
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

Rarian Rakista (rakista) wrote :

Replicated on 2 machines with 9.04

This happens only on my SATA drives when trying to access an NTFS volume

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

IDE works on one, no problems accessing NTFS volumes on it.

affects: ubuntu → gvfs (Ubuntu)
KevinM (kevbert1) wrote :

I get this with Kernel 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64

Changed in gvfs (Ubuntu):
importance: Undecided → Low
Kriptus (kriptus) wrote :

I have same error ! :(

Linux kriptus-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

echo73 (fleetadmiral73) wrote :

I receive DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

But only on the second CD, or USB drive or whatever. The first one I use works fine, the second will not open properly, and I get the message above. Currently using Ubuntu 64-bit, with SATA drives, newest kernel via regular update methods, on a System76 Wildebeest system.

zob (zob) wrote :

Same error here mounting USB-drives on ubuntu 9.10 kernel 2.6.31-19-generic.

I addition I get different errors trying to mount other driver. F.ex. this one:
Error mounting: mount exited with exit code 13: Error reading bootsector: Input/output error
Failed to mount '/dev/sdc2': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Or things like this in my syslog:
Feb 13 14:26:51 lars-desktop kernel: [ 1323.088743] sd 5:0:1:0: [sdc] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Feb 13 14:26:51 lars-desktop kernel: [ 1323.088748] end_request: I/O error, dev sdc, sector 204796620
Feb 13 14:26:51 lars-desktop kernel: [ 1323.088754] __ratelimit: 294 callbacks suppressed
Feb 13 14:26:51 lars-desktop kernel: [ 1323.088758] Buffer I/O error on device sdc2, logical block 0
Feb 13 14:26:51 lars-desktop kernel: [ 1323.088762] Buffer I/O error on device sdc2, logical block 1
etc...

Or these ones (in syslog as well):
Feb 13 14:17:12 lars-desktop kernel: [ 743.382648] sd 5:0:1:0: [sdc] Unhandled error code
Feb 13 14:17:12 lars-desktop kernel: [ 743.382654] sd 5:0:1:0: [sdc] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Feb 13 14:17:12 lars-desktop kernel: [ 743.382659] end_request: I/O error, dev sdc, sector 294594137
Feb 13 14:17:12 lars-desktop kernel: [ 743.382664] __ratelimit: 112 callbacks suppressed
Feb 13 14:17:12 lars-desktop kernel: [ 743.382668] Buffer I/O error on device sdc5, logical block 786448
Feb 13 14:17:12 lars-desktop kernel: [ 743.382671] lost page write due to I/O error on sdc5

I'm currently booting without ureadhead/sreadahead because I thought it was part of the problem (I was getting a lot of ureadahead errors in syslog to), but it didn't seem to fix it. Here's an example of the ureadahead error I was getting:
Feb 13 12:51:06 lars-desktop init: ureadahead-other main process (11318) terminated with status 4
Feb 13 12:51:06 lars-desktop init: ureadahead-other main process (11325) terminated with status 4
Feb 13 12:51:06 lars-desktop init: ureadahead-other main process (11332) terminated with status 4
Feb 13 12:51:06 lars-desktop init: ureadahead-other main process (11339) terminated with status 4
etc...
It would go on forever like that.

Paco Riviere (pacoriviere) wrote :

This same bug makes my usb drives and usb-mouse useless, working with my desktop an impossible nightmare.

Tried to restart /inid.d/udev and this made the system to freeze.

May somebody change the importance please?

Changed in gvfs (Ubuntu):
assignee: nobody → vibhor.nakshine87@gmail.com (vibhor-nakshine87)
status: New → Fix Committed
Changed in gvfs (Ubuntu):
assignee: vibhor.nakshine87@gmail.com (vibhor-nakshine87) → nobody
status: Fix Committed → Invalid
Savvas Radevic (medigeek) wrote :

Why was this set as invalid without any explanation?
I have the same error using ubuntu 11.04 with an ntfs usb flash drive:

Unable to mount x
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

Changed in gvfs (Ubuntu):
status: Invalid → Confirmed
Savvas Radevic (medigeek) wrote :

Hm, not the same case as mine, I have to file a new bug probably :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.