"DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending" on CD eject attempt

Bug #366076 reported by David Kohen on 2009-04-24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-mount (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Ubuntu 9.04 - Jaunty.
All updates applied.
Upgraded from intrepid.
gvfs 1.2.2-0ubuntu1

I put a DVD in the drive (DVD-ROM, no video) and saw the nautilus window open.
I pressed the eject button on the drive and received this error:
Unable to eject CD-RW/DVD±RW Drive
DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

I expected the DVD to eject, or to receive a device busy message.
The command-line "eject" works like a charm, but the gnome option doesn't.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, does gnome-eject works when you get the issue?

Changed in gvfs (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
David Kohen (kohen-d) wrote :

gnome-eject returns without doing anything and doesn't give out any error.
When trying with -v it outputs the version:
$ gnome-eject -ve /media/cdrom0/
gnome-mount 0.8

Should it be run with sudo? the normal eject works without superuser privs...

Sebastien Bacher (seb128) wrote :

what about gnome-eject -vbd device?

David Kohen (kohen-d) wrote :

-vbd works...
So I assume this means it's not a gnome-mount issue?

gnome-eject -vbd /dev/sr0
gnome-mount 0.8
** (gnome-eject:22332): DEBUG: Ejecting /org/freedesktop/Hal/devices/volume_label_MyPal_Bonus_CD
Device /dev/sr0 is in /etc/fstab with mount point "/media/cdrom"
Ejected /dev/sr0 (using /etc/fstab).

Sebastien Bacher (seb128) wrote :

that doesn't really makes sense nautilus only call gnome-eject

David Kohen (kohen-d) wrote :

Doesn't nautilus call gnome-eject using D-Bus?
Could it be a D-Bus issue?

Sebastien Bacher (seb128) wrote :

no, it doesn't use dbus, you can probably see the command used by looking at the processus displaying the error dialog you get

David Kohen (kohen-d) wrote :

It turns out that my fstab contained /media/cdrom as a mountpoint, even though it is a soft-link...
and it tried to umount according to it, so it failed.
I got another message as well:

There was an error ejecting the volume or drive.
org.freedesktop.Hal.Device.Volume.UnknownFailure: eject: tried to use `/media/cdrom0' as device name but it is no block device
eject: tried to use `/media/cdrom0' as device name but it is no block device
eject: unable to find or open device for: `/media/cdrom'

adding a 0 to the mountpoint in fstab did the trick, but gnome-mount should be able to handle these soft-links, just like command line mount does.
Can you change the priority to wishist?

Sebastien Bacher (seb128) wrote :

could you describe exactly how to configure it in a buggy way?

affects: gvfs (Ubuntu) → gnome-mount (Ubuntu)
Changed in gnome-mount (Ubuntu):
importance: Low → Wishlist
David Kohen (kohen-d) wrote :

this line in /etc/fstab
/dev/cdrom /media/cdrom iso9660 noauto,ro,user,exec 0 0

Sebastien Bacher (seb128) wrote :

using that line cdrom directory should just be used to mount and unmount the cd no?

David Kohen (kohen-d) wrote :

$ ls -ld /media/cd*
lrwxrwxrwx 1 root root 6 2009-04-03 15:12 /media/cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2009-04-03 15:12 /media/cdrom0
drwxr-xr-x 2 root root 4096 2009-04-03 15:12 /media/cdrom1

Sebastien Bacher (seb128) wrote :

to confirm and send to bugzilla.gnome.org by somebody having the issue

Changed in gnome-mount (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → New
David Kohen (kohen-d) wrote :

What does your last comment mean?

Sebastien Bacher (seb128) wrote :

it means that the bug is waiting for a bug triager now to use your instruction to confirm the bug and send to the people writting the code to the GNOME bug tracker, ubuntu only distribute the software and doesn't write it

usr (usrlp) wrote :

The same for me, with a clean installation of Ubuntu 9.04, after I canceled a dvd-burn simulation.

"DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending"

David Kohen (kohen-d) wrote :

Paste the contents of your /etc/fstab please.

The same to me.

The contents of my /etc/fstab is:

proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=9b05cd4d-86c4-480e-aeb9-02c833280190 / ext4 relatime,errors=remount-ro 0 1
# /home was on /dev/sda3 during installation
UUID=d587d1b8-d116-45f2-a73d-b929973235bf /home ext4 relatime 0 2
# swap was on /dev/sda5 during installation
UUID=b3d1cde0-7c57-4c79-aedb-19fb4ee62632 none swap sw 0 0

Bryce Harrington (bryce) wrote :

I'm able to confirm this against karmic with current updates as of Aug 25th. Steps I used to reproduce:

1. Open nautilus to /media
2. Insert disk, wait for it to automount (new window pops up)
3. In /media window, right click. "Unmount" is shown, but "Eject" isn't (bug 419450)
4. Click Unmount. Dbus error message is shown.

seb128, this bug looks worthwhile to send upstream. At the least, the error message could be made less cryptic since it's going to be quite easy for end users to run into.

Changed in gnome-mount (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-mount (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers