gvfs-fuse-daemon halted with futex_wait signal

Bug #320581 reported by mlissner on 2009-01-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Unknown
Critical
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs-fuse

Since installing intrepid, I have had trouble with programs freezing. From what I have determined, it is caused by thread locking, and gvfs-fuse-daemon.

The way to make it happen seems to be to use my computer for a while, and then sooner or later, a program freezes. When it does, if I open system monitor, it will show the waiting signal for the frozen program to be futex_wait, and will show the waiting signal for gvfs-fuse-daemon to be futex_wait.

I've tried to find information about futexes, but the web is pretty quiet on the matter. This bug seems similar to bug 303190, but I think it's different.

The only solution I have found to this bug is to kill the application that is frozen. This has happened to:
 - gnome-panel
 - gnome-do
 - firefox
 - eclipse
 - python
 - getty (I think)
 - and a few others

Every now and then my computer freezes, and I think this is the culprit because if this happened to a process like gdm, it would cause me to be unable to figure out the waiting channel.

Also, I'm not sure if this helps, but I installed with the encrypted drive option via the alternate installer.

If there is anything I can do to provide a less subjective bug report, I'd love to help, but I've little idea where to go from here so this can be confirmed.

I've attached a screenshot of system-monitor at the time of the current futex_wait lock-up.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you open the bug on bugzilla.gnome.org where the people writting the software will read it? they know their code better than ubuntu bug triagers

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low

Sure.

I've refiled the bug here: http://bugzilla.gnome.org/show_bug.cgi?id=569229

Is there a guideline anywhere about which system should be used for filing which bugs?

Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gvfs:
status: New → Triaged
Sebastien Bacher (seb128) wrote :

There is no specific guideline about that, ubuntu users are encouraged to submit their issues on the ubuntu bug tracker, the majority of bugs received are due to the upstream code and not specific to ubuntu though and bug triagers send those to the right bug tracker, in your case the bug is quite specific and it's better if somebody having the issue open the upstream bug to be able to reply to their questions

Sebastien Bacher (seb128) wrote :

do you use the gvfs-fuse mounts a lot to trigger the issue?

Thanks for the info - that makes sense.

I don't deliberately use gvfs-fuse mounts - I thought gvfs-fuse-daemon did things behind the scenes. Honestly though, have no idea what it (fuse, gvfs) actually does or if I use it. Maybe you can tell me if I use it.

I can't figure out how to trigger the lock. I wish I could.

Sebastien Bacher (seb128) wrote :

the gvfs-fuse mounts are a way for softwares which don't use gvfs directly (ie which don't understand smb or ssh uris for example) to access network shares through gvfs using transparently a local directory

Interesting. I'm still not sure if I use them though. I don't use smb, but I do use ssh. I'd guess that I don't use them...

Changed in gvfs:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in current jaunty?

Sure. But first, they need to release Jaunty. And I need to update to it. Let's not get carried away, sir.

Changed in gvfs:
status: New → Invalid
Eugene Savelov (savelov) wrote :

I am having a similar issue with java application, which hangs in futex_wait in a reproducible scenario. This was happenning in interpid, and happens in jaunty as well. I tried different version of jre, which makes me think that its not an issue with java itself, but with futexes. And yes, gvs-fuse-daemon also is displayed with 'futex_wait' status at that time

Kaa (tselouyou) wrote :

Hello,

It seems I have the same problem.
It happens with evolution (hangs sometimes) and even worse with a Java program I use for work (it never starts).
I already posted on: https://bugs.launchpad.net/ubuntu/+bug/374007

This is really a problem, can somebody help please?

Thanks,

Karen

Sebastien Bacher (seb128) wrote :

could somebody try if that's still an issue on jaunty or karmic? upstream seems to think that's a GNOME bug

Changed in gvfs (Ubuntu):
status: Triaged → Incomplete

Hi,

I'm on Jaunty and I still have the problem.
Very annoying.

Thanks,

K

> could somebody try if that's still an issue on jaunty or karmic?
> upstream seems to think that's a GNOME bug
>
> ** Changed in: gvfs (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> gvfs-fuse-daemon halted with futex_wait signal
> https://bugs.launchpad.net/bugs/320581
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Invalid
> Status in ?gvfs? package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gvfs-fuse
>
> Since installing intrepid, I have had trouble with programs freezing. From
> what I have determined, it is caused by thread locking, and
> gvfs-fuse-daemon.
>
> The way to make it happen seems to be to use my computer for a while, and
> then sooner or later, a program freezes. When it does, if I open system
> monitor, it will show the waiting signal for the frozen program to be
> futex_wait, and will show the waiting signal for gvfs-fuse-daemon to be
> futex_wait.
>
> I've tried to find information about futexes, but the web is pretty quiet
> on the matter. This bug seems similar to bug 303190, but I think it's
> different.
>
> The only solution I have found to this bug is to kill the application that
> is frozen. This has happened to:
> - gnome-panel
> - gnome-do
> - firefox
> - eclipse
> - python
> - getty (I think)
> - and a few others
>
> Every now and then my computer freezes, and I think this is the culprit
> because if this happened to a process like gdm, it would cause me to be
> unable to figure out the waiting channel.
>
> Also, I'm not sure if this helps, but I installed with the encrypted drive
> option via the alternate installer.
>
> If there is anything I can do to provide a less subjective bug report, I'd
> love to help, but I've little idea where to go from here so this can be
> confirmed.
>
> I've attached a screenshot of system-monitor at the time of the current
> futex_wait lock-up.
>

jarry (javier-rotelli) wrote :

still happens in Karmic.
i use smb shares, but not quite much...

jarry (javier-rotelli) wrote :

i think this is related to pulseaudio.
in battle of wesnoth after a while the game sound mutes, and then if i try to close it it freezes, an i have to kill the process.
it happens with a lot of other progrmas too.

Changed in gvfs:
importance: Unknown → Critical
status: Invalid → Unknown
i1abnrk (i1abnrk) wrote :

I have this problem constantly. I agree this seems to be triggered most often by pulseaudio. I'm using an epa kernel mod for Oneiric which sets a nice value of -12 for pulse (I've used it since. The most common way to trigger the crash is when an internet ad on a website like yahoo tries to push audio through firefox while I'm listening to music with any music player. Firefox works fine but pa sometimes stutters in threadbuffering and the desktop crashes behind firefox (memlock?) and icons and sometimes even characters become corrupted. It seems there is a ruthless thread in buffer overrun. Also happens frequently when a second user logs in to the same Ubuntu box. Perhaps there's a bug in thread cloning between pa and gvfs? Bad header info in the XXXThread.clone of one or both? I'm not a thread expert but these are issues worthy of someone more familiar with the specific projects I suppose.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.