Mounted USB harddrive showes twice on the desktop - right click one of the icons and choose "Unmount Volume" results in error "DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given mount was not found"

Bug #251991 reported by Tom Imhof on 2008-07-25
128
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
High
Ubuntu Desktop Bugs
Intrepid
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Ok, quite a long summary. Anyway this is what happens on Intrepid Alpha 3:

1. I plug in my USB hard disk (I tried with several different USB hard disks of different makes - they all show the same behaviour)
2. The hard disks appears twice on the desktop, on the Places menu of the Gnome menu, on the Sidepane in Nautilus and under the URL "My Computer:///" in Nautilus.
3. My hard drive has a custom icon assigned to it. On the deskop I see the drive once with the custom, once with the default icon.
4. If I right click the custom icon on the desktop and choose "Unmount Volume" from the context menu, the drive unmounts fine, however, if I click the default icon and do exactly the same thing, I get "Unable to unmount <drivename> - DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given mount was not found".
5. I double click any of the icons and the drive opens fine in Nautilus.
6. I can copy to and from the drive - no problem.

Related branches

mattismyname (mattismyname) wrote :

Confirm. Same happens to me with a SD card. Card worked fine before last night's update.

A. Walton (awalton) wrote :

Probably a problem with the new remote volume monitor, but it's definitely either a GIO or (more likely) a GVFS issue, so I'm reassigning to GVFS for now. Is there a guaranteed way to reproduce this, or is it spontaneous?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Hebert (hebert-bernardo) wrote :

I can also confirm that issue.

It's happening with a External USB Hard Disk.

And also this:

My second internal hard drive appears on gnome places but nothing happens when I click on it.

No error message, nothing.

Nautilus apparently doesn't know how to mount my slave hard disk.

The odd Thing. It works on the Live CD. Behaving just like described above.

I can mount manually.

Hope that helps.

Tom Imhof (tomimhof) wrote :

@A.Walton - I can reproduce this each time I plug in a USB drive. The exact automatic behavior, when I plug in the external USB drive is:

Nautilus opens one window at /media/drivename
Nautilus opens a second window at /media/drivename
Nautilus shows an error message, saying: Unable to mount <drivename> - DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found

Not sure, but probably it tries to mount the drive a third time and fails?

Anyway - once I click away the message, the behavior is as described in my original bug report.

Hope it helps!

Cheers
tom

xens (r-aviolat) wrote :

Same problem here with Intrepid Ibex Alpha 3, every USB stick I plug are mounted twice with the error message: Unable to mount <drivename> - DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found.
Thanks :)

xens (r-aviolat) wrote :

ooops forgot to say that the error also occurs with an optical medium (DVD/CD-ROM).

sojourner (itsmealso2) wrote :

I also will confirm this on interpid A3 fresh amd64 install .

André Barmasse (barmassus) wrote :

Bug confirmed here with Ubuntu Intrepid Ibex, kernel 2.6.26-4-generic, and Gnome 2.23.5. My Western Digital 120GB external USB harddrive pops up with two desktop icons and the above error - but is nevertheless accessible without any problems.

In Nautilus this becomes visually nastier when I plugin my multiple card reader with just one flash card installed: Not only all four slots popup as icons - but all of them twice, even though only one is accessible (see attached pictures).

sojourner (itsmealso2) wrote :

not only does it double mount cd' dvd's and usb sticks it WONT mount local (internal) hard drives as user , if I switch user to root I can mount them either by clicking on the drive icons in places>computer or from the sidebar in nautilus , they too double mount , after mounting I can switch back to normal user and access them .

A. Walton (awalton) wrote :

Marking the Nautilus bug as a duplicate of this one and bumping status per the other bug. It's almost certainly a bug in the new volume monitor code, just need to sit down with it, as nothing much has changed in the way Nautilus handles volumes, recent changes have been down the stack.

Changed in gvfs:
importance: Medium → High
milestone: none → intrepid-alpha-5
milestone: intrepid-alpha-5 → none
A. Walton (awalton) wrote :

Fair chance upstream would like to see a the output from lshal to make sure this issue isn't coming from below us. If someone affected would attach the output from that command, it would be very helpful, thanks.

Changed in gvfs:
status: Confirmed → Incomplete
sojourner (itsmealso2) wrote :

here is the output of lshal on my intrepid A3 install , note I had to increase my bash scrollback to 4096 to get all of it that dont seem right ,

Philipp Meier (meier-philipp) wrote :

I have the same problem on intrepid (8.10), devices are shown twice on desktop and menu, but only once in /media/. Please find my lshal output in the attachment.

When I want to umount it through the gnome right click menu this messag appears (see below), but if I'm doing that again it's just fine.

(DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given mount was not found)

Phil

André Barmasse (barmassus) wrote :

Just for the sake of completeness, here is my lshal output. Keep up the good work!

Tom Imhof (tomimhof) wrote :

and here is my lshal output - the drive in question is /dev/sdb

cheers
tom

Same here on fully updated/upgraded Intrepid double icon on desktop when i insert a usb memory stick and the mount error.

In attach my lshal.txt with usb memory stick mounted

Thank you

A. Walton (awalton) on 2008-07-30
Changed in gvfs:
status: Incomplete → Confirmed
enderwig (enderwig) wrote :

Same bug here on a fresh Intreped Alpha 3 install. Memory stick and mounted internal drives and partitions cause this bug.
Attached lshal.txt also.

Sebastien Bacher (seb128) wrote :

the issue seems to be due to the gphoto monitor, upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=545695

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gvfs:
status: Confirmed → Fix Committed
Changed in gvfs:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.99.4-0ubuntu1

---------------
gvfs (0.99.4-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Require glib >= 2.17.6
    - Support und update serialization of GEmblem and GEmblemedIcon
    - Add x-content/* support to daemon mounts
    - Use standard icon names
    - Bug fixes
      545695 – any new volume is mounted twice (lp: #251991)
      545489 – Nautilus hangs when inserting a CD
      544008 – g_daemon_file_replace_async mode err
      543552 – gvfs-fuse-daemon crashes if dbus dies (lp: #235698)
      528891 – Handle URI schemes case insensitive
      525779 – Dont look for trashs dir on sys mounts
      545968 – leaks xml documents in error cases
      545966 – Disallow net access to WebDAV xml parser
      509740 – Trash icon not updated ..
      539167 – Use g_set_error_literal where appropriate
      528848 – [PATCH] statfs lies
      518284 – need to add i18n on module branching
    - Translation updates
  * debian/control.in:
    - updated libglib requirement
  * debian/patches/90_upstream_change_fix_rhythmbox_crasher.patch:
    - upstream change to fix incorrectly url parsing leading to a rhythmbox
      crasher, thank gicmo (lp: #254617)
  * debian/patches/91_no_autofs_trashs.patch:
    - the change is in the new version now

 -- Sebastien Bacher <email address hidden> Tue, 05 Aug 2008 11:03:15 +0200

Changed in gvfs:
status: Fix Committed → Fix Released
syko21 (syko21) wrote :

I am running the latest gvfs and I still receive this error when trying to connect to samba shares on my network, or is that a separate issue?

I am also running the newest version of gvfs with Intrepid Alpha 4

Version 0.99.5-0ubuntu1 and have the same issue.

Dbus Error
org.freedesktop.DBus.Error.InvalidArgs
Mountpoint Already Registered

The icon appears only once on the desktop but is not accesible and can right click and umount succesfully, any info you require please reply!

Andy

marcozambi (marcozambi) wrote :

I also confirm this error:
Dbus Error
org.freedesktop.DBus.Error.InvalidArgs
Mountpoint Already Registered
whenever I try to mount any of the available win shares in my local network.

I have the icon in the left panel of Nautilus, but still unable to access the content of the directory without receiving this error.
Really annoing.. :(

syko21 (syko21) wrote :

The issue has been documented and triaged. Follow https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/241139 for more information and possible fixes.

hotani (hotani) wrote :

I seem to have the same problem. I get a total of 8 pop-up errors when trying to connect my samsung instinct phone (which shows on most systems as a removable external 2GB drive):

1: This one produces 3 identical pop-up windows:
[Unable to mount 2.0 GB Media]
DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

2: this one produces 2:
[Cannot mount volume]
Error org.freedesktop.Hal.Device.UnknownError.

3: 2 of these:
[Cannot mount volume]
Unable to mount the volume

4: and one of these:
[Unable to mount 2.0 GB Media]
org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found

Sean Cleary (seanearlyaug) wrote :

I am getting this message:
DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered
as part of trying to access my winxp computer from my Ubuntu 9.04 computer.
Not fixed completely as of Aug 5, 2009
Sean

LinuxN00B33 (conan72o) wrote :

I can confirm what Sean wrote above me. This problem may have crept back in. Running Ubuntu 9.04 Server and I can't mount any of my winXP shares. I've attached a screenshot for reference. Please note I whited out any personally identifiable information, but the full error is visible. I'm not sure if this is getting any attention due to the "Fixed" status and am sorely tempted to change the status back to Confirmed. Please advise. Will switch it back to Confirmed if this goes without response for awhile so it does get attention again. Thanks!

Heimen Stoffels (vistaus) wrote :

This bug still appears at my laptop running Ubuntu Netbook Remix 9.10

Changed in gvfs (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs because you have a similar issue open a new bug

Sebastien Bacher (seb128) wrote :

closing the bug again there

tags: added: iso-testing

Really closing the bug.

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
jordanice77 (jordan-gebhart) wrote :

same issue occurs. this does not allow me to create a bootable flash drive. pops up the error everyone else is talking about

Changed in gvfs (Ubuntu):
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs because you have a similar issue, open a new bug rather...

Changed in gvfs (Ubuntu):
status: New → Fix Released
Hohni83 (hohnihohnloser) on 2010-02-03
Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Pedro Villavicencio (pedro) wrote :

Please do not change the status/importance or even assigned of a bug if you don't know what you're doing. Thanks.

Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
smokydig (smokydig) wrote :

I had the same exact issue but then I unmounted my usb key unplugged and plugged it back in when the icon appeared on my desktop I right clicked and selected format and it quickly formatted after it finished I went back to the usb creator and it worked and finished making my startup drive now I am off to try booting up some other pc's woohoo!

Changed in gvfs:
importance: Unknown → Medium

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

reeboker (reeboker-cz) wrote :

DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered error message pops-up after inserting iPhone too

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.