the ftp backend doesn't handle server with limited access correctly

Bug #236114 reported by SnaiL on 2008-05-30
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I have a public FTP server where root directory listing is forbidden and server redirects clients to another working directory basing on its login name implicitly after login. Embedded Nautilus ftp client fails to work with such server because of trying to access "/" instead of current directory. Moreover, when I type correct working directory Nautilus says that it is not found. I checked gFTP and it works just perfect. Windows Explorer also works fine. Please see gFTP output below this message. Hope it helps the community. Do not hesitate to ask any further questions you probably may have, you are welcome.

gFTP output:

TYPE I

200 Type set to I.
PWD

257 "/pHDSN-HAMM" is current directory.
Loading directory listing /pHDSN-HAMM from server (LC_TIME=en_US.UTF-8)
PASV

227 Entering Passive Mode (4,78,136,68,196,16).
LIST -aL

125 Data connection already open; Transfer starting.
226 Transfer complete.

SnaiL (vladislav-lazarenko) wrote :
Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Can you add the output of 'apt-cache policy nautilus' and 'lsb_release -d' ?
Thanks in advance.

SnaiL (vladislav-lazarenko) wrote :

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.22.3-0ubuntu2
  Candidate: 1:2.22.3-0ubuntu2
  Version table:
 *** 1:2.22.3-0ubuntu2 0
        100 /var/lib/dpkg/status
     1:2.22.2-0ubuntu6 0
        500 http://us.archive.ubuntu.com hardy-updates/main Packages
     1:2.22.2-0ubuntu4 0
        500 http://us.archive.ubuntu.com hardy/main Packages

$ lsb_release -d
Description: Ubuntu 8.04

Sergio Barjola (sbarjola) wrote :

confirmed.

* Steps to reproduce it:
- connect to a ftp server with a default home directory different from /
I've test in ProFTPD 1.3.1 and set "DefaultChdir /home/ftp"
- connect to server from nautilus, for example, with url: ftp://user@server

Nautilus list the content of / and don't redirect to default directory

If I want to go to default directory, need to specify in url, like: ftp://user@server/home/ftp

Changed in nautilus:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, that's known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=520399

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gvfs:
status: Unknown → New
summary: - FTP works incorrectly with custom default folder and forbidden ls
- command in /
+ the ftp backend doesn't handle server with limit access correctly
summary: - the ftp backend doesn't handle server with limit access correctly
+ the ftp backend doesn't handle server with limited access correctly
Changed in gvfs:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the issue should be fixed in jaunty now

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Sergio Barjola (sbarjola) wrote :

with the latest updates nautilus still doesn't redirect to default directory.

Sebastien Bacher (seb128) wrote :

right, that's explain in the GNOME bug if you read it

Aidan Fitzpatrick (afit) wrote :

As I understand it, the problem is that Nautilus doesn't show the default directory on FTP login, leaving the user to guess their path. The upstream fixed a problem whereby the user wouldn't be able to enter their path, once guessed... so I guess we've got a workaround.

As the upstream ("can't access non-listed (hidden) ftp directory") is marked as "resolved fixed" (last comment is: "the patch doesn't solve the 'Nautilus starts in home directory' problem, but it allows to manually cd into readable directories using the location bar now.") I suspect we need to prod upstream or raise another. I shall ask.

Changed in gvfs:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.