Ubuntu

Option to connect to "secure webdav" network locations missing in nautilus

Reported by haelix on 2008-04-26
90
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Low
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Unassigned
Intrepid
Medium
Unassigned
Jaunty
Medium
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Low
Ubuntu Desktop Bugs

Bug Description

Gnome file explorer -> "File" menu -> "Connect to Server"

You would have the "Secure Webdav" service type available in an option, at least in Gutsy. Where's it gone ?

Plus, I have a witness http://ubuntuforums.org/showpost.php?p=4443027&postcount=128
 and then, Sebastien Bacher mentions availability of secure webdav in hardy (see bug 24731).

TEST CASE:
 * In Gnome, click on Places on the top panel.
 * Select "Connect to Server..." in the now visible menu.
 * Check if "Secure WebDAV (HTTPS)" is listed in the "Service type" dropdown box.

Christof Krüger (christofkr) wrote :

Confirmed, in my Hardy installation, I also lack a "Secure WebDAV" entry in the dialog. There is solely a "WebDAV (HTTP)" entry, which I'm not willing to be using on the internet.

Changed in nautilus:
status: New → Confirmed
Christof Krüger (christofkr) wrote :

I got it working by modifying the URI by hand (from dav:// to davs://). However, I've got the impression that the dav implementation of gvfs is broken. I can't get it working properly with my DAV server, nautilus keeps complaining about status 301 (permanent redirect).
Configuring apache with 'BrowserMatch "gvfs/*" redirect-carefully' makes it work halfways, but with errors here and there...
Could it be that this is known and that this is the reason why "Secure Webdav" doesn't appear in the dialog?

Henry S. (snowball2050-gmail) wrote :

I'm having the same issue. In addition to that, after connecting to a regular dav:// server, I cannot open any of the files displayed, or navigate outside of the root folder. Using the "Places" -> "Connect to Server" menu also gives me issues with ftp, but i can work around that.

fields_g (fields-g) wrote :

I started bug #225480. It is a duplicate of this and have marked it as such, but I did have something else to add to this:

I tried to play around with the "Custom Location" service type and now I know there is something wrong. Here's what I found when I put in various URIs:

http://xxxxxx.com/users/myaccount -> Firefox opens and asks for authentication, followed by web interface.

https://xxxxxx.com/users/myaccount -> Same behavior as http

dav://xxxxxx.com/users/myaccount -> "Can't display location "dav://xxxxxx.com/users/myaccount" HTTP Error: Moved Temporarily"

davs://xxxxxx.com/users/myaccount -> Nautilius prompts for User/Pass, then says "Can't display location "dav://xxxxxx.com/users/myaccount" HTTP Error:Not Found" BUT!!!!! a network folder is mounted (appears on desktop and under places in Nautilus) named "WebDAV on xxxxxx.com" and clicking on it opens a properly usable net folder.

fox (jm-whx) wrote :

I can confirm this too. Cant connect with dav or davs. Error -> "Moved Permanently"

reader4 (cbrace1) wrote :

Same here... same behavior as fields_g describes.

Luca Corbo (lucor) wrote :

Same behavior as fields_g describes.

Same problem here in a fresh install of Hardy Heron... whatever I try (same as fields_g above), I cannot connect to our secure WebDAV server.

Fred K Huang (fredkhuang-gmail) wrote :

I originally had this error, though it seems that DAVS://website.com/folder works ok for me. I agree that the old Secure DAV option is now missing from the Connect to Server... dialog.

Timo (timo-benk) wrote :

Same problem here, i cannot access DAV folders even if i use the davs://website.com/folder notation.

reader4 (cbrace1) wrote :

Edit: Same behavior as fields_g but no folder is mounted to the desktop.

eSpencer (espencer) wrote :

Same behavior.

Also I've tried to browse from the command line, on $HOME/.gvfs; and seems to be broken too. If I execute "ls -l" this is the output:

ls: cannot access my-folder-name: Input/output error
total 0
?????????? ? ? ? ? ? my-folder-name

John Pye (jdpipe) wrote :

I think that this is a bug with the 'Connect to Server' tool, rather than any inherent problem with Nautilus.

I found that I was able to access a WebDAV (HTTPS) server by opening Nautilus, then typing ctrl-L to open the location bar, then typing in davs://server.example.com/folder/name/ and pressing enter. A box then popped up asking for username and password.

There is still a bug however, because I cannot access the same location using the Places-->Connect to Server method.

Cheers
JP

Phr00t (phr00t) wrote :

I also have the same problem as fields_g describes. However, I do not get an icon on my desktop that works.

As of right now, I do not know of a way to access our University's "UDrive" via secure Webdav using Ubuntu 8.04. It worked fine in 7.10... :-( Using a location bar does not work either.

I am monitoring this bug and am willing to help resolve it -- as I want to develop a UMass Amherst-specific Ubuntu 8.04 distribution (I've already made a 7.10 that works great).

Sebastien Bacher (seb128) wrote :

that's known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=538461

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in gvfs:
status: Unknown → Confirmed
Mr Losoi (mrlosoi) wrote :

I tried to set up a webdisk to my bluehost account.
I tried to put a webdisk to my desktop that would link to this address: https://[my internet page].com:2078
The only way I could reach my files in firefox was to add an exception.

In Nautilus, this command davs://[my internet page].com gave me this
Couldn't display "davs://[my internet page].com:2078/"

This seems to be a libgnomegvfs problem.

KDontenville (kevin-keepnet) wrote :

I get the same not found errors, whether SSL or not! How did this slip by with an LTS release? Can't see any progress on a fix. Anyone heard things I haven't perhaps?

Debs works fine as do other distros, is this all down to gvfs?

Changed in gvfs:
status: Confirmed → In Progress
frederyk (frederyk) wrote :

The same problem here. davs:/... works, but it is not directly selectable in the gui.

ignasi (igp-oenus) wrote :

This is what I do to access my webdav account (both dav and davs) under hardy:

when I enter the parameteres in gnome "Connect to Server" don't enter your username. I will ask for it later along with the password. However, in mixed (both anonymous and user-based) dav folders (i.e. Gallery2) this trick won't work, since it will, by default, mount the dav folder anonymously.

Sebastien Bacher (seb128) wrote :

the bug is a gvfs one not a nautilus one

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
gwallet (wallet-guillaume) wrote :

Same behaviour,

When I'm using nautilus address bar to open davs remote directory :
1) It fails with url like this davs://<email address hidden>/remote/dir
2) It first succeed with url like this davs://<email address hidden>/ but fail when I want to browse remote directory

The error is always the same :
HTTP Error : Moved Permanently (see screenshot in attachement)

I know it works fine in 7.10
I wish it works again in 8.10 ... or sooner in 8.04 if possible

best regards
Guillaume WALLET

Giovanni Lovato (heruan) wrote :

I agree that a "Secure DAV" option will be very useful on the Connect to Server dialog!

Not sure if this will work for the rest, but I just did a clean install to Intrepid and needed to reconfigure my webDAV shares. The webDAV option in "Connect to Server..." dialog was not working, so I ended up simply using the "Custom" option and entered the https url to the webDAV location I am trying to reach:

davs://server.address.com/folder/path/here/

I assume dav://server.address.com/folder/path/here/ will also work.

I was then prompted for my username/password via the keyring, and the folder then opened properly in Nautilus.

redhound (redhound-red) wrote :

Could be caused by a missing mount file in the /usr/share/gvfs/mounts directory. Had this problem in my Hardy installation.

The mount file for Secure WebDAV is just not present. Add a davs.mount file in the directory with content

[Mount]
Type=davs
Exec=/usr/libexec/gvfsd-dav
AutoMount=false

and the Secure WebDAV should reappear in the listbox.

Philipp Kern (pkern) wrote :

You could try the gvfs package from my PPA (you need to install gvfs-backends and gvfs at least): https://edge.launchpad.net/~pkern/+archive/ppa

It fixes the issue for me. Debdiff attached, ubuntu-main-sponsors subscribed as I cannot upload to -proposed directly.

Scott Kitterman (kitterman) wrote :

Needs to be fixed in the development release first.

Scott Kitterman (kitterman) wrote :

Confirmed fixed in Jaunty via testing.

Changed in gvfs:
status: Triaged → Fix Released
Scott Kitterman (kitterman) wrote :

Fix uploaded for Intrepid as this appears to be a regression from the pre-gvfs functionality. Please edit the bug to provide a simple test case to verify the fix.

Changed in nautilus:
status: New → Invalid
Changed in gvfs:
importance: Undecided → Medium
status: New → Fix Committed
Philipp Kern (pkern) on 2009-03-02
description: updated
Philipp Kern (pkern) wrote :
Changed in nautilus:
status: New → Invalid
Scott Kitterman (kitterman) wrote :

Uploaded for Hardy. Thank you for the patches.

Changed in gvfs:
importance: Undecided → Medium
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Mark Edgington (edgimar) wrote :

I am using Intrepid with the -proposed source enabled. When using the "Connect to Server..." dialog, I still get the 'Cannot display location "davs://user@<FQDN of local host>/webdav" HTTP Error: Moved Permanently' dialog. I can access the URL fine with the "cadaver" commandline tool.

Martin Pitt (pitti) wrote :

Mark, that sounds like a different bug, though? This one is about not having the option in the menu in the first place, or am I mistaken?

Philipp Kern (pkern) wrote :

Sounds like a different bug indeed. Folks, could you please test on intrepid on hardy that the menu item is now indeed there?

nh2 (nh2) wrote :

Confirmed, menu item is there in Intrepid.

I get the same error as Mark Edington. When connecting to non-anonymous dav(s)://, either via Nautilus location line or via "Connect to server" dialog, but ONLY if providing a username in the first step (so using "dav://username@..." or filling in the username field in the "Connect to server" dialog box, "Moved Permanently" pops up.
I found out this only happens when connecting to a sub-directory.

This bug is known: #227852, it was filed for Hardy but now it seems to be back (or still not fixed).

Please try to connect to the WebDAV webdavtest.nh2.me and also to webdavtest.nh2.me/webdavtest via dialog or dav:// link. Both are mapped to the same directory, but only the first one will work. And please take some seconds to report your experience to Bug 227852.

Changed in gvfs:
status: In Progress → Fix Released
Andreas Olsson (andol) wrote :

It seems as if both gvfs 0.2.5-0ubuntu4 (hardy-proposed) and gvfs 1.0.2-0ubuntu3 (intrepid-proposed) does the trick. I can now connect to a https webdav share going thru Places -> Connect to Server.. -> Secure WebDAV (HTTPS). I've verified this in both Hardy and Intrepid.

@nh2 & Mark: I'm familiar with the problem you are referring to. It has been reported in bug #325058.

Andreas Olsson (andol) wrote :

@nh2 & Mark: Well, actually bug #314044 is probably the relevant one.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.2.5-0ubuntu4

---------------
gvfs (0.2.5-0ubuntu4) hardy-proposed; urgency=low

  * debian/patches/94_fix_davs_mounting.patch:
    - Recover lost DAV over HTTPS mounting functionality. (LP: #222532)

 -- Philipp Kern <email address hidden> Mon, 02 Mar 2009 22:43:49 +0100

Changed in gvfs (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.0.2-0ubuntu3

---------------
gvfs (1.0.2-0ubuntu3) intrepid-proposed; urgency=low

  * debian/patches/92_fix_davs_mounting.patch.dpatch:
    - Recover lost DAV over HTTPS mounting functionality. (LP: #222532)

 -- Philipp Kern <email address hidden> Sun, 01 Mar 2009 20:08:30 +0100

Changed in gvfs (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Changed in gvfs:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.