Hardy - Nautilus shortcut to Samba Share reports wrong password, double icons

Bug #216104 reported by Michael Lueck on 2008-04-12
90
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

Ubuntu (Gnome) Hardy

Steps to Recreate:
1) Places \ Connect to Server... \ Type is Windows Share
2) Fill in Server, Share, User Name, Domain Name, then click Connect
3) An error dialog comes up:
"Can't display location smb://...."
"The specified location is not mounted"
4) So I open the desktop icon for the share. It does open, but a second desktop icon appears for the same share.
In the Naultis side pane w/ tree view, the share shows up twice as well.

Works as expected / desired with Ubuntu 7.04 Feisty Fawn, none of this non-sense.

Michael Lueck (mlueck) wrote :

Also, simply logging off / onto the same user account, all such connections are lost. Also not so with Ubuntu 7.04 Feisty Fawn.

Michael Lueck (mlueck) wrote :

Today I reloaded my Hardy test box with the release version - formatted all partitions. Problem as described still exists.

richbl (richbl) wrote :

I can repro this with no problem.

DOES:

0) From Main Menu, choose Places / Connect to Server...
1) In Connect to Server dialog, choose Windows Share from Service type droplist
2) Fill in relevant Server, Share, User Name and Domain Name information.
3) Choose Connect

--Observe error message generated: "Can't display location "smb://main/rich/ The specified location is not mounted."
--Observe two mount icons created on the Desktop (or from Nautilus).

4) Restart

--Observe that mount points have been removed.

SHOULD:

--Do as in prior Ubuntu releases: no error message generated; only a single mount icon created; mount points persist across sessions.

This is a clean install of Hardy Heron.

Michael Kofler (michael-kofler) wrote :

I can also confirm this bug (8.04 with all updates installed as of 2008-05-20). It is annoying, as it prevents to pre-configure the desktop for non-skilled users. I need to add a Windows share which stays on the desktop, so other users can simply open this share without knowing anything about network details.

PS: I remember the days when people started switching to Ubuntu because 'it just worked'. These days are gone, obviously. All recent Ubuntu release had quite some bugs, but in 8.04 there are simply too much. Esp. for an LTS release. Very disappointing.

Johan (deberghes-johan) wrote :

I have the same problem on hardy heron with all its updates

8472 (dv-underworld) wrote :

today, i've upgraded from GG to HH, with no problem.
after i've logged in to the system, on my desktop, previously there were at least 2-3 icons pointing to some smb shares on different servers in the network.
now, they are gon.

when i try to recreate them, i'm getting similar errors like other people are mentioning here.

and this is now month ago after a final release, so please fix this ASAP.
thx

P.S. another problem occured, when i try to open windows share through - Places \ Network \ Win Network \ %domain% \ --- and when i choose some Windows 2003 Server or Win XP computer, i can't see shares inside. But with Win 2000 , there is no problem.

Michael Kofler (michael-kofler) wrote :

Fedora 9 has the same problem, so this is obviously a Gnome problem (which doesn't make it any better).

Michael Lueck (mlueck) wrote :

Thanks for the note that Fedora 9 is also affected, thus a Gnome problem.

I will note that no Ubuntu folks have made a peep about this report. Could we have some feedback on this one, please?

richbl (richbl) wrote :

Given that reports have confirmed that this bug can be repro'd on distros other than Ubuntu, I've opened a new bug in Gnome/Nautilus referring back to this bug.

See http://bugzilla.gnome.org/show_bug.cgi?id=535514 for details.

I've also reported the bug to Canonical (I have a support contract). I didn't see this post before reporting the issue. Etienne Goyer from Canonical was able to reproduce it and has escalated it internally within Canonical so hopefully this will get fixed since a paying customer is asking as well.

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/235786

richbl (richbl) wrote :

Looks like we now have three bugs that are related/dupes: two in Ubuntu (launchpad), and one in Gnome (bugzilla).

If BrianDrab/Etienne are driving this from within Canonical, then it might make sense to close two of these out (Ubuntu 216104 and Gnome 535514) as dupes of the Canonical bug.

One caveat, however, is that bug behavior has been repro'd under non-Ubuntu distros (e.g. Fedora), so the fix will likely need to be communicated back into Gnome.

BrianDrab, can you talk this issue over with Etienne for how best to handle this situation?

Thanks.

Will do. I'll get back to you with the answer from them shortly.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → New

Here is the response from an employee of Canonical. I can't say it answers your question but I would assume we should keep the bugs open.

6/2/2008 9:42 AM | Etienne Goyer
Usually, we give back any bug fixes that where done in the course of troubleshooting a customer's issue, but we try very hard not to expose the internal process behind it. The support process is somewhat is different than the purely community-driven bug reporting/fixing process, and mixing the two can cause confusion at time. I am not 100% sure, but I think the Launchpad user you quote believe you are a Canonical employee. No big deal, tough, just saying.

In this particular case, and this is all presumption on my part, the fix will likely come in the form of a UVF (Upstream Version Freeze) exception. That is, a new version of GVFS and/or Nautilus will be released as an update to the current version of Ubuntu, rather than having the problem fixed in the current version of Nautilus and GVFS subsystem within the release, as it would if it was of lesser scope. But the decision is not mine, it rest in the hand of the QA and distribution team. I have not received an ETA yet, but they will communicate progress to me in due time, which I will in turn communicate to you. In general, as we have escalated a publically-known bug, progress will also be documented for the entire community to know in the relevant public bugs.

In short: I do not know yet, but peoples are working on it. I will keep you updated!

Many thanks,

Etienne Goyer

Changed in nautilus:
importance: Low → Medium
DrC (drcowsley) wrote :

re https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/216104/comments/8
I will note that no Ubuntu folks have made a peep about this report. Could we have some feedback on this one, please?

There is a lot on bug 209520 (about problems when security=user) that looks very similar.

I posted there two comments on the similarity between security=user and my own case with security=share but the client username does not match the server samba account name. Rather than double post, you can find them at

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/209520/comments/77
and
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/209520/comments/105

and #106 chides me (again) for posting on the wrong bug thread - sorry, but I am really worried that if there is a link between these two sets of symptoms (ie a common source) it will be harder to nail the bug if the available evidence is too dispersed.

In my trawling (can't remember duplicate/related bug numbers I'm afraid) I've seen several other reports that in the mixed Linux/Windows environment the usability of Hardy is much degraded from Gutsy, and that Hardy is for these users at least, a big disappointment.

Hope you can nail it soon

Chris

I'm a little confused Chris (DrC). Most of the responses on this bug WERE from Ubuntu users including myself. It's already been mentioned that the problem will exist in any distro that is using the newest version of Gnome which incorporates GVFS which is a replacement for "Gnome VFS". Ubuntu Hardy is the first Ubuntu version to use this so the problem exists. I will however agree with you that so far Hardy has been a huge disappointment. To be touted as an alternate for windows and you can't even connect properly to a Windows Share...eeechhh.

I was evaluating for a windows replacement and simply stopped once I got to this bug.

Michael Lueck (mlueck) wrote :

BrianDrab, I think DrC was referring to Ubuntu support rather than Ubuntu users when they said "I will note that no Ubuntu folks have made a peep about this report."

I did not know that Gnome VFS to GVFS twist. I suppose that is the reason for other nonsense I see going on. (Mount a Samba share to a mount point on the local file system, Browse it with Nautilus, double click a file and up comes a box asking you to authenticate again! Reason being something decides to launch the app with smb:// instead of file://).

I tried to log this nonsense during the beta. I recall one response I received was "I do not have Samba in my recreate / test environment." And that is MY problem HOW?!?!? Annoying!

Duh. Thanks. I should have understood that.

palmdoc (palmdoc) wrote :

FWIW, I did a clean reinstall of 8.04, did the latest updates and used the latest maintainer version of samba.conf
I am a Ubuntu newbie and the inability to access password protected shared folders in a Windows network is a HUGE disappointment in this release which is otherwise very nice.
I have tried Places/Connect to server yet I get a "cannot mount error" . I don't even get the "double icons" on the desktop!
I have tried smb://server IP/share and also can't access the folder.
If the folder is not password protected I can access it

For the best experience, simply browsing the Windows network should show up the shares but it is a blank for me as well.

Sorry to whine but I do hope this bug gets fixes asap as it will put off a lot of people thinking about migrating from Windows.

richbl (richbl) wrote :

I can concur with Michael Lueck in the original bug report above: I'm still seeing identical incorrect functionality, even after the recent (2008-09-06) updates to SAMBA.

DOES:

0. Go to Places \ Connect to Server...
1. Service type: Windows Share
2. Fill in Server, Share, User Name, Domain Name
3. Click Connect

An error dialog is displayed:"Can't display location smb://.... The specified location is not mounted"

In Nautilus with side pane (tree view), I see two identical share icons listed.

SHOULD:

Not generate an error message.
Not create two identical share icons.

8472 (dv-underworld) wrote :

finally, the v2.24 released.
http://blogs.gnome.org/metacity/2008/09/22/2-24/

now i'm curious if they fixed this bug (and of course lot more bugs too)

Steve Langasek (vorlon) on 2009-01-24
Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
milestone: none → ubuntu-8.04.3
status: New → Triaged
Steve Langasek (vorlon) wrote :

Thank you for reporting this bug and helping to improve Ubuntu.

I have tested with the current version of GNOME in jaunty and can no longer reproduce this bug, which was reproducible for me with the 8.04 release. If you experienced this bug in hardy, please test to confirm that this bug is fixed for you in jaunty (you can do this using the latest alpha build of jaunty, available from http://cdimage.ubuntu.com/releases/jaunty/alpha-5/).

If you are still experiencing the bug described by the test case, we will need more information about your server configuration in order to debug further.

If you are experiencing a bug that does *not* match the test case in the bug description, you are experiencing a different bug and should file a separate bug report (possibly leaving a comment here linking that bug, for reference).

It is important to verify whether your bug is addressed in the latest development version of Ubuntu, as that is a precondition for backporting the bugfix to the LTS release.

Changed in nautilus:
status: Triaged → Fix Released

it is fixed in Jaunty *and* in Intrepid, but not in Hardy

basically, it is fixed since Gnome 2.24

the problem is: Hardy is LTS and is promoted for enterprise and business use; this is a serious flaw for inexperienced desktop users; therefore, it should be fixed also in Hardy (backport the Nautilus fix or whatever); if Hardy were not LTS, this bug could have been closed a half year ago

Steve Langasek (vorlon) wrote :

The fix is thought to be http://svn.gnome.org/viewvc/gvfs?view=revision&revision=1774; reassigning to the gvfs package

Martin Pitt (pitti) wrote :

Accepted gvfs into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gvfs (Ubuntu Hardy):
status: Triaged → Fix Committed
tags: added: verification-needed

The fix in hardy-proposed (gvfs-backends 0.2.5-0ubuntu7) appear to be working just fine here. Thanks!

Martin Pitt (pitti) on 2009-06-23
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.2.5-0ubuntu7

---------------
gvfs (0.2.5-0ubuntu7) hardy-proposed; urgency=low

  * Remove patch 95_svn_change_fix_smb_browsing.patch, reported to
    introduce regressions.
  * debian/patches/96_svn_fix_smb_username_handling.patch: upstream fix
    for nautilus shortcuts to smb shares. LP: #216104.

 -- Steve Langasek <email address hidden> Thu, 18 Jun 2009 00:52:37 +0000

Changed in gvfs (Ubuntu Hardy):
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.