Comment 141 for bug 209520

> Is this not caused by the same problem that causes bug 207072

No, it is not. This bug is about incompatibility with servers that negotiate weak password encryption for connections, and it has been worked around by a change to the default settings for samba in Ubuntu 8.04. If your problem was fixed by the patch from bug #207072, then your problem is unrelated to this bug report.