FTP Transfer from whole directorys fails

Bug #205370 reported by Christian Becker on 2008-03-23
62
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
Suse
Fix Released
Unknown
gvfs (Fedora)
Fix Released
High
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs
Intrepid
Low
Ubuntu Desktop Bugs

Bug Description

I just want transfer a directory with ~ 30 files in there from a FTP Server.

Just copy the folder and drop it in my home directory dont work.

The error message is "Datei nicht verfügbar". Its german and means "file not accessable".

When I copy the files by hand, it works.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug is already known upstream on http://bugzilla.gnome.org/show_bug.cgi?id=522933

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in gvfs:
status: Unknown → New
Laszlo Lukacs (lukacs-laci) wrote :

I experienced the same problem.

Same problem here, Hardy x86 client using Nautilus and FileZilla 0.9.25 for Windows server.

pheeror (pheeror) wrote :

Same here :-( Any chance of distributing patched version of gvfs to hardy anytime soon?

wensveen (wensveen) wrote :

I can confirm this.
This is especially annoying when the directory you want to copy has subdirectories and sub-subdirectories etc. Recursing into each directory is something the ftp client (gvfs) should do for the user. Also, the old gnome-vfs ftp client did already do this, so users might expect this to 'just work'.

Description of problem:
The ftp file transfer of whole directories containing more than one file fails.
The error is "Datei nicht verfügbar" which means something like "File not
available".

Version-Release number of selected component (if applicable):
gvfs-0.2.3-11.fc9.i386

How reproducible:
Always

Changed in gvfs:
status: Unknown → Confirmed

Reproducible here, raising severity as this is a major issue.
Thanks for the link to Gnome bugzilla.

Changed in gvfs:
status: Confirmed → In Progress
Changed in gvfs:
status: New → In Progress
Savvas Radevic (medigeek) wrote :

What's the point of tracking novell and fedora? they all point to gnome's bugzilla :\

pirast (pirast) wrote :

Well it is quiet interesting which distros adopt the fix first, as the problem is of high importance to me.

Fix for Samba shares should be included in updated gvfs-0.2.4-1 package.
Fix for FTP is under development and will be available soon.

gvfs-0.2.4-3.fc9 has been submitted as an update for Fedora 9

gvfs-0.2.4-3.fc9 has been pushed to the Fedora 9 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update gvfs'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5197

Changed in gvfs:
status: In Progress → Fix Committed
Savvas Radevic (medigeek) wrote :

One person confirmed that it fixes the bug, let's hope we don't get any negative replies on this one:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-5197

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gvfs:
status: Triaged → Fix Committed
Changed in gvfs:
status: In Progress → Fix Released
Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the new stable version has been uploaded as an hardy update candidate now

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gvfs:
status: Confirmed → Fix Committed

ZOMG. Doesn't gnome have some sort of QA?

Anyway,
-proposed fixed this for me.

@Jakob: Sure they do. It's called 'install the unstable version and test it' ;-)
@Martin: Updating with the proposed channel open fixed this bug for me.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gvfs:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.99.3-0ubuntu1

---------------
gvfs (0.99.3-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Fix frequent crasher in volume monitor

gvfs (0.99.2-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Move hal and gphoto volume monitors out of process
    - Fix recursive copying (lp: #205370)
    - Require glib >= 2.17.4
    - Make the fuse daemon more reliable (lp: #235698)
    - Many smaller bugfixes
  * debian/control.in:
    - updated libglib requirement
  * debian/patches/80_samba_browsing_authentification.patch:
    - dropped since the changes create some issues
  * debian/patches/90_from_svn_fix_fuse_crasher.patch:
    - dropped since the changes are in the new version
  * updated install lists for the new version changes

 -- Sebastien Bacher <email address hidden> Thu, 24 Jul 2008 16:09:03 +0200

Changed in gvfs:
status: Fix Committed → Fix Released
Michael Nagel (nailor) wrote :

my bug ( Bug 251517 ) has been closed as duplicate. i suppose it is supposed a duplicate of this bug (found nothing better) i just wanted to add that i have a up-to-date system (as of today, august, 1st) and things are still broken.

Savvas Radevic (medigeek) wrote :

Michael, your bug seems to be private
If it's marked as a duplicate, it should say so somewhere at the beginning of the page of that bug

Post back the output of the following command (Applications > Accessories > Terminal):
apt-cache policy gvfs-backends gvfs

Michael Nagel (nailor) wrote :

the bug has been reopened as we believe it is not a duplicate currently. it has been marked private as it contains some not-for-general-public information. i'll post the output of this command there. if i can add you as a subscriber (so you can see the bug) i'll do that, too.

Well this has been pushed to stable, hasn't it? So I'd say it can be closed.

gvfs-0.2.5-1.fc9 has been pushed to stable, which includes this fix.

Changed in gvfs:
status: Fix Committed → Fix Released
Mike (mike-prorouting) wrote :

I just found that I am running into this problem, searched google and came across this bug. I double checked that my ubuntu hardy is already up to date.

Changed in gvfs:
importance: Unknown → Medium
Changed in gvfs (Fedora):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.