Ubuntu

camera automount prevents import

Reported by Richard Hammersley on 2008-02-28
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Undecided
Unassigned
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

f-spot:
  Installed: 0.4.2-0ubuntu2
libgphoto2-2:
  Installed: 2.4.0-8ubuntu3
nautilus:
  Installed: 1:2.21.92-0ubuntu1

Digital camera Canon IXUS 750

When connecting the camera, camera is correctly recognised and the "Camera Import" dialog pops up.
When selecting Import Photos, F-Spot starts, but gives
"Error connecting to camera" Received error "Could not lock device".

If before clicking import photos, I unmount the camera from its icon, importing works perfectly.

Thanks,
Richard

Related branches

I can confirm this with f-spot 0.4.2-0ubuntu2 on Hardy with a Nikon Coolpix L11.

I dod not have this issue with the same camera under Gutsy.

Changed in f-spot:
status: New → Confirmed

Got the same as you Andrew! I'm using Nikon coolpix L11

Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.1.11svn20080307-0ubuntu1

---------------
gvfs (0.1.11svn20080307-0ubuntu1) hardy; urgency=low

  * New svn snapshot:
    - fix nautilus crasher on eject (lp: #198448)
    - the obex code correctly handing colons now (lp: #196770)
    - correctly initialize webdav variables to avoid a crash (lp: #195917)
    - don't list partitions not mounted in media or the user directory
    - correctly translation the media names (lp: #199252)
    - don't automounts camera or other applications can't use the device
      (lp: #196757)
  * debian/patches/80_translate_volumes_names.patch:
    - translate media and volumes names correctly (lp: #199252)
  * debian/patches/90_from_svn_fix_camera_disconnect_locking.patch,
  * debian/patches/90_from_svn_fix_smb_login_crasher.patch:
    - dropped since the svn change is in the new version
  * debian/patches/91_respect_automount_enabled_hint.patch:
    - updated to the new version

 -- Sebastien Bacher <email address hidden> Fri, 07 Mar 2008 19:33:06 +0100

Changed in gvfs:
status: Confirmed → Fix Released

thanks to the developers! thanks for the work!

Hi and thanks for looking at this.

I've just tried Hardy Alpha 6. Not sure if this is now the correct behaviour as the camera no longer mounts, but, for some reason F-spot-import does not automagically launch, perhaps there is something wrong with my setup?
System->Preferences->Removable Drives and Media says under Cameras tab with check box checked (also unchecked and rechecked just in case)
Digital Camera Import digital photographs when connected, Command f-spot-import

The camera is recognised in the usb ports:
richard@clem:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 008: ID 04a9:3116 Canon, Inc. Digital IXUS 750 (PTP mode)
Bus 001 Device 001: ID 0000:0000

and doing an f-spot-import from the command line works fine. albeit with a lot of messages.

Cheers,
Richard

Hi,

As of 4 April 2008 update, f-spot is now starting up when the camera is switched on and images are importing fine.

Thanks again for the prompt response and taking care of this.

Cheers,
Richard

Pedro Villavicencio (pedro) wrote :

thanks for the update. closing the report.

Changed in f-spot:
status: New → Fix Released
Benn (benn-blessing) wrote :

This bug seems to be present in Intrepid alpha AMD64 early September.
I have to unmount the camera before starting F-spot.
Canon Powershot A590IS

mike (ubuntu-holmesfamily) wrote :

I have this problem in ibex alpha 6 for a cannon sd850 is, it was fine previously.
It opens F spot and 2 repeated camera selection dialogs, each with a pair of IXU950 IS (PTP mode) one on port usb: and done on port usb:005,006.

No combinations of actions will load photos.

Mike

Pedro Villavicencio (pedro) wrote :

new bug is 258083 please feel free to subscribe to it, thanks.

Changed in f-spot (Ubuntu):
status: Fix Released → Fix Committed
Changed in gvfs (Ubuntu):
status: Fix Released → Fix Committed
Sebastien Bacher (seb128) wrote :

don't change bugs without comment

Changed in f-spot (Ubuntu):
status: Fix Committed → Fix Released
Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released

I did not mean to do that Sebastien. Twas a mistake.
-Leslie

Fred (frederic-lespez) wrote :

I am seeing this bug in Lucid release candidate : F-Spot works fine but with Gthumb and Digikam I need to unmount the camera (a CANON EOS 350D) from its icon before importing.

Should I need to open a new bug or could we re-open this one ?

jepler (jepler) wrote :

Also seeing this bug in Lucid final version. The commandline f-spot-import suggested earlier was an adequate workaround.

Bernard Decock (decockbernard) wrote :

I have still this problem on Lucid

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

Camera = Canon Powershot SX20 IS

Bus 001 Device 008: ID 04a9:31e4 Canon, Inc.
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x04a9 Canon, Inc.
  idProduct 0x31e4

I enabled this camera in 40-libgphoto2-2.rules

ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="31e4", ENV{ID_GPHOTO2}="1", ENV{GPHOTO2_DRIVER}="proprietary", ENV{ID_MEDIA_PLAYER}="1", MODE="0664", GROUP="plugdev"

gphoto2 --list-files
"Error initializing camera: -60: Could not lock the device"

The workarounds for this bug all well known :

Before you use F-Spot, Shotwell, Picasa3 you only have to unmount the camera
or prevent the execution of /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

I hope that this bug will get fixed as some of folks (where I replaced WinXp with Ubuntu on their computer) don't
understand why the camera-icon is shown on the desktop (they love that!) but that before you can use the
camera (in order to download photos) you first have to click away (due to the unmount-operation) that icon.

When the camera-icon pops up and you click right, then you are allowed to open the camera with Rhythmbox,
VLCPlayer, ... This does not make sense it all! I would rather expect to see F-Spot, Shotwell, Picasa, ... here.
(Anyway, the Shotwell-people do have anticipated this bug, because Shotwell allows you to unmount the camera
before downloading your stuff).

Bernard Decock (decockbernard) wrote :

Maybe I have to file another bug. The camera is seen as a gphoto2-filesystem.

Open Nautilus (Places -> Home Folder) -> Edit -> Preferences -> File Management Preferences -> Media

Media Handling : If you change the option Photos to Ask what to do or Shotwell Photomanager nothing happens
when you plug the camera in.

However, if you change the option Musicplayer to be opened with Shotwell, then shotwell is started at plugging the
camera in! This means that a gphoto2-filesystem is considered as a music-file-system ??? Alas, when Shotwell
is started, you still have to unmount the camera before Shotwell can use it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers