gvfs-smb-browse hogs CPU after only opening nautilus

Bug #1572260 reported by AndreK on 2016-04-19
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
samba (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

upgraded to 16.04 from 15.10
- the process in subject hogs 25% CPU after only starting nautilus, and keeps hogging it "forever" - no samba browsing needed.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gvfs-backends 1.28.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 19 20:03:12 2016
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/gvfs/gvfsd-smb-browse
InstallationDate: Installed on 2012-10-15 (1281 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121015.2)
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=en_US
 PATH=(custom, user)
 LANG=en_US.UTF-8
SourcePackage: gvfs
UpgradeStatus: Upgraded to xenial on 2016-04-06 (13 days ago)

AndreK (andre-k) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Fournier Erwan (erwan.me) wrote :

I can confirm this issue on a fresh installation

Changed in gvfs (Ubuntu):
importance: Undecided → High
importance: High → Medium
Haedri (jb-launchpad) wrote :

I don't know if I have the exact same problem, but in my case it is because gvfs-smb-browse tries to access a samba server (first problem is why does it try to contact it, I never browse samba shares) using ipv6
When gvfs-smb-browse uses the whole cpu core I can run a :
netstat -laputenW | grep gvfs
And see that gvfs is trying to contact an ipv6 address

I reproduced it at home (16.04) and at work (14.04, happens since a recent update, did not happen last month for example) :
- at home it tries to connect to the samba share of my internet box / router, using its public ipv6 address, so this will never ever work
- at work it tries to connect to some co workers windows 10 share, using local ipv6 addresses

I have solved my problem by :
- at home, using google ipv6 dns, that way gvfs can't get the ipv6 of my internet box and won't try to connect to it
- at work I just disabled ipv6 (switched to local link iirc)

Sebastien Bacher (seb128) wrote :

the issue looks similar to bug #1409032

Changed in samba (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in gvfs (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:4.4.5+dfsg-2ubuntu3

---------------
samba (2:4.4.5+dfsg-2ubuntu3) yakkety; urgency=medium

  * debian/patches/git_smbclient_cpu.patch:
    - backport upstream patch to fix smbclient users hanging/eating cpu on
      trying to contact a machine which is not there (lp: #1572260)

 -- Sebastien Bacher <email address hidden> Fri, 05 Aug 2016 17:32:43 +0200

Changed in samba (Ubuntu):
status: In Progress → Fix Released

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

Changed in samba (Ubuntu Xenial):
importance: Undecided → High
status: New → Triaged

Hello AndreK, or anyone else affected,

Accepted samba into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/samba/2:4.3.9+dfsg-0ubuntu0.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in samba (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of samba from xenial-proposed was performed and bug 1614562 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1614562 (not this bug). Thanks!

tags: added: verification-failed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu Xenial):
status: New → Confirmed
AnonymouseP (anonymouse.p) wrote :

I'm a little new at this so not sure if this was the right way, but i added xenial-proposed and selected the 3 samba updates.

libwbclient0:amd64 (2:4.3.9+dfsg-0ubuntu0.16.04.2, 2:4.3.9+dfsg-0ubuntu0.16.04.3), samba-libs:amd64 (2:4.3.9+dfsg-0ubuntu0.16.04.2, 2:4.3.9+dfsg-0ubuntu0.16.04.3), libsmbclient:amd64 (2:4.3.9+dfsg-0ubuntu0.16.04.2, 2:4.3.9+dfsg-0ubuntu0.16.04.3)

This is a on a fresh install of 16.04 with all current updates. Problem is resolved for me and no errors or other odd behavior. I don't use samba shares though. Someone in another thread seems to think it is an ISP problem.

Running nautilus now no longer causes 100% on one core, and my computer is running a lot cooler in general. It's a passive cooled system so quite noticeable!

tags: added: verification-done
tags: removed: verification-failed verification-needed
Changed in gvfs (Ubuntu Xenial):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:4.3.9+dfsg-0ubuntu0.16.04.3

---------------
samba (2:4.3.9+dfsg-0ubuntu0.16.04.3) xenial; urgency=medium

  * debian/patches/git_smbclient_cpu.patch:
    - backport upstream patch to fix smbclient users hanging/eating cpu on
      trying to contact a machine which is not there (lp: #1572260)

 -- Sebastien Bacher <email address hidden> Thu, 11 Aug 2016 10:39:10 +0200

Changed in samba (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for samba has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers