Nautilus browse network broken pipe on AFP after suspend

Bug #1093185 reported by svenmeier
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Unassigned

Bug Description

I use Nautilus to browse my files on my Synology Diskstation:
- Browse Network
- Select DiskStation
- Select a folder to connect to

After I suspend my notebook and logging in after 10 to 20 minutes, this procedure does not work any longer.
Nautilus reports "Error sending data: Broken pipe" when selecting the DiskStation.

It works again after logging out and in.

$ lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Revision history for this message
r (tatrabanka) wrote :

also for me on AFP:
"Error sending data: Broken pipe"
but mine does it even when computer runs as well as NAS!
then i cannot get that NAS' shared folder unmounted. keeps throwing error messages about time out. reboot resolves it.
wifi connection to it seems stable, today it did it after several hours of copying large iso files.
Nautilus 3.4.2 on 12.10 64bit, 3.5.0-22

Revision history for this message
r (tatrabanka) wrote :

also noticed when it happens, the process "gvfsd-afp" or "gvfsd-afp-browse" rockets up to around 100% of CPU load on at least of my 4 threads. it takes around 1.2MiB. visible in my scr-shot.

Revision history for this message
r (tatrabanka) wrote :

killing those two processes above tends to shut the error message but not resolving the cause.

today i've successfuly transferred (without any interruption) large files onto NAS, over the same wi-fi, but via Synology's web-based DSM GUI. so that means that NAS and wi-fi cannot be blamed. however the throughput speed was slower.

Revision history for this message
NuZeb (nudelzebra) wrote :

I got this error too on Ubuntu 13.04 (64bit) with an ethernet cable connection. The problem still occurs, sometimes after some time when I didn't use suspend. I'm not sure when exactly. Maybe when the Diskstation goes to sleep and wakes up again. Killing "gvfsd-afp" does work.

Revision history for this message
borninbronx (daniele-segato) wrote :

I can confirm this issue.

For me gvfsd-afp does not go to 100% CPU but gvfsd-afp-browse consume a little of it (about 12%).

Killing gvfsd-afp-browse and re-trying to enter the AFP share works (ask the password again)

Revision history for this message
Vic (ubuntu-slagter) wrote :

I can confirm this issue also
Release: 13.04

The broken pipe issue also happen when I am connected to a share on my Synology Diskstation and I change the privileges of the connected or any other share on the Synology for the connected or any other user.
For example I connect as user Piet to share music and change the privileges of user guest from readonly to read/write for share photos (all on teh sane NAS).
The the connection for user Piet is lost and the broken pipe error occurs.

Killing gvfsd-afp-browse makes the shares available again.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Undecided → Low
Revision history for this message
Abelardo Jara-Berrocal (abelardotomasjb) wrote :

I really dont know how these types of bugs are assigned with importance low? this is why linux cant be widely adopted because these bugs that heavily refer to user interface are just ignored - this is frustrating.

can someone fix this bug, i would say importance medium no low.

Revision history for this message
Pablo Quirós (polmac1985) wrote :

Any news on this? This bug is two years old and there doesn't seem to be much activity...

Revision history for this message
Krzysztof Janowicz (janowicz) wrote :

Same problem here with Synology Diskstation 214. Nautilus worked initally but after a few minutes all I am getting is 'This location could not be displayed. Sorry, could not display all the contents of “SERVERNAME”: Error sending data: Broken pipe'

Revision history for this message
Firen (f1ren) wrote :

Any news? After killing the gvfs processes it's possible to mount the remote location again in the terminal; gvfs-mount afp://[location]

The mount will also be shown by nautilus

Revision history for this message
Jean-Lin PACHERIE (jean-lin-pacherie) wrote :

Same problem here also. Having a Synology Diskstation 214Play and Ubuntu 14.04. After suspend/resume nemo can't reconnect a shared folder.

Processes gvfsd-afd and gvfsd-afd-browse at 100%. I killed them and nemo as well (nemo -q).

Then I restarted nemo and reconnected my shared folder and it worked. I had the connection up and running.

Revision history for this message
Regular User (dot.ru) wrote :

I can confirm this on ubuntu 14.04 synology ds213j.

Revision history for this message
Chris Gill (chris-gill7) wrote :

Same here with Ubuntu 14.04 and DS213J using the default file manager. Attempting to dismount NAS shares that appear in the file manager generally time out. Attempting to open them or the NAS gets the broken pipe error

Revision history for this message
Melvin Carvalho (melvincarvalho) wrote :

Same problem here 14.04 synology DS214

Revision history for this message
stef (topjetboy) wrote :

Same problem ubuntu 14.04, Synology DS1511+, Synology firmware DSM 5.0-4493 version3

explained here
http://stackoverflow.com/questions/4584904/what-causes-the-broken-pipe-error

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers