Ubuntu

gvfsd-obexftp crashed with SIGSEGV

Reported by Matthijs Lambooy on 2012-09-27
134
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Critical
gvfs (Gentoo Linux)
Fix Released
Critical
gvfs (Ubuntu)
Medium
Unassigned

Bug Description

Trying to open file dialog to download files from my phone.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gvfs-backends 1.13.9-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Thu Sep 27 16:16:15 2012
ExecutablePath: /usr/lib/gvfs/gvfsd-obexftp
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
ProcCmdline: /usr/lib/gvfs/gvfsd-obexftp --spawner :1.10 /org/gtk/gvfs/exec_spaw/6
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f813431860d: movdqu 0x30(%rsi),%xmm3
 PC (0x7f813431860d) ok
 source "0x30(%rsi)" (0x00966000) not located in a known VMA region (needed readable region)!
 destination "%xmm3" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: gvfsd-obexftp crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Matthijs Lambooy (lambooy) wrote :

StacktraceTop:
 memmove (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/string3.h:58
 delete (start=<optimized out>, len=2096, real=<optimized out>, real=<optimized out>) at ../../dbus/dbus-string.c:1175
 delete (len=<optimized out>, start=<optimized out>, real=<optimized out>) at ../../dbus/dbus-string.c:2695
 _dbus_string_delete (str=str@entry=0x932be8, start=start@entry=0, len=len@entry=2096) at ../../dbus/dbus-string.c:1200
 load_message (body_len=2032, header_len=64, fields_array_len=<optimized out>, byte_order=108, message=<optimized out>, loader=0x932be0) at ../../dbus/dbus-message.c:4171

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
tags: added: raring
information type: Private → Public
tags: added: apport-request-retrace
Cameron Smith (cameron-smith) wrote :

I have this problem in 12.10 and the same bug happens regardless of whether I try to browse the files on device via blueman, or the lame bluetooth-applet which has unfortunately become the default bluetooth app in 12.10.

Whereas on another laptop which is EXACTLY THE SAME MODEL (Samsung NP900X4C) as this one, I installed 12.04 and Bluetooth works like a dream. 2 mins after install, I was able to link to my phone via Bluetooth and immediately set up the internet connection via the phone, all using a simple wizard. I am really regretting going for 12.10 on the first laptop, it has brought a lot of trouble compared to 12.04.

Cameron Smith (cameron-smith) wrote :

For anyone who is suffering while waiting for this bug to be fixed, there is a workaround at: http://askubuntu.com/questions/214635/bluetooth-cant-browse-files-in-ubuntu-12-10/235517#235517

Software: Gentoo ~amd64, Gnome 3.6, G-bluetooth 3.6.1, gvfs 1.14.2, obexd 0.46,
0.4.6, bluez 4.101

To reproduce: try to browse a cell phone via bt menu on G-shell top bar.

gvfsd-obexftp[1815]: segfault at 4 ip 00007fe2ee4f3e60 sp 00007fff9d8408b8
error 6 in libdbus-1.so.3.7.2[7fe2ee4d2000+3c000]
pool[1862]: segfault at 0 ip 00007f305235b6a3 sp 00007f3049677940 error 4 in
libdbus-1.so.3.7.2[7f3052339000+3c000]

Reproducible 100%

Downgrade gvfs up to 1.12.3 fixes the problem.

Reproducible: Always

We need a gdb backtrace to determine what caused the crash.

Please re-emerge gvfs, glib, bluez, dbus, and dbus-glib with "-ggdb" in CFLAGS and "splitdebug" in FEATURES (see http://www.gentoo.org/proj/en/qa/backtraces.xml for more details).

Then emerge app-admin/abrt (if you don't have it already), do /etc/init.d/abrt start, do whatever needs to be done to crash gvfsd-obexftp, obtain the backtrace from abrt-gui, and attach it here.

This bug has been reported also upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=693574

Jussi Saarinen (jussaar) wrote :

This bug has been reported also upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=693574

Created attachment 340182
backtrace of the crash

Sorry for delay. Backtrace is attached. Please, help!

Package: gvfs-backends 1.15.3-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfsd-obexftp --spawner :1.10 /org/gtk/gvfs/exec_spaw/3

tags: removed: apport-request-retrace
Changed in gvfs (Gentoo Linux):
importance: Unknown → Critical
status: Unknown → New
Changed in gvfs:
importance: Unknown → Critical
status: Unknown → Incomplete
Changed in gvfs:
status: Incomplete → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.16.0-1ubuntu4

---------------
gvfs (1.16.0-1ubuntu4) raring; urgency=low

  * debian/patches/git_shutdown_segfault.patch:
    - backport fix for a common mtp backend segfault (lp: #1130101)
  * debian/patches/git_obex_dbus_segfault.patch:
    - backport another fix for a obexftp segfault (lp: #1057546)
  * debian/patches/gvfsd_http_handle_socketpair_error.patch:
    - replace with the upstream version
 -- Sebastien Bacher <email address hidden> Wed, 03 Apr 2013 21:40:19 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Jussi Saarinen (jussaar) on 2013-04-22
no longer affects: gvfs (Arch Linux)

solved in 1.16.x

Changed in gvfs (Gentoo Linux):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.