install of 'gv' package failed with 'no dir file specified'

Bug #316557 reported by Scot Becker on 2009-01-12
2
Affects Status Importance Assigned to Milestone
gv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gv

install of gv (1:3.6.4-3) using 'apt-get' failed with the error 'no dir file specified'. Full error report follows:

Get:1 http://gb.archive.ubuntu.com intrepid/main xaw3dg 1.5+E-15 [156kB]
Get:2 http://gb.archive.ubuntu.com intrepid/universe gv 1:3.6.4-3 [178kB]
Fetched 334kB in 6s (52.1kB/s)
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
 {{note that I had my terminal window at reduced height, but could that have cause the problem?}
debconf: falling back to frontend: Readline
Selecting previously deselected package xaw3dg.
(Reading database ... 145740 files and directories currently installed.)
Unpacking xaw3dg (from .../xaw3dg_1.5+E-15_i386.deb) ...
Selecting previously deselected package gv.
Unpacking gv (from .../gv_1%3a3.6.4-3_i386.deb) ...
Processing triggers for man-db ...
Setting up xaw3dg (1.5+E-15) ...

Setting up gv (1:3.6.4-3) ...
install-info: No dir file specified; try --help for more information.
dpkg: error processing gv (--configure):
 subprocess post-installation script returned error exit status 1
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 gv
E: Sub-process /usr/bin/dpkg returned an error code (1)

Apparently 1 package is installed correctly, the other not.

The command 'gv' does launch ghostview, but I haven't tested to see if it does everything as it should.

This is on Ubuntu 8.10, 32 bit.

*** UPDATE ***
I just got the same error installing GNU Enscript, which makes me think it's something on my own system. A messed up path for GNU info?
***************

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: gv 1:3.6.4-3
SourcePackage: gv
Title: package gv 1:3.6.4-3 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.27-9-generic i686

Scot Becker (scot-becker) wrote :
description: updated
Florian Diesch (diesch) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Could you please open a Terminal and post the output of the following commands:
  install-info --version
  type install-info

Changed in gv:
status: New → Incomplete
Scot Becker (scot-becker) wrote :

Thank *you* for following up on this. Since then I have also gotten the error while installing other packages (all GNU, I think). Here are the results of the commands:
-----------------------------------------<
$ install-info --version
\install-info (GNU texinfo) 4.12

Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

$ type install-info
install-info is hashed (/usr/local/texlive/2008/bin/i386-linux/install-info)
-----------------------------------------<
Further information: as you can perhaps see, I did install TeXLive 2008, which I had to do apart from the debian dpkg tools, since (1) it's not packaged yet and (2) I hoped to make use of the TeXlive packaging system for TeX-related updates (I too am tempted by a life of ease). So I see this might not be an Ubuntu bug.

If it is outside the realm of things Ubuntu to fix this, perhaps you might point me in the direction of a solution. I had planned a blog entry on "Installing TeXLive 2008 to Ubuntu." and perhaps I can save a few others this problem.

I just checked and I do have /usr/bin/install-info, it's just that the texlive path is first in my $PATH
Here's the '--version' results for it:
------------------------------------------<
$ /usr/sbin/install-info --version
Debian install-info version 1.14.20ubuntu1.

Copyright (C) 1994,1995 Ian Jackson.
This is free software; see the GNU General Public Licence version 2 or
later for copying conditions. There is NO warranty.
------------------------------------------<

[does a little web searching]
Aha, it is (as you probably suspected): I have GNU's install-info in my path before debian's install-info.
I see now that this is reasonably well trodden ground:

A debian bug report (demoted to a wishlist item):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=32550

Further discussion:
http://forum.soft32.com/linux2/Debian-gnu-install-info-ftopict273112.html

Proposals to migrate to GNU install-info:
http://lists.debian.org/debian-dpkg/2007/04/msg00031.html
http://lists.debian.org/debian-dpkg/2006/05/msg00061.html

So this is not strictly a debian/Ubuntu bug, since you can't prevent pesky users from putting GNU's install-info in their path before debian's--especially if they are installing outside the dpkg system, as I was. But perhaps one could add my little battle to the (surely growing) weight of cases which might someday tip the balance toward a migration to GNU's version, which I assume would fix this 'non-bug' :-)?

And meanwhile, it's not your job at all, but I don't suppose you have an elegant idea for keeping both dpkg *and* TeXLive's installer happy with their respective install-info's? (It may be that TeXLive does fine with debian's version. I haven't tried).

Anyway, sincere thanks for following this up (it's my first bug report, and, well, it is heartening to have seen it get handled).

And meanwhile

Scot Becker (scot-becker) wrote :

scratch that last "And meanwhile.." It was due to a non-bug bug in my brain.

It seems that this is the same issue discussed in these two bug reports, fwiw:
https://bugs.launchpad.net/bugs/79459
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/79459

Florian Diesch (diesch) wrote :

I'm going to mark this bug as a duplicate of bug #38538 (like #79459) to add your weight there. ;-)

To keep both dpkg and TeXLive happy I would make sure the GNU install-info is not in root's $PATH and then either use a wrapper script for the TeXLive installer that adds GNU update-info to $PATH or use an extra user that has GNU install-info in $PATH to manage TeXLive.

BTW, very good job for a first bug report :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.