guvcview crashes when starting to record video

Bug #872026 reported by Riccardo Pelizzi on 2011-10-10

This bug report was converted into a question: question #179325: guvcview crashes when starting to record video.

90
This bug affects 20 people
Affects Status Importance Assigned to Milestone
guvcview (Ubuntu)
Undecided
Unassigned

Bug Description

When i press "capture video" guvcview segfaults. unfortunately it does not produce a crash report even with apport enabled so i don't have a backtrace. I am attaching the console output, hopefully it helps.

Note: this does not seem to be a dup of #655528, i get the bug no matter what codec i choose, and the output seems to be different.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: guvcview 1.4.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.4-chipmunk i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Mon Oct 10 17:29:48 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
SourcePackage: guvcview
UpgradeStatus: No upgrade log present (probably fresh install)

Riccardo Pelizzi (r-pelizzi) wrote :
Riccardo Pelizzi (r-pelizzi) wrote :

this is what i get with gdb guvcview, not helpful either:

#0 0x080680a1 in ?? ()
#1 0x0805e2a5 in ?? ()
#2 0xb79825f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb7810d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#4 0xb6ba90ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in guvcview (Ubuntu):
status: New → Confirmed
Salih EMIN (salih-emin) wrote :

I don't know if I should file a new bug report but I want to add that it crashes also when I press "Capture Image"

Riccardo Pelizzi (r-pelizzi) wrote :

capture image works for me

Brittany Dunlap (xdunlapx) wrote :

Neither capture image or video works for me. It segfaults on either. I've attached my own terminal output of running guvcview and the segfault at the end. I hope we can figure this out. I want to be able to record video with audio that actually sync's up as cheese doesn't work right in that regard.

titaniumtux (titaniumtux) wrote :

Capture video makes Guvcview crash for me too, however capture image does not crash Guvcview for me. Anyone know of any work-arounds or is anyone able to use video capture in Guvcview in Ubuntu 11.10 without it crashing?

caixamagica (caixa-magica) wrote :

Same here, video capture (not image capture) makes Guvcview crash on Lubuntu 11.10. Changing the video codec doesn't make any difference.

Terminal output, in the end says:

[mp2 @ 0xb6720140] codec type or id mismatches
could not open codec
segmentation fault

Rino (rino-sapere) wrote :

Guvcview crashs again.......

Rino (rino-sapere) wrote :

When I start capturing video Guvcview goes crash !

Changed in guvcview (Ubuntu):
status: Confirmed → Invalid
giosoftware (giosoftware) wrote :

The same for me.
When I start to capture video a get this error:
[mp2 @ 0x175e7a0] codec type or id mismatches
could not open codec
Segmentation fault

And program crashes :(

Bruce Crowther (bwucie) wrote :

I get the same problem, with this message in a terminal:

"Closing audio stream...
[libvo_aacenc @ 0x7f8058002000] codec type or id mismatches
could not open codec
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
guvcview: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed."

But! If I use the "PCM -uncompressed (16 Bit)" sound setting, then it's fine.

So we have yet another Ubuntu regression, because in the past this program has worked fine with either MP2 or MP3.

clockworkpc (clockworkpc) wrote :
Download full text (12.5 KiB)

Using PCM -uncompressed (16 Bit) only half works, because it seems to drop half the audio frames and consequently half the video frames in order to compensate:

cpcmonster@cpcmonster-EX58-UD3R:~$ guvcview
guvcview 1.4.5
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
video device: /dev/video0
Init. Microsoft® LifeCam HD-3000 (location: usb-0000:00:1a.7-6)
{ pixelformat = 'YUYV', description = 'YUV 4:2:2 (YUYV)' }
{ discrete: width = 640, height = 480 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 1280, height = 720 }
 Time interval between frame: 1/10, 2/15,
{ discrete: width = 960, height = 544 }
 Time interval between frame: 1/15, 1/10, 2/15,
{ discrete: width = 800, height = 448 }
 Time interval between frame: 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 640, height = 360 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 424, height = 240 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 352, height = 288 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 320, height = 240 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 800, height = 600 }
 Time interval between frame: 1/15, 1/10, 2/15,
{ discrete: width = 176, height = 144 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 160, height = 120 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 1280, height = 800 }
 Time interval between frame: 1/10,
{ pixelformat = 'MJPG', description = 'MJPEG' }
{ discrete: width = 640, height = 480 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 1280, height = 720 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 960, height = 544 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 800, height = 448 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 640, height = 360 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 800, height = 600 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 416, height = 240 }
 Time interval between frame: 1/30, 1/20, 1/15, 1/10, 2/15,
{ discrete: width = 352, height = 288 }
 Ti...

Mark Fraser (launchpad-mfraz) wrote :

My daughter is having this problem in Kubuntu 11.04 and it seems to be affecting Fedora users too http://forums.fedoraforum.org/showthread.php?t=267553

Mark Fraser (launchpad-mfraz) wrote :

Using version 1.5.1 from Paulo Assis' PPA pj-assis/ppa seems to fix the crashing problem.

Bruce Crowther (bwucie) wrote :

Certainly does: good call, Mark, and nice verks, Paulo.

dplmartin (dominic-martin) wrote :

Just to confirm, I'm on Ubuntu 11.10. I installed GUVCView and as soon as I clicked the button to record, it crashed out on me. I went to the website refered to above - https://launchpad.net/~pj-assis/+archive/ppa . I installed the PPA according to the instructions on the site. Then I used ubuntu update manager to look for new updates. It found one at the bottom of the list for GUVCView. After the update, I could record view just fine.

Tomislav (hefest) wrote :

Crashes for me, too, both on image and video acquisition.

Ubuntu 11.10, guvcview 1.4.5 apt-get installed 5 minutes ago from default repositories.

Tomislav (hefest) wrote :

Managed to take a picture by switching camera output from MJPEG to RGB3, video still broken.

I believe I have also discovered at least one packaging bug: installing guvcview did not install ffmpeg (although it supposedly depends on it) so I installed it myself. Didn't help video recording, though. :\

Bruce Crowther (bwucie) wrote :

Try the 1.5.1 version as in answer #15 in this thread, Tomislav.

Filipo Rviz (filipo747) wrote :

Version 1.5.2 works for me.
But I still having black screen on preview window.

Changed in guvcview (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
status: Invalid → Confirmed
Chris Gagnon (chris.gagnon) wrote :

Marked confirmed this is still a bug

apt-cache policy guvcview:
  Installed: 1.4.5-1ubuntu1
  Candidate: 1.4.5-1ubuntu1
  Version table:
 *** 1.4.5-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

Mörgæs (moergaes) wrote :

Have you tried 1.5.3?

Dirk Wallenstein (halsmit) wrote :

It works when installing ogmrip (found when looking for for lavc)

Mörgæs (moergaes) wrote :

With the release of Ubuntu 12.04, Guvcview is now in version 1.5.3 where the bug is fixed.

If a similar bug appears in 1.5.3 please open a new bug report.

Changed in guvcview (Ubuntu):
status: Confirmed → Fix Released
Patrick Schmalstig (xanaftp) wrote :

I am experiencing the bug in 1.5.3 on Kubuntu 11.10

If I use ANY OTHER SETTING other than the strictly default settings for guvcview of 320X240 image res, codec MJPG compressed, format AVI, Audio format PCM 16 bit... I either get:

guvcview: relocation error: guvcview: symbol avcodec_open2, version LIBAVCODEC_53 not defined in file libavcodec.so.53 with link time reference

OR

Floating Point Exception

I do not wish to use the default settings as... on my computer... the codec causes the video and audio to be out of sync.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions