Can't open gufw in Ubuntu 16.04

Bug #1573567 reported by 賴家亨 on 2016-04-22
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Gufw
Critical
Devid Antonio Filoni
One Hundred Papercuts
Medium
Unassigned
gui-ufw (Ubuntu)
Medium
Devid Antonio Filoni
Xenial
Undecided
Unassigned

Bug Description

[Impact]
 * gui-ufw doesn't start in Xenial due to missing dependency on python-gi as we can see on the following traceback. Uploaded package (I'm attaching debdiff too) adds missing dep.

[Test Case]
 * Try to run gufw on a system where python-gi package is not installed

[Regression Potential]
 * We cannot evaluate regressions as the package at the moment does not work at all, however upstream (costales) is very active, as you can see from this bug comments too, so I'm really confident he will fix any possible big issue ASAP if asked for.

[Other Info]

ORIGINAL BUG:

Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 21, in <module>
    from view.gufw import Gufw
  File "/usr/share/gufw/gufw/view/gufw.py", line 19, in <module>
    import gi

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gufw 16.04.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 22 20:17:49 2016
InstallationDate: Installed on 2016-04-22 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=zh_TW:zh
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=zh_TW.UTF-8
 SHELL=/bin/bash
SourcePackage: gui-ufw
UpgradeStatus: No upgrade log present (probably fresh install)

賴家亨 (laichiaheng) wrote :
costales (costales) wrote :

Hi 賴家亨
Could you try this and confirm it is fixing the issue?
sudo apt-get install python-gi
Thanks in advance!

Changed in gui-ufw (Ubuntu):
status: New → Confirmed
Changed in gui-ufw:
assignee: nobody → Devid Antonio Filoni (d.filoni)
importance: Undecided → Critical
status: New → Triaged
costales (costales) wrote :

Hi Devid Filoni :)

Please, could you upload the same version 16.04.1:
https://lists.launchpad.net/gufw-maintainers/msg00020.html
with the "python-gi" dependence in the package?

Thanks in advance!

賴家亨 (laichiaheng) wrote :

It works after I install python-gi, thanks.

Changed in gui-ufw (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gui-ufw (Ubuntu Xenial):
status: New → Confirmed
Devid Antonio Filoni (d.filoni) wrote :
description: updated
Changed in gui-ufw (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in gui-ufw (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Devid Antonio Filoni (d.filoni)

Hello 賴家亨, or anyone else affected,

Accepted gui-ufw into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gui-ufw/16.04.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gui-ufw (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I tested with Lubuntu 16.04 LTS. First I uninstalled python-gi (which removed lubuntu-software-center and lubuntu-desktop.) Then I installed gufw. It didn't run.

Then I installed gufw from -proposed which has a hard dependency on python-gi. Once python-gi was installed again, gufw runs.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gui-ufw has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gui-ufw - 16.04.1-0ubuntu1.1

---------------
gui-ufw (16.04.1-0ubuntu1.1) xenial-proposed; urgency=medium

  * debian/control: add python-gi to Depends field (LP: #1573567)

 -- Devid Antonio Filoni <email address hidden> Tue, 17 May 2016 19:16:51 +0200

Changed in gui-ufw (Ubuntu Xenial):
status: Fix Committed → Fix Released
costales (costales) on 2016-08-29
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in gui-ufw:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches