File picker gets bigger more and more each time!

Bug #1971112 reported by Alixsep
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gtk4 (Ubuntu)
Fix Released
High
Unassigned
Jammy
Fix Released
High
Unassigned

Bug Description

Impact
------
Many users are annoyed that the GTK4 file chooser gets bigger every time it's used until it fills the whole screen. The GTK4 file chooser is used by xdg-desktop-portal-gnome so it's used by many Snap apps like Firefox & Chromium.

Test Case
---------
Install the gtk4 updates.
Then log out or restart your computer (the xdg-desktop-portal-gnome runs in the background).
From the Firefox snap, hit Ctrl+O to open the file chooser.
Manually reduce the size of the file chooser by dragging the edges in.
Hit Ctrl+O multiple times.
The file chooser should stay the same size.

What Could Go Wrong
-------------------
Please see the master bug for this update: https://launchpad.net/bugs/1976500

Original Bug Report
-------------------
Hello. I've just switched to Ubuntu and ever since day 1 I had this issue that whenever I tried to choose a file the file picker window was way too big and it was getting bigger and bigger each time. I have posted a video on Reddit recording this unusual/unexpected behavior.
Here is the reddit post link (with video):
https://www.reddit.com/r/Ubuntu/comments/ug97qx/annoying_bug_file_picker_gets_bigger_more_and/
I've also attached the video to this post, in case you don't want to click the link above.

Here is my neofetch output:

OS: Ubuntu 22.04 LTS x86_64
Kernel: 5.15.0-27-generic
Uptime: 13 hours, 13 mins
Shell: bash 5.1.16
Resolution: 1440x900, 1920x1080
DE: GNOME 42.0
WM: Mutter
WM Theme: Adwaita
Theme: Yaru-viridian-dark [GTK2/3]
Icons: Yaru-viridian [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i7-8700K (12) @ 4.700GHz
GPU: NVIDIA GeForce GTX 1060 3GB
Memory: 5869MiB / 15936MiB

Revision history for this message
Alixsep (alixsep) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Libera.chat.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1971112/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → nautilus (Ubuntu)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, which software are you using there? do you get the issue with any other gtk client?

Revision history for this message
George (george-labuschagne-gmail) wrote :

Hi, I get the same bug. It is mainly under Google Chrome, effecting multiple of my users (they only use file open on that).

Revision history for this message
George (george-labuschagne-gmail) wrote :

Confirmed now that the same bug happens on the default installed Firefox browser.

Setup tested used two screens with different resolutions: 1366x768 and 1920x1080

Revision history for this message
Sebastien Bacher (seb128) wrote :

Is that on an xorg session? If so it sounds like https://gitlab.gnome.org/GNOME/gtk/-/issues/4136

affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
Revision history for this message
Tim Richardson (tim-richardson) wrote :

I see this in the xorg session in the flatpak firefox save downloads dialog, for instance.

Revision history for this message
Dario (duperuser) wrote (last edit ):

I also have this issue and have tried to troubleshoot it.

Maybe this is an interesting contribution.

If you use dconf-editor and find the "window-size" option for filechooser, you can see the dimensions of the current filechooser window. Here, you can manually set it to something reasonable (e.g., 800x600) or the default. Then press save.

https://i.postimg.cc/zvGTpYmy/filechooer.jpg

Ok, how here is the interesting bit. When you next call the filechooser from an app showing this annoying behaviour, you will see that you need to reload the deconf-editor window because changes have been made. So the app call changed the user-set size and increased it. But also changes it from default to another size (bigger).

In my desperation I even tried to make the dconf file read only and even tried to change its owner to prevent my user from writing (changing it). None of these work.

Another addition to this bug.
The behaviour where the dialogue window is not responsive is because the background window (the browser, for example) is still in focus. This is why you cannot press escape to close the filechooser. In fact, you can press ctr+s multiple times and it just opens a new instance of filechooser with a larger window than before until maximised.

I can confirm that this behaviour is shown in Brave browser (chrome), Firefox, and Telegram.

Revision history for this message
Matthew Gallagher (smokey-panda) wrote :

As I've noted in my duplicate bug report, this effects snaps (Firefox, Brave) but not apts (Evince, Thunderbird).

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → gtk4 (Ubuntu)
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue isn't snap vs deb, it's a bug in gtk4 on x11. The snaps (and flatpak) use portals to interact with the filesystem and the GNOME portal is written in gtk4 where the evince and thunderbird debs are still on gtk3

reading upstream posts it sounds like doing
$ gsettings reset org.gtk.gtk4.Settings.FileChooser window-size

should workaround the issue until the dialog is manually resized again

Jeremy Bicha (jbicha)
Changed in gtk4 (Ubuntu):
status: Confirmed → Fix Committed
Changed in gtk4 (Ubuntu Jammy):
status: New → In Progress
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk4 - 4.6.5+ds-1ubuntu1

---------------
gtk4 (4.6.5+ds-1ubuntu1) kinetic; urgency=medium

  * Sync with Debian. Remaining change:
    - debian/tests:
      + include the memorytexture test in the flaky set, it has been unreliable

gtk4 (4.6.5+ds-1) unstable; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release (LP: #1976500)
    - Fixes file chooser getting bigger each time it opens (LP: #1971112)
  * Drop 2 patches applied in new release

  [ Laurent Bigonville ]
  * debian/control.in: Disable librsvg BD on architectures where it's not
    building

 -- Jeremy Bicha <email address hidden> Thu, 19 May 2022 10:16:34 -0400

Changed in gtk4 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Alixsep, or anyone else affected,

Accepted gtk4 into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk4/4.6.5+ds-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gtk4 (Ubuntu Jammy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-jammy
Jeremy Bicha (jbicha)
description: updated
description: updated
Revision history for this message
Pirouette Cacahuète (lissyx) wrote :

Looks like it finally fixes the issue on Firefox Snap, stable channel with XWayland enabled.

Revision history for this message
Paul White (paulw2u) wrote :

Further to comment #14, I am using Ubuntu in an Xorg session. After upgrading gtk4 to version 4.6.5+ds-0ubuntu1 I rebooted and referred to the testcase in the bug description.

While running the snap version of Firefox I see that after resizing the 'File | Save' and 'File | Open' choosers the new size is remembered unlike before the update. Bug fix verified.

tags: added: verification-done verification-done-jammy
removed: verification-needed verification-needed-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk4 - 4.6.5+ds-0ubuntu1

---------------
gtk4 (4.6.5+ds-0ubuntu1) jammy; urgency=medium

  * New upstream release (LP: #1976500)
     - Fixes file chooser getting bigger each time it opens (LP: #1971112)
  * Build-Depend on gi-docgen
  * Drop patches applied in new release

 -- Jeremy Bicha <email address hidden> Wed, 01 Jun 2022 11:36:03 -0400

Changed in gtk4 (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for gtk4 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.