gtk2-engines-murrine desktop text shadow problem

Bug #1598316 reported by Rob Peters on 2016-07-01
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gtk2-engines-murrine (Debian)
Fix Released
Unknown
gtk2-engines-murrine (Ubuntu)
Critical
Unassigned
Xenial
Critical
Unassigned

Bug Description

Impact
======
https://launchpad.net/ubuntu/+source/gtk2-engines-murrine/0.98.2-0ubuntu2.1

The above SRU caused a major regression: On Xfce, desktop icon labels are now badly misaligned. This affects numix-gtk-theme which is included (but not as the default theme) with Xubuntu 16.04 LTS. Third-party affected themes include Arc and Vertex.

Test Case
=========
1. In Xubuntu 16.04 LTS, open the Xfce menu in the top left corner of the screen.
2. Select Settings>Appearance
3. Select Numix.

Do the desktop icon labels look ok or do they look like the screenshot posted in comment #17?

Regression Potential
====================
This obviously re-opens bug 1294699 but that seems to be a fairly obscure bug. Who sets their default system theme to a bitmap font in 2016? That regression is outweighed by breaking several popular themes.

Original Bug Report and Followup
================================
Upgraded my xubuntu 16.04 system on 01 Jul 2016. The apt update included an upgrade to gtk2-engines-murrine. However, after the upgrade and boot, the any desktop text, folder, launcher, etc. had a problem with the text and shadow being quite far apart.

This bug affects themes that use the textstyle feature of the murrine engine on xfdesktop4. Ubuntu MATE 16.04, which also uses gtk2 but has caja draw the desktop icons instead of xfdesktop, does not appear to be affected (or at least not nearly as noticeably).

Rob Peters (makitso) wrote :

Problem is in the Numix theme.

Changed in gtk2-engines-murrine (Ubuntu):
status: New → Incomplete
Corey Bruce (cdfrosty) wrote :

It's not the Numix theme it's gtk2-engines-murrine, after a update all my themes including default themes are having issues and look buggy with the shadows/background colour for the text out of place.

Alex (7-alex-a) wrote :

Using the Vertex theme, same problem. Downgraded from 0.98.2-0ubuntu2.1 to gtk2-engines-murrine=0.98.2-0ubuntu2 which fixed the out-of-place shadow for me.

Alex (7-alex-a) wrote :

The patch from 0.98.2-0ubuntu2.1 which is supposed to fix a crash when using bitmap fonts,
and is causing this issue: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827134

Jeremy Bicha (jbicha) on 2016-07-16
tags: added: regression-update
Changed in gtk2-engines-murrine (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Changed in shimmer-themes (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in numix:
status: Unknown → Fix Released
Jason (jholland918) wrote :

I don't think it's the numix theme either as I was using the Arc theme. Here's a post showing the screen shot of the issue I was having until I downgraded the package:
http://askubuntu.com/questions/798778/desktop-icon-foreground-text-is-way-offset

Jeremy Bicha (jbicha) on 2016-07-18
Changed in arc-theme (Ubuntu):
status: New → Triaged
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-07-18
tags: added: iso-testing
Changed in arc-theme:
status: Unknown → New
Changed in gtk2-engines-murrine (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) on 2016-07-19
tags: added: xubuntu-exp
Jeremy Bicha (jbicha) on 2016-07-19
description: updated
Changed in shimmer-themes (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

ochosi, I think this is a bug in xfdesktop, but since Numix has a workaround for it I'm going to re-open the shimmer-themes task.

Changed in shimmer-themes (Ubuntu):
status: Invalid → Triaged
Simon Steinbeiß (ochosi) wrote :

The workaround from Numix is not using the shadow drawing of Murrine but the one that is (totally superfluously) coded into xfdesktop4.

You can also see this issue with Greybird in the Alt-tab dialog of xfwm4, so it's definitely an issue with Murrine and working around it in shimmer-themes is possible, but will only help if we also drop all text-shadow from everywhere else (and I'm not even talking about other themes that might be using this Murrine function).

(Easy way to reproduce: Open a few different windows, one of them being the xfce4-terminal, then use "alt-tab" to cycle and when your focus hits the terminal - boom, text-shadow with weird offset.)

Changed in shimmer-themes (Ubuntu):
status: Triaged → Invalid
Kev Bowring (flocculant) wrote :

@~jbicha

This might be a bit obvious - but why are we not reverting to the package that doesn't cause the issue?

In addition - why did this package land anyway?

Kev Bowring (flocculant) wrote :

It's hard enough for a flavour to get testing while a development version is running - changing things and breaking them when we have tested isn't very fair socially ...

Jeremy Bicha (jbicha) wrote :

@flocculant, had this bug been noticed before the SRU went out everywhere, it wouldn't have been released. I feel I was fairly proactive on this issue (I don't even use Xfce) pinging the original commit writer and the Debian maintainer and pushing a bit on some theme developers. And I release-noted the issue. I thought Xubuntu was aware of the issue but maybe I should have made sure of that.

At this point, the bug is "fixed" in yakkety in that the only distro theme I am aware of that is still affected is arc-theme (I just have to ping the maintainer of the arc-theme to backport the upstream commit, but arc-theme isn't packaged in Xenial.)

For Xenial, we can just backport the numix-gtk-theme patch to the shimmer-themes package and then this bug is fixed for all distro themes I believe. That is on my to-do list unless someone gets to it sooner. It took me longer than I expected to get numix-gtk-theme repackaged in Yakkety.

If you still think the murrine bugfix to be reverted, you can go ahead. It might not be necessary now though...

Kev Bowring (flocculant) wrote :

@jbicha, I certainly didn't see the SRU (perhaps because of bug subscription(S)), first we knew of the issue was someone in #xubuntu ;)

I'm still catching people in the irc channel - been away, updating, boom

Jeremy Bicha (jbicha) wrote :

I posted it to http://iso.qa.ubuntu.com/qatracker/milestones/363/builds so I think you should have seen it there

hoek (hoek) wrote :

I have the same problem. After update to Xubuntu 16.04 :( on any theme and icon set.

alan winn (i-alan) wrote :

This issue affects all themes and icon sets that I have tried it with on 16.04.
It also remains in the daily build of 16.10.
Reverting to gtk2-engines-murrine=0.98.2-0ubuntu2 fixes the problem, but this does not seem to be available in 16.10 so is more difficult to fix.

Alexander (sality) wrote :

I have the same problem. Plz fix! Xubuntu 16.04

Jeremy Bicha (jbicha) on 2016-09-05
no longer affects: arc-theme (Ubuntu Xenial)
Changed in gtk2-engines-murrine (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
Jeremy Bicha (jbicha) wrote :
description: updated
Jeremy Bicha (jbicha) wrote :

I'm setting the Importance to Critical according to https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in gtk2-engines-murrine (Ubuntu):
status: Triaged → Fix Committed
importance: High → Critical
Changed in gtk2-engines-murrine (Ubuntu Xenial):
importance: High → Critical
Jeremy Bicha (jbicha) wrote :

Closing the shimmer-themes task since we decided to fix this by reverting the murrine engine SRU instead.

Changed in shimmer-themes (Ubuntu Xenial):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk2-engines-murrine - 0.98.2-0ubuntu5

---------------
gtk2-engines-murrine (0.98.2-0ubuntu5) yakkety; urgency=medium

  * Remove pango_cairo_update_layout.patch:
    - The patch caused text shadows to be very misaligned for Xfce desktop
      icon labels with several different themes (LP: #1598316)

 -- Jeremy Bicha <email address hidden> Mon, 05 Sep 2016 19:15:00 -0400

Changed in gtk2-engines-murrine (Ubuntu):
status: Fix Committed → Fix Released

Hello makitso, or anyone else affected,

Accepted gtk2-engines-murrine into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk2-engines-murrine/0.98.2-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk2-engines-murrine (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Andreas (andreas84) wrote :

Hello Martin,
thanks a for the new and patched version.
I had this issue with the Numix Theme in XFCE as well for quiet some time.

I just updated the xenial-proposed packages and rebooted.
I can confirm that the display of desktop icon shadows is now fixed.

This is my currently installed version:
apt list gtk2-engines-murrine
Auflistung... Fertig
gtk2-engines-murrine/xenial-proposed,now 0.98.2-0ubuntu2.2 amd64 [installiert]

Thanks a lot for your fix.
I really appreciate your efforts.

All the best,
Andreas

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu Xenial):
status: New → Confirmed
Andreas (andreas84) on 2016-09-07
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gtk2-engines-murrine has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk2-engines-murrine - 0.98.2-0ubuntu2.2

---------------
gtk2-engines-murrine (0.98.2-0ubuntu2.2) xenial; urgency=medium

  * Remove pango_cairo_update_layout.patch and revert to previous
    version of gtk2-engines-murrine. The patch caused text shadows
    to be very misaligned for Xfce desktop icon labels with several
    different themes (LP: #1598316)

 -- Jeremy Bicha <email address hidden> Mon, 05 Sep 2016 18:58:41 -0400

Changed in gtk2-engines-murrine (Ubuntu Xenial):
status: Fix Committed → Fix Released
no longer affects: xfdesktop4 (Ubuntu Xenial)
no longer affects: xfdesktop4 (Ubuntu)
no longer affects: shimmer-themes (Ubuntu Xenial)
no longer affects: shimmer-themes (Ubuntu)
no longer affects: arc-theme (Ubuntu)
affects: numix → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
affects: arc-theme → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
no longer affects: ubuntu-translations
Changed in gtk2-engines-murrine (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.