GTK applications crash sometime with gdk_events functions to the backtrace

Bug #71345 reported by Ralf on 2006-11-11
348
Affects Status Importance Assigned to Milestone
GTK+
Expired
Critical
gtk-qt-engine (Ubuntu)
Medium
Unassigned

Bug Description

I've installed Kubuntu 6.10. To have the best of both desktops - KDE and Gnome - I did update the system and then installed the metapackage Ubuntu-Desktop and configured the system to use GDM.

Restarted the system and login to KDE, seems to work (did not test very much).

Closed the session and login to Gnome, the first thing I noticed was the starnge menu color. The highlighted menuentry appears in purple, not the default Human-color. Also some (strange, but not all) icons are now KDE-style. For example the icons "Back", Forward", "Up", "Stop" and "Refresh" in Nautilus are KDE-sylte, the other icons "Personal Folder", "Computer" and "Search" are Human-icons.

Started the Gnome-Theme-Manager and all the themes had a ? in the picture. Changing settings then is simply not possible, because the theme-manager crashes.

Regards,

rpw

Ralf (ralf-weyer) on 2006-11-11
description: updated
Ralf (ralf-weyer) wrote :
Fish (growlatoe) wrote :

I've had similar a experience, except I started with Xubuntu 6.10 (although I've been using the Gnome desktop for weeks without any problems). I installed the KDE Desktop the other day, and now the Gnome Theme Manager crashes. At least, some of it does. The theme window remains usable, but only changes to the Window Border are applied.

I also had a list of "?" where the theme icons should be.

Sebastien Bacher (seb128) wrote :

Debug backtrace:

#0 0xb7d61a9a in ?? ()
#1 0x433e9021 in gdk_event_apply_filters (xevent=0xbffd7868, event=0x80820f0, filters=0x80a5320) at gdkevents-x11.c:345
#2 0x433ea78c in gdk_event_translate (display=0x807b098, event=0x8106d08, xevent=0xbffd7868, return_exposes=0)
    at gdkevents-x11.c:894
#3 0x433ec3bb in _gdk_events_queue (display=0x807b098) at gdkevents-x11.c:2254
#4 0x433ec7bf in gdk_event_dispatch (source=0x8085210, callback=0, user_data=0x0) at gdkevents-x11.c:2314
#5 0x4298d802 in IA__g_main_context_dispatch (context=0x8085258) at gmain.c:2045
#6 0x429907df in g_main_context_iterate (context=0x8085258, block=1, dispatch=1, self=0x8086690) at gmain.c:2677
#7 0x42990b89 in IA__g_main_loop_run (loop=0x8085df0) at gmain.c:2881
#8 0x41d6b574 in IA__gtk_main () at gtkmain.c:1024
#9 0x08059d09 in theme_thumbnail_factory_init ()

Sebastien Bacher (seb128) wrote :

Upstream assigned that bug to GTK: http://bugzilla.gnome.org/show_bug.cgi?id=364396, doing the same with the Ubuntu task

Changed in control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in gtk:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Do people having that problem have gtk2-engines-gtk-qt or kubuntu installed?

I installed Kubuntu first and "Ubuntu-Desktop" on top of that. Then I
removed the gtk2-engines-gtk-qt or something like that, which also
removes "kubuntu-desktop".

The problem persists in Feisty, but in Edgy removing the gtk2...
package solved the problem of "gnome-theme-manager" crashing (Although
now Firefox and all the gtk applications look ugly on KDE).

Let me know what else I can do to help you guys.

Cheers

Mariano

On 2/24/07, Sebastien Bacher <email address hidden> wrote:
> Do people having that problem have gtk2-engines-gtk-qt or kubuntu
> installed?
>
> --
> GTK applications crash sometime with gdk_events functions to the backtrace
> https://launchpad.net/bugs/71345
>

Sebastien Bacher (seb128) wrote :

Could you get a backtrace on feisty without gtk2-engines-gtk-qt installed? do you have a .gtkrc-2.0? what it contain? could you copy that to a comment?

I did a backtrace last time but I forgot how. Could you please refresh
my memory?

I dis not find a file with that name.

Thanks!!!!

Mariano

On 2/24/07, Sebastien Bacher <email address hidden> wrote:
> Could you get a backtrace on feisty without gtk2-engines-gtk-qt
> installed? do you have a .gtkrc-2.0? what it contain? could you copy
> that to a comment?
>
> --
> GTK applications crash sometime with gdk_events functions to the backtrace
> https://launchpad.net/bugs/71345
>

Sebastien Bacher (seb128) wrote :

the package name has change, do people have gtk-qt-engine installed?

Hello,

I had the gtk-qt-engine installed the last time. The one I had removed
originally was the gtk2-engines-qt...

Now that I also removed the gtk-qt-engine package GNOME loads and I
can modify the themes. However, I still got a crash at startup
(Synaptic this time). I am attaching a ZIP file with the crash reports
I got in /var/crash/ (Sorry, I cannot send it it is a 21MB file! Can I
upload it somewhere?).

Just let me say that now KDE looks very ugly without the qt-gtk
engine. Especially Firefox looks very creepy. Do you think this bug is
fixable?

Let me know what else I could do for helping you guys.

Cheers

Mariano

On 2/28/07, Sebastien Bacher <email address hidden> wrote:
> the package name has change, do people have gtk-qt-engine installed?
>
> --
> GTK applications crash sometime with gdk_events functions to the backtrace
> https://launchpad.net/bugs/71345
>

Sebastien Bacher (seb128) wrote :

The synaptic bug might be a different problem. To attach a light crash file you can install libglib2.0-0-dbg libgtk2.0-0-dbg synaptic-dbgsym and run apport-retrace -c file.crash, it'll update it with a debug backtrace and drop the dump

Ok, I upload all the crash reports I had when loading GNOME with the
gtk-qt-engine installed.

Hope hat helps

Cheers

Mariano

On 3/1/07, Sebastien Bacher <email address hidden> wrote:
> The synaptic bug might be a different problem. To attach a light crash
> file you can install libglib2.0-0-dbg libgtk2.0-0-dbg synaptic-dbgsym
> and run apport-retrace -c file.crash, it'll update it with a debug
> backtrace and drop the dump
>
> --
> GTK applications crash sometime with gdk_events functions to the backtrace
> https://launchpad.net/bugs/71345
>

Sebastien Bacher (seb128) wrote :

that looks like a gtk-qt-engine bug

Changed in gtk:
status: Confirmed → Rejected
Changed in gtk:
status: Invalid → Confirmed
Jonathan Thomas (echidnaman) wrote :

Still an issue in Intrepid?

Changed in gtk-qt-engine:
status: Confirmed → Incomplete
Changed in gtk-qt-engine:
assignee: desktop-bugs → nobody
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gtk-qt-engine:
status: Incomplete → Invalid
Changed in gtk:
importance: Unknown → Critical
Changed in gtk:
status: Confirmed → Expired
To post a comment you must log in.