Ubuntu

notification-daemon crashed with signal 5 in g_return_if_fail_warning()

Reported by jmattock78 on 2012-02-04
428
This bug affects 70 people
Affects Status Importance Assigned to Milestone
notification-daemon
Fix Released
Medium
gtk+3.0 (Ubuntu)
Medium
Unassigned
Precise
High
Unassigned

Bug Description

Impact:
Some software using a GtkStatusIcon (classic notification area icons) get segfaults from GTK with some panel configurations

The update also include small other fixes from git, including some api documentation changes and an obvious typo fix

Test Case 1:
if you are one of those users getting segfault, try on your configuration with the update version to see if they stop

Test Case 2:
look at the api documentation changes in the diff and see if you disagree with any

Test Case 3:
try to use get_property('stock') on a GtkImage, it should return the icon id not the name

Regression potential:
notification area icons could be incorrectly displayed in some cases if the maths done in the patch are wrong

the documentation changes are obvious, review for errors

the property change is obvious as well, it's changed to return the right value
---

no idea what this did..: but looking in .xsession* I see

** WARNING **: Failed to show notification: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

guess /usr/share/dbus-1 is where the problem can be fixed.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: notification-daemon 0.7.3-1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Feb 4 09:10:26 2012
ExecutablePath: /usr/lib/notification-daemon/notification-daemon
InstallationMedia: Lubuntu 11.04 "Natty Narwhal" - i386 (20101203)
ProcCmdline: /usr/lib/notification-daemon/notification-daemon
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: notification-daemon
UpgradeStatus: Upgraded to precise on 2012-02-04 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

jmattock78 (justinmattock) wrote :
jmattock78 (justinmattock) wrote :

im sorry I filed a duplicate bug.. a more complete description is this bug..: Bug #927031

StacktraceTop:
 g_return_if_fail_warning (log_domain=0xb7036de6 "GdkPixbuf", pretty_function=0xb7038501 "gdk_pixbuf_scale_simple", expression=0xb703839e "dest_width > 0") at /build/buildd/glib2.0-2.31.14/./glib/gmessages.c:801
 gdk_pixbuf_scale_simple (src=0x9e394b8, dest_width=0, dest_height=0, interp_type=GDK_INTERP_BILINEAR) at gdk-pixbuf-scale.c:323
 gtk_icon_theme_lookup_by_gicon (icon_theme=0x9e61500, icon=0x9e394b8, size=0, flags=20) at /build/buildd/gtk+3.0-3.3.12/./gtk/gtkicontheme.c:3911
 gtk_icon_theme_lookup_by_gicon (icon_theme=0x9e61500, icon=0x9e23818, size=0, flags=20) at /build/buildd/gtk+3.0-3.3.12/./gtk/gtkicontheme.c:3886
 ensure_pixbuf_for_icon_name_or_gicon (context=0x9dc5648, self=0x9d93658) at /build/buildd/gtk+3.0-3.3.12/./gtk/gtkiconhelper.c:254

Changed in notification-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in notification-daemon (Ubuntu):
status: New → Confirmed
visibility: private → public

On 03/23/2012 04:20 AM, Sebastien Bacher wrote:
> ** Visibility changed to: Public
>

yeah I think this can be closed.. updated/upgraded my version of
lubuntu, and I don't see this, but will double check once I get on that
machine just to make sure in the next few days.

Thanks for the response!

Justin P. Mattock

I'm still getting this on elementary OS. From .xsession-errors:

** (nm-applet:3502): WARNING **: Failed to show notification: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
gnome-session[3086]: WARNING: Could not launch application 'gdu-notification-daemon-pantheon.desktop': Unable to start application: Failed to execute child process "/usr/lib/gnome-disk-utility/gdu-notification-daemon" (No such file or directory)

Full .xsession-errors file is attached

well, gdu leftovers are there because of my poor integration XD
in elementary OS stuff seems to be crashing because notify-osd is not running

summary: - crashed and burned upon startup..
+ crashes on startup if notify-osd is not running

happens if I start notify-osd manually too.

summary: - crashes on startup if notify-osd is not running
+ notification-daemon crashed with signal 5 in g_return_if_fail_warning()
tags: added: bugpattern-needed
David Young (dove-young) wrote :

I experienced Internal System Error almost everyday. My Ubuntu 12.04 was fresh installed. And my Thinkpad T400 worked smoothly through 10.04, 10.10, 11.04 and 11.10.

I used Gnome Shell environment.

On 05/03/2012 04:44 AM, David Young wrote:
> I experienced Internal System Error almost everyday. My Ubuntu 12.04
> was fresh installed. And my Thinkpad T400 worked smoothly through 10.04,
> 10.10, 11.04 and 11.10.
>
> I used Gnome Shell environment.
>

from what I remember I was hitting this, then downgraded notification
daemon then all was good.
one thing to note is(when using lubuntu) is I upgraded to Cinnamon and
this was not present. maybe they are missing something with lxde and
notification/notify-osd daemon(s)

raboof (launchpad-bzzt) wrote :

The upstream bugreport seems to suggest this should be fixed from libgtk-3.4.4 onwards

no longer affects: notification-daemon
Changed in notification-daemon:
importance: Unknown → Medium
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

The issue is fixed in quantal with gtk +3.5.4

affects: notification-daemon (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in gtk+3.0 (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-12.04.1
Changed in gtk+3.0 (Ubuntu Precise):
status: Triaged → In Progress
description: updated
jmattock78 (justinmattock) wrote :

I'm not seeing this with a stock build of ubuntu through
deebootstrap(latest). most if not all window managers/desktop(s) are
installed.. will look to see if I see this message.

On 07/03/2012 11:06 AM, Sebastien Bacher wrote:
> ** Changed in: gtk+3.0 (Ubuntu Precise)
> Status: Triaged => In Progress
>
> ** Description changed:
>
> + Impact:
> + Some software using a GtkStatusIcon (classic notification area icons) get segfaults from GTK with some panel configurations
> +
> + The update also include small other fixes from git, including some api
> + documentation changes and an obvious typo fix
> +
> + Test Case 1:
> + if you are one of those users getting segfault, try on your configuration with the update version to see if they stop
> +
> + Test Case 2:
> + look at the api documentation changes in the diff and see if you disagree with any
> +
> + Test Case 3:
> + try to use get_property('stock') on a GtkImage, it should return the icon id not the name
> +
> + Regression potential:
> + notification area icons could be incorrectly displayed in some cases if the maths done in the patch are wrong
> +
> + the documentation changes are obvious, review for errors
> +
> + the property change is obvious as well, it's changed to return the right value
> + ---
> +
> +
> no idea what this did..: but looking in .xsession* I see
>
> ** WARNING **: Failed to show notification:
> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
> org.freedesktop.Notifications was not provided by any .service files
>
> guess /usr/share/dbus-1 is where the problem can be fixed.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: notification-daemon 0.7.3-1
> ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
> Uname: Linux 3.2.0-12-generic-pae i686
> ApportVersion: 1.91-0ubuntu1
> Architecture: i386
> Date: Sat Feb 4 09:10:26 2012
> ExecutablePath: /usr/lib/notification-daemon/notification-daemon
> InstallationMedia: Lubuntu 11.04 "Natty Narwhal" - i386 (20101203)
> ProcCmdline: /usr/lib/notification-daemon/notification-daemon
> ProcEnviron:
> - PATH=(custom, no user)
> - LANG=en_US.UTF-8
> - SHELL=/bin/bash
> + PATH=(custom, no user)
> + LANG=en_US.UTF-8
> + SHELL=/bin/bash
> Signal: 5
> SourcePackage: notification-daemon
> UpgradeStatus: Upgraded to precise on 2012-02-04 (0 days ago)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

Hello jmattock78, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtk+3.0/3.4.2-0ubuntu0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Ok, I've been running that version for 10 days without issue on my main work machine, setting verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.4

---------------
gtk+3.0 (3.4.2-0ubuntu0.4) precise-proposed; urgency=low

  * debian/patches/git_gtkstatusicon_segfault.patch:
    - should fix segfault in status icon clients (lp: #926758)
  * debian/patches/git_get_property.patch:
    - "GtkImage: fix get_property('stock')"
  * debian/patches/git_api_documentation_tweaks.patch:
    - backported some api documentation updates
 -- Sebastien Bacher <email address hidden> Tue, 03 Jul 2012 19:59:58 +0200

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
tags: added: saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.