set_size_request is ignored [update-manager details is one line]

Bug #840942 reported by Rob Snelders on 2011-09-04
140
This bug affects 23 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned
gtk+3.0 (Ubuntu)
Medium
Unassigned
Oneiric
Low
Unassigned
Precise
Medium
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

update-manager details is one line (the terminal when expanding the details expander). This way you can't see what happens and is the function useless

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: update-manager 1:0.152.17
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
Architecture: i386
Date: Sun Sep 4 14:04:42 2011
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Rob Snelders (ertainl) wrote :
Robert Roth (evfool) on 2011-09-04
description: updated
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Sam_ (and-sam) wrote :

Suggest it's a dupe of Bug #739647

Robert Roth (evfool) wrote :

Sam_: it's not a dupe of that bug, because the other bugs is about the error dialog specifically, while this is about the terminal shown when an install progress is expanded.

Robert Roth (evfool) wrote :

Reassigning to aptdaemon package, the package providing the dialogs displayed in update-manager.

affects: update-manager (Ubuntu) → aptdaemon (Ubuntu)
Sam_ (and-sam) wrote :

Robert, you're right of course. Although screenshots may make it easier to tell. If this bug is about the install progress dialog, then Bug #819201 comment #2 isn't a dupe of Bug #739647 it's a dupe of this one here.

Robert Roth (evfool) wrote :

Thanks Sam_, you're right on this one, marking bug #819201 a duplicate of this one.

Chris (fabricator4) wrote :

Thanks, you got my bug (819201) unlinked from 739647. Not only that, but your's got a 'medium' while I only managed a 'low' :-)

This should be a relatively easy fix that will improve the appearance of the update status window (see my screenshot on bug 819201 for a messed up example).

Regards,

Chris.

Sam_ (and-sam) wrote :

Actually it's a regression. Two example screenshots from Natty show it's fine there, then why isn't it transfered like this to Oneiric, because of gtk-3?

Sam_ (and-sam) wrote :
Sebastian Heinlein (glatzor) wrote :

ineed it is an issue with gtk3. but i haven't yet found the root of it.

Sam_ (and-sam) wrote :

Should we add gtk+3.0 then and sent it upstream like they did there? Bug #836604

Sam_ (and-sam) wrote :

Just updated via update-manager and found the details dialog window resizable and useful to read as with Natty.
aptdaemon:
  Installed: 0.43+bzr691
  Candidate: 0.43+bzr691
  Version table:
 *** 0.43+bzr691 0

update-manager:
  Installed: 1:0.152.17
  Candidate: 1:0.152.17
  Version table:
 *** 1:0.152.17 0

Sam_ (and-sam) wrote :
Jane Silber (silbs) wrote :

Resizable is better than not, but I think it is still a bug that it appears initially as one line. Initial appearance should be large enough to be useful.

Sebastian Heinlein (glatzor) wrote :

The set_size_request is ignored in the case of the downloads list and the changes in the confirmation dialog.

summary: - update-manager details is one line
+ set_size_request is ignored [update-manager details is one line]
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tekstr1der (tekstr1der) wrote :

My bug got duped here. I don't see a screenshot of the actual issue on this report, so I've attached on, even though it seems the problem is well understood.

tekstr1der (tekstr1der) wrote :

Any chance of this being fixed in Oneiric?

Sebastian Heinlein (glatzor) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.43+bzr742-0ubuntu1

---------------
aptdaemon (0.43+bzr742-0ubuntu1) precise; urgency=low

  * New bzr snapshot:
    - Fix resizing the GTK3 progress dialog (LP: #840942)
    - py3 exception compat fixes
    - fixes in pkcompat code
    - merged "pretty repo" branch with nicer progress information on
      cache updates
    - cache changelogs
 -- Michael Vogt <email address hidden> Thu, 01 Dec 2011 14:40:52 +0100

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released

The attachment "fix_dialog_sizes.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Hello ertai, or anyone else affected,

Accepted aptdaemon into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in aptdaemon (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
tnynxn (tnynxn) on 2012-01-01
Changed in gtk+3.0 (Ubuntu Precise):
status: Confirmed → New
Changed in aptdaemon (Ubuntu Oneiric):
importance: Undecided → Medium
assignee: nobody → Bartosz Kosiorek (gang65)
Bartosz Kosiorek (gang65) wrote :

Verification failed.
It is work only at first time.

Step to reproduce:
1. Start updating
2. Click "Details" to expand - it works correctly
3. Click "Details" to unexpand - it works correctly
4. Click "Details" to expand - failed - only one line of details is visible

tags: added: verification-failed
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu Oneiric):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in aptdaemon (Ubuntu Oneiric):
status: Fix Committed → In Progress
Chris (fabricator4) wrote :

Confirmed, it is a partial fix that works the first time only. I have a slower machine (2.8GHz Celeron) and observed something interesting:

1. Start updating
2. Click "Details" to expand - it works correctly
3. Click "Details" to unexpand - it works correctly
4. Click "Details" to expand - for a very brief instant the window expands to nearly it's full size as observed in step 2.
5. Window then collapses to one line
6. Subsequent attempt to close and open details only shows one line.

Chris

Sebastian Heinlein (glatzor) wrote :

Chris, Boris: Are you using Precise?

Changed in aptdaemon (Ubuntu Oneiric):
status: In Progress → Fix Committed
assignee: Bartosz Kosiorek (gang65) → nobody
Chris (fabricator4) wrote :

Sorry, yes it is Precise 12.04 A1

I will double check apt-daemon version and re-test when I get home tonight.

Chris

Chris (fabricator4) wrote :

The aptdaemon installed in Precise seems to be this one:
aptdaemon_0.43+bzr756-0ubuntu1_all.deb

I tried to install the aptdaemon from Oneiric proposed on my Oneiric test box but completely broke update manager in the process. I was following the instruction given in the link to bring in the proposed aptdaemon module.

I'm now back to where I was (unbroken) and tried the other option with aptitiude and got the following:

________________________________________________________

$ sudo aptitude install aptdaemon/oneiric-proposed
The following packages will be upgraded:
  aptdaemon{b}
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 15.4 kB of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
  aptdaemon: Depends: python-aptdaemon (= 0.43+bzr697-0ubuntu1.1) but 0.43+bzr697-0ubuntu1 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:
1) aptdaemon
2) language-selector-gnome
3) sessioninstaller
4) software-center
5) ubuntu-desktop

      Leave the following dependencies unresolved:
6) oneconf recommends software-center (>= 4.1.21)
7) python-aptdaemon recommends aptdaemon
8) file-roller recommends sessioninstaller | packagekit
9) software-center recommends sessioninstaller
10) update-notifier recommends aptdaemon

Accept this solution? [Y/n/q/?]
______________________________________________________________

Obviously it wants to break something again so I'm wary... And yes I feel like a dill because I have no idea how to install the proposed module without letting aptitude uninstall all those other packages at the same time.

Chris

Sam_ (and-sam) wrote :

This is on Precise.
aptdaemon:
  Installed: 0.43+bzr784-0ubuntu1
  Candidate: 0.43+bzr784-0ubuntu1
  Version table:
 *** 0.43+bzr784-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

.xsession-errors says:
(update-manager:1229): Gtk-WARNING **: /build/buildd/gtk+3.0-3.3.20/./gtk/gtkliststore.c:851: Unable to convert from (null) to PyObject

Changed in gtk+3.0 (Ubuntu Oneiric):
importance: Undecided → Low
status: Confirmed → Won't Fix
tekstr1der (tekstr1der) wrote :

This regression bug is still present in 12.04.1 LTS.

The aptdaemon fix does not resolve the bug [update-manager details is one line].

Does this mean the issue must be fixed in gtk+3.0?

tags: added: precise regression-release regression-update

Unfortunately the bug was fixed in the aptdaemon gtk widgets but update manager now uses its own progress window (quantal). I will have a look if we can back port the fix.

tekstr1der <email address hidden> schrieb:

>This regression bug is still present in 12.04.1 LTS.
>
>The aptdaemon fix does not resolve the bug [update-manager details is
>one line].
>
>Does this mean the issue must be fixed in gtk+3.0?
>
>
>** Tags added: precise regression-release regression-update
>
>--
>You received this bug notification because you are a member of
>Aptdaemon
>Developers, which is subscribed to aptdaemon in Ubuntu.
>https://bugs.launchpad.net/bugs/840942
>
>Title:
> set_size_request is ignored [update-manager details is one line]
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/840942/+subscriptions

--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.

Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in aptdaemon (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
David Pearson (akxwi-dave) wrote :

Still Happening on AA (17.10)

see http://i.imgur.com/VlV1bxu.png

for how it looks in Xubuntu

sam tygier (samtygier) wrote :

Still an issue in Bionic. Can't see how to add the release. If I understand comment #31 the bug is in update-manager now not apt-daemon

no longer affects: update-manager (Ubuntu Oneiric)
no longer affects: update-manager (Ubuntu Precise)
dino99 (9d9) on 2018-01-30
tags: added: artful bionic
removed: oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers