String length of items seems limited (system settings label get truncated)

Bug #819994 reported by Jean-Louis Dupond on 2011-08-02
194
This bug affects 29 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
Ubuntu Translations
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

It seems there is a limit of the chars in a setting button.

In my panel I have 'Systeeminformati', but it should show 'Systeeminformatie'.
So it looks like the 'e' got cut off.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

confirmed with a french installation on oneiric, gnome-control-center 3.1.4

Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :
affects: gnome-control-center (Ubuntu) → gtk+3.0 (Ubuntu)
affects: gnome-control-center → gtk
Sam_ (and-sam) wrote :

After latest updates of g-c-c incl. _make_window_wider labels are still truncated.

summary: - String length of items seems limited
+ String length of items seems limited (system settings label get
+ truncated)
Felix Kay (felix-kiessling) wrote :

Confirmed with German language installation (also confirming Mr. Sam;).

Kinda annoying, the menu layout does not look professional in any way in my opinion.

Willing to help.

The same goes for the Dutch language. Many words are truncated, which looks really ugly.

Redmar (redmar) wrote :

The length restriction is 13 characters for a single word, a long string with multiple short words gets split over multiple lines.

Dennis Baudys (thecondordb) wrote :

Is this length restriction of13 (???) chars per word now _definitively_ the length ALL the translators have to stick to with their translations? Or is this serious cosmetic bug _going to be fixed_ or the restriction to be expanded? I don't know whether to change the translations now or to wait for improvement of the GUI.

There are a lot of languages (not only German, Dutch etc.) where it is practically impossible or at least very ugly to squeeze/shorten words like this.

In the GNOME bug tracker there seems to be _no activity_ on this bug since 2011-04-13 (nearly one year???).

Thanks.

Nicolas Delvaux (malizor) wrote :

@Dennis: as there is still no move upstream, it's now pretty sure that it won't be fixed until, at least, the next Gnome release.
So yes, you should try to tweak translations for the next Ubuntu release.

Felix Kay (felix-kiessling) wrote :

Is it possible to write a gnome patch on this for a simple user? Well... as posted on "Brainstorm" by me, the System Settings should urgently be restructured and graphically developed in my opinion...

Ask Hjorth Larsen (askhl) wrote :

Which strings are affected? Since this is apparently a GTK issue, is it thousands (and thus impossible to fix for translators)? What should translators do specifically?

Sam_ (and-sam) wrote :

Imho comparing g-c-c and ccsm it's so mega embarrassing that it makes me cry when they deliver an LTS with such an UI of a core app.
Millions are now doomed to view this daily for five years? There is and has been no alternative? No plan B if gtk-3 fails?
It also can't be serious to ask translators to shortcut strings or select other terms.

@Ask: we are talking about strings in gnome-control-center (for the system settings), but there are also words truncated in the dash (e.g. jockey-gtk). I agree with Sam that, for an LTS version, it is a shame that this is not fixed.

Simply change your translations. We from the German team do that... I know
that this does not work with every language.

2012/4/14 Hannie Dumoleyn <email address hidden>

> @Ask: we are talking about strings in gnome-control-center (for the
> system settings), but there are also words truncated in the dash (e.g.
> jockey-gtk). I agree with Sam that, for an LTS version, it is a shame
> that this is not fixed.
>
> --
> You received this bug notification because you are a member of Ubuntu
> German Translators (Community-Team), which is subscribed to a duplicate
> bug report (930777).
> https://bugs.launchpad.net/bugs/819994
>
> Title:
> String length of items seems limited (system settings label get
> truncated)
>
> Status in GTK+ GUI Toolkit:
> New
> Status in Ubuntu Translations:
> New
> Status in “gtk+3.0” package in Ubuntu:
> Triaged
>
> Bug description:
> It seems there is a limit of the chars in a setting button.
>
> In my panel I have 'Systeeminformati', but it should show
> 'Systeeminformatie'.
> So it looks like the 'e' got cut off.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/819994/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ubuntu-l10n-de-community
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~ubuntu-l10n-de-community
> More help : https://help.launchpad.net/ListHelp
>

--
About.me / Über.mich <http://about.me/gotwig>

ka_bra (ka-bra) wrote :

@ 6and/\lf (eduardgotwig):

Will those "changed german translations" be available for german ubuntu users in 12.04 LTS?

It may be a "possible" solution....

Eduard Gotwig (gotwig) wrote :

I think so. They are already reviewed for gnome-control-center and the
relevant other packages that are directly integrated in control-center, so
have their own windows.

2012/4/14 ka_bra <email address hidden>

> @ 6and/\lf (eduardgotwig):
>
> Will those "changed german translations" be available for german ubuntu
> users in 12.04 LTS?
>
> It may be a "possible" solution....
>
> --
> You received this bug notification because you are a member of Ubuntu
> German Translators (Community-Team), which is subscribed to a duplicate
> bug report (930777).
> https://bugs.launchpad.net/bugs/819994
>
> Title:
> String length of items seems limited (system settings label get
> truncated)
>
> Status in GTK+ GUI Toolkit:
> New
> Status in Ubuntu Translations:
> New
> Status in “gtk+3.0” package in Ubuntu:
> Triaged
>
> Bug description:
> It seems there is a limit of the chars in a setting button.
>
> In my panel I have 'Systeeminformati', but it should show
> 'Systeeminformatie'.
> So it looks like the 'e' got cut off.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/819994/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ubuntu-l10n-de-community
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~ubuntu-l10n-de-community
> More help : https://help.launchpad.net/ListHelp
>

--
About.me / Über.mich <http://about.me/gotwig>

Sebastien Bacher (seb128) wrote :

@Sam: your screenshot is a customized grid, not what most users will see, and suggestions on how to fix the issue are welcome if somebody has some

Sam_ (and-sam) wrote :

Sebastien, of course it's customized, pc has a larger size monitor than my laptop.
On laptop the font size is 11 but the window itself is way too large it almost uses half of the desktop.
The ccsm window is resizable and looks fine in any mode or font size.
Why do I need to defend or explain a custom setup anyway? Do we talk about font size or a compiled kernel here?

Please don't mix cause and effect. The user didn't break the UI - developers did.
Thus I'd like to ask developers if they have an idea to fix the issue.

Imho the solution is to revert incomprehensible decisions like windows shouldn't be resizable.
Or are developers telling us, don't customize your font size, no matter which monitor, you're doomed to select 8-10 font size otherwise try accessibility features?
Fine, then they should say so loud, so users know, this DE isn't one which should be customized, otherwise it may become useless.
Then why font-selector has an option to resize larger than 10 in the first place if anything above 10 can make an UI unuseable?
Sounded pretty realistic in the past.
< ... however each user has different preferences. >
https://wiki.ubuntu.com/font-selector

No answer yet there.
https://bugzilla.gnome.org/show_bug.cgi?id=649242#c16

Window size mandatory.
https://bugzilla.gnome.org/show_bug.cgi?id=666000

Example how perfect it looks when using smaller font size. What is it, 8?
http://bugzilla-attachments.gnome.org/attachment.cgi?id=203253

@ 6and/\lf (eduardgotwig)
Please tell me how you change translation of shortcut descriptions and keep their rational. bug 933761

Changed in gtk:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/819994

tags: added: iso-testing
Changed in gtk:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.