Print Dialog does not allow editing of page parameters

Bug #428817 reported by Swift Arrow on 2009-09-13
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups-pdf

In Ubuntu-jaunty amd64,

Cups PDF driver does not allow us to change the paper size, orientation, or anything. I would like to print my images from GIMP to pdf, but they are wider than an A4 page, and so I cannot print them to a whole pdf! I know PDF format can support multiple sizes. And the options are there, just greyed out.

This is non-application specific. Firefox print dialog behaves the same. OOo Print dialog doesn't even show the Cups PDF driver.

If those options are there, but are just greyed out, I would consider this a problem. If the options have not been implemented, perhaps put up a notice on that tab saying that they don't exist?

I hope whoever fixes this gets paid for it! Thanks for the awesome work!

Till Kamppeter (till-kamppeter) wrote :

This is not a problem of cups-pdf, it also occurs with other printer drivers. The problem is a usability issue of the current GTK printing dialog. To select the page size you have to choose "File"/"Page Setup" in the main menu and select the page size. Then you click "File"/"Print" to do the printing. See also the "Image Settings" tab to adjust the position of the image on the paper. Mark "Ignore Page Margins" there as the margins are not set correctly.

Please report the usability problem to GTK upstream.

affects: cups-pdf (Ubuntu) → gtk+2.0 (Ubuntu)
Swift Arrow (swiftarrow9) wrote :

Till, Thanks for your clarification. I will follow that up with GTK.

Swift Arrow (swiftarrow9) wrote :

Oops... I notice that you've assigned it to GTK. Good on you!

My suggestions:

1. Get rid of page setup tab on printer dialog. Its useless. Integrate the functionality that seems to be targeted at it in the File > page setup dialog box.

2. Allow the application to specify custom page sizes automatically (eg, printing to pdf in GIMP should give the option to use the image size for page size).

3. Move the new Page Setup dialog box to the printer dialog, as a tab. Make File>Page Setup open the dialog set to that tab.

Again, I hope this is ironed out in the future. I love and really appreciate all the work that so many selfless ppl have put in!

Sebastien Bacher (seb128) wrote :

The issue is fixed in karmic

Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Fix Released
Jason W (jasonw-co) wrote :

I'm using Karmic and these options are still grayed out in Firefox.

You have to use File>print setup, not the options in the print dialogue box.

On Wed, Nov 4, 2009 at 12:54 AM, Jason W <email address hidden> wrote:

> I'm using Karmic and these options are still grayed out in Firefox.
>
> --
> Print Dialog does not allow editing of page parameters
> https://bugs.launchpad.net/bugs/428817
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gtk+2.0” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: cups-pdf
>
> In Ubuntu-jaunty amd64,
>
> Cups PDF driver does not allow us to change the paper size, orientation, or
> anything. I would like to print my images from GIMP to pdf, but they are
> wider than an A4 page, and so I cannot print them to a whole pdf! I know
> PDF format can support multiple sizes. And the options are there, just
> greyed out.
>
> This is non-application specific. Firefox print dialog behaves the same.
> OOo Print dialog doesn't even show the Cups PDF driver.
>
> If those options are there, but are just greyed out, I would consider this
> a problem. If the options have not been implemented, perhaps put up a
> notice on that tab saying that they don't exist?
>
> I hope whoever fixes this gets paid for it! Thanks for the awesome work!
>

grn (gaurangarora) wrote :

This issue is not fixed in Karmic. The Page Setup options are still grayed out in all applications.

Changed in gtk+2.0 (Ubuntu):
status: Fix Released → Confirmed

In Lucid Lynx the same. 8 months later

David Nice (davidjnice) wrote :

Still an issue - Lucid (10.04) - Possible Duplicate of Bug #269687?

To summarise this long standing bug; users cannot adjust the page settings using the 'page set-up' tab in the print dialogue. (Apparently of applications using gtk print.) To recreate the bug, go to the page set-up tab in the print dialogue of any of the following programs:

Eye of Gnome Image Viewer
Firefox
Epiphany
Evolution
Gimp
F-Spot

(you get the idea).

The options can be adjusted directly from the page set-up menu, but many users look to the page set-up tab in the print dialogue.

Thanks to all for the great work.

Sebastien Bacher (seb128) wrote :

> To summarise this long standing bug; users cannot adjust the page settings using the 'page set-up' tab in the print dialogue.

Could you describe what settings exactly? The orientation, paper type, etc can be changed just fine there with gedit or eog. Could be driver specific though and depending of your printer

Changed in gtk+2.0 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
David Nice (davidjnice) wrote :

I've just run a clean install of 10.04 to test this again and you are correct, GEdit does allow the page setup tab to be used. However, tried with Eye of Gnome and the problem still exists.

When viewing the page-setup tab in GEdit to an HP Laserjet 1200:

Layout:
- Two-sided: Available to Change
- Pages per side: Available to Change
- Page ordering: Not available (Greyed out) - I'd expect this on this printer
- Only print: Available to Change
- Scale: Available to Change

Paper:
- Paper Type: Not available (Greyed out)
- Paper Source: Available to Change
- Output Tray: Not available (Greyed out) - I'd expect this on this printer, only one output tray.
- Paper Size: Available to Change
- Orientation: Available to Change

When viewing the page-setup tab in Eye of Gnome Image Viewer using the same HP Laserjet 1200:

Layout:
- Two-sided: Available to Change
- Pages per side: Available to Change
- Page ordering: Not available (Greyed out)
- Only print: Available to Change
- Scale: Available to Change

Paper:
- Paper Type: Not available (Greyed out)
- Paper Source: Available to Change
- Output Tray: Not available (Greyed out)
- Paper Size: Not available (Greyed out)
- Orientation: Not available (Greyed out)

To set the paper size, type and orientation, users have to use the File > Page Setup. This changes the values shown on the print dialogue tab but they are still greyed out.

Since this can be worked around using the 'File > Page Setup', I thought that I shouldn't be be thinking of this as a bug, more of a usability issue. Then I found the Dictionary application which doesn't have the 'File > Page Setup' and the options on the print dialogue tab are still greyed out.

I don't think that this will be a driver issue I have tried with three different systems with three difference printers:
System 1. An upgrade from from 8.04 - printing to the PDF printer.
System 2. A clean 10.04 install printing to an HP Color Ink jet. (I'll check the model and post it shortly).
System 3. Another clean 10.04 install with an HP Laserjet 1200.

Let me know if you need any other information. (Screen-shots Maybe?)

Thank you.

fig_wright (fig-wright) wrote :

This is still a problem in image viewer and gimp in a clean install of lucid. To be honest this kind of bug is pretty frustrating because it should be so simple to solve and has persisted for a year.

David Nice (davidjnice) wrote :

Could it be??!!

I've just upgraded the clean install of 10.04 that I ran the tests on (above) to 10.10 and the problem seems to have been resolved.
The page set-up option is gone from the 'Image' menu of EOG and the Page Setup tab works!

Also, checked Gedit and it is OK.

Can anyone else confirm that this issue may finally be resolved?

(I'm going to update and check my LTS 10.04 install tonight).

David Nice (davidjnice) wrote :

Confirm that Firefox (3.6.10) still has the Page setup option in the file menu AND the page setup tab works too!

Fresh install of Ubuntu 10.10 on two different PC's. Printer: HP Color LaserJet 2605dn (via network)

No matter if I try to print from "Eye of Gnome 2.32.1", "Shotwell 0.9.3" or "Gimp 2.6", I cannot change the "Paper Type:". It's stuck at "Not available (Greyed out)". I attached a screen shot.

I remember that with older Ubuntu versions I could change the paper type to "rough paper" or "labels".

correction on my previous comment #15, both have a fresh install of Ubuntu 11.04!

Hey, I think you have to use the "Page Setup" or "Print Setup" option from
the File menu. It's an old bug; the page setup in the print dialog doesn't
work, only the one in the file menu does.
Thanks, Love, Peace,
Link
P.S. Please pray for Japan.

On Sun, Jul 3, 2011 at 2:48 AM, Lieven Blancke <email address hidden> wrote:

> correction on my previous comment #15, both have a fresh install of
> Ubuntu 11.04!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/428817
>
> Title:
> Print Dialog does not allow editing of page parameters
>
> Status in “gtk+2.0” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: cups-pdf
>
> In Ubuntu-jaunty amd64,
>
> Cups PDF driver does not allow us to change the paper size,
> orientation, or anything. I would like to print my images from GIMP
> to pdf, but they are wider than an A4 page, and so I cannot print them
> to a whole pdf! I know PDF format can support multiple sizes. And
> the options are there, just greyed out.
>
> This is non-application specific. Firefox print dialog behaves the
> same. OOo Print dialog doesn't even show the Cups PDF driver.
>
> If those options are there, but are just greyed out, I would consider
> this a problem. If the options have not been implemented, perhaps put
> up a notice on that tab saying that they don't exist?
>
> I hope whoever fixes this gets paid for it! Thanks for the awesome
> work!
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/428817/+subscriptions
>

This is still a problem in several applications. After I have posted this Blueprint

https://blueprints.launchpad.net/ubuntu/+spec/packageselection-desktop-n-improve-photo-printing

it got fixed in some but not in all applications.

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

@Swift Arrow (swiftarrow9) Eye Of Gnome (2.32.1) does not even have a "Page Setup" in the Image menu. The applications that *do* have a "Page Setup" entry in the File menu do not provide a "Paper Type" option, only page orientation and paper size.

I can find no way at all to set the "paper type". This is important because heavier paper is moved slowly through the printer and with different temperature settings so the toner does not loosen so easily.

Swift Arrow (swiftarrow9) wrote :

@Lieven Blancke (launchpad-kks36)

You're right.

This ought to be submitted as a "paper-cut" to canonical.

I think I have found a workaround: This problem does not occur on a fresh ubuntu install if I add my printer (HP Color LaserJet 2605dn) as a LPD/LPR-printer. The the device URI is lpd://<ipaddress>/PASSTHRU

Can anyone confirm this?

Jonathan Kamens (jik) wrote :

I was having this problem on Ubuntu 18.10 (WOW, THIS PROBLEM HAS BEEN AROUND FOR A VERY LONG TIME) with my HP LaserJet 500 color M551 printer. When I tried to install it, the driver that kept getting selected was "HP LaserJet 500 color M551, driverless, cups-filters 1.21.3". This, despite the fact that I have "hpijs-ppds", "hplip", and "hplip-data" installed.

I solved the problem by downloading the current version of HPLIP directly from HP (https://sourceforge.net/projects/hplip/ or https://developers.hp.com/hp-linux-imaging-and-printing), unpacking it, locating the PPD for my printer in the source code ("hp-laserjet_500_color_m551-ps.ppd"), and changing the configured driver of the printer installed in Linux to specify that PPD directly rather than using the recommended driver.

I think the problem here, or at least one of the problems here, is not nearly all of the HP printer drivers are being installed by Ubuntu. In particular, while I can't say for certain, it looks to me like the hpijs-ppds package is only installing a few fax drivers, not the full array of drivers available in HP's HPLIP package. I have no idea why that's the case.

Jonathan Kamens (jik) wrote :

Added hplip to the affects list for this bug because hpijs-ppds appears to only be installing a few fax PPDs, not the full array of available HPLIP PPDs.

tags: added: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments