Scrollbars escape the bottom and right side of the Terminal window by 1px

Bug #1691678 reported by Daniel van Vugt on 2017-05-18
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Unknown
gnome-terminal (Ubuntu)
Low
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned
yaru-theme (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu's orange overlay scrollbars escape the bottom of the window during resizing.

To reproduce try gnome-shell on artful using the Ambiance theme. Open a Terminal window and resize it vertically, quickly. Notice the bottom of the overlay scrollbar overruns the bottom of the window.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.24.2-0ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-20.22-generic 4.10.8
Uname: Linux 4.10.0-20-generic x86_64
ApportVersion: 2.20.5-0ubuntu3
Architecture: amd64
Date: Thu May 18 15:28:33 2017
DisplayManager: lightdm
GsettingsChanges:
 b'org.gnome.shell' b'app-picker-view' b'uint32 1'
 b'org.gnome.shell' b'favorite-apps' b"['firefox.desktop', 'org.gnome.Terminal.desktop', 'rhythmbox.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop', 'yelp.desktop']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'scaling-factor' b'uint32 1'
InstallationDate: Installed on 2017-05-03 (15 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170502)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
Changed in overlay-scrollbar (Ubuntu):
importance: Undecided → Medium
Adolfo Jayme (fitojb) wrote :

The package overlay-scrollbar hasn’t been used in GTK+ 3 applications for a long time

affects: overlay-scrollbar (Ubuntu) → gtk+3.0 (Ubuntu)
Jeremy Bicha (jbicha) on 2017-06-10
affects: gnome-shell (Ubuntu) → gnome-terminal (Ubuntu)

Confirmed the same bug with Adwaita. In fact it's worse in Adwaita -- the overlay scrollbar can end up overrunning the right and bottom edges of the window after resizing finishes.

summary: - Ubuntu's orange overlay scrollbars escape the bottom of the window
- during resizing
+ Overlay scrollbars escape the bottom of the Terminal window during
+ resizing
tags: added: cosmic
summary: - Overlay scrollbars escape the bottom of the Terminal window during
- resizing
+ Scrollbars escape the bottom and right side of the Terminal window

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Still a problem in Ubuntu 18.10 cosmic.

tags: added: bionic
summary: - Scrollbars escape the bottom and right side of the Terminal window
+ Scrollbars escape the bottom and right side of the Terminal window by
+ 1px
amano (jyaku) wrote :

Is this an upstream issue (does Fedora show that behavior as well?) or the outcome of a Debian patch? There is at least one which is scrollbar related:

+ Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.

https://lists.canonical.com/archives/cosmic-changes/2018-September/009594.html

amano (jyaku) wrote :

https://4.bp.blogspot.com/-CKw5ikw4WNo/WWo7WrezseI/AAAAAAAAKC4/CPbs48OQj0A2hMNY5_Ivu6iTaRzClDYMQCLcBGAs/s1600/07%2BGNOME%2BTerminal.jpg

This is a gnome-terminal screenshot from Fedora 26. There everything seems ok. Can we drop the Debian patch above to see if that fixes the issue?

Didier Roche (didrocks) wrote :

Are you sure this is due to the above patch, can you try without it?

amano (jyaku) wrote :

Nope. Not completely sure, sorry. I didn't compile GNOME apps before, so that would probably be a rather heavy task for me ;) I had a quick look at the 3.30.0 source but couldn't even find out which lines were changed by the Debian patch. Aren't the patches included within the source tar?

mbrennwa (mbrennwa) wrote :

This issue is still there in in the current beta of Ubuntu 19.04 (Gnome 3.32 with Adwaita).

amano (jyaku) wrote :

Adwaita? What about Yaru?

Daniel van Vugt (vanvugt) wrote :

In 19.04 right now the bug appears with Adwaita but not with Yaru. That doesn't mean it's a theme bug though -- it might be a universal bug and something about the Yaru design is hiding it.

tags: added: disco
Changed in gtk+3.0 (Ubuntu):
importance: Medium → Low

I confirm the previous suspicion: This is _not_ an upstream bug. Upstream gnome-terminal draws the scrollbar perfectly.

This bug is introduced by one of the Ubuntu patches.

upstream bug report confirms that this is a bug in Ubuntu:

https://gitlab.gnome.org/GNOME/gnome-terminal/issues/132

Daniel van Vugt (vanvugt) wrote :
Changed in yaru-theme (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in gnome-terminal:
status: Unknown → Fix Released
Daniel van Vugt (vanvugt) wrote :

Still a problem with upstream Adwaita so it would be nice to find a universal solution.

tags: added: desktop-lts-wishlist

What's the current status of this bug? Where is the fix? One of my report is made duplicate to this bug but I think this is much older. I'm using 19.10

Daniel van Vugt (vanvugt) wrote :

It appears we would need a new upstream bug to track this because the old one didn't go anywhere. Please create one in:

  https://gitlab.gnome.org/GNOME/gnome-terminal/issues

or

  https://gitlab.gnome.org/GNOME/gtk/issues

and then tell us the URL.

> It appears we would need a new upstream bug to track this because the old one didn't go anywhere.

This is not true. The old one did go somewhere: It examined the behavior and clearly concluded that upstream gnome-terminal is NOT buggy here, it never was. It's one of the Ubuntu patches that introduces the bug. This conclusion was also stated in this thread here.

Could you please clarify how you expect upstream gnome-terminal to fix this situation?

Meanwhile, this bug is almost 3 years old, and I haven't seen any worthwile comment from any Ubuntu developer trying to track down which of its patches, and which part within that is the culprit.

Or if you believe that upstream gnome-terminal is indeed buggy, this bug just doesn't happen to trigger anywhere else, except with your perfect innocent patches, then this claim should be justified with technical arguments, something I haven't seen in this thread yet.

And I can't help to notice that this is not the only issue where Ubuntu introduces a regression to the overall gnome-terminal user experience, and then really doesn't care about fixing it. Bug 1770507 is another prominent example, you guys broke something during the feature freeze period(!) of the previous LTS, and still til this day haven't cared about fixing.

I'm sad and disappointed to see that the software I've been co-developing for years, putting my passion, heart, and lots and lots of time into, is broken in multiple ways by perhaps the most popular Linux distribution, and its developers just don't care. I don't even know what to think about you pointing fingers at us.

Instead, maybe could you Ubuntu devs finally please, pretty please get yourself together and fix at the very least these two bugs that YOU introduced, in time for the just-around-the-corner LTS release? If simply by dropping the patches that introduces the bugs, along with then dropping whatever features those patches add, so it be. Thanks!

I firmly believe that Ubuntu should revise its bug prioritizing policy, and handle with much-much higher priority if one of its changes introduces a regression from mainstream. It should be something like: if a regression is found, and not fixed within a week, the patch is automatically dropped. Think about it...

It's not an upstream bug. I checked several other distribution with different themes, none of them is affected. Only Ubuntu's gnome-terminal is affected.

I don't understand why this simple bug is still around after realizing it was reported 3 years ago! I am retrying to home on Ubuntu after several years of leave, but again annoyed by this bug! The report saying 'fixed released' without any fixes!

Please, try to fix these annoying bugs which preventing us to use themes other than default Ones!

I support the idea in the last para. of @egmont-gmail. If a patch introduce a regression which is worse than the improvement made by the patch, the patch should be dropped. I'm getting tired of Ubuntu fixing something and breaking some other things.

Ubuntu LTS was rock solid once upon a time, but for regular users I don't see any point using LTS these days.

Sebastien Bacher (seb128) wrote :

The issue is due to the patch scrollbar-background-theming.patch but dropping the change creates a regression on the Ubuntu session/theme which is what most users will see. It would be nice to see the problem resolved by removing the change is not the solution

> but dropping the change creates a regression on the Ubuntu session/theme

So the situation is: Unpatched gnome-terminal looks perfect on the default GTK theme and on many others, except Ubuntu's.

Conclusion: Let's patch gnome-terminal! Wow.

I'm wondering: Has anyone considered fixing the Ubuntu theme(s) instead?

Oh, sure, in comment 16: "there's a workaround hacked into Yaru"

Why is that a workaround, and not a fix? Any why Yaru only and not Ambiance or any other affected Ubuntu theme? Move forward please in this direction, fix (or workaround, whatever) the affected themes so that then you can drop the broken gnome-terminal patch.

Or, again: If you believe that your themes as well as your gnome-terminal patch are correct, and other themes are buggy, please provide evidence. If that's not the case, adding a workaround to (and thus breaking) gnome-terminal instead of fixing the broken themes was clearly the wrong thing to do, and should be properly fixed ASAP.

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid
no longer affects: gtk+3.0 (Ubuntu)
no longer affects: ubuntu-themes (Ubuntu)
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

I'm not familiar with gnome-terminal and not much with CSS, but I have decided to dig into this bug and see what's happening.

My first finding is that yes we should just drop the 'scrollbar-background-theming.patch' from gnome-terminal and fix the theme. So I made that change to gnome-terminal...

My second finding is that the Yaru theme is already correct and doesn't seem to need fixing:

terminal-window {
    notebook {
        scrollbar {
            background-color: transparent;

It seems Yaru's request for 'transparent' comes out as white. Any other colour seems to work -- it's only 'transparent' that doesn't. So this appears to be a bug in either GTK or gnome-terminal failing to honour 'transparent'. And yes we should still remove the patch scrollbar-background-theming.patch as well.

I'll be away for the next week or so, so maybe someone else can finish this or I will look into it further when I return.

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Carlo Lobrano (c-lobrano) wrote :

Hi Daniel,

do you think that removing Yaru's style would have a positive impact on this issue or it would be useless?

The slice of css you reported comes from a file containing specific style for applications that can be dropped easily if not necessary (and even more easily if harmful)

Daniel van Vugt (vanvugt) wrote :

I don't think that's necessary and probably not helpful. There are already multiple moving parts here so it would be easier to deal with if the theme was not changed simultaneously.

Daniel van Vugt (vanvugt) wrote :

Possibly the pixels under the scrollbar are being painted as white before the scrollbar itself gets painted. So any transparency in the theme won't come out right, but is still technically transparent.

Daniel van Vugt (vanvugt) wrote :

Actually the proper solution to comment #28 would be to change to overlay scrollbars, which is already covered by bug 1451924. It's still a different bug to this one, but if implemented it would close this bug nicely.

If we just wanted to work on this bug without doing bug 1451924 then that would involve replacing the white background with the actual terminal background colour. Kind of similar to scrollbar-background-theming.patch but in a way that would actually be upstreamable...

What is the current status of this bug? Can we have any workaround for this bug?

Daniel van Vugt (vanvugt) wrote :

I would like to continue working on this bug but it's just not a priority right now.

tags: added: focal groovy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.