Single click doesn't work in file chooser dialog box

Bug #11544 reported by Russell Cok on 2004-12-30
170
This bug affects 24 people
Affects Status Importance Assigned to Milestone
GTK+
Confirmed
Wishlist
One Hundred Papercuts
Undecided
Timothy Arceri
gtk+2.0 (Ubuntu)
Low
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

when you select single click in file management it works for nautilus and the
desktop but not for applications that use the "file chooser dialog box" to open
files, i.e. you have to double click to open directories even with single click
selected as the gnome default.

http://bugzilla.gnome.org/show_bug.cgi?id=121113: http://bugzilla.gnome.org/show_bug.cgi?id=121113

Sebastien Bacher (seb128) wrote :

GTK is not GNOME, doesn't require GNOME and doesn't use gconf ... I'll ping
upstreams, but not sure it's easy to fix

Lionel Dricot (ploum) wrote :

accepted upstream

Changed in gtk+2.0:
status: Unconfirmed → Confirmed
Changed in gtk:
status: Unconfirmed → Confirmed
Changed in gtk:
status: Confirmed → In Progress
Vincenzo Ciancia (vincenzo-ml) wrote :

Could the upstream patch be included in hardy so that everybody can test it and report possible brokennes?

Changed in gtk+2.0:
assignee: seb128 → desktop-bugs
status: Confirmed → Triaged
Vincenzo Ciancia (vincenzo-ml) wrote :

Any progress on this?

tags: added: hundredpapercuts

This does not affect the usability of the default Ubuntu experience, which uses double-click activation for files and folders, so it is not a paper cut.

Changed in hundredpapercuts:
status: New → Invalid
Changed in gtk:
importance: Unknown → Wishlist
Martin Kohn (mtk001) wrote :

@David Siegel

With the greatest of respect David, surely you would concede that for Kubuntu users the default is single-click activation and for us therefore this issue is indeed a paper cut. I am not in any way interested in petty flaming wars but I would have thought that the simplest solution for all is to allow the behaviour to be configured to suit the individual user and thereby satisfy everyone. Since this issue has been flagged for at least six years now, might it not be possible for someone to look into the feasibility of a solution acceptable to all.

Regards, Martin Kohn

Changed in gtk+2.0 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in hundredpapercuts:
status: Invalid → Triaged
milestone: none → raring-misc
Changed in hundredpapercuts:
assignee: nobody → Timothy Arceri (t-fridey)
Changed in hundredpapercuts:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Chris Wilson (notgary) on 2012-11-28
Changed in hundredpapercuts:
milestone: raring-misc → raring-gtk
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: raring-gtk → papercuts-s-nautilus
Changed in gtk:
status: In Progress → Invalid
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gtk:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.