Ubuntu

Resize grip always appears in bottom right of GTK+2.0 windows

Reported by Gareth Hart on 2011-01-17
278
This bug affects 48 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Unassigned

Bug Description

Since a recent update, in a non-maximised GTK+2.0 window, a resize grip will always appear in the bottom right of the window. This causes problems with applications which use the bottom right of the screen, such as Firefox pop-up windows for video content where the bottom right of the window is obscured and looks out of place and the Audacious media player where the total time of a playlist is obscured, to give two examples.

I have included pictures of the problem. As the saying goes, a picture tells a thousand words.

I use KDE with only essential GTK packages installed and the Oxygen GTK engine to integrate GTK apps into the Oxygen KDE theme. The same problem occurs with the Raleigh GTK engine. I am also using Kubuntu Natty Alpha 1 with libgtk2.0-0 version 2.23.90-0ubuntu4.

What should happen: No resize grab should show in the window, as previous behaviour.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libgtk2.0-0 2.23.90-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Jan 17 19:16:55 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101201.1)
ProcEnviron:
 LANGUAGE=
 LANG=en_GB.UTF-8
 SHELL=/bin/bash

Workaround
==========

Edit ~/.gtkrc-2.0-kde4 and add:

---------------------------------------------------------------------
style "default-style"
{
  GtkWindow::resize-grip-height = 0
  GtkWindow::resize-grip-width = 0
}

class "GtkWidget" style "default-style"
---------------------------------------------------------------------

Related branches

Gareth Hart (tghe-retford) wrote :
Gareth Hart (tghe-retford) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the issue is rather an application one though, it should call gtk_window_set_has_resize_grip() to set the grip to false in cases where it should not be displayed, can you confirm Cody?

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

I also see this with the Do windows, which I'm pretty sure are explicitly set to be non-resizable. Presumably such windows should also not get a resize grip?

Sebastien Bacher (seb128) wrote :

That's a valid point, Cody is that a bug in the gtk patch or is there any reason to not to it this way?

Cody Russell (bratsche) wrote :

I already have a branch for gnome-do.

Radics Ottó (saboteur777) wrote :

Resize grip appears in Covergloobus, too. When you have transparent theme set in Covergloobus, the resize grip looks quite ugly.

Matthieu Baerts (matttbe) wrote :

This resize grip appears in Cairo-Dock too.

It's easy to fix this bug by adding one line but how can we detect that we have to add this line?
We've added a condition (#if (GTK_MAJOR_VERSION >= 3) but I see that this grip (and its function "gtk_window_set_has_resize_grip()") has been backported to libgtk2.0 on Ubuntu Natty. Of course we can add a flag for CMake or create a patch only for Ubuntu packages but it's not so clean... because if we compile Cairo-Dock on Natty with default options, this grip appears.

This is also appearing in Xubuntu applications. We have identified it on the Desktop, bug 709279, as well as Xfce4-settings already.

tista (tista) wrote :

Grip appears in WingPanel, too. it looks ugly....

Coz (cosimo321) wrote :

Hey guys,
  This is out of curiosity.
Is it possible simply to make the "grip" handle transparent?

coz

Matthieu Baerts (matttbe) wrote :

Yes, for me it's a great idea.
Of course some apps have to add this "gtk_window_set_has_resize_grip()" function but this 'grip' can look a bit ugly for some other apps (I guess this grip depends of the GTK theme but it's new and maybe it can look ugly with a lot of old theme)

tista (tista) wrote :

I think it doesn't matter which new theming or not... the point is that all types of gtk window would be forced to include ugly grip. and also transparency pixmap for grip couldn't help us at all now. why we NEVER have the choice in grip or non-grip ???

Märt Põder (boamaod) wrote :

Is there a possibility to turn off the resize grip in Python by now?

Shawn Smout (silroquen) wrote :

I have this problem in Chrome, where it covers up the bottom arrow on the scrollbar.

Also, I'm presently running the XMonad window manager, so the grip doesn't work anyway. So I would really appreciate an option to remove the grip from everything.

Sebastien: How can this be an application issue? gtk_window_set_has_resize_grip() does not exist in upstream gtk+ 2.0; it was added by an Ubuntu patch (debian/patches/044_grips.patch). In order to maintain compatibility with upstream applications, the default needs to be changed to FALSE.

spiongraz (tomfasching) wrote :

indeed anders

and its about time this gets fixed. its easy enough.
we kubuntu/xubuntu users are not using unity, pls dont let us "suffer" for that.

Ioannis Ramfos (isr81) wrote :

This is even an issue for the Firefox main window running under Unity, where the down arrow of the scrollbar is obscured (when the window is not maximized).

Martin Stjernholm (msub) wrote :

The resize grips may be good for Unity users only using Unity-adapted applications, but the change has the wrong scope since it affects all resizable windows, regardless of desktop environment and window manager (personally i use Sawfish and enjoy a better solution to the resize problem).

If it cannot be fixed the proper way, i.e. so that it only affects Unity, then please at least make it possible to disable at the user level, e.g. through a gconf setting.

Imo this bug should have a higher importance; these things are disruptive for all non-Unity Ubuntu users.

Kjell L. (lkjell) wrote :

Finally found the right bug report. This resize thing is annoying on tiling wm as we do not resize at all!

metamarket (cancel-allow) wrote :

Can confirm this bug in Chrome, Firefox, Audacious (Impossible to resize playlist). (System: fresh Kubuntu 11.04 i386 without any mods).

Tzury Bar Yochay (tzury-by) wrote :
cdunphy (rc-dunphy) wrote :

This makes GTK applications in Firefox and Chrome look horrible in Kubuntu/KDE.

I confirm this bug in audacious 2.5.0 running in Natty x64 - white resize grip always seen, and one is unable to resize playlist (window snaps to the position of the cursor when mouse button released).

benjamin (jesuisbenjamin) wrote :

If i create a window using PyGtk with a GtkLabel there is no resize grip on the window.
If i embed the GtkLabel in a GtkEventBox, even when its set_visible_window() function is set to False, the resize grip is rendered.

Andrey (waster2008) wrote :

Confirm bug as it in #25 post with fresh installed Natty + Compiz + Gnome + NVIDIA.

This is specially ugly in Kubuntu, where it shows up as a black triangle on top of whatever is in the corner.

description: updated
description: updated
Cornelius Sicker (ysis) wrote :

I'm on Xubuntu 11.04 and have this grip on every non-maximized window.
Especially on borderless terminals it looks awful and is of no use for me since I always resize with Alt+Right mouse drag.

An option to disable this globally would be very much appreciated.

Changed in gtk2-engines-oxygen (Ubuntu):
status: New → Confirmed
Mark__T (mark-trompell) wrote :

Wouldn't that help for most cases. + changing the default theme for unity, that it shows them.

tags: added: patch
Changed in gtk+2.0 (Ubuntu):
status: Confirmed → New
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I believe this was fixed in Ubuntu 11.10, wasn't it?

mahfiaz (mahfiaz) wrote :

Some of these grips are gone at least in 10.04.
Now the most annoying appearance of this grip is in LibreOffice, where clicking on it opens File menu (or is it unrelated?).

mahfiaz (mahfiaz) wrote :

In 12.04, sorry.

Timothy Arceri (t-fridey) wrote :

The problem is caused by Ubuntu back porting grips to gtk2 (from gtk3). gtk2 applications have not been written expecting grips to be there.

Timothy Arceri (t-fridey) wrote :

The backport does not detect if the grip should be turned off properly see: https://bugs.launchpad.net/hundredpapercuts/+bug/734381

Timothy Arceri (t-fridey) wrote :

Ignore my last post that bug only applys to when the window shouldn't be able to be resized.
The reasons some grips are gone in 12.04 is probably because the application have migrated to gtk3 and have disabled grips, this will happen over time and the problem will disapear.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.10-0ubuntu5

---------------
gtk+2.0 (2.24.10-0ubuntu5) precise; urgency=low

  * debian/control.in:
    - breaks on the binaries which were using the grip function backported
  * debian/libgtk2.0-0.symbols:
    debian/patches/044_grips.patch:
    - dropped the feature is only in gtk3 upstream, the backport had
      issues and most upstream softwares are not made to deal with it.
      the grips will be also dropped from the default gtk3 theme since unity
      has resize borders (lp: #744993)
    - will fix issues with libreoffice (lp: #749986) and splash screens
      in other softwares (lp: #704105, #734381)
 -- Sebastien Bacher <email address hidden> Fri, 24 Feb 2012 18:39:56 +0100

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
no longer affects: gtk2-engines-oxygen (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers