Ubuntu

f-spot.exe crashes when using new wave theme

Reported by Andrey Zhekov on 2009-08-11
280
This bug affects 57 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Sebastien Bacher
Karmic
Low
Ubuntu Desktop Bugs
Lucid
Medium
Sebastien Bacher

Bug Description

Binary package hint: f-spot

Ubuntu 9.10 a3
updated at 4pm CET 11.08.2009
f-spot 0.6.0
Crash at start

ProblemType: Crash
Architecture: i386
Date: Tue Aug 11 16:01:47 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/f-spot/f-spot.exe
InterpreterPath: /usr/bin/mono
NonfreeKernelModules: nvidia
Package: f-spot 0.6.0.0-1~ubuntu1
ProcCmdline: f-spot /usr/lib/f-spot/f-spot.exe
ProcEnviron:
 SHELL=/bin/bash
 LANG=ru_RU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
Signal: 5
SourcePackage: f-spot
StacktraceTop:
 ?? () frhostname /usr/lib/libgdk-x11-2.0.so.0
 _XError () frhostname /usr/lib/libX11.so.6
 ?? () frhostname /usr/lib/libX11.so.6
 _XReply () frhostname /usr/lib/libX11.so.6
 XSync () frhostname /usr/lib/libX11.so.6
Title: f-spot.exe crashed with signal 5 in _XError()
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse sambashare

Related branches

Andrey Zhekov (x3ro.daemon) wrote :

StacktraceTop:gdk_x_error (display=0x9f71dd0, error=0xbfa62aec)
_XError (dpy=0x9f71dd0, rep=0xa2c8d10)
process_responses (dpy=0x9f71dd0,
_XReply (dpy=0x9f71dd0, rep=0xbfa62c50, extra=0, discard=1)
XSync (dpy=0x9f71dd0, discard=0) at ../../src/Sync.c:48

Changed in f-spot (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Hi,

I'm afraid your bug does not have the information we need to try to fix it. Does the crash happen every time? Can you try running from a terminal with "f-spot --debug" and pasting/attaching the entire output to the bug if it crashes. Thanks in advance.

Iain

visibility: private → public
Andrey Zhekov (x3ro.daemon) wrote :

andrey@om:~$ f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
[Info 17:25:35.501] Initializing DBus
[Debug 17:25:35.732] DBusInitialization took 0,211451s
[Info 17:25:35.732] Initializing Mono.Addins
[Debug 17:25:36.038] Mono.Addins Initialization took 0,305726s
[Info 17:25:36.059] Starting new FSpot server (f-spot 0.6.0.0)
[Debug 17:25:36.304] Db Initialization took 0,076106s
[Debug 17:25:36.736] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:36.736] QueryToTemp took 0,00087s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:36.736] Reloading the query took 0,004789s
[Debug 17:25:36.984] PhotosPerMonth took 0,000605s
[Debug 17:25:36.987] TimeAdaptor REAL Reload took 0,227039s
[Debug 17:25:37.100] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:37.101] QueryToTemp took 0,000909s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:37.164] Reloading the query took 0,065033s
[Debug 17:25:37.169] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:37.170] QueryToTemp took 0,000915s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 17:25:37.179] Reloading the query took 0,010451s
[Info 17:25:37.185] Starting BeagleService
[Debug 17:25:37.186] BeagleService startup took 1,9E-05s
[Info 17:25:37.218] Hack for gnome-settings-daemon engaged

(f-spot:4624): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
[Debug 17:25:37.307] PhotosPerMonth took 0,000647s
[Debug 17:25:37.307] TimeAdaptor REAL Reload took 0,137082s
[Debug 17:25:37.373] PhotosPerMonth took 0,000667s
[Debug 17:25:37.373] TimeAdaptor REAL Reload took 0,203206s

Gdk-ERROR **: The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3446 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap (core dumped)

Andrey Zhekov (x3ro.daemon) wrote :

It happens every time I start f-spot

Pako (elektrobank01) wrote :

same happens here :

$ f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
[Info 02:11:34.198] Initializing DBus
[Debug 02:11:34.549] DBusInitialization took 0.318159s
[Info 02:11:34.549] Initializing Mono.Addins
[Debug 02:11:34.975] Mono.Addins Initialization took 0.426237s
[Info 02:11:34.989] Starting new FSpot server (f-spot 0.6.0.0)
[Debug 02:11:35.504] Db Initialization took 0.208508s
[Debug 02:11:36.243] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:36.248] QueryToTemp took 0.00499s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:36.248] Reloading the query took 0.012433s
[Debug 02:11:36.517] PhotosPerMonth took 0.009884s
[Debug 02:11:36.521] TimeAdaptor REAL Reload took 0.218888s
[Debug 02:11:37.046] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:37.047] QueryToTemp took 0.001445s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:37.191] Reloading the query took 0.145743s
[Debug 02:11:37.201] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:37.209] QueryToTemp took 0.007534s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 02:11:37.249] Reloading the query took 0.049115s
[Debug 02:11:37.265] PhotosPerMonth took 0.009415s
[Debug 02:11:37.266] TimeAdaptor REAL Reload took 0.056491s
[Info 02:11:37.272] Starting BeagleService
[Debug 02:11:37.274] BeagleService startup took 2.7E-05s
[Info 02:11:37.355] Hack for gnome-settings-daemon engaged

(f-spot:8072): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
[Debug 02:11:37.417] PhotosPerMonth took 0.007506s
[Debug 02:11:37.417] TimeAdaptor REAL Reload took 0.208365s

Gdk-ERROR **: The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3484 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap (core dumped)

It is a problem with the gtk theme. With New Wave it crashes, but with other themes such as Dust, Human it works.

affects: f-spot (Ubuntu) → gnome-themes-ubuntu (Ubuntu)
affects: gnome-themes-ubuntu (Ubuntu) → f-spot (Ubuntu)
affects: f-spot (Ubuntu) → gnome-themes-ubuntu (Ubuntu)
summary: - f-spot.exe crashed with signal 5 in _XError()
+ f-spot.exe crashes when using new wave theme
Lucas Bxxx (splidtter) wrote :

workaround: set ubuntu to some other theme, go to preferences in f-spot, set theme to new wave, then set ubuntu back to new wave

Kenneth Wimer (kwwii) wrote :

After testing, this seems to be a problem with gtk+-2.0 pixmap engine. Any theme using the pixmap engine crashes with fspot in the same manner.

Changed in gnome-themes-ubuntu (Ubuntu):
status: New → Invalid
affects: gnome-themes-ubuntu (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
status: Invalid → New
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
lhotari (lartsa) wrote :

Eclipse (SpringSource Tool Suite / STS in my case) also crashes in "New wave" theme.

~/.xsession-errors :
The program 'SpringSource Tool Suite' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 344487 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Reproducing bug: make a search which has a lot of search results. Pressing the expand all nodes button makes eclipse crash.

itsjareds (itsjareds) wrote :

I found this bug through some other bugs which marked this as their duplicate. Here's my output when trying to start F-Spot:

$ f-spot
[Info 21:05:50.877] Initializing DBus
[Info 21:05:51.056] Initializing Mono.Addins
[Info 21:05:51.293] Starting new FSpot server (f-spot 0.6.1.5)

** (f-spot:3605): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3605): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3605): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3605): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3605): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 21:05:52.532] Starting BeagleService
[Info 21:05:52.559] Hack for gnome-settings-daemon engaged

(f-spot:3605): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3534 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I can confirm that this bug exists, I'm currently experiencing it myself...console output from running f-spot:

** (f-spot:27519): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:27519): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:27519): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:27519): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:27519): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 07:12:45.360] Starting BeagleService
[Info 07:12:45.385] Hack for gnome-settings-daemon engaged

(f-spot:27519): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 5103 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Rich Jones (richwjones) wrote :

I also get this. Ubuntu Netbook Remix

/$ f-spot
[Info 13:11:03.000] Initializing DBus
[Info 13:11:03.338] Initializing Mono.Addins
[Info 13:11:03.797] Starting new FSpot server (f-spot 0.6.1.5)

** (f-spot:13480): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:13480): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:13480): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:13480): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:13480): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 13:11:06.416] Starting BeagleService
[Info 13:11:06.480] Hack for gnome-settings-daemon engaged

(f-spot:13480): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3789 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Shaun Menzies (shaunmenzies) wrote :

Same error on Samsung n310 Ubuntu 9.10 Netbook Remix (1GB Ram)

Cheers, Shaun.

(f-spot:2668): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3299 error_code 11 request_code 53 minor_code 0)

Nuno (nuno-miguel-vitorino) wrote :

Same error here on Ubuntu Desktop 9.10

Simon741 (simon-okko) wrote :

I can confirm that bug. And I can also confirm that work-around: if a take another Appearance than New Wave, F-Spot works fine.

Roy Jamison (xteejx) wrote :

Marking Confirmed as per the comment above. In future you can set the status of the bug to Confirmed yourself if you are experiencing it as well, as long as you are not the original reporter. Thank you.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
ian cy shipman (ian-shipman) wrote :

same error on toshiba tecra a7 running 9.10

(/usr/lib/f-spot/f-spot.exe:20771): GLib-WARNING **: g_set_prgname() called multiple times
[Info 13:02:49.677] Initializing DBus
[Info 13:02:49.906] Initializing Mono.Addins
[Info 13:02:50.170] Starting new FSpot server (f-spot 0.6.1.5)

** (/usr/lib/f-spot/f-spot.exe:20771): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:20771): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:20771): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:20771): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:20771): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 13:02:51.489] Starting BeagleService
[Info 13:02:51.526] Hack for gnome-settings-daemon engaged

(/usr/lib/f-spot/f-spot.exe:20771): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2939 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Download full text (3.4 KiB)

build@build-desktop:~$ f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
/home/build/.themes/NewSlicknesS/gtk-2.0/gtkrc:29: Overlay image options specified without filename
[Info 14:23:24.909] Initializing DBus
[Debug 14:23:25.063] DBusInitialization took 0.120102s
[Info 14:23:25.064] Initializing Mono.Addins
[Debug 14:23:25.271] Mono.Addins Initialization took 0.206366s
[Info 14:23:25.284] Starting new FSpot server (f-spot 0.6.1.3)
[Debug 14:23:25.406] Db Initialization took 0.061179s

** (f-spot:3966): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3966): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3966): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3966): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:3966): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Debug 14:23:25.729] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:25.741] QueryToTemp took 0.012365s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:25.741] Reloading the query took 0.016307s
[Debug 14:23:25.985] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:25.992] PhotosPerMonth took 0.015687s
[Debug 14:23:25.992] QueryToTemp took 0.007372s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:25.994] TimeAdaptor REAL Reload took 0.23712s
[Debug 14:23:26.029] Reloading the query took 0.04412s
[Debug 14:23:26.031] Query Started : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:26.040] QueryToTemp took 0.008717s : SELECT * FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY time DESC, filename DESC
[Debug 14:23:26.089] Reloading the query took 0.058215s
[Info 14:23:26.093] Starting BeagleService
[Debug 14:23:26.094] BeagleService startup took 1.2E-05s
[Info 14:23:26.114] Hack for gnome-settings-daemon engaged

(f-spot:3966): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
[Debug 14:23:26.202] PhotosPerMonth took 0.005137s
[Debug 14:23:26.202] TimeAdaptor REAL Reload took 0.161536s
[Debug 14:23:26.241] PhotosPerMonth took 0.000497s
[Debug 14:23:26.241] TimeAdaptor REAL Reload took 0.201137s
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2267 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   ...

Read more...

Cody Russell (bratsche) wrote :

Using New Wave theme, I run f-spot and I'm not seeing any crasher yet. I've tried flipping between views and stuff, but so far nothing. Can anyone still reproduce this?

Cody Russell (bratsche) wrote :

Looks like we may have narrowed this down to 32-bit systems only.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.gnome.org/show_bug.cgi?id=607687

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Triaged
Changed in gtk:
importance: Undecided → Unknown
status: New → Unknown
Download full text (3.8 KiB)

I replicated the error on my son's machine (running Ubuntu 9.10). Here is
the error -

rowan@rowan-desktop:~$ f-spot

(/usr/lib/f-spot/f-spot.exe:
2038): GLib-WARNING **: g_set_prgname() called multiple times
[Info 18:48:02.630] Initializing DBus
[Info 18:48:02.835] Initializing Mono.Addins
[Info 18:48:03.149] Starting new FSpot server (f-spot 0.6.1.5)

** (/usr/lib/f-spot/f-spot.exe:2038): CRITICAL **: atk_object_set_name:
assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2038): CRITICAL **: atk_object_set_name:
assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2038): CRITICAL **: atk_object_set_name:
assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2038): CRITICAL **: atk_object_set_name:
assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2038): CRITICAL **: atk_object_set_name:
assertion `name != NULL' failed
[Info 18:48:04.765] Starting BeagleService
[Info 18:48:04.797] Hack for gnome-settings-daemon engaged

(/usr/lib/f-spot/f-spot.exe:2038): GdkPixbuf-WARNING **: GdkPixbufLoader
finalized without calling gdk_pixbuf_loader_close() - this is not allowed.
You must explicitly end the data stream to the loader before dropping the
last reference.
The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2950 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Hope this helps?

Steve

On 21 January 2010 17:40, Sebastien Bacher <email address hidden> wrote:

> Thanks for your bug report. This bug has been reported to the developers
> of the software. You can track it and make comments here:
> https://bugzilla.gnome.org/show_bug.cgi?id=607687
>
> ** Bug watch added: GNOME Bug Tracker #607687
> https://bugzilla.gnome.org/show_bug.cgi?id=607687
>
> ** Changed in: gtk+2.0 (Ubuntu)
> Status: Confirmed => Triaged
>
> ** Bug watch added: GNOME Bug Tracker #607687
> https://bugzilla.gnome.org/show_bug.cgi?id=607687
>
> ** Changed in: gtk
> Importance: Undecided => Unknown
>
> ** Changed in: gtk
> Status: New => Unknown
>
> ** Changed in: gtk
> Remote watch: None => GNOME Bug Tracker #607687
>
> --
> f-spot.exe crashes when using new wave theme
> https://bugs.launchpad.net/bugs/411941
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in GTK+ GUI Toolkit: Unknown
> Status in “gtk+2.0” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: f-spot
>
> Ubuntu 9.10 a3
> updated at 4pm CET 11.08.2009
> f-spot 0.6.0
> Crash at start
>
> ProblemType: Crash
> Architecture: i386
> Date: Tue Aug 11 16:01:47 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/f-spot/f-spot.exe
> InterpreterPath: /usr/bin/mono
> NonfreeKernelModules: nvi...

Read more...

tags: added: bugpattern-needed
Changed in gtk+2.0 (Ubuntu Karmic):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Changed in gtk+2.0 (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.19.3-1ubuntu3

---------------
gtk+2.0 (2.19.3-1ubuntu3) lucid; urgency=low

  * debian/patches/093_git_change_fix_rectangle_intersection_error.patch:
    - git change to fix a rectangle intersection overflow issue which leads
      to a f-spot crash when using the new wave theme for example (lp: #411941)
 -- Sebastien Bacher <email address hidden> Fri, 22 Jan 2010 12:32:47 +0100

Changed in gtk+2.0 (Ubuntu Lucid):
status: Triaged → Fix Released
lory (lorenzo-themax) wrote :

how to fix? i have already this bug, on ubuntu 9.10, and my system is updated.

It looks like this bug is fixed!
Today I updated Ubuntu and I've noticed that there was a new patch for gtk2-engines-pixbuf... so I decided to test f-spot using new wave theme and there were no crashes.
I've restarted my computer after update.
Can someone please confirm this?

I forgot to mention that I'm using Ubuntu 9.10 Karmic Koala!

Steve Cole (sjrkcole) wrote :

I can confirm that the bug has now been fixed on my machine.

Steve

On 2 February 2010 19:31, Jaime Fernando Ortega Culaciati <
<email address hidden>> wrote:

> It looks like this bug is fixed!
> Today I updated Ubuntu and I've noticed that there was a new patch for
> gtk2-engines-pixbuf... so I decided to test f-spot using new wave theme and
> there were no crashes.
> I've restarted my computer after update.
> Can someone please confirm this?
>
> --
> f-spot.exe crashes when using new wave theme
> https://bugs.launchpad.net/bugs/411941
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in GTK+ GUI Toolkit: Unknown
> Status in “gtk+2.0” package in Ubuntu: Fix Released
> Status in “gtk+2.0” source package in Lucid: Fix Released
> Status in “gtk+2.0” source package in Karmic: Triaged
>
> Bug description:
> Binary package hint: f-spot
>
> Ubuntu 9.10 a3
> updated at 4pm CET 11.08.2009
> f-spot 0.6.0
> Crash at start
>
> ProblemType: Crash
> Architecture: i386
> Date: Tue Aug 11 16:01:47 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/f-spot/f-spot.exe
> InterpreterPath: /usr/bin/mono
> NonfreeKernelModules: nvidia
> Package: f-spot 0.6.0.0-1~ubuntu1
> ProcCmdline: f-spot /usr/lib/f-spot/f-spot.exe
> ProcEnviron:
> SHELL=/bin/bash
> LANG=ru_RU.UTF-8
> ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
> Signal: 5
> SourcePackage: f-spot
> StacktraceTop:
> ?? () frhostname /usr/lib/libgdk-x11-2.0.so.0
> _XError () frhostname /usr/lib/libX11.so.6
> ?? () frhostname /usr/lib/libX11.so.6
> _XReply () frhostname /usr/lib/libX11.so.6
> XSync () frhostname /usr/lib/libX11.so.6
> Title: f-spot.exe crashed with signal 5 in _XError()
> Uname: Linux 2.6.31-5-generic i686
> UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gtk/+bug/411941/+subscribe
>

CMB (magnus-bjureblad) wrote :

I can also confirm the the bug is fixed (Ubuntu 9.10). :-)

/CMB

Ben (ben-lemire) wrote :

The recent update to the gtk2-engines-pixbuf package seems to have fixed this issue for me also on Ubuntu 9.10, 32-bit, using the "New Wave" theme.

Changed in gtk+2.0 (Ubuntu Karmic):
status: Triaged → Fix Released
Per Vikman (pelleve) wrote :

I am today running:

9.10

2.6.31-19-generic-pae

GNOME 2.28.1

and still have the problem with F-spot as described in #515120

Br,
Per

Steve Cole wrote:
> I can confirm that the bug has now been fixed on my machine.
>
> Steve
>
> On 2 February 2010 19:31, Jaime Fernando Ortega Culaciati <
> <email address hidden>> wrote:
>
>
>> It looks like this bug is fixed!
>> Today I updated Ubuntu and I've noticed that there was a new patch for
>> gtk2-engines-pixbuf... so I decided to test f-spot using new wave theme and
>> there were no crashes.
>> I've restarted my computer after update.
>> Can someone please confirm this?
>>
>> --
>> f-spot.exe crashes when using new wave theme
>> https://bugs.launchpad.net/bugs/411941
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in GTK+ GUI Toolkit: Unknown
>> Status in “gtk+2.0” package in Ubuntu: Fix Released
>> Status in “gtk+2.0” source package in Lucid: Fix Released
>> Status in “gtk+2.0” source package in Karmic: Triaged
>>
>> Bug description:
>> Binary package hint: f-spot
>>
>> Ubuntu 9.10 a3
>> updated at 4pm CET 11.08.2009
>> f-spot 0.6.0
>> Crash at start
>>
>> ProblemType: Crash
>> Architecture: i386
>> Date: Tue Aug 11 16:01:47 2009
>> DistroRelease: Ubuntu 9.10
>> ExecutablePath: /usr/lib/f-spot/f-spot.exe
>> InterpreterPath: /usr/bin/mono
>> NonfreeKernelModules: nvidia
>> Package: f-spot 0.6.0.0-1~ubuntu1
>> ProcCmdline: f-spot /usr/lib/f-spot/f-spot.exe
>> ProcEnviron:
>> SHELL=/bin/bash
>> LANG=ru_RU.UTF-8
>> ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
>> Signal: 5
>> SourcePackage: f-spot
>> StacktraceTop:
>> ?? () frhostname /usr/lib/libgdk-x11-2.0.so.0
>> _XError () frhostname /usr/lib/libX11.so.6
>> ?? () frhostname /usr/lib/libX11.so.6
>> _XReply () frhostname /usr/lib/libX11.so.6
>> XSync () frhostname /usr/lib/libX11.so.6
>> Title: f-spot.exe crashed with signal 5 in _XError()
>> Uname: Linux 2.6.31-5-generic i686
>> UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse sambashare
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/gtk/+bug/411941/+subscribe
>>
>>
>
>

Sebastien Bacher (seb128) wrote :

the fix has not been backported to karmic

JamesH (jnahughes) wrote :

I have suddenly started getting this issue, on themes that are NOT New Wave. Originally, moving to a non-New wave theme fixed the issue, but since I did an update earlier this evening, the fault has come back, but for all the themes I have tried - so the workaround no longer works.

Using KK 9.10, 2.6.31.-19
Nvidia drivers
Gnome 2.28.1

I have tried with desktop effects on and off.

Machine is an Acer Revo with Atom 230 processor, 3GB RAM.

Error as follows :

(/usr/lib/f-spot/f-spot.exe:2013): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 4021 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

JamesH (jnahughes) wrote :

Since this bug has been flagged as fixed, and since I am getting problems on a non-new wave theme on KK, and no-one has commented here, I will file a new bug report.

Diogo Baeder (diogobaeder) wrote :

Comment #11 is still valid for me, using Ubuntu 10.04; Eclipse was crashing with New Wave, and doesn't crash with older themes, when I do a large result list search.

Jens Kubieziel (qbi) wrote :

Today I installed f-spot 0.7.1 (PPA) and encounter the same problem. I'm using basically the Ambience theme with some customisations. When I started f-spot it didn't show me the images which I previously imported. I only saw some red-crossed circles.

When I chose Import and my camera model, f-spot started to connect/download and crashed. Console output was:

> f-spot
Moving /home/jens/.gnome2/f-spot to /home/jens/.config/
[Info 21:16:33.836] Initializing Mono.Addins
Add-in could not be loaded: Could not read add-in file: /home/jens/.config/f-spot/addin-db-001/addin-data/1/FSpot.Core,0.7.0.0.maddin
System.InvalidOperationException: Could not read add-in file: /home/jens/.config/f-spot/addin-db-001/addin-data/1/FSpot.Core,0.7.0.0.maddin ---> System.InvalidOperationException: Could not read add-in description
  at Mono.Addins.Addin.get_Description () [0x00000]
  at Mono.Addins.Addin.get_AddinInfo () [0x00000]
  --- End of inner exception stack trace ---
  at Mono.Addins.Addin.get_AddinInfo () [0x00000]
  at Mono.Addins.Addin.get_Enabled () [0x00000]
  at Mono.Addins.Database.AddinDatabase.IsAddinEnabled (System.String domain, System.String id) [0x00000]
  at Mono.Addins.AddinRegistry.IsAddinEnabled (System.String id) [0x00000]
  at Mono.Addins.AddinSessionService.LoadAddin (IProgressStatus statusMonitor, System.String id, Boolean throwExceptions) [0x00000]
[Info 21:16:36.399] Unregistering http://addins.f-spot.org/0.4.3/main.mrep
[Info 21:16:37.073] Updating F-Spot Database

(f-spot:12749): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.

Unhandled Exception: GLib.GException: Vorgang wird vom Backend nicht unterstützt
  at GLib.FileInputStream.QueryInfo (System.String attributes, GLib.Cancellable cancellable) [0x00000]
  at GLib.GioStream.get_Length () [0x00000]
  at TagLib.File.get_Length () [0x00000]
  at TagLib.Jpeg.File.ReadSegmentSize () [0x00000]
  at TagLib.Jpeg.File.ReadMetadata () [0x00000]
  at TagLib.Jpeg.File.Read (ReadStyle propertiesStyle) [0x00000]
  at TagLib.Jpeg.File..ctor (IFileAbstraction abstraction, ReadStyle propertiesStyle) [0x00000]
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.