Ubuntu

[master] ASX files that don't play

Reported by Alexander Jones on 2007-01-18
46
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GStreamer
Expired
Medium
gstreamer0.10 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem-gstreamer-firefox-plugin

Error dialog:

Can't parse that

no files

Alexander Jones (alex-weej) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? It's played correctly on my feisty desktop, might be fixed by the mozilla plugin changes from the new version (lot of code has been rewritten)

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Alexander Jones (alex-weej) wrote :

I don't get the error message if I play through the attached HTML file. (I'm not sure if it's faithful to the original, sorry.)

However, it halts at what looks like the first frame, just like in the standalone application.

Changed in totem:
status: Needs Info → Unconfirmed
Sebastien Bacher (seb128) wrote :

Do you still get the bug?

Alexander Jones (alex-weej) wrote :

Yes, it still halts on the first frame.

LC всадник cbet (lc1884) wrote :

I was able to play it perfectly on gxine, when trying to play with vlc it didn`t work, when playing with gstreamer on Firefox it took a while till it started but it played eventually, I had problems with .asf and some .asx are still crap to play i I tried for something for .asf which may work for you which is to try installing through synaptic all the gstreamer (type that and search) plugins than you install those and reinstall totem/mplayer and gxine(I prefer gxine). Hopefully it`ll work.

Changed in totem:
assignee: desktop-bugs → nobody
LC всадник cbet (lc1884) wrote :

http://www.cubavision.cubaweb.cu/tv_cubana.asx

the live TV link above which is a .asx doesn`t play correctly, sometimes when playing with Gxine it lasts no longer than 15 seconds.
Why is .asx so difficult to play?
The library test put here by Alex Jones plays just fine.

LC всадник cbet (lc1884) wrote :

http://www.cubavision.cubaweb.cu/tv_cubana.asx
It`s a bit odd but if I record it with VLC and then wait a few minutes and start playing with another VLC I the stream is not interrupted,
Although the colors are totally weird(which might be a codec thing)

Xtreme (vamshi2508) wrote :

u can play asx files using mplayer from the terminal if u want

the command is

mplayer -playlist url

if u want to download it

mplayer -playlist url -dumpfile out.mpg -dumpstream

Åskar (olskar) wrote :

I can not play asx in latest hardy with all updates.
For example http://svt.se/content/1/c8/01/08/07/11/080311BECKMAN_ERT43TY.asx doesnt work

If I remove the totem-mozilla and install mozilla-mplayer instead it works great..perhaps we should change the default?

Alexander Jones (alex-weej) wrote :

The original bug reported here still stands, with exactly the same symptoms, in Hardy.

Sebastien Bacher (seb128) wrote :

Should be sent upstream by somebody getting the issue

Åskar (olskar) wrote :

Is something happening with this bug?

A workaround is to remove totem-mozilla and install mozilla-mplayer instead.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Could you try to reproduce the same with Ubuntu 8.10 or 9.04? Thanks in advance.

Changed in gstreamer0.10:
status: New → Incomplete

Binary package hint: firefox-3.0

Ubuntu 9.04
Firefox 3.0.5+nobinonly-0ubuntu1
Movie player, totem 2.25.3-0ubuntu2

What happens
* Link number four at http://www.radionz.co.nz/search?mode=results&queries_all_query=stallman redirects to http://www.radionz.co.nz/__data/assets/audio_item/0008/1699424/sat-20080809-0845-Richard_Stallman_Freedom-m048.asx which should play an interview with Richard Stallman
* A page opens with a media icon and nothing happens. The right click context menu includes "Totem Browser Plugin 2.25.3 - Browser Plugin using GStreamer 0.10.22"
* 'Open with "Movie player" ' complains "An error occurred /r Could not open location; you might not have permission to open the file."

What should happen:
* If Ubuntu can play the supplied file, then it should 'just work'.
* If Ubuntu can't play the supplied file it should explain why.

In Ubuntu 9.04 these streams also fail:

* http://launchpadlibrarian.net/5780054/test.asx The windows just says "stopped". 'Open with Movie Player' reports 'buffering' and then 'playing' but nothing happens.
* http://www.abc.net.au/science/broadband/catalyst/asx/Catalyst16_vortex_hi.asx The windows just says "stopped". 'Open with Movie Player' reports 'buffering' and then 'playing' but nothing happens.

Using cli and mplayer I can download the file at http://www.radionz.co.nz/__data/assets/audio_item/0008/1699424/sat-20080809-0845-Richard_Stallman_Freedom-m048.asx which then plays fine.

$ mplayer -playlist url -dumpfile out.mpg -dumpstream

Changed in gstreamer0.10:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

thanks for sent it upstream.

Changed in gstreamer0.10:
status: New → Triaged
Changed in gstreamer:
status: Unknown → New
skillllllz (bmustafa) wrote :

I am experiencing failures in playing embedded video in Firefox when using totem-mozilla. Below is the output I get every time I attempt to play any of the embedded videos found at www.biziizle.com.

** Message: Viewer DBus interface name is 'org.gnome.totem.PluginViewer_10407'
** Message: NameOwnerChanged old-owner '' new-owner ':1.124'
** Message: Viewer now connected to the bus
** Message: ViewerSetup
** Message: Calling SetWindow
Viewer: SetWindow XID 50333729 size 320:309
TotemEmbedded-Message: Viewer state: STOPPED
** Message: SetWindow reply
** Message: ViewerReady
** Message: Stream requested (force viewer: 0)
TotemEmbedded-Message: totem_embedded_open_uri: uri /player/SAlone.asp?id=101 base_uri: /player/SAlone.asp?id=101
Emptying current_uri
Base URI /player/SAlone.asp?id=101 has no parent!
totem_embedded_set_uri uri /player/SAlone.asp?id=101 base /player/SAlone.asp?id=101 => resolved (null)
** Message: OpenURI reply

** (firefox:10390): WARNING **: OpenURI failed: No URI to play
** Message: NewStream mimetype 'video/x-ms-asf' URL 'http://www.biziizle.com/player/SAlone.asp?id=101'
** Message: Not expecting a new stream; aborting stream

Changed in gstreamer:
status: New → Invalid
skillllllz (bmustafa) wrote :

This problem still exists. Has existed all the way through to Karmic, and still exists in Lucid as well.

Changed in gstreamer:
status: Invalid → New
Changed in gstreamer:
status: New → Invalid
Shahin (muameleh) wrote :

Trying to play a *.asx file I get the message: „GstDecodeBin2:This appears to be a text file.“
It seems that asx files which contain a dynamic link produce this message. I can play the same file in “Windows Media player” immediately! In Ubuntu I have installed all codecs. It did not help. Neither Totem nor VLC is able to stream the file.

Changed in gstreamer:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.