rhythmbox crashed with SIGSEGV in g_object_set()

Bug #455421 reported by dieterv on 2009-10-19
734
This bug affects 149 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
gstreamer0.10 (Ubuntu)
Medium
Unassigned
Declined for Karmic by Sebastien Bacher
Nominated for Lucid by krabas

Bug Description

Binary package hint: rhythmbox

This crash occurred when i was trying to change the volume using the volume slider in rhythmbox. However, when i restarted rhythmbox i was unable to reproduce the problem. Everything was up to date when the crash occurred.

ProblemType: Crash
Architecture: i386
Date: Mon Oct 19 08:16:40 2009
Disassembly: 0x0: Cannot access memory at address 0x0
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.5-0ubuntu4
ProcCmdline: rhythmbox
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? ()
 g_object_set () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
 ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
 g_object_set_valist () from /usr/lib/libgobject-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in g_object_set()
Uname: Linux 2.6.31-14-generic i686
UserGroups: Domain Users adm admin audio cdrom dialout lpadmin plugdev pulse pulse-access sambashare

dieterv (dieterv77) wrote :

StacktraceTop:?? ()
g_object_set () from /usr/lib/libgobject-2.0.so.0
gst_play_sink_set_volume (playsink=0x1,
gst_play_bin_set_property (object=0xa9500d8, prop_id=17,
g_object_set_valist () from /usr/lib/libgobject-2.0.so.0

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

backtrace matches: https://bugzilla.gnome.org/show_bug.cgi?id=590431 ; adding the link. thanks for reporting.

visibility: private → public
Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
prakteon (codeprofiling) wrote :

I pretty much had the same problem.

The thing is I am able to reproduce it. All I have to do is just start playing with my mouse's scroll button placed upon the volume control...

Br8knitOFF (todd-lapittus) wrote :

Same exact problem as described above. Dell Latitude E6400, upgraded to 9.10 last night.

xiangfu (xiangfu) wrote :

same problem here MacBook 5.1, upgraded to 9.10 today

For some reason no sounds play when the master volume slider is 3 clicks or below. So I was messing with that and then I tried moving the Rythmbox slider and thats when it crashed.

Same problem

Reddox (gopiaravind) wrote :

Crashes when I change volume.

Michalxo (michalxo) wrote :

Are there any fixes for now? It's still on karmic...

Pedro Villavicencio (pedro) wrote :

no there's no fixes for it yet, patches are more than welcome though.

I have moved off 9.10 back to 9.04....works like a charm and no
crashes! Till 9.10 issues are sorted out I intend to continue with
9.04.

On 12/10/09, Pedro Villavicencio <email address hidden> wrote:
> no there's no fixes for it yet, patches are more than welcome though.
>
> ** Bug watch added: GNOME Bug Tracker #533427
> https://bugzilla.gnome.org/show_bug.cgi?id=533427
>
> ** Changed in: rhythmbox
> Remote watch: GNOME Bug Tracker #590431 => GNOME Bug Tracker #533427
>
> --
> rhythmbox crashed with SIGSEGV in g_object_set()
> https://bugs.launchpad.net/bugs/455421
> You received this bug notification because you are a direct subscriber
> of the bug.
>

cyberIQ (oktayahmed) wrote :

Yes, 9.04 was more stabile for me than 9.10, who crashed often. It was upgraded to 9.10 from 9.04 online (via Update Manager). I thought many times to go back to 9.04, but I made an experiment: I formated the disk with EXT4 and made a clean install of 9.10. Now it works terrific. No crashed for now.

This problem doesn't occur with EXT4. At least, for now.

Could this be the problem (even doesn't seem possible)?

I use DELL Inspiron laptop.

Nope, EXT4 has nothing to do with it. I'm using ext4 since the 9.04 and Rhythmbox wasn't crashing untill I upgraded to 9.10 via update-manger. And as I wrote in bug, which seems to be closed as duplicate, for me this happens on tracks with replay-gain info only.

same here, please fix it soon

I can't believe, How can that error get to Ubuntu?

Michalxo (michalxo) wrote :

Still in.. :-( Managed to catch it here -> http://www.mediafire.com/?ymmkmvmzyi0 :-(

Dirk Mcbratney (djmcbratney) wrote :

An odd observation - I removed a seemingly rather buggy little package called ledcontrol, which allows for cosmetic uses for the keyboard LEDs, and a couple of virtual keyboard apps (klavier and something I don't recall) and this problem went away. The bug was consistently repeatable for me until I did this.

James Blackwell (jblack) wrote :

@Dirk I believe that's coincidence. I have never had ledcontrol and I still get crashes when adjusting the rhythmbox volume.

fastness (godjesusheaven) wrote :

same here, crashed randomly when adjusting the rhythmbox volume.

MoarningSun (slowinthedark) wrote :

same problem here, reproducible by changing the volume, also on Karmic

Bogdan (bogdan-veringioiu) wrote :

just discovered the bug, very annoying.
hope that it will be fixed.
thanks

Mike Morraye (mike-morraye-be) wrote :

Looks like it's not on all songs/files.
I had it on a 128 kbps .mp3 file from 5MB size.
I'm not sure if this helps a lot.
If it does, you can ask me to test more different filetypes/sizes/bitrates etc...
Detailed information added trough apport.

Mike Morraye (mike-morraye-be) wrote :

Only encountered during lowering down volume, not on turning it up till now...

scottuss (scottuss) wrote :

Seems to do the same in Banshee. I'm suspecting it's something to do with either PulseAudio or some other common sound component?

affects: rhythmbox (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer0.10 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
bazmail (bazmail) wrote :

Affects me too. It repros every time. As Mike Morraye said above, only when lowering the volume.

It started happening after I opened Rhythmbox without mounting the NTFS volume that has all my music, so RB started to remove library items it could not locate on disk, i quickly mounted the volume to stop it emptying the library. Rhythmbox froze, crashed then the volume weirdness started during subsequent sessions. Might be coincidence.

This is still happening after upgrading from 9.10 to 10.04.

Marcelo (marceloramone-gmail) wrote :

Yes, is impossible edit the tags....

2010/5/1 cjlindem <email address hidden>

> This is still happening after upgrading from 9.10 to 10.04.
>
> --
> rhythmbox crashed with SIGSEGV in g_object_set()
> https://bugs.launchpad.net/bugs/455421
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
http://en.windows7sins.org/

Adam Hallgat (hallgat) wrote :

I tried it with mp3 on ntfs,
mp3 on ext
with LastFM plugin,
The same crash every time.

kyleabaker (kyleabaker) wrote :

Also affects Rhythmbox 0.12.8 in Ubuntu 10.10 (x86_64).

Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Fix Released
Phil Ayres (ayres-phil) wrote :

I see a similar issue in Lucid, up to date as of yesterday's updates.

In syslog I see this at the time of the crash. I included the pulseaudio ratelimit message just before, in case it is relevant.

Jul 28 12:28:51 consected-sv1-001 pulseaudio[1670]: ratelimit.c: 130 events suppressed
Jul 28 12:29:17 consected-sv1-001 kernel: [15882.976141] __ratelimit: 6 callbacks suppressed
Jul 28 12:29:17 consected-sv1-001 kernel: [15882.976155] rhythmbox[30966]: segfault at 0 ip (null) sp b233e16c error 4 in libgdk-x11-2.0.so.0.2000.1[110000+93000]

One thing I observed is this seems to happen more often if I change the volume soon after opening Rhythmbox and just after starting to play a track. Perhaps it doesn't like a change in volume at the same time a lot of other things are going on, such as trying to get a bunch of data streamed.

Phil

Jens Janssen (jayjay) wrote :

The bug is still present in Lucid. As Phil Ayres describes you can easily trigger the bug by changing the volume soon after switching to another track. I use my scroll wheel to change the volume if that matters.

Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.