Comment 9 for bug 1017486

Iain Lane (laney) wrote :

This bug was fixed in the package tulip - 3.7.0dfsg-4

---------------
tulip (3.7.0dfsg-4) unstable; urgency=low

  * Completely disable crash handler on archs other than i386 and amd64,
    it currenty requires explicit knowledge of the architecture's
    instruction pointer (<sigh> should have read upstream code at first...).

 -- Yann Dirson <email address hidden> Sat, 19 May 2012 14:07:32 +0200

tulip (3.7.0dfsg-3) unstable; urgency=low

  * Replace all remaining uses of __linux and __linux__ by __unix__.
  * Restrict binutils-dev build-depend any-i386 and any-amd64 instead of
    using negation (which did not appear to work for any reason ?).
  * Add license paragraph for "Files: *" (lintian).

 -- Yann Dirson <email address hidden> Sat, 19 May 2012 10:32:50 +0200

tulip (3.7.0dfsg-2) unstable; urgency=low

  * Restrict binutils-dev build-depend to exclude archs with cpus
    not supported by the "detailed stack traces" feature.
  * Check for __unix__ instead of __linux, so the "detailed stack traces"
    feature will work on non-linux archs.

 -- Yann Dirson <email address hidden> Fri, 18 May 2012 15:26:14 +0200

tulip (3.7.0dfsg-1) unstable; urgency=low

  * New upstream release:
    * drop patches included or superceded upstream:
      * "Make gzstream library name tunable as GZStreamLibrary"
      * "Use system FTGL, not the one shipped in thirtparty/"
      * "Rename gzstream library to gzstreamtlp-3.6"
      * "Rename libOGDF.so to libOGDFtlp-3.6.so"
    * Refreshed remaining patches:
      * Factored out references to doc-building jars in cmake files
      * Comment out INSTALL_RPATH flag on executables.
      * Disable python binding.
      * Use Debian-packaged jars.
      * Fix FTBFS with GCC 4.7.
    * Set the UBUNTU_PPA_BUILD cmake flag to benefit from this work.
    * Updated package names for new version and new lib names.
    * Builds and installs docs when using -DBUILD_DOC=ON.
  * Acknowledge NMU, sync with work done in parallel on the package:
    * Don't call dh_auto_build for arch-indep which do not need it
    * Remove -a and -i flags from calls where dh already adds them.
  * Separate shlib version with a dash in 3rdparty libs, so parsing the
    soname will correctly identify the version (thanks lintian...).
  * Move online help from tulip-doc into new tulip-help package, and let
    tulip recommend it.
  * Build-depend on binutils-dev to benefit from detailed stack traces on crash.
  * Use bash for tulip-config script with bashism (Closes: #530127).
  * When making docs, move expansion of the "doc-*" pattern from the shell
    up to make, so log failures on buildd can give meaningful information.
  * Updated debian/README.maint, to reflect the use of a collab-maint git repo.
  * Added Vcs-git and Vcs-browser control fields.
  * Declare "dfsg" version mangling in debian/watch (lintian).
  * Fixed continuation lines in debian/copyright (lintian).
  * Added GPL2 license paragraph for the (unused) ftgl subtree (lintian).
  * Bumped Standards-Version to 3.9.3, no other change.

 -- Yann Dirson <email address hidden> Sat, 12 May 2012 11:18:11 +0200

tulip (3.6.0dfsg-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix debian/rules, so the package compiles on the buildds. Closes: #650653.
  * Add gcc4.7_ftbfs patch to fix FTBFS with GCC 4.7. Closes: #667401.
  * Update Build-Depends on libpng-dev. Closes: #662526.
  * Bump debhelper Build-Depends to >= 9, as recommended by lintian.

 -- Regis Boudin <email address hidden> Mon, 23 Apr 2012 22:52:11 +0200

tulip (3.6.0dfsg-2) unstable; urgency=low

  * Don't build docs for tulip-doc from build-arch, move java packages,
    docbook-xsl and doxygen to Build-Depend-Indep (where default-jre-headless
    was, already). Closes: #639313. Uses debhelper compat level 9 for this,
    but for unknown reason so we do not get multiarch paths.
  * Drop apparently-useless build-dep on texlive-extra-utils (Closes:
    #616282).
  * Cleanup: merge the 2 gzstream-related patches in debian/patches, since
    the second one was obsoleting the first one.
  * Drop long-useless build-dep on sharutils.
  * Remove docs/doxygen/xml on clean.

 -- Yann Dirson <email address hidden> Fri, 09 Sep 2011 22:58:34 +0200

tulip (3.6.0dfsg-1) unstable; urgency=low

  * New upstream release (Closes: #617602).
   * Upstream changed build system to cmake, dropping all previous patches.
     Closes: #407855, #559083, #633269 (not applicable any more).
   * Builds correctly with g++-4.5 (Closes: #615687).
   * Deactivate tlprender package, it is neither built nor buildable
     any more. Drop build-dep on libosmesa6-dev.
  * Noted REJECT in previous changelog entry.
  * Converted debian/copyright to DEP-5.
  * Regenerated upstream tarball as tar.bz2 after removing:
    * thirdparty/libgpugraph/: no license, unused upstream
    * thirdparty/{saxon,xml-commons}/: jars only, use debs instead
    * thirdparty/ftgl/: use debs instead
    * thirdparty/{QScintilla-gpl-2.4.6,sip-4.12.1}/: unused for now, see below
  * Kept DEP-5 entries for removed dirs in debian/copyright.nuked
  * Update debian/watch for new upstream naming scheme.
  * Switched build-dep from libjpeg62-dev to libjpeg-dev (Closes:
    #634636).
  * Switched build-dep from libgl1-mesa-swx11-dev to libgl1-mesa-dev |
    libgl-dev (Closes: #560012, #638169).
  * Disable thirdparty/ftgl directory and point to system one.
  * Changed libOGDF lib name to OGDFtlp-3.6. Ideally we should rely on a
    standalone package for this, but OGDF upstream only build static libs
    anyway, so thirdparty/OGDF is as close to a usable shared lib as we
    can get, I guess... Create new binary package for it.
  * Make the name of the gzstream library tunable via cmake variable.
  * Change libgzstream name to libgzstreamtlp-3.6. Create new binary package
    for it.
  * Disable the python stuff for now even if it would be normally
    activated, it is even more work to get it right. Will need build-dep
    on at least python-dev, python-sphinx, python-sip-dev,
    python-qscintilla2 when we want to do that.
  * Comment out INSTALL_RPATH flag on executables. Call cmake with
    -DCMAKE_SKIP_RPATH:BOOL=YES.
  * Factored out references to doc-building jars in cmake files.
  * Use Debian-povided versions of doc-building jars, build-depend on
    libsaxon-java, libxml-commons-resolver1.1-java.

  * Switched to "dh", set compat level to 8.
  * Merge all -dev packages into tulip-dev for packaging convenience.
  * Fix typo in changelog (lintian).
  * Bumped Standards-Version to 3.9.1, no change.

 -- Yann Dirson <email address hidden> Thu, 25 Aug 2011 02:19:48 +0200

tulip (3.3.1-1) unstable; urgency=low

  * (rejected by ftpmaster because of thirdparty/*).
  * New upstream release.
  * Acknowledge NMUs.
  * Change lib package names to *-3.3.
  * Fixed patch for docbook-xsl catalog: move -D flags before the class
    name, so that also works when sun's jre is the default.
  * Dropped unneeded patches:
    * missing headers for gcc4.4
    * xml markup improvements
  * Regenerated autotools files, this time using autoconf2.59 to match
    upstream.
  * Use packaged ftgl instead of in-source one.
  * Capitalize doc-base section (lintian).
  * Bumped Standards-Version to 3.8.4, no change.

 -- Yann Dirson <email address hidden> Tue, 29 Jun 2010 22:13:47 +0200