[MASTER] Apps using gstreamer0.10 do not support all available formats because gstreamer0.10-ffmpeg was removed

Bug #1275556 reported by Lonnie Lee Best
516
This bug affects 122 people
Affects Status Importance Assigned to Milestone
WebcamStudio
Fix Released
High
Karl Ellis
gstreamer0.10-ffmpeg (Ubuntu)
Medium
Unassigned

Bug Description

gstreamer0.10-ffmpeg was removed from the Trusty repositories because of bug 1253071. Apps still using gstreamer0.10 now have no ffmpeg/libav support.

[WORKAROUND For Trusty/14.04]
http://www.webupd8.org/2014/03/get-firefox-and-phonon-gstreamer-to.html

tags: added: needs-packaging trusty
description: updated
Revision history for this message
Thaddaeus Tintenfisch (thad-fisch-deactivatedaccount) wrote :
Revision history for this message
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Package 'gstreamer0.10-ffmpeg' has no installation candidate
+ [needs-packaging] Package 'gstreamer0.10-ffmpeg' has no installation
+ candidate
Changed in gstreamer0.10-ffmpeg (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: [needs-packaging] Package 'gstreamer0.10-ffmpeg' has no installation candidate

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Confirmed
Revision history for this message
Roman (m01brv) wrote :

Without this package Amarok does not play WMA files, and it cannot find a sutable plugin to install.

Revision history for this message
Roman (m01brv) wrote :

(I mean in Ubuntu 14.04)

Revision history for this message
Vasco Alves (vascofalves) wrote :

Without this package, KDE apps won't play any h264 videos (as long as you're using the phonon gstreamer backend, and not the vlc one, but the former is the default). Firefox won't either, so yeah, this is kind of important to have back by release time. Could you not build the version of ffmpeg/libav bundled with the gst-ffmpeg source, and statically link it?

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

AFAIK Firefox is able to use GStreamer 1.0 upstream (prooflink: https://bugzilla.mozilla.org/show_bug.cgi?id=806917) so Ubuntu Mozilla team should just complie it against 1.0 and not 0.10 which is no longer supported by GStreamer developers.

Revision history for this message
David F. (malteworld) wrote :

But it's only fixed in trunk and they don't want to backport it.

Revision history for this message
Roman (m01brv) wrote :

See also bug 1293413

Revision history for this message
Stefan Metzmacher (metze) wrote :

Why is the importance = Wishlist?

This package is available in 12.04, I think it's a regression that it will be missing in 14.04!

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

gstreamer0.10-ffmpeg package for Ubuntu 14.04 is available at this repository:
ppa:mc3man/trusty-media
 but it seems some apps crashes if this gstreamer0.10-ffmpeg package is installed, see http://webupd8.org/2014/03/get-firefox-and-phonon-gstreamer-to.html#comment-1308764844
 Musictube crashes with that package installed, and so does Pitivi too :-(

Revision history for this message
Simon Eisenmann (longsleep) wrote :

Well imho it is an absolute no go that Ubuntu 14.04 should have no playback support of H.264 content. This should work out of the box and is a major problem which will prevent people to switch. It really should be able to play back H.264 and HEVC content - hey its 2014.

Revision history for this message
Karl Ellis (soylent-tv) wrote :

Hi, I am a contributor to a java project that use gstreamer backend ...
The gstreamer0.10-ffmpeg is very important for us, please fix this.
Thanks.

Revision history for this message
Karl Ellis (soylent-tv) wrote :

In WebcamStudio Project I can't use gstreamer 1.x backends because is too heavy for slower machines ... gstreamer 0.10 is much more stable and needs less resources yet. I will be very happy to use 1.x version in our project, and i also implemented it for use, but i truly find that 0.10 is better.
If you need, I can send tests for cpu usage about what I'm saying.
Anyway, always Thanks for gstreamer project.
karl.

Changed in webcamstudio:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Karl Ellis (soylent-tv)
Revision history for this message
Karl Ellis (soylent-tv) wrote :

Just passed to gst-launch-1.0 with the use of Gnonlin 1.x to playback h264 media. Anyway Gnonlin 1.2 gnlfilesource is missed (I used gnlurisource instead) and the overall WebcamStudio Performance were affected. Also with gst-launch-1.0 I experienced Audio/Video out of sync issues. I'm working on it.

Changed in webcamstudio:
status: Confirmed → In Progress
Revision history for this message
Karl Ellis (soylent-tv) wrote :

Fixed in WebcamStudio build 538 using gst-launch-1.0 to playback h264 media.

Changed in webcamstudio:
status: In Progress → Fix Released
Revision history for this message
Joey Chan (qqworini) wrote :

Everyone knows that now Qt5 is the primary development env in Ubuntu, but Qt5 is using this(ffmpeg-plugin) for video playback, without this plugin, all videos failed to play in Qt5.

PLS get it back !!!

summary: - [needs-packaging] Package 'gstreamer0.10-ffmpeg' has no installation
- candidate
+ [MASTER] Apps using gstreamer0.10 do not support all available formats
+ because gstreamer0.10-ffmpeg was removed
description: updated
Revision history for this message
Daniel Letzeisen (dtl131) wrote :

The bug was automatically marked 'Wishlist' because of the needs-packaging tag. Changing to Medium for now (though in all likelihood, it is a 'Won't Fix' issue and users will have to use a PPA).

tags: removed: needs-packaging
Changed in gstreamer0.10-ffmpeg (Ubuntu):
importance: Wishlist → Medium
status: Confirmed → Triaged
Revision history for this message
mlissner (mlissner-michaeljaylissner) wrote :

@Daniel, but the problem is I *really* don't want a bunch of random PPAs. How can I possibly know who is even putting the code in there? I want centralized security, not randomized PPAs. Seriously, this isn't a tenable solution if Ubuntu takes itself seriously.

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

Ubuntu can't package every last piece of software (just like Microsoft and Apple). PPA's are sometimes unavoidable if you want to use software not in the repos.

The solution to the issue is for programs to move to gstreamer1.0. Firefox 30 now supports gstreamer1.0 and phonon/KDE does as well.

Revision history for this message
Yves Dorfsman (dorfsmay) wrote :

I think the issue is that the default Ubuntu 14.04 install is not installing a couple of gstreamer packages. I have added these three packages and am now able to watch H.264 (so I can now watch Vimeo for example):

gstreamer1.0-libav
gstreamer1.0-plugins-ugly
gstreamer1.0-tools

Could those be added to the default Ubuntu workstation install?

Revision history for this message
Sezer Yalcin (sy-y) wrote :

Arista can't convert due to this bug.

Revision history for this message
Herminio (herminio-hernandezjr) wrote :

I am running to alot of video playback issues in vlc and mplayer. I have placed bug reports on them but I am wondering if this issue is part of the problem.

Revision history for this message
Karl-Philipp Richter (krichter722) wrote :

Workaround on 15.04: `gstreamer0.10-ffmpeg` is provided by PPA `ppa:mc3man/gstffmpeg-keep`.

Revision history for this message
Marcos Alano (mhalano) wrote :

This bug still occurs on Xenial, Yakkety?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions