Fails to associate decoder-video/x-ms-asf with gstreamer1.0-plugins-ugly

Bug #1723599 reported by Doug McMahon on 2017-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gst-plugins-ugly1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Test case:
With gstreamer1.0-plugins-ugly not installed try to play a .wmv with totem

What happens:
Prompt to find in software opens, clicking on opens Software with no results
What should happen: Software should show the gstreamer1.0-plugins-ugly package as suitable to afford decoding.

From terminal
totem /home/doug/Videos/Amazon_720.wmv
** Message: Missing plugin: gstreamer|1.0|totem|Advanced Streaming Format (ASF) demuxer|decoder-video/x-ms-asf (Advanced Streaming Format (ASF) demuxer)
** Message: PackageKit: xid = 37748757
** Message: PackageKit: desktop_id = org.gnome.Totem.desktop
** Message: PackageKit: Codec nice name: Advanced Streaming Format (ASF) demuxer
** Message: PackageKit: structure: gstreamer1(decoder-video/x-ms-asf)()(64bit)

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gstreamer1.0-packagekit 1.1.7-1
ProcVersionSignature: Ubuntu 4.13.0-15.16-generic 4.13.4
Uname: Linux 4.13.0-15-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Oct 14 08:05:42 2017
InstallationDate: Installed on 2017-10-06 (8 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20171004)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: packagekit
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Jeremy Bicha (jbicha) on 2017-10-14
affects: packagekit (Ubuntu) → gst-plugins-ugly1.0 (Ubuntu)
tags: added: rls-aa-incoming
Doug McMahon (mc3man) wrote :

The ugly plugin package shows proper info. Is it possible in the past sessioninstaller fell back to package info where packagekit isn't doing that? If that's the case then why wouldn't this be packagekit's issue?

apt-cache show gstreamer1.0-plugins-ugly
......
Gstreamer-Decoders: application/vnd.rn-realmedia; application/x-pn-realaudio; application/x-rdt, media=(string)application, encoding-name=(string)X-REAL-RDT; application/x-rtp, media=(string){ application, video, audio }, payload=(int)[ 96, 127 ], encoding-name=(string)X-ASF-PF; audio/AMR; audio/AMR-WB; audio/ac3; audio/mpeg, mpegversion=(int)1, layer=(int)[ 1, 3 ], parsed=(boolean)true; audio/x-ac3; audio/x-lpcm; audio/x-private1-ac3; audio/x-private1-lpcm; audio/x-private2-lpcm; audio/x-sid; video/mpeg, mpegversion=(int)[ 1, 2 ], systemstream=(boolean)false; video/x-ms-asf
Gstreamer-Elements: a52dec, amrnbdec, amrnbenc, amrwbdec, asfdemux, cdiocddasrc, dvdlpcmdec, dvdreadsrc, dvdsubdec, dvdsubparse, lamemp3enc, mpeg2dec, mpg123audiodec, pnmsrc, rademux, rdtdepay, rdtmanager, rmdemux, rtpasfdepay, rtspreal, rtspwms, siddec, twolamemp2enc, x264enc, xingmux

Will Cooke (willcooke) on 2017-10-17
tags: added: rls-aa-notfixing
removed: rls-aa-incoming
tags: added: rls-aa-incoming
removed: rls-aa-notfixing
tags: added: rls-aa-notfixing
removed: rls-aa-incoming
Doug McMahon (mc3man) wrote :

Still an issue in 18.04, also affects .swf

tags: added: bionic
removed: rls-aa-notfixing
Doug McMahon (mc3man) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers