Easy codec installation is not working

Bug #412927 reported by Dave Morley on 2009-08-13
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
bluez (Ubuntu)
High
Sebastien Bacher
Karmic
High
Sebastien Bacher
gst-plugins-base0.10 (Ubuntu)
High
Ubuntu Desktop Bugs
Karmic
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

Totem's easy codec installer seems to nolonger function.

Steps to reproduce:

Open totem
click on the drop down box called playlist
Select the bbc plugin from the dropdown menu
select any track (they are all mp3)

See the dialog box that reads:
An error occurred
Internal data flow error.

Expected behaviour:
You expect easy codec installer to appear saying you need this codec to play this feed

ProblemType: Bug
Architecture: amd64
Date: Thu Aug 13 10:34:18 2009
DistroRelease: Ubuntu 9.10
LogAlsaMixer:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [off]
Package: totem 2.27.2-0ubuntu3
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: totem
Uname: Linux 2.6.31-5-generic x86_64

Dave Morley (davmor2) wrote :
Alex Lourie (alourie) on 2009-08-13
Changed in totem (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here:

summary: - Easy codec installer nolonger seems to function
+ Easy codec installation is not working
Changed in totem (Ubuntu Karmic):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=591677

Changed in totem:
status: Unknown → Incomplete
affects: totem (Ubuntu Karmic) → gst-plugins-base0.10 (Ubuntu Karmic)
affects: gst-plugins-base0.10 (Ubuntu Karmic) → totem (Ubuntu Karmic)
affects: totem (Ubuntu Karmic) → gst-plugins-base0.10 (Ubuntu Karmic)
Changed in totem:
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :

The bug has been fixed in git now

Changed in gst-plugins-base0.10 (Ubuntu Karmic):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The change will be uploaded to debian later or in karmic before the beta image

Martin Pitt (pitti) wrote :

Currently proposed patch causes regression. This apparently requires some major refactoring to get working again, setting back to triaged.

tags: added: regression-proposed
Changed in gst-plugins-base0.10 (Ubuntu Karmic):
status: Fix Committed → Triaged
Alejandro Vidal (mancvso) wrote :

Can a patch like looking in the extension of the file and see if the codec is installed work?

Is really simple, but could work.

Sebastien Bacher (seb128) wrote :

The gstreamer bug is fixed but bluez-gstreamer still breaks the codec installation

Changed in bluez (Ubuntu Karmic):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

slomo said that the bluez issue is that "a2dpsink should not have a rank>=marginal"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-base0.10 - 0.10.24.3-1ubuntu1

---------------
gst-plugins-base0.10 (0.10.24.3-1ubuntu1) karmic; urgency=low

  * debian/patches/91-decodebin2-Rewrite-autoplugging-and-how-groups-of-pa.patch
    debian/patches/92-uridecodebin-Don-t-post-missing-plugin-messages-twic.patch
    debian/patches/93-decodebin2-Make-sure-that-the-GstDecodePads-are-stil.patch
    - upstream change to the new decodebin which should fix easy codec
      installation and some other issues, the changes are not trivial though so
      require good testing before karmic (lp: #412927)

 -- Sebastien Bacher <email address hidden> Thu, 24 Sep 2009 16:45:49 +0200

Changed in gst-plugins-base0.10 (Ubuntu Karmic):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

superm also pointed that on irc "the sink was intentionally registered as marginal: http://git.kernel.org/?p=bluetooth/bluez.git;a=commit;h=013f56322de6ff5a974fed56c8aec56d3b69ef09"

Sebastien Bacher (seb128) wrote :

<slomo> seb128: iirc the problem was, that a2dpsink handles audio/mpeg... you have no mpeg decoder installed but there's a sink that supports it so no easy codec installation is needed. then that sink is tried to be used but it fails (because it's broken)
<slomo> seb128, asac, superm1: problem simply is, that a2dpsink can't be used without configuration (you need to set the device property of it before it works)

Changed in bluez (Ubuntu Karmic):
milestone: none → ubuntu-9.10-beta
milestone: ubuntu-9.10-beta → none
milestone: none → ubuntu-9.10
milestone: ubuntu-9.10 → ubuntu-9.10-beta
milestone: ubuntu-9.10-beta → ubuntu-9.10
milestone: ubuntu-9.10 → ubuntu-9.10-beta
milestone: ubuntu-9.10-beta → ubuntu-9.10
milestone: ubuntu-9.10 → ubuntu-9.10-beta
Sebastien Bacher (seb128) wrote :

I'm going to upload the change slomo suggested, has anybody contacts with bluez upstream to discuss it there?

Changed in bluez (Ubuntu Karmic):
status: Confirmed → Fix Committed
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.51-0ubuntu2

---------------
bluez (4.51-0ubuntu2) karmic; urgency=low

  * debian/patches/01_lower_sink_ranking.patch:
    - lower the gsta2dpsink ranking so it's not autoconfigured, right now it
      claims to handle mpeg but has no decoder for it which breaks easy codec
      installation, the sink cannot be used without configuring a device
      which means it doesn't need to be used by default, thanks slomo who
      looked at the issue and adviced about the change (lp: #412927)

 -- Sebastien Bacher <email address hidden> Thu, 24 Sep 2009 23:12:24 +0200

Changed in bluez (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.