grub-mount assert failure: *** glibc detected *** grub-mount: free(): corrupted unsorted chunks: 0x09530568 ***

Bug #756297 reported by Смирнов Александр Валериянович on 2011-04-10
304
This bug affects 40 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: grub2

Ubuntu Natty 11.04
grub2 1.99~rc1-10ubuntu1

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: grub-common 1.99~rc1-10ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
AssertionMessage: *** glibc detected *** grub-mount: free(): corrupted unsorted chunks: 0x09530568 ***
Date: Sun Apr 10 08:42:33 2011
ExecutablePath: /usr/bin/grub-mount
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110320)
ProcCmdline: grub-mount /dev/sda1 /var/lib/os-prober/mount
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF8
Signal: 6
SourcePackage: grub2
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: grub-mount assert failure: *** glibc detected *** grub-mount: free(): corrupted unsorted chunks: 0x09530568 ***
UpgradeStatus: Upgraded to natty on 2011-03-25 (15 days ago)
UserGroups:

Related branches

StacktraceTop:
 __kernel_vsyscall ()
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 __libc_message (do_abort=2, fmt=0x9d28ac "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<value optimized out>, str=<value optimized out>, ptr=0x9530568) at malloc.c:6283

Changed in grub2 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Colin Watson (cjwatson) wrote :

The retrace is incomplete for some reason, but the missing frames are:

  #7 grub_disk_read
  #8 grub_fat_read_data
  #9 grub_fat_read
  #10 grub_file_read

I'm not sure how illuminating that will be by itself, since it's malloc arena corruption so the symptom will probably be distant from the cause. I think this needs to be reproduced under valgrind somehow.

visibility: private → public
Colin Watson (cjwatson) wrote :

Is there any sensitive data on /dev/sda1? It's a FAT partition, so perhaps it's just a recovery partition or something? If it has no sensitive data and isn't too big, then perhaps we could have a copy of that filesystem to debug against? Ask me if you need help extracting that.

Jean-Baptiste Lallement (jibel) wrote :

Here is a dump of the partition table:
$ sudo sfdisk -d /dev/sda
# partition table of /dev/sda
unit: sectors

/dev/sda1 : start= 2048, size= 16384000, Id=1c
/dev/sda2 : start= 16386300, size= 11711385, Id=82
/dev/sda3 : start= 28097685, size=156248190, Id=83, bootable
/dev/sda4 : start=184345875, size=304046190, Id=83

I'll try to provide a dump of the partition but it's 8G

Jean-Baptiste Lallement (jibel) wrote :

I'm setting to confirmed. I can reproduce on another system with a FAT recovery partition and a Windows partition.
The compressed dump of the partition is 7.7GB. That's a bit heavy to upload it somewhere.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Unfortunately a filesystem dump is about the only way I'm going to be able to fix this. This is a slightly desperate option, but I don't suppose you could post me a DVD or something?

I am happy to send a DVD to you. Shall I install the Beta 2 first to
see if the bug is still there?
It is not available at the moment but should be later today.

Rod Jones

2011/4/13 Colin Watson <email address hidden>:
> Unfortunately a filesystem dump is about the only way I'm going to be
> able to fix this.  This is a slightly desperate option, but I don't
> suppose you could post me a DVD or something?
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (758378).
> https://bugs.launchpad.net/bugs/756297
>
> Title:
>  grub-mount assert failure: *** glibc detected *** grub-mount: free():
>  corrupted unsorted chunks: 0x09530568 ***
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/756297/+subscribe
>

--
Roderic Jones

Trout Cottage
Llanvihangel Crucorney
Abergavenny
Monmouthshire
NP7 7NB

Telephone 01873 890050

Colin Watson (cjwatson) wrote :

Jean-Baptiste gave me remote access to his system, and I've found and fixed the bug. It'll be in my next upload.

Colin Watson (cjwatson) on 2011-04-14
Changed in grub2 (Ubuntu):
status: Confirmed → Fix Committed
tags: added: bugpattern-needed
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99~rc1-13ubuntu1

---------------
grub2 (1.99~rc1-13ubuntu1) natty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Adjust for default Ubuntu boot options ("quiet splash").
    - Default to hiding the menu; holding down Shift at boot will show it.
    - Set a monochromatic theme and an aubergine background for Ubuntu.
    - Apply Ubuntu GRUB Legacy changes to legacy update-grub script.
    - Fix backslash-escaping in merge_debconf_into_conf.
    - Remove "GNU/Linux" from default distributor string.
    - Add crashkernel option.
    - Bypass menu unless other OSes are installed or Shift is pressed.
    - Allow Shift to interrupt 'sleep --interruptible'.
    - Reduce visual clutter in normal mode.
    - Remove verbose messages printed before reading configuration.
    - Suppress kernel/initrd progress messages, except in recovery mode.
    - Handle filesystems loop-mounted on file images.
    - Ignore devices loop-mounted from files in Linux grub.d scripts.
    - Show the boot menu if the previous boot failed.
    - Don't generate device.map during grub-install or grub-mkconfig.
    - Adjust upgrade version checks for Ubuntu.
    - Suppress "GRUB loading" message unless Shift is held down.
    - Adjust versions of grub-doc and grub-legacy-doc conflicts.
    - Fix LVM/RAID probing in the absence of /boot/grub/device.map.
    - Look for .mo files in /usr/share/locale-langpack first.
    - Build-depend on qemu-kvm rather than qemu-system for grub-pc tests.
    - Add a grub-rescue-efi-amd64 package.
    - On Wubi, just update wubildr rather than asking for an install device.
    - Check hardware support before using gfxpayload=keep.
    - Put second and subsequent Linux menu entries in a submenu.
    - Preferred resolution detection for VBE.
    - Set vt.handoff=7 for smooth handoff to kernel graphical mode.
    - Add grub-mount-udeb, containing just grub-mount.
  * Use /lib/plymouth/themes/default.grub if it exists, rather than
    hardcoding an aubergine background (LP: #696915).

grub2 (1.99~rc1-13) unstable; urgency=low

  * Cherry-pick from upstream:
    - Use correct limits for mips initrd.
  * Run grub-install on install or upgrade of grub-yeeloong.
  * Update branch_fuse.patch:
    - Tell FUSE to run single-threaded, since GRUB code is not thread-safe
      (LP: #756297).
 -- Colin Watson <email address hidden> Fri, 15 Apr 2011 14:37:43 +0100

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.