Comment 8 for bug 718670

It is not needed to set again the user's passwords. The workaround works simply defining 'superusers' variable into submenus.

Example:

submenu "Previous Linux versions" {
set superusers='xxuser_namexx'
menuentry 'Ubuntu, mit Linux 2.6.37-12-generic' --class ubuntu --class gnu-linux --class gnu --class os {
...