Countdown not displayed when GRUB_HIDDEN_TIMEOUT_QUIET is set to false

Bug #647250 reported by Twisted Lincoln, Inc. on 2010-09-25
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

Setting a numerical value for GRUB_HIDDEN_TIMEOUT in /etc/default/grub properly sets a delay during boot that allows the user to press "shift" to display the Grub menu. However setting GRUB_HIDDEN_TIMEOUT_QUIET=false no longer displays a countdown during this delay period.

Running "sudo update-grub" as indicated after changing the /etc/default/grub has no effect -- the countdown is still not displayed.

This feature worked just fine on Karmic, but appears broken on Lucid.

This bug ist still present in Maverick. I had a workaround for Lucid (see attached file, just put it in /etc/grub.d/ and make it executable), but this doesn't seem to work on Maverick any more. Does anyone else have any idea how to fix this?

drs305 (drs305) wrote :

Still broken in Maverick as far as I can determine.

drs305 (drs305) wrote :

This bug still exists in 1.99RC.

The countdown timer will not display even when the setting value is set to 'false'.

I have completely purged/reinstalled Grub 1.99RC and the setting still does not work.

I just did a clean install of grub (the version in natty) to an empty partition using grub-install and manually created grub.cfg and there the timeout works fine.

I just copied the part generated by 01_hidden_timeout from the old to the new grub.cfg and left out everything generated by 00_header, so I think the reason why my fix from comment #1 didn't work any more has to do with the output of that file. Maybe someone else can try this out and help me narrow it down further.

Peter Selinger (selinger) wrote :

In case you are using the textual boot screen (i.e., with GRUB_TERMINAL=console), the flag GRUB_HIDDEN_TIMEOUT_QUIET apparently has no effect. Instead, you should uncomment "hiddenmenu" in /boot/grub/menu.lst.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed

This is happening to e since I had to change GRUB_HIDDEN_TIMEOUT=0 to #GRUB_HIDDEN_TIMEOUT=0; from this I could not correct more anything once that my next line is correct GRUB_HIDDEN_TIMEOUT_QUIET=true as also the others...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers