Ubuntu

grub does not appear to load after maverick post-beta install

Reported by Ronald McCollam on 2010-09-17
82
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
grub2 (Ubuntu)
Critical
Colin Watson
Maverick
Critical
Colin Watson

Bug Description

Binary package hint: grub2

On some server hardware, grub does not load upon reboot after installing. There is no message indicating that grub is loading, nor does holding shift have any effect. The firmware and BIOS are completely up to date and the system works properly under 10.04 LTS.

I will attach system information from a 10.04 LTS install for an affected system for reference. This may be related to bug 630586 -- I will attempt an install of maverick followed by a side-by-side install of 10.04 LTS and see if I can boot to maverick after that.

Related branches

Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ameet Paranjape (ameetp) wrote :

Ronald,

Is this a PXE boot install? See bug 625383 if it is.

>I will attempt an install of maverick followed by a side-by-side install of 10.04 LTS and
>see if I can boot to maverick after that.

Sounds good. Please update the bug with your findings.

Changed in grub2 (Ubuntu):
status: New → Incomplete
Thierry Carrez (ttx) on 2010-09-17
tags: added: server-mro
Ronald McCollam (fader) wrote :

Ameet,

This system was installed via PXE, but this bug doesn't come into play until attempting to boot from the local disk after install. So PXE should not be a factor here.

Per cjwatson's request, I tried changing grub options (removing the GRUB_HIDDEN_TIMEOUT options from /etc/default/grub and removing the 30_os-prober section from the grub config) but these had no effect.

However, performing a side-by-side install of 10.04 LTS on this system allows it to load grub and boot into maverick normally.

I will attach the various relevant logs from the maverick install to this bug.

Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ronald McCollam (fader) wrote :
Ameet Paranjape (ameetp) wrote :

Marking as Critical since this is affecting a number of systems.

Changed in grub2 (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Critical
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Ameet Paranjape (ameetp) wrote :

Ronald,

Could you try "grub-install --debug-image=all" to maybe pull a bit more information.

Changed in grub2 (Ubuntu Maverick):
status: Triaged → Incomplete
Ronald McCollam (fader) wrote :

I ran this after booting into maverick from the grub installed during the 10.04 LTS install.

This produces the following:

ubuntu@ubuntu:~$ sudo grub-install --debug-image=all /dev/cciss/c0d0
Installation finished. No error reported.

Booting into maverick after this was run worked successfully. A script log of the boot process is attached.

Ameet Paranjape (ameetp) on 2010-09-17
Changed in grub2 (Ubuntu Maverick):
status: Incomplete → Triaged
Robbie Williamson (robbiew) wrote :

I don't believe we can fix this in time for the release, especially given that Colin would need to be in physical contact with the hardware to make any significant progress in the short time between now and the RC. Does IBM have anyone within the LTC who can do some debugging on this. If they can find the problem and propose a possible solution, then we *might* have a chance of making 10.10.

Changed in grub2 (Ubuntu Maverick):
milestone: none → maverick-updates
Ameet Paranjape (ameetp) wrote :

Working to contact external developers who can physically access affected hardware for debug assistance.

It breaks on the Vaio P (1st gen) if that helps... if someone in the Boston
area is working on it, I can make some arrangement. (The workaround works
for me, and if there are useful grub diags or alternative versions, I can
try...)
On Sep 20, 2010 11:56 AM, "Robbie Williamson" <
<email address hidden>> wrote:

> I don't believe we can fix this in time for the release, especially
> given that Colin would need to be in physical contact with the hardware
> to make any significant progress in the short time between now and the
> RC. Does IBM have anyone within the LTC who can do some debugging on
> this. If they can find the problem and propose a possible solution,
> then we *might* have a chance of making 10.10.
>
> ** Changed in: grub2 (Ubuntu Maverick)
> Milestone: None => maverick-updates
>
> --
> grub does not appear to load after maverick post-beta install
> https://bugs.launchpad.net/bugs/641259
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On Mon, Sep 20, 2010 at 07:45:13PM -0000, Mark Eichin wrote:
> It breaks on the Vaio P (1st gen) if that helps... if someone in the Boston
> area is working on it, I can make some arrangement. (The workaround works
> for me, and if there are useful grub diags or alternative versions, I can
> try...)

Which workaround was that? If you mean running 'grub-install
--debug-image=all', then the thing is that that was actually meant to be
a diagnostic tool ...

(I'm in the UK, and I don't think we have any GRUB experts in the US
right now.)

SaskiaP (saskia-ploeg) wrote :

Had the exact same problem on a MSI S420 laptop, after installing alsa 2.6.35 through the synaptic package manager: No grub, had to load from a live cd.
Thats why I added that it affected my system. do not know much abut bug reprorts sorry if I screw things up..

Ameet Paranjape (ameetp) wrote :

I'm removing the duplicate because bug 641161 is reported against Ubiquity instead of grub. There is not enough information to determine if the root cause of both bugs are the same at this time.

Changed in ubuntu-release-notes:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Mark Eichin (eichin-gmail) wrote :

@cjwatson the "workaround" was the one @fader suggested at #8 -- install 10.04.1 on another partition, let *it* install grub (the Lucid grub, in this case) and autodetect the other partitions (including the Maverick one) - that grub boots just fine, and you can manually select the 10.10 install instead of the 10.04.1 one, and it comes up just fine. That's probably why people are calling it a clear regression - because the Lucid one still works fine with everything else Maverick (the bug *could* be more subtle than that, of course.)

Colin Watson (cjwatson) wrote :

Marjo Mercado has a machine which fails in a similar way. It's hard to say whether it's the same bug, given the general lack of debug output, but it's possible. We're both going to be at the Ubuntu 10.10 release sprint from next Wednesday, and I'll have a look at it first thing on Wednesday morning. This will be skating very close to the edge of our release schedule, so I don't know if I'll be able to get a fix into 10.10 for release day, but I'll do my best; if not, I'll publish an update ASAP after release (always assuming that his machine is in fact suffering from the same bug).

Changed in grub2 (Ubuntu Maverick):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)

Ronald McCollam's workaround worked for me.
1. Install 10.04 LTS in side-by-side mode, letting it resize the disk
2. Reboot
3. Select the maverick install in the grub loader

Now boots fine into Maverick.

System is an Acer Aspire One ZA3
A0751h-1522
Maverick ISO image used: http://cdimage.ubuntu.com/daily/20100928.1/maverick-alternate-i386.iso

hewbert (josh-hewbert) wrote :

FWIW, I'm seeing this on an Acer AS1410 as well.

Miguel Rodríguez (migrax) wrote :

As the old grub package works good with this systems, maybe it should be mentioned in the release notes that installing it before the update can prevent this bug from happening.

Mark Eichin (eichin-gmail) wrote :

@migrax what you suggest isn't actually what we're doing - we're installing Lucid itself on a partition. Simpler things like booting a lucid live CD and just telling it to grub-install onto the maverick partition *don't* work (probably because some part of what that does actually comes from the target disk.)

When I tried this, none of the boot-from-memory-stick Maverick installs worked at all on the Vaio P (the Lucid ones worked fine, but the Maverick ones all failed to find the stick they were booted from) so I don't have a fast way of cycling through versions... otherwise, divide-and-conquer on the grub package history might be worth doing (and not actually need grub experience.) Hmm, maybe booting a Lucid stick and grub-install'ing the extra *lucid* partition might work, I'll give that a poke if this doesn't get anywhere...

Miguel Rodríguez (migrax) wrote :

@Mark, I posted my comment as a suggestion to improve the release notes so as people with affected computers can downgrade grub-pc to grub *before* updating to maverick, so that they are not affected by the bug.

In any case, you can fix your installation using the lucid alternate image, select recover system and run a shell in the maverick installation. From that shell you can replace grub-pc with grub. Then you exit the shell and select "install boot manager" (or something like that) in the menu. Not simple for the average user, but it is faster than installing lucid in the disk again.

HTH.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98+20100804-5ubuntu3

---------------
grub2 (1.98+20100804-5ubuntu3) maverick; urgency=low

  * Improve message if too many embedding area sectors need to be avoided
    (thanks, Vladimir Serbinenko).
  * Expand on "sector already in use" message to note that the software in
    question may cause other problems and suggest reporting a bug (thanks,
    Vladimir Serbinenko).
  * Disable video_bochs and video_cirrus on PC BIOS systems, as probing PCI
    space seems to break on some systems (LP: #641259).
 -- Colin Watson <email address hidden> Wed, 06 Oct 2010 11:55:58 +0100

Changed in grub2 (Ubuntu Maverick):
status: Triaged → Fix Released

grub2 - 1.98+20100804-5ubuntu3 fixed my netbook installation problem report on 2010-09-30.

Mark Eichin (eichin-gmail) wrote :

I can confirm that grub2 1.98+20100804-5ubuntu3 fixes the original problem on the Sony Vaio P as well (and I got it directly via "aptitude safe-upgrade", if you needed evidence that it's percolated through to the release repos.) Terrific, thanks!

Colin Watson (cjwatson) on 2010-10-08
Changed in ubuntu-release-notes:
assignee: Canonical Foundations Team (canonical-foundations) → nobody
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers