Ubuntu

grub fails after running Windows

Reported by JohnL on 2009-10-04
382
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
grub
New
Undecided
Unassigned
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
High
Colin Watson
Nominated for Karmic by Filippo De Luca
Lucid
Undecided
Unassigned
Maverick
High
Colin Watson

Bug Description

Ubuntu 9.10 beta
Grub

After installing 9.10 beta, machine displays GRUB screen and allows rebooting into either Ubuntu or Windows.
Both Windows and Ubuntu will load and run BUT, once you log out of windows, grub fails with only one line of text displayed - something like Loading GRUB. Computer is unusable - can't even Control-Alt-Delete. Must turn off and reinstall ubuntu.

Usual method to restore GRUB is to run from the CD and fix grub from a terminal. This doesn't work in 9.10 with message "grub not installed"

Mansour (oxplot) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in grub2.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → grub2 (Ubuntu)
Felix Zielcke (fzielcke) wrote :

To reinstall GRUB 2 from a Live cd see this guide: http://grub.enbug.org/Grub2LiveCdInstallGuide

Seems like something in your Windows is overwriting the embeding area.
The only workaround for this, which isn't recommended, would be to install GRUB 2 to a bootsector and use some MBR code which doestn't use the embed area, like Microsoft's or the one from the mbr package.
In that case the partition with the GRUB 2 bootsector needs the boot/active flag.

JohnL (cbarter) wrote :

Thanks for the link

I've been using this machine successfully dual booting Ubuntu 8.04 with Windows XP since Apr-08 and with 9.04 for the last few months.
I haven't touched the Windows install so I'm guessing that the problem is grub2 letting Windows overwrite it, which doesn't happen with grub.

I've uninstalled 9.10 and reinstalled 9.04 and everythings fine again so the problem is definitely with grub2 / 9.10 and not some other random Windows thing.

Am Mittwoch, den 14.10.2009, 11:06 +0000 schrieb JohnL:
> the problem is definitely with grub2 / 9.10 and not some other random
> Windows thing.

Just 2 days ago someone reported the same problem in Debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550702

He confirmed that something in his Windows overwrites some stuff in the
embeding area (i.e. the sectors between MBR and first partition)

Please do the same things I told in message #20 there.

Check with fdisk -lu at what sector the first partition starts at.
Usually this is 63
Save the embeding area when you recovered GRUB 2 to sda.1 with e.g.
dd if=/dev/sda of=sda.1 count=63
Then boot Windows and then some LiveCD or your Ubuntu with a rescue disk
or something like that.
And do it again but this time use of=sda.2

To see the difference you could then e.g. use
diff -u <(hd sda.1) <(hd sda.2)

GRUB 2's core.img is much bigger then GRUB Legacy's stage1.5.
Seems like some Windows thing doestn't use the first part of the
embeding area but something in the middle or end of it.

--
Felix Zielcke
Proud Debian Maintainer and GNU GRUB developer

I have the same problem on dual-boot with Windows Vista. I am going to try the workaround but I really have to wonder: if that's happening regularly I would consider this one of the more serious problems...?
In any case, thank you for your help!

PeterF (peter-van-der-ploeg) wrote :

I have the same problem on a dual boot with Windows XP Professional.
I attached the files created by the suggestion by Felix Zielcke.

berman56 (berman56) wrote :

I also experienced this exact problem when doing a clean installation of 9.10 (dual boot with Windows XP Professional). After installation, I can boot into Ubuntu over and over. If I boot into Windows XP once, when I reboot it hangs at "Grub loading" indefinitely. Only option is to hold the power button. I must confess I am too timid to attempt the workaround. I went ahead and went back to grub legacy and 9.04 for now.

JohnL (cbarter) wrote :

I've been using 9.04 since I reported this bug in 9,10 beta, but have just installed the final release of 9.10.
I was shocked to find the bug still there.
In MY OPINION, this is so critical that 9.10 should be withdrawn immediately and released as 9.11, 9.12 or whatever once the bug is fixed.
This will do irreprable harm to Ubuntu and possibly Linux in general.

dipo (pdipeppe) wrote :

I have the same problem on dual-boot with XP.
My machine is an HP.
I've read on the web that HP BIOS write in MBR the Microsoft activation code.
After every GRUB2 restore I'm able to run one shot windows.
Clsing windows at startup appear:
GRUB loading.
...
...
20 minute later
grub rescue>

Thanks for your job

PeterF (peter-van-der-ploeg) wrote :

After some more testing (and numerous rebooting) I found the culprit. My laptop (a HP6710b) came with Windows XP professional pre installed. HP added a credential manager and HP protecttools, after removing them I'm able to use Windows without corrupting the MBR.
Why it did work with the old grub and not grub2 I don't know, in my opinion this is a Windows problem (or HP) and not a grub problem.

berman56 (berman56) wrote :

Thanks to PeterF! I confirmed your solution on my HP nc6400 laptop, I deleted HP protecttools and the HP recovery manager installer and now GRUB2 boots normally. Your point is well taken this a problem specific to Windows/HP software. Obviously, it is isn't the responsibility of Ubuntu to support GRUB and Windows XP dual booting. But given the popularity of GRUB and the reality that many linux users dual boot would it really be too much to ask to test Ubuntu/Windows dual boot setups on some standard computers like our HP laptops? Nevertheless, the beauty of linux is that people like you solve these problems just because you care. Thanks again!!!

JohnL (cbarter) wrote :

I too have an HP nc6400.
Before I read PeterF's post I tried to replace GRUB2 with GRUB which works without losing (whatever utility is provided by )HP protecttools or recovery manager.

I went into Synaptic and marked grub 2 for deletion (I WAS worried that grub wasn't an option) but went ahead anyway.

Unfortunately the GNU GRUB-Legacy doesn't have debs or rpms but only source code tarballs but the source won't complile (dependency on binutils_2.9 or later fails because Ubuntu has binutils_2.20 - the old ASCII ordering which caused so much angst with Mandrake 8 all those years ago is still alive and kicking)

Fortunately, after refreshing the archives grub 0.97 appeared alongside grub 2 so the solution is

open synaptic
delete grub 2
refresh archives (if necessary to show grub)
install grub
open a terminal and type sudo update-grub

and everything works without fiddling with the HP utilities.

So far I've booted in and out of Ubuntu and Windows 3 times without problem

JohnL (cbarter) wrote :

Loading grub 0.97 from the ubuntu repositories is Not the solution.
After the 3rd boot into windows its back to the normal Grub 2 failure mode.
Grub 0.97 is some sort of hybrid - the menu.lst file doesn't contain any windows settings - just a GRUB 2 Chainloader setting - see below

title Chainload into GRUB 2
root 4b8177ca-f6fc-4bbb-8989-b8b2a03d19d7
kernel /boot/grub/core.img

replacing this with a standard grub instruction eg

title Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1

doesn't fix the problem.

As this computer doesn't belong to me, I can't just delete something from Windows so I'll be reverting to 9.04 until the problem is fixed.

berman56 (berman56) wrote :

Before you go to the trouble of installing 9.04, perhaps you could try the experiment of uninstalling Hp ProtectTools and then clean installing 9.10. If it works, I'm sure the owner of laptop won't miss any of the ProtectTools functions (unless their computer is a corporate laptop). If it doesn't work, you can easily reinstall ProtectTools:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=321957&prodSeriesId=1847703&swItem=ob-60144-1&prodNameId=1847704&swEnvOID=1093&swLang=8&taskId=135&mode=4&idx=0

berman56 (berman56) wrote :

Sorry that link isn't quite right.

The Protecttools comes in a few parts (Security Manager, Embedded Security, Device Access Manager, etc). So you might have to reinstall a few things depending on what is installed and what you uninstall (see the software - security section).

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1847704&prodTypeId=321957&prodSeriesId=1847703&swLang=8&taskId=135&swEnvOID=1093#93211

Djainette (djainette) wrote :

Which particular software in the HP suite is to be removed to fix the grub problem ?

Tomasz Lorek (tlorek) wrote :

It is hpqwmiex.exe to be responsible for the whole mess with GRUB. Just go to service manager and disable hpqwmiex.exe service so that it is not started automatically, I guess you even do not have to uninstall anything.

Djainette (djainette) wrote :

Sorry, but wrong lead, I don't have that service.

tq (tqbw) wrote :

I have a HP xw6200 and also cannot find a service in windows called hpqwmiex.exe

I agree with John L "In MY OPINION, this is so critical that 9.10 should be withdrawn immediately and released as 9.11, 9.12 or whatever once the bug is fixed. This will do irreprable harm to Ubuntu and possibly Linux in general."

This happens also on a Dell Vostro 1520, obviously there is no such HP service. I'm trying to sort out if uninstalling/deactivating the corresponding Dell Tools helps.

Ivo Mans (ivomans) wrote :

On my HP dc5800 microtower I got same problem.
Continuing on JohnL messages: Just downgrading grub also resulted in some 'hybrid' for me. Cleaning up a bit more brought me to the 'oldfashioned' grub. So far (a few reboots) no problem anymore. What I did:

sudo apt-get purge grub-pc
sudo rm /boot/grub/*
sudo apt-get install grub
sudo update-grub
sudo grub-install /dev/sda (replace sda with your boot device!)

Add a section in /boot/grub/menu.lst:
title Windows XP
root (hd0,0)
makeactive
chainloader +1

hha (haujie) wrote :

I can confirm this bug on a Dell Vostro 1320. I dual boot between Windows 7 Professional (x64) and Ubuntu 9.10 (i386). I think I could boot into Windows several times before I started to encounter the bug earlier today. Also, my Dell seems to react a little different than described earlier in this topic. It freezes for about 5 seconds on "Loading Grub." and then immediately reboots itself.

After reinstalling Grub2 with the Live CD, I can now boot into Windows again. I'm looking forward to some results of the "Dell Tool testing" HenningGebhard wanted to do, although I think that I have none of those installed...

PhoneixS (phoneixsegovia) wrote :

I have a HP Compaq dx23000 Microtower and the same bug. I will try to disable the HP ProtectTools.

PhoneixS (phoneixsegovia) wrote :

Okay, after many restarts, I've discovered what caused the corruption.

The program that corrupt the grub (in my case) is "PC Angel" a recover software, more exactly their windows service.

You can disable it by going into Start / Control panel / Administrative tools / Services, search for a service named "PC Angel" and right click it, then click Properties, and select the start type to disabled.

For restore the grub, the only thing you need is to boot into ubuntu and using Synaptic (for example), reinstall grub-pc and grub-common.

I have used the Super Grub Disk (version 2) to launch first into windows for disable PC Angel and then to go into Ubuntu to reinstall grub. If you reinstall grub before disable PC Angel, you MUST run windows in safe mode (F8) for not damage the new grub installation.

I think that PC Angel, can be disabled if you don't need it to do new backup, because you can initiate the restore if you need, and my grub2 detect the rescue partition.

winux (g-vaquant) wrote :

I'm in the same situation with HP 6510b. Even though HP is doing something with MBR, why this did not happen in previous versions with legacy grub ? Maybe something to think about in GRUB2 design and enhancement.

I agree w/ what has been said above: If a new comer faces this.
1- he will come back to windows immediatly
2- he'll make such a noise about "Ubuntu bullshit" ...

I think the developers should find a way to overcome this bad publicity. On my part, I stop recommending Ubuntu from the 9.10 version

Dalek (harluad) wrote :

Same Issue

Disable PC ANGEL fix it.

But WHY grub2 can't deal with PC Angel ?

winux (g-vaquant) wrote :

I wonder why, but I don't have any PC Angel where indicated (I'm the only exception in this post!!).

I solved my problem by uninstalling HP backup and recovery manager, but as Dalek, I wonder why Grub2 is not able to manage what legacy Grub did. Dual-boot worked fine with the same PC on prévious Ubuntu versions!

For new Ubuntu fans, it's not the right way to start. Moreover, Windows 7 is coming and sorry to say so, very promising!! easy to install, easy to use, but .... to be honest, still not able to manage dual-boots apart from Windows systems (as long as I know!)

Ubuntu Developers, that's a challenge, please do something better than windows: manage nicely dual-boot

PhoneixS (phoneixsegovia) wrote :

First I don't have sufficient experience and I haven't investigated this problem, but this is what other says and what I think.

The problem isn't grub2, the problem is HP backup (or PC Angel), it write their things into the boot sector and suppose that this boot is the Microsoft boot that have a fixed size and structure. Grub2 have more size than grub1 and other structure that have windows and then PC Angel write into it deleting Grub2 data (because in this part windows don't have nothing).
The solution that I think that can be do is to detect if it is a HP computer and advise to the user about this problem (I don't know if this is possible).

If you think that this is a big problem, send an e-mail to HP.

PhoneixS (phoneixsegovia) wrote :

I think that we have enough info to star investigating it.

Changed in grub2 (Ubuntu):
status: New → Confirmed
winux (g-vaquant) wrote :

Isn't it possible for Grub2 to use the same room in he MBR as Grub1. I mean send the rest of info as stage 1.5 somewhere else where HP and others will not write.

I think this is a major issue, and send a mail to HP will have no effect. They don't care about Grub2 (less than 5% of the market!).

Because it worked beautifully w/ HP and Grub1, why not to try to use the same space and no more on the MBR. Otherwise a lot of new linux "prospects" will disappear, they are not concerned w/ these writing Pb in MBR. They just want a dual-boot PC which works right away.

IanJ (ian-jeffray) wrote :

Seeing this on a DELL 1600SC server too. Initial install of Ubuntu failed to install the bootloader on the correct disc! Manually changing the BIOS to boot from the disc where grub had been put left me at just a "GRUB Loading." prompt. My first look at Ubuntu and it's failed, miserably.

IanJ (ian-jeffray) wrote :

A 2nd attempt at install yields just "GRUB " and no more. Stuff it. Back to Debian for me.

Christiano (christiano-ifsp) wrote :

I had reported anote problem bug#482757, but now I think I am on the same track that you guys with this problems, after a few numbers of times using win7 - kubuntu, grub fails. nothing to do, only reinstall!
I'm using an Dell Inspiron 1545, without hp protect tools, or whatever.

On Dell Vostro 1520, uninstalling the program Dell Recovery Tool solves the problem.

amgalitz (amgalitz) wrote :

I've been telling many friends about Ubuntu for the last year or so but after this bug got me and my HP nx9420 I'm holding off on suggesting ubuntu to anyone. I think this a shame since Karmic seems to have worked so well on my laptop: finding the wirelss access points, having good touch pad response, screen fonts etc.

 I agree with the suggestion of at least having the installation process check to see if the potential for this exists and warning the user. I was left with a completely unbootable or restartable machine except by shutting off power which has the potential for random harddrive corruption. If I did not have an Acronis TrueImage Image backup to do a MBR restore, I would have lost use of the machine as the windows mbr recovery procedure failed as did the GRUB2 Wiki instructions.

BTW Taking an Acronis TrueImage backup of the windows partion before installation worked very well for recovery. i only needed to restore the MBR section which completed in a few minutes. Of course it took me a few days to think of that solution. In the mean time I had to repair Grub from the USB live session, reboot into XP and loose the machine if i rebooted from XP; quite annoying.

I will now try deleting the offending HP components, but I do like the security they offered. Of course Truecrypt is likely a better choice anyway. cheers

darthomir (telebo) wrote :

Any update on that bug? I need to reinstall grub on a daily basis after using Windows 7, and I have a Dell Vostro 1520 but without any Dell software (at least, no backup tool). I cannot pinpoint the software in Windows that destroys the grub. It fails to load after 5 seconds ("Grub is loading...") and then reboots, as mentioned by someone in a post above. Cheers

Ivo Mans (ivomans) wrote :

darthomir: my downgrade to "grub1" with the procedure as mentioned in this thread at msg #21 has survived dozens of reboots now without changing anything in Windows.

darthomir (telebo) wrote :

Thanks Ivo, I had this in mind, but thought it was counter productive to go back to Grub 1.
For the sake of saving time and maybe for others who will need to do that too, can you quickly detail your steps?
Thanks!

darthomir (telebo) wrote :

Ok, I think you simply have to follow instructions given here: https://help.ubuntu.com/community/Grub2#Reverting%20to%20GRUB%20Legacy
Was wondering also if using EasyBCD and launch Ubuntu from it without GRUB would do the trick?

darthomir (telebo) wrote :

Update: I did follow the procedure to revert to grub-legacy, and it did boot fine in Windows 7 and Ubuntu 9.10. Although the first reboot after running Windows for 1 minute was fine, using Windows the next time for a prolonged time left my grub at the command line the next time I rebooted. As mentioned I have Dell Vostro 1520, but unlike someone mentioned before I don't have any Dell Software installed. I am back to Grub 2, reinstalling every single time after using Windows 7. Should it be the Dell software causing a problem, where can I uninstall it? This is a major problem! Thanks!

griese (troy-griese) on 2009-12-03
description: updated
Mihai Capotă (mihaic) on 2009-12-18
Changed in grub:
importance: Unknown → Undecided
status: Unknown → New
Changed in grub2 (Debian):
status: Unknown → New
amy (a7mdyassin) on 2010-06-09
Changed in grub2 (Ubuntu):
assignee: nobody → Ahmed Mohammed Yassin (a7mdyassin)
assignee: Ahmed Mohammed Yassin (a7mdyassin) → nobody
Philip Muškovac (yofel) on 2010-06-11
Changed in grub2 (Ubuntu):
importance: Undecided → High
tags: added: i386
tags: added: amd64
Philip Muškovac (yofel) on 2010-06-28
tags: added: karmic
Changed in grub2 (Ubuntu Maverick):
assignee: nobody → Colin Watson (cjwatson)
117 comments hidden view all 197 comments
mavosaure (mavosaure) wrote :

As reported in bug #551721, I experimented this bug since the 20th of august on my Dell Studio 1558 laptop, just after a Dell update when I was using Windows Seven. But the little difference is the error message. (Each time I recover GRUB using the same method, with a the lucid live USB) Most of time, I got :
"no module name found
Aborted. Press any key to exit." (as in #551721)
or sometimes , just a blinking "_"

I'm using Ubuntu 10.04.1 amd64 in dual boot with Seven and the problem is probably caused like other people by "Dell Datasafe Local Backup", that I didn't uninstall.

@ Colin : you 'll find files requested by Felix attached here.
@ Colin (bis) : Bugs #551721 and #482757 are very similar. Maybe do we have to mark them as duplicate of this one?

zhouzhk@hotmail.com (zhouzhk) wrote :

I found the following applications could fire this bug also: UtraISO,Adobe Flash Builder 4

Colin Watson (cjwatson) wrote :

mavosaure: Thanks. Regarding possible duplicates: I think I'll keep them separate because otherwise this bug is going to get VERY long as reports about application after application come in.

<email address hidden>: Please provide the information requested in comment 4 for these applications. I'm afraid simply saying that an application is affected doesn't help us very much.

Colin Watson (cjwatson) wrote :

Could people affected by this bug please upgrade to the grub-common and grub-pc packages from this PPA:

  https://launchpad.net/~cjwatson/+archive/ppa

... and try rebooting into Windows to see if that still makes GRUB unbootable? Hopefully it won't.

If it still breaks, then there are two possibilities:

  1) Nobody provided the information requested in comment 4 for whatever application is causing this on your system.
  2) Somebody provided this information, but the signature is more complicated than I thought.
  3) I screwed up somehow.

In all those cases, please provide the information requested in comment 4, and I'll see what I can figure out. If it does work for you, positive confirmation is good as well; if I can get confirmation that I'm improving things for a respectable number of people, then I should be able to get this into Maverick and possibly backport the change to earlier releases as well.

Changed in grub2 (Ubuntu Maverick):
status: Confirmed → In Progress
milestone: none → ubuntu-10.10
mavosaure (mavosaure) wrote :

Bad news!

I just tried your packages (@Colin Watson) but after rebooting on Seven, it fails again. (I setted up Maverick on an another partition of the same disk).

You'll find the requested files here.

Colin Watson (cjwatson) wrote :

I've replied to mavosaure in bug 551721. The failure is specific to this case, and other people with the same problem should still give my packages a try.

Marko Vertainen (mve) wrote :

I upgraded grub from the mentioned ppa to my Lucid installation. After upgrade was finished I rebooted and went to Windows 7, and started Adobe Photoshop. After reboot, grub2 was still missing. I rebooted from the live CD and restored grub installation (in chroot), and got following message after 'grub-install /dev/sda':

/usr/sbin/grub-setup: warn: sector 9 is already in use by FlexNet; avoiding it.
Installation finished. No error reported.

I think that I needed to install grub twice in the MBR because I hadn't used any of the offending Adobe software because of this bug and in first install new grub didn't see any trace from the FlexNet. So to get rid of this bug you need to use offending app in windows and then fix grub installation once more using live CD.

I have now started Photoshop few times in Windows 7 and grub is still working and I can select Ubuntu, Windows 7 and MeeGo in the boot time. Thank you very much for your work done to fix this problem.

mavosaure (mavosaure) wrote :

@Colin Watson : you'll find requested files for multiple GRUB's breaks due to Windows software.

@Marko Vertainen : your experience is interesting! How did you proceed? something as described on this page?
https://wiki.ubuntu.com/Grub2#Recover%20Grub%202%20via%20LiveCD

Thxs

Gogl (pscharpfenecker) wrote :

Using Ubuntu 10.10 beta on a Dell laptop. Grub2 doesn't break every time i boot Win7. I think the reason for me is LoJack. When I start a test call, grub breaks and the boot process results in an infinite loop. I'm going to try burg and see if it still breaks.

Marko Vertainen (mve) wrote :

@mavosaure. I used excactly that wiki page to recover grub installation. I set ppa's distribution to maverick even though I'm using lucid on that laptop, because there wasn't new grub package made for lucid. No problems so far.

Colin Watson (cjwatson) wrote :

Marko: Great, that's as expected so far, thanks. (In a future version of GRUB, it will be able to tolerate one sector being overwritten using an error-correcting code; for now, all I'm trying to get to is that you can at least reinstall GRUB afterwards and it won't be broken again.)

mavosaure: Your attachments in comment 162 and comment 165 are exactly identical. Did you perhaps attach the wrong file?

Gogl: Your example is much worse. It looks as though something has installed an entirely different boot loader; even the boot sector has been changed. It really is impossible for GRUB to recover from this.

mavosaure (mavosaure) wrote :

@Colin : Sorry for my mistake. This one is the good one!

I tried to recover/re-install GRUB by using chroot instead of simple
recover but I didn't receive any special message.

Gogl (pscharpfenecker) wrote :

@Colin : Hmmm the interessting thing is, that burg works great. I compared the mbr with burg to the bad mbr with grub and it seems that the changes to the mbr didn't influence burg. Whatever changes the mbr, burg with the '--alt' option seems to be immune.

Colin Watson (cjwatson) wrote :

BURG doesn't install to the MBR. This has an entirely different set of problems, which I won't explain again here as I've done so before. We won't be following its example, and we definitely won't be using BURG as it has very little development effort on it compared to the GRUB project from which it forked.

Colin Watson (cjwatson) wrote :

This upload is now in maverick:

grub2 (1.98+20100804-5ubuntu2) maverick; urgency=low

  * When embedding the core image in a post-MBR gap, check for and avoid
    sectors matching any of a list of known signatures (mitigates LP
    #441941; more work may be required).

 -- Colin Watson <email address hidden> Mon, 27 Sep 2010 18:42:42 +0100

This has been confirmed to fix Photoshop for at least one person. I expect that more work on gathering signatures may be required, so I will not close this bug, but I will take it off the critical list for 10.10 at this point.

Changed in grub2 (Ubuntu Maverick):
milestone: ubuntu-10.10 → none
Colin Watson (cjwatson) wrote :

Gogl: anyway, no matter what burg does it can't possibly recover from its *boot sector* being overwritten, which is what your logs show; that's like removing its brain! I suspect that you have not told me the full story here; perhaps you have installed some other MBR program to the boot sector, and have installed grub or burg to a partition. At any rate something is very fishy.

Gogl (pscharpfenecker) wrote :

@Colin: Sorry, i didn't know the differences between burg and grub. To your last comment: The only thing I did was installing burg with the --alt option to /dev/sda, my only hard drive. Again, I don't know exactly what it does, but it works. But I think, corresponding to your previous comment that this discussion doesn't depend to this bug.

mavosaure (mavosaure) wrote :

@Colin : I hope you 'll find something interesting with my files.

Reading the comment #166 of Gogl make me remember that I have also LoJack, but in my case it isn't activated. But it may be a service or something like this which is launching at the set-up and that I didn't recognize. I read a little about and it seems it's setted up in the BIOS and in some cases it could write into the MBR :-(.

In other hand, note that I removed Dell DataSafe from the start-up list of msconfig without any effect.

Gary M (garym) wrote :

https://wiki.ubuntu.com/MaverickMeerkat/TechnicalOverview recently mentioned this bug in rev. 104.

Changed in ubuntu-release-notes:
status: New → Confirmed
crashfourit (crashfourit) wrote :

What about giving grub its own dedicated partition and move it out of the staging area?

Reserving only one track (aprox 63 sectors) should work.

Could also put grub in the staging area of an extended partition.

David Sharp (whereami) wrote :

@Colin I had experienced this bug with the Beta. So, before installing the RC (in the meantime I had to RMA my hard drive) I was able to take a clean copy of my MBR. Attached is a tarball with three versions of the first 63 sectors of my disk:

sda.0.beforeubuntu.clean:
 - This is taken with the livecd before installing (but after partitioning with gparted) Ubuntu 10.10 RC
 - The sector starting at offset 0x1400 contains some Dell-specific strings. I redacted my service tag number from here in two places (hence the ".clean" suffix).
sda.1.afterubuntu:
 - This is taken after first successful boot of Ubuntu
sda.2.afterwindows:
 - Finally, this is taken after booting into windows and then booting back into Ubuntu.

I did notice that the situation has improved for me between the beta and RC. I did not have to recover grub after starting windows, nor uninstall Dell DataSafe Local Backup. This is essentially fixed from my perspective, but if you wanted additional improvement, avoiding overwriting the bytes at 0x1400 would probably be nice. I don't know what those are used for.

Mike Ter Louw (miketl) wrote :

I have an HP and suspect ProtectTools is corrupting grub 2 (see attachment). Thank you for your effort on this, Colin.

Gary M (garym) on 2010-10-09
affects: grub → kgrub2editor
Gary M (garym) on 2010-10-09
affects: kgrub2editor → grub
Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
Changed in grub2 (Debian):
status: New → Confirmed

Attaching output as asked in colin's blog post

Michael Bolotov (bolotov-mu) wrote :

   Hello!
 I am owner Dell Inspiron 1012. My basic OS Ubuntu netbook edition 10.04. The second OS is preestablished Windows 7 Starter.
 I too have a problem with this bug. I heard, that it is maybe connected with the utility ' Dell Datasafe Local Backup '. I have removed ' Dell Datasafe Local Backup ' from automatic loading. But it has not helped.
 I very badly know English, excuse.

I am "enjoying" this bug on my HP nc8430 laptop with ubuntu 10.10 and windows XP pro.
I did restore with Ubuntu 10.10 Live USB-key.
I have not figured yet what windows software is causing this, I did some updates to my Windows XP and this bug was my result.
I have attached output as asked in colin's blog post

I also have this bug on a Dell Vostro 1520, and already removed the Dell Recovery Tool. However, next time I had this problem again.

Here are my dump output as asked in comment #4.

Changed in grub2 (Debian):
status: Confirmed → Fix Released
jooh plo (mmnch) wrote :

I'm using an HP/Compaq nx 7300 laptop and something from windows definitely seems to be messing up the GRUB2 procedure. I've attached output from fdisk -lu, the diff of good and bad MBR, and the whole output of MBR for good and bad. I understand the basics of what's going on here, but I'm not techie enough to know how to interpret the MBR output, so any help that is geared toward a non-technical person is appreciated.

Ryan Little (ryan-little) wrote :

I have experienced the same issue with my Compaq 6715b.

I have XP SP3 and Ubuntu 10.10 on a single drive. When booting up the GRUB appears OK. If I boot in to Unbuntu and then restart GRUB still appears. As soon as I boot in to XP and restart GRUB is gone.

I can't say for sure what software is responsible, I decided to remove all of the HP bundled software that is shipped with the laptop that I never use. This has fixed the problem and I can now boot between operating systems quite happily without any more issues.

The HP software that remains on my laptop is listed below and can therefore be ruled out as possible culprits;

HP Backup and Recovery Manager Installer
HP Integrated Module with Bluetooth wireless technology
HP Quick Launch Buttons 6.20 F2
HP User Guide Bluetooth Addendum 0062
HP User Guides 0064
HP Wireless Assistant

Tom (tom1) wrote :

HP 6325, XP SP3 and 10.04.
Uninstalled: HP Backup and Recovery Manager Installer
Reinstalled GRUB as per griese's tips
No further problems.

John Papineau (j-lp) wrote :

I add the same problem with someone computer. I used the cd disk to boot the computer and backed up all the the picture and other personal document . Then I installed the new version of Ubuntu with windows and i add no more problem.

ps. other thing you may whant to look at is the configuration of the hard drive on the computer. When you dual boot windows with Ubuntu you need to put windows on your first sata boot and ubuntu has your second sata boot on your motherboard. Then , install windows operating system on the first boot sata on your motherboard. After you are done. Install Ubuntu on your sata that is on your sacond boot on your motherboard. If when you boot your computer you do not see the ubuntu menu, just go into the bios menu and put your hard drive that has ubuntu installed on it has your first drive to boot in your boot selection menu . THen boot your computer again you should now see the ubuntu menu .

I hope that this help you

Changed in grub2 (Ubuntu Lucid):
status: New → Confirmed
Graham Inggs (ginggs) wrote :

Recently installed Ubuntu 11.04 with grub-pc 1.99~rc1-13ubuntu3 in a dual-boot with Windows, grub fails after running Windows.

Colin Watson (cjwatson) wrote :

Graham, please follow the instructions in http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/debian/2010-08-28-windows-applications-making-grub2-unbootable.html to gather more data, except rather than following up to this bug please file a *new* bug report against grub2 in Ubuntu.

Changed in grub2 (Ubuntu):
status: In Progress → Triaged
Changed in grub2 (Ubuntu Maverick):
status: In Progress → Triaged
Graham Inggs (ginggs) wrote :

Colin, just checking whether you can see the attachment to my post on 2011/07/25.
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/441941/+attachment/2231448/+files/jbergh.tar.gz

1 comments hidden view all 197 comments
Ruben (info-rubenfelix) wrote :

Hey!

Bedankt voor je mail! Ik ben er even tussenuit geknepen naar een lekker warm land! Ik beantwoord je mail na mijn vakantie (11 oktober).

Groetjes!

Ruben

Tabs (tabsc) wrote :

Hi, i got the same problem:
- no grub problem by default but after a log in windows the computer start to boot in a loop (computer reboots at the moment when grub should start);
- when installing grub I have the warning "Sector 5 is already in use by ZISD; avoiding it. This software may cause boot or other problems in future. Please ask its authors not to store data in the boot track".

I am running Unbuntu 11.04 and grub 1.99~rc1-13ubuntu3.
The boot is done on a RAID 5 array.

And finally you will find the files files attached as requested here:
http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/debian/2010-08-28-windows-applications-making-grub2-unbootable.html

I hope you can help and thanks in advance.

1 comments hidden view all 197 comments
Tabs (tabsc) wrote :

Hi Again,

I found an alternate solution to my problem: I simply disabled the ZISD at startup. I found many post saying that it is not possible but it seems it is (or at least this step resolved my booting problem). That is why I take the liberty to write it here, although not directly related to Grub.

What you have to do is to create the following String Value using regedit:
ZISWIN Disabled
and set it to 1

The exact location of the key and more informations can be found here:
http://www.novell.com/support/php/search.do?cmd=displayKC&docType=kc&externalId=3302285&sliceId=1&docTypeID=DT_TID_1_1&dialogID=18570921&stateId=1%200%2018572294

I would still be interested in a Grub update that manage to avoid this stupid ZISD MBR modification.

Thanks !

YannUbuntu (yannubuntu) wrote :

Hello
Here is a similar case due to the use of SolidWorks2010 : Bug #907283

Hope this helps.

JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bug task for Maverick. Please upgrade to a newer version of Ubuntu.
More information here: https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Changed in grub2 (Ubuntu Maverick):
status: Triaged → Invalid
1 comments hidden view all 197 comments
Phillip Susi (psusi) wrote :

Hey Colin, didn't this fix make it into Ubuntu as well or is it really just Debian?

Displaying first 40 and last 40 comments. View all 197 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.